15:02:11 <adamw> #startmeeting Fedora QA meeting
15:02:11 <zodbot> Meeting started Mon May 13 15:02:11 2013 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:15 <adamw> #meetingname fedora-qa
15:02:15 <zodbot> The meeting name has been set to 'fedora-qa'
15:02:22 <adamw> #topic roll call
15:02:28 * jskladan lurks
15:02:29 <adamw> calling all rolls
15:02:29 <tflink> roll!
15:02:32 * mkrizek is here
15:02:39 * pschindl is here
15:02:52 * brunowolff is here
15:03:02 * Viking-Ice is here
15:03:23 <jreiser> jreiser lurks
15:03:41 * satellit listening
15:04:15 <adamw> morning folks
15:04:21 <adamw> #topic previous meeting follow-up
15:04:26 <adamw> bit of a bumper crop here
15:04:55 <adamw> #info "martix or adamw to write a Graphics Test Week recap email" - still not done yet. we suck
15:04:58 <adamw> #action martix or adamw to write a Graphics Test Week recap email
15:05:15 <adamw> tflink to write a list post announcing the blocker bug proposal webapp - I believe you did that?
15:05:28 <tflink> I don't think I did
15:06:09 <tflink> nope, I don't see one
15:06:28 <adamw> ah, well you suck too
15:06:31 <adamw> #action tflink to write a list post announcing the blocker bug proposal webapp
15:06:40 <adamw> "brunowolff to update the FE guidelines to reflect the agreement (see above)"
15:06:41 <brunowolff> #link http://lists.fedoraproject.org/pipermail/test/2013-May/115318.html
15:06:44 <adamw> great job of legibility there, me
15:07:07 <adamw> #info "brunowolff to update the FE guidelines to reflect the agreement (see above)" - this was done, see https://lists.fedoraproject.org/pipermail/test/2013-May/115318.html
15:07:08 <adamw> thanks bruno!
15:07:19 <brunowolff> I didn't get any feedback from the message posted to the test list.
15:07:19 <adamw> "adamw to look into Test_Day:2013-04-30_MariaDB lack of participation and see if we should re-run it"
15:07:32 <adamw> brunowolff: it looked fine to me, so no action needed...i guess everyone else was the  same
15:07:52 <adamw> yeah, I didn't do this one either, good lord, I need to read my action items
15:08:12 <adamw> #info "adamw to look into Test_Day:2013-04-30_MariaDB lack of participation and see if we should re-run it" - not done yet
15:08:14 <adamw> #action adamw to look into Test_Day:2013-04-30_MariaDB lack of participation and see if we should re-run it
15:08:24 <adamw> #info "tflink to write a list post announcing the blocker bug proposal webapp" - not done yet
15:08:40 <adamw> "kparal to ensure abrt and sssd test days have live images ready" - do we have a kparal?
15:08:43 <Viking-Ice> adamw, it's simple no point in re-running it
15:10:41 <adamw> no kparal, okay
15:10:44 <adamw> let me take a look
15:11:16 <adamw> #info "kparal to ensure abrt and sssd test days have live images ready" - this got done, by the looks of things, both pages have live images listed
15:11:48 <adamw> #info "adamw to do some promotion for the test days" - this was done, i got blog posts and twitter messages out: http://www.happyassassin.net/2013/05/06/abrt-and-sssd-test-days-this-week/
15:11:59 <adamw> #topic Fedora 19 Beta status/planning
15:12:20 <adamw> So, any particular notes on Beta, anyone? we'll be hitting freeze soon
15:12:37 <adamw> #info Beta TC4 is currently under testing, some significant bugs found already
15:12:40 <Viking-Ice> adamw, promotion means handing it out to marketing not private blog post that nobody reads
15:12:59 <jreiser> gdm greeter to gnome shell does not work on non-3D cards.  Bug 955779 graphical desktop does not start.
15:13:03 <Viking-Ice> ( or some or few people read ) marketing should just handle that stuff for us
15:13:04 <brunowolff> cwickert asked about images for the non-desktop spins on the spins list. I said that for alpha/beta nightlies should be used.
15:15:44 <jreiser> There is a rumor of gnome 3.8.2 arriving on Tuesday, perhaps fedora-branched on wednesday.  Wait and see?
15:16:26 <adamw> jreiser: did you create passwords for your test users?
15:16:44 <adamw> jreiser: well, not a rumour, we're trying to get it done ahead of the freeze indeed
15:17:08 <jreiser> yes, I have passwords.  This is an alpha that has been updated daily.
15:17:16 <adamw> i'm pretty sure that "ERROR:gdm-slave.c:1094:_get_uid_and_gid_for_user: assertion failed: (username != NULL)" is what I saw when I tried creating a user with no password via g-i-s (it was entertaining)
15:17:24 <adamw> hum, then probably something different
15:17:33 <adamw> can you try and reproduce with a clean install? or not practical?
15:17:53 <jreiser> OK, I'll do a clean install from TC4.
15:18:44 <adamw> has anyone else seen this one?
15:19:46 <brunowolff> Bug 955779 sounds pretty similar to what I was seeing after gdm/gnome-shell got fixed enough that they didn't crash while using llvmpipe on non-SSE2 CPUs.
15:20:02 <robatino> 955779 looks like my 946964
15:20:27 <adamw> brunowolff: ah yeah, what was the bug# for that?
15:20:30 <robatino> thanks for that, i'll probably mark mine as a dupe - my video is nvidia btw
15:20:54 <jreiser> No crash, but no transition to desktop.  just all gray, everybody waiting.
15:21:08 <brunowolff> I am not sure. I was just looking, but I think it got closed since the crashing part was fixed, even if things were still pretty unusable.
15:21:16 <brunowolff> I'll look harder.
15:21:28 <adamw> brunowolff: i remember the bug yeah, i'm just blanking on the # / title
15:21:32 <jreiser> strace shows 1st "can you do 3D" gets a no, but 2nd ask gets a Yes.
15:21:34 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=909473
15:21:47 <adamw> jreiser: see my latest comment
15:22:38 <adamw> brunowolff: doesn't really look the same, but certainly possibly related
15:23:44 <brunowolff> Yeah, 909473. I think the reported problem was different, but the state after the fix seemed a bit similar.
15:23:50 <jreiser> adamw: 909473 last comment is a question "open new X bug or not?"  If that will help, I'll do it.
15:24:13 <adamw> jreiser: well to me it doesn't, really, but I might be reading it wrong...
15:24:23 <adamw> jreiser: I think we'd best wait for gdm input at this point
15:24:27 <brunowolff> I also was using an ATI 9200 for some of the testing.
15:25:47 <brunowolff> I haven't look at it much since, because it takes a lot of messing around to test, since my old slow to boot machines have been switched over to kdm/xfce.
15:25:47 <jreiser> Ok, I'll try clean TC4, then wait for gdm 3.8.2
15:26:09 <jreiser> I see same trouble on xfce, too.
15:26:14 <adamw> jreiser: i _think_ your issue may simply be a clean report of what happens with a blacklisted 3D adapter at present
15:26:23 <adamw> now I come to think of it, I'm not sure we have any other bug report for that case
15:26:40 <adamw> jreiser: have you tested GDM/GNOME with the laundry list of cards in c#13?
15:26:47 <adamw> i'd guess it'd work better with those?
15:28:50 <jreiser> 955779#c13 gives exact status on all cards as of April 23.  "3D" cards pass, "X does not support 3D" cards fail.
15:30:42 <halfline> jreiser: re 955779 do you have gnome-initial-setup installed ?
15:30:50 <adamw> jreiser: Xfce and lightdm behave completely differently from GNOME and gdm in this regards, so that comment is more confusing than enlightening
15:31:03 <adamw> it's strange that they seem to respond 'the same' for you, but the actual code paths are pretty different
15:31:13 <adamw> lightdm doesn't have any form of '3D test' because it doesn't need to care
15:31:19 <jreiser> Please restate what you want me to try.
15:31:20 <adamw> (afaik anyway)
15:31:39 <adamw> jreiser: try the combination of GDM/GNOME on all those cards, rather than lightdm/Xfce
15:31:44 <halfline> i'd personally like you to try yum -y install gnome-initial-setup
15:31:50 <adamw> only because I know the maintainer would want the same; they do not behave the same at all
15:32:19 <jreiser> So far I have installed default gnome first, then "yum groupinstall xfce-desktop".
15:32:38 <jreiser> I get gdm as greeter.  Both gnome desktop and xfce session fail to reach desktop.
15:32:51 <halfline> ahh interesting
15:32:55 <jreiser> That's why I believe the problem is in gdm.
15:33:09 <adamw> jreiser: comment #13 talks about trying the Xfce live image. what I'm saying is that that tells us nothing about gdm's behaviour
15:33:44 <adamw> i just wanted to know how your different adapters/machines behaved with GDM.
15:34:01 <adamw> clearly you have a problem with GDM on the 9200, but I wanted to clarify if you saw it with any other adapters.
15:34:53 <jreiser> I believe that "X11 supports 3D" implies that gdm+gnome works, and gdm+xfce works.
15:35:16 <jreiser> The problem is "x11 does not support 3d" implies failure of gdm greeter.
15:35:54 <adamw> anyhow
15:36:01 <adamw> i think we have Top Men on the case now
15:36:13 <halfline> jreiser: gnome-session does this little dance at startup
15:36:25 <halfline> where it first runs check-accelerated and sees if it succeeds
15:36:31 <halfline> if it fails, it forces software rendering
15:36:36 <halfline> and then runs check-accelerated again
15:36:44 <halfline> the second run should always succeed
15:36:52 <halfline> that's why you see it twice in your trace
15:36:59 <halfline> it's not able to do accelerated rendering the first time around
15:37:08 <halfline> so it's falling back to software
15:37:36 <adamw> #info Beta freeze is tomorrow, 2013-05-14; next goal is to build an RC ASAP
15:37:53 <halfline> let's chat in #fedora-devel
15:37:54 <jreiser> halfline: yes, that is what I see.  This is Pentium4, has sse2.  problem is no desktop after that dance.
15:38:13 <adamw> thanks halfline!
15:38:18 <jreiser> halfline: going to #fedora-devel
15:38:59 <adamw> brunowolff: so the behaviour on non-SSE2 CPUs is still as bad as described in 909473 >
15:38:59 <adamw> ?
15:39:54 <brunowolff> I need to retest.
15:40:12 <brunowolff> But the last time I tried, gnome wasn't really usable.
15:40:14 <adamw> ok, could you do that? and if it's still bad let's just re-open the bug to try and trigger ajax's attention
15:40:32 <adamw> #action brunowolff to re-test 909473 and re-open if it's still bad
15:41:00 <adamw> okay...anything else to cover on the f19 front?
15:41:13 <adamw> #info GNOME 3.8.2 is coming, we will try to land it in Beta just ahead of the freeze'
15:41:14 <brunowolff> Even if it gets fixed, my CPUs aren't really good enough to make gnome pleasant. I'll probably be using xfce for the rest of the lifetime of these machines.
15:41:37 <adamw> still, it'd be good to have it fixed
15:41:48 * satellit will this break cinnamon?
15:41:53 <adamw> satellit: will what?
15:41:59 <adamw> GNOME 3.8.2? I'd hope not; it's a bugfix release
15:42:02 <satellit> gnome upgrade
15:42:30 <satellit> fyi cinnamon works at this time
15:42:35 <adamw> yeah, I know, I tested it
15:42:50 <brunowolff> Isn't it landing the day of the freeze?
15:43:04 <Viking-Ice> let's hope it get's included in beta
15:43:18 <brunowolff> That's not much time to get it tested and into stable.
15:44:55 <adamw> brunowolff: yeah, I know, I'm going to try and co-ordinate getting karma on it
15:45:04 <adamw> if we don't make it, though, we'll file an FE bug
15:45:29 <adamw> #topic Test Days
15:46:17 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-07_ABRT went ahead and we got some good results, though not much testing outside of RH's Brno office
15:46:55 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-09_SSSD_Improvements_and_AD_Integration went ahead and looks like there was a good amount of testing
15:47:41 <adamw> #info NetworkManager test day has been postponed to 2013-06-04: https://fedoraproject.org/wiki/Test_Day:2013-06-04_Network_Manager
15:47:56 <adamw> anything else on test days?
15:48:11 <adamw> Martix_: is everything in hand for next week's?
15:48:32 <Martix_> no :-(
15:48:58 <adamw> oh dear :( what's the problem?
15:49:14 <Martix_> note: NM test day has been moved to 2013-06-04
15:49:24 <adamw> yeah, I noted that
15:49:31 <adamw> hence "next week's"
15:50:05 <adamw> AnacondaNewUI Followup and Thermostat are scheduled for next week
15:50:10 <Martix_> I must admit I don't have much time until June for Test Days :-/
15:50:15 <adamw> ah
15:50:37 <adamw> in that case, any help with wrangling the remaining May test days is appreciated, I'll try and help out
15:50:51 <Martix_> adamw: thank you
15:52:14 <Martix_> adamw: btw I suggested to reschedule MariaDB TD, but I'm not sure if they can get more testers
15:52:15 <adamw> #topic Open floor
15:52:36 <adamw> we've got 8 minutes for open floor before exciting blocker review fun starts up in #fedora-blocker-review: anything to discuss?
15:53:24 <kalev> I have collected a few fixes that should help get the desktop live media closer to the target size
15:53:25 * satellit wait for blocker review for FE requst
15:53:27 <Viking-Ice> so what we are going to include the gnome 3.8.2 in beta or not?
15:53:28 <kalev> I'll send an email to the test list a bit later, would be awesome to get some testing & karma to have them included in the Beta release
15:53:32 <kalev> (waiting for one more build)
15:54:19 <adamw> Viking-Ice: i'm hoping we can. if we can get it done ahead of tomorrow, fine. if not, i'll file an FE ticket and people will have to vote on it
15:54:57 <adamw> Viking-Ice: if you and I each submit karma once the update is in, then we only need one other person :)
15:55:05 <adamw> (assuming it actually works, of course)
15:55:25 <adamw> #info GNOME 3.8.2 update should be landing soon, please test and file karma so we can try to get it in ahead of freeze
15:55:36 <kalev> we'll need some releng coordination to get an updates-testing push once the update is ready
15:55:52 <adamw> kalev: i'll ask releng to do that, but people can get it from bodhi in the mean time
15:55:53 <kalev> hard to test otherwise
15:55:53 <Viking-Ice> adamw, yeah well doing so we risk breaking and delaying beta
15:55:55 <kalev> cool
15:56:12 <Viking-Ice> not doing so we risk mass duplicated bug report from users
15:56:12 <adamw> Viking-Ice: i think it'd be ok to get it in the first day or two of freeze, after that it'd be worrying
15:56:34 <adamw> but if we co-ordinate we should be able to get it done today/tomorrow, so hopefully no problems
15:57:42 <adamw> #info desktop team is still working on getting the spin below the size target
15:58:21 <Viking-Ice> what about the rest of the spins?
15:58:44 <Viking-Ice> did you hear something from cwickert regarding lxde size (  FE )
15:59:17 <adamw> oh, good point. no, I haven't, has anyone else?
15:59:35 <adamw> notting thinks the DVD might squeeze under size on the next compose, so we're keeping an eye open for that
16:00:26 <adamw> #info no word on LXDE spin being over size, we believe the DVD may make it under size on the next spin
16:00:48 * nirik has been working on Xfce. we are down to deciding about browsers.
16:00:59 <adamw> #info nirik is working on Xfce spin size
16:01:01 <nirik> I'll do something today with it, so we should be back under size tomorrow.
16:01:09 <adamw> blocker review starting up right now over in #fedora-blocker-review, folks
16:01:14 <adamw> so let's set the Patent Fuse
16:01:19 <cwickert> ??!
16:01:27 * cwickert never heard of it
16:01:32 <cwickert> is it oversized?
16:01:45 <adamw> cwickert: https://bugzilla.redhat.com/show_bug.cgi?id=958427
16:01:59 <adamw> oh, damn, i missed that it's assigned to bill :/
16:02:11 <adamw> do you want to re-assign to yourself?
16:02:23 <adamw> robatino: in future it'd be good to CC the maintainer of the spin on 'spin oversize' tickets
16:02:33 <adamw> or assign it directly to them
16:02:36 <nirik> perhaps those should be against livecd-spinname?
16:02:42 <cwickert> I will take care of this
16:02:42 <adamw> yeah, probably
16:02:46 <adamw> thanks cwickert
16:02:49 <adamw> good thing we caught it ;)
16:03:00 <cwickert> however I want to say it sucks we are getting fatter and fatter with every releasee
16:03:32 <cwickert> at some point we should consider removing esoteric input methods and fonts nobody needs
16:03:41 <cwickert> anyway, too late for f19
16:03:52 <nirik> yeah, I have no idea which of the i18n stuff is important.
16:03:53 <nirik> :(
16:04:18 <cwickert> none? :-P
16:04:44 <nirik> well, I mean some of the dictionaries or fonts... are they required to make things work? or just an extra?
16:04:49 <cwickert> #info LXDE will continue to target 700 MB, cwickert to work on slimming it down
16:05:24 <robatino> i reassigned to LiveCD-LXDE
16:05:30 <cwickert> thanks
16:05:35 <cwickert> move on please
16:05:45 <cwickert> and thanks for the heads-up, adamw
16:05:50 <adamw> nirik: do ask the i18n folks. it sucks when people rip stuff out unnecessarily
16:05:54 <adamw> cwickert: thank viking
16:06:00 <cwickert> thanks Viking-Ice!
16:06:11 <adamw> alrighty folks, everyone over to blocker review, thanks for coming!
16:06:21 <adamw> #endmeeting