15:00:50 <adamw> #startmeeting Fedora QA meeting
15:00:50 <zodbot> Meeting started Mon Jun 3 15:00:50 2013 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:53 <adamw> #meetingname fedora-qa
15:00:53 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:56 <adamw> #topic Roll call
15:01:07 <adamw> morning folks, who's ready for fun?
15:01:21 * jreznik is ready for another meeting in a row
15:01:27 * jskladan tips his hat
15:01:38 * j_dulaney lurks
15:01:39 * satellit listening in Bellingham motel
15:01:49 <tflink> jreznik: /me is here
15:02:15 <tflink> huh, that didn't work
15:02:30 * kparal here
15:04:11 * brunowolff is here
15:04:11 * nirik is lurking as well
15:05:20 * adamw really needs to get that anti-lurking kit installed
15:05:45 * jreznik is working on an announcement for the devel-announce list, needs anti-lurking kit as he's more lurking now :)
15:06:17 <adamw> #topic previous meeting follow-up
15:07:00 <adamw> #info "adamw and anyone else to work on updating Common_F19_bugs" - I got that one done, it's pretty much up to date
15:07:24 <adamw> #info "adamw to talk to rbergeron and make sure packagekit/policykit issue makes it into the beta release notes" - yup, got a mention of it into the release announcement, and no crazy slashdot conspiracy theories yet
15:07:51 <adamw> #info "adamw to complete 'new model' criteria revision by converting the final criteria" - I started working on that Friday, I'll aim to complete it today or tomorrow
15:08:02 <adamw> "tflink to update the iscsi test case for newUI" - tflink?
15:08:13 <tflink> not done yet, on my todo list for today
15:09:31 <adamw> .fire tflink first of the week
15:09:34 <zodbot> adamw fires tflink first of the week
15:09:34 <adamw> aw, no bot in here? boo.
15:09:37 <adamw> yay!
15:09:58 <adamw> #info "tflink to update the iscsi test case for newUI" - not done yet but should be soon
15:10:12 <adamw> #info "tflink to schedule first blocker review meeting for this week" - that was done, we had two review meetings last week
15:10:28 <adamw> #info "adamw to look at extracting some test cases from Test_Day:2013-05-21_AnacondaNewUI_Followup for use as optional test cases (or even enforceable partitioning test cases) for the validation matrices" - not done yet but it's kind of a long-term plan, it's on my todo list
15:10:57 <adamw> #info "martix to ensure spice test day is ready on time" - that seemed to be sorted out fine
15:11:58 <adamw> #info "satellit_e to work on some test cases for SoaS" - satellit drafted up some ideas at http://wiki.sugarlabs.org/go/Fedora_19-sugar_test_cases
15:12:01 <satellit> SoaS test cases? list of ideas http://wiki.sugarlabs.org/go/Fedora_19-sugar_test_cases
15:12:07 <satellit> : )
15:12:13 <adamw> :)
15:12:20 <adamw> sorry i didn't get a sec to review them yet, i'll do it today
15:12:27 <adamw> any other follow-up items I missed?
15:13:49 <brunowolff> I retested llvmpipe on a particular non-SSE2 CPU and it's still broken.
15:16:05 <adamw> ah yeah I saw your comment
15:16:25 <adamw> that's a bit of a pain. and you might be right about advising people with old machines to grab something other than GNOME
15:16:34 <adamw> we could probably mark the bug as requiring a release note for that
15:17:03 <adamw> #action adamw to mark LLVMpipe-without-SSE2 bug as needing a release note and explain why to docs team
15:19:56 <adamw> #topic Fedora 19 Final planning
15:20:08 <adamw> #info TC1 is due tomorrow, 2013-06-04, I will request the compose then
15:20:23 <adamw> do we have any major worries at this point, or things we need to get in place soon?
15:20:38 * adamw can't think of anything urgent beyond the revised criteria
15:21:05 <kparal> the sooner we have TC1 the better. let's request today :)
15:21:30 <tflink> have we done much upgrade testing? I've seen several comments and bugs, but wasn't sure how much poking has been done so far
15:21:37 * jreznik would not be against requesting it sooner, if there's nothing we really want in tc1
15:21:47 <kparal> I did some upgrade testing on UEFI
15:22:10 <jreznik> poor kparal touching UEFI
15:23:20 * kparal now has a master's degree in bios re-flashing
15:24:08 <adamw> tflink: quite a few people have run fedup I think, and we did fill the matrix for beta
15:24:10 <adamw> kparal: :)
15:24:38 <tflink> adamw: yeah, I was just thinking about the less-straightforward configs that ended up causing trouble after F18 release
15:25:55 <mjg59> adamw: We should finally have a patch that resolves most of the UEFI variable issues
15:26:03 <adamw> right, that's another area we could do with more test cases
15:26:11 <adamw> mjg59: yay! so there _were_ still issues on the kenrel side?
15:26:18 <adamw> what's the timeframe on landing that?
15:26:29 <mjg59> adamw: Well, no. Issues on the firmware side.
15:26:44 <kparal> mjg59: what are the changes?
15:26:53 <mjg59> But I have finally come up with an elegant mechanism for making the damn things do what we want
15:26:55 <jreznik> mjg59: and how much you can do with fw side?
15:27:08 <jreznik> mjg59: nice to hear!
15:27:17 <mjg59> kparal: Change the threshold from 50% to 5KB, do something magic which will (in theory) force the firmware to trigger garbage collection
15:27:37 <kparal> mjg59: sounds good. can we expect a blogpost about the details?
15:27:49 <mjg59> kparal: http://mjg59.dreamwidth.org/25091.html
15:27:54 <jreznik> mjg59: what do you achieve by changing 50% to 5 KB?
15:28:02 <kparal> mjg59: thanks!
15:29:08 <mjg59> jreznik: It's less than the maximum variable size, so we can create a new variable that's larger than the remaining space
15:29:13 <mjg59> Or, rather, attempt to
15:29:42 <kparal> mjg59: does it mean that kernel panics will never again be stored in uefi nvram, too risky?
15:29:43 * jreznik is reading the blog post
15:29:56 <mjg59> kparal: No, we should be safe in doing that
15:29:59 <adamw> mjg59: any news on the timeframe?
15:30:13 <mjg59> adamw: It's on LKML, jwb has a scratch build
15:30:46 <mjg59> kparal: That's currently disabled because it turns out the code is shit (which may be, uh, my fault)
15:31:08 <adamw> mjg59: well, I mean, getting it in an official f19 kernel build
15:31:55 <mjg59> adamw: Once we've got confirmation from some testing of the scratch build
15:32:15 <adamw> kparal: hint hint :)
15:32:16 <jreznik> kparal: hint, hint ^^^
15:32:24 <kparal> thanks guys
15:32:27 <jreznik> adamw: hey, you were faster!
15:32:30 <adamw> .fire jreznik there can be only one
15:32:30 <zodbot> adamw fires jreznik there can be only one
15:32:50 <kparal> mjg59: can you give us a link to that scratch build?
15:33:00 <mjg59> Linked from https://bugzilla.redhat.com/show_bug.cgi?id=964335
15:33:06 <adamw> #info mjg59 informs us a kernel patch is coming which ought to resolve most of the UEFI variable space issues. scratch build for testing linked from https://bugzilla.redhat.com/show_bug.cgi?id=964335
15:33:30 <adamw> thanks matt!
15:33:31 <kparal> I'll try to understand the blogpost and then test the build
15:34:47 * jreznik thinks he understands what mjg59 wants to achieve, hopes firmwares will be cooperative :)
15:34:54 <adamw> #topic Test Days
15:35:47 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-05-28_Virtualization and https://fedoraproject.org/wiki/Test_Day:2013-05-30_Spice both went off pretty successfully last week, i saw lots of active testing on both
15:36:11 <adamw> although - kparal, next time check in with the virt folks on the details of the live image; we kinda needed it to be installable for virt testing
15:36:29 <kparal> they didn't say
15:36:34 <kparal> why we need anaconda?
15:36:42 <adamw> they weren't aware we dropped anaconda from test day lives
15:36:48 <adamw> well, because you can't really do virt hosting from a live session
15:36:54 <adamw> unless you have like 32GB of RAM
15:37:09 <adamw> we just told people to use the beta lives and that worked out fine, so it wasn't a big deal
15:37:17 <kparal> I see
15:37:43 <kparal> in that case maybe a tailored Live wasn't needed at all
15:37:51 <adamw> yeah, maybe
15:37:59 <adamw> like i said, it didn't turn out to be a big problem, just a note
15:38:21 <kparal> I'm waiting for dcbw to give me a list of packages for tomorrow's test day so that I can build a Live image for them
15:38:34 <kparal> FreeIPA test day should be good, they're creating the image themselves
15:38:46 <adamw> cool;
15:39:13 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-06-04_Network_Manager page looks ready, kparal is working on the live image
15:39:29 <adamw> #info https://fedoraproject.org/wiki/Test_Day:2013-06-06_FreeIPA_Two_Factor_Authentication looks ready to go
15:39:46 <adamw> any other test day notes from anyone?
15:42:11 <adamw> #topic Open floor
15:42:19 <adamw> welp, here we are folks, any other business/
15:42:52 <tflink> nothing I can think of, no
15:43:27 <adamw> tflink: we have rather a lot of proposed blockers; should we do blocker review next?
15:44:02 <tflink> probably, yes
15:44:11 <kparal> oh, I hoped you wouldn't ask :)
15:44:11 <tflink> that looks like at least 3 hours of fun
15:44:49 * tflink gets started on prep
15:45:14 <adamw> kparal: c'mon, you know I never miss blocker review fun
15:46:42 <kparal> well, I don't miss it either
15:46:43 * j_dulaney is off
15:46:51 <j_dulaney> Apologies for not participating
15:47:25 <adamw> so that's blocker review fun in bat-channel #fedora-blocker-review at the top of the clock, folks
15:47:28 <adamw> strap yourselves in
15:48:09 <brunowolff> Note that if you are using rawhide kernels on f19, the grub(2) conf files don't (and won't) get updated.
15:48:42 <adamw> oh, yeah, that bug's worth a call-out
15:48:47 <adamw> do you have the number handy?
15:49:29 <brunowolff> I can find it. I think it is closed though.
15:54:15 <adamw> welp, sounds like that's everything
15:54:24 <adamw> blocker review in 5 minutes folks, thanks for coming!
15:54:24 <brunowolff> While looking, it looks like they might have pushed the fixed systemd to f19 today. Yeah!
15:54:28 <adamw> yay!
15:54:31 <adamw> #endmeeting