16:00:48 <adamw> #startmeeting Fedora QA meeting
16:00:48 <zodbot> Meeting started Mon Nov 4 16:00:48 2013 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:52 <adamw> #meetingname fedora-qa
16:00:52 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:55 <adamw> #topic Roll call
16:01:01 <adamw> so, i'm around for once :)
16:01:11 <cmurf> shocking
16:01:13 * nirik is lurking around in the back
16:01:15 * roshi is here
16:01:16 * tflink is quaking in his boots due to presence of adamw
16:01:18 * kparal says hi
16:01:20 * jreznik needs a few more minutes ;-)
16:01:24 * Viking-Ice is also lurking in the back
16:01:30 * mkrizek is here
16:01:54 * cmurf has coffee but has to drive to ABQ in 3 hours, not here for long.
16:03:20 <adamw> so while roll call's going on - my apologies for disappearing last week, and the shim snafu
16:03:52 <adamw> i'd told so many people i was going on vacation i was kinda assuming everyone knew, but turns out it was all IRL and no-one here was aware. and shim 0.5 going in ahead of votes was my bad, sorry again
16:03:53 * pschindl is here
16:04:26 <cmurf> badaboom
16:05:08 * handsome_pirate waves
16:05:18 * handsome_pirate isn't on drugs this week
16:05:20 <tflink> adamw: no worries, it happens
16:05:33 <adamw> handsome_pirate: then all is lost'
16:05:34 <tflink> handsome_pirate: DARE finally worked for someone?
16:05:46 <handsome_pirate> heh
16:05:56 <handsome_pirate> I'm off the vicodan
16:05:57 <cmurf> kparal: Fricaceed = stewed and served in sauce. As in dead. Kaput. Axed. Killed. Squashed. Squished. Strangled.
16:06:09 <handsome_pirate> I actually don't remember last week very well
16:06:20 <handsome_pirate> Especially last Monday
16:06:27 <kparal> cmurf: thanks. now we need to teach google to know that as well
16:06:52 <cmurf> kparal: well i was trying to go for obscure as well as amusing if not weird
16:07:13 <adamw> alrighty folks
16:07:20 <adamw> #topic Previous meeting follow-up
16:07:26 <adamw> let's see, doing this by the seat of my pants...
16:07:52 <adamw> "roshi to write up recap of the graphics test week"
16:07:54 <adamw> roshi?
16:08:00 <roshi> done :)
16:08:09 * roshi finds link
16:08:12 <adamw> cool, did you use my super-lame math stuff? :) (haven't had a chance to read the list yet)
16:08:23 <roshi> http://scriptogr.am/roshi/post/graphics-test-week-recap
16:09:18 <roshi> I used the recap script - if that's what you mean
16:09:28 <pjones> kparal: cmurf: "fricassee" will probably get you better google results
16:09:36 <adamw> no, for graphics test weeks i have this thing where i calculate the number of bugs getting fixed and stuff
16:09:46 <adamw> no biggie, can go back and do it later
16:09:58 <adamw> #info "roshi to write up recap of the graphics test week" - this was done, see http://scriptogr.am/roshi/post/graphics-test-week-recap
16:10:06 <roshi> cool, I'd like to see that
16:11:49 <adamw> ok, anything from last week that isn't obvious from the minutes?
16:12:39 * handsome_pirate admits to not remembering last week
16:12:54 <cmurf> adamw: Possibly that I volunteered you and me to work out an exception policy for Btrfs and LVM thinp.
16:13:27 <adamw> oh goody. so, unless i borrowed pirate's drugs, i'm assuming we haven't done that yet.
16:13:45 <cmurf> adamw: Maybe we have and you did borrow his drugs.
16:14:05 <Viking-Ice> what was that supposed to be about
16:14:29 <Viking-Ice> write exception policy for that from the current release criteria
16:14:50 <cmurf> yes because in practice when the going gets tough we try to find exceptions anyway
16:14:58 <adamw> Viking-Ice: i believe the idea is to update the criteria to only cover certain areas of LVM and btrfs functionality, not implicitly cover everything they're capable of
16:15:32 <Viking-Ice> is that something we would apply now or $next_release?
16:15:47 <adamw> dunno? /me only just got here :P
16:15:50 <cmurf> and as dlehman put it, LVM is the emacs of storage, so not everything LVM can be supported in the installer anyway. So actually, critieria could be modified.
16:16:04 <adamw> i suppose now, if installer team considers it impractical to cover the entirety of lvm functionality as blocker stuff now
16:16:16 <cmurf> right
16:16:23 <cmurf> i think in the short term we keep doing what we've been doing
16:16:54 <Viking-Ice> then we just keep it simple btrfs lvm thinp issues wont block the release this cycle
16:17:19 <adamw> my initial thought was along the lines that the installer only has to read/interpret stuff it's capable of writing itself, but eh
16:17:20 * satellit join late
16:17:28 <adamw> we can always do proposal/revision through th elist
16:17:37 <Viking-Ice> mean either anaconda supports this stuff properly or they dont we cant be running around every release cycle to adjust our criteria based on their whims
16:17:46 <cmurf> Viking-Ice: well no it's more complicated than that it depends on the issue because i don't think it's appropriate to have bugs that qualify for e.g. final block violations, to be available in Guided partitioning where people get into trouble easier
16:18:10 <cmurf> Viking-Ice: on the other hand, we can't do major changes between beta and final because that risks more bugs
16:18:38 <cmurf> hence an exception that actually allows some blatantly obvious and subjective judgement calls
16:18:56 <Viking-Ice> I think it's best that we avoid "exceptions" at all cost in the release criteria
16:19:02 <drago01> adamw: does this code gets rewritten every release?
16:19:16 <drago01> adamw: I mean it should have matured at some point
16:19:27 <adamw> Viking-Ice: i don't think it'd be written as a 'this except this' kind of way
16:19:35 <cmurf> it would not
16:19:45 <adamw> drago01: it gets touched quite a lot every cycle, yeah, but i don't know if the bug that's prompted this is even a new bug
16:19:50 <Viking-Ice> drago01, one would have thought so but the feeling of that is no it does not...
16:19:57 <adamw> it came up in thinp testing, and we didn't really touch thinp before this release
16:19:58 <cmurf> it's not
16:20:01 <cmurf> and there are lots of other bugs
16:20:05 <cmurf> and there are maturity issues
16:20:23 <cmurf> and there are UI/UX concerns adamw brought up on anaconda list over a week ago that relate
16:20:28 <adamw> if we're going to get philosophical about it i'd still argue the installer just tries to be too much of a partitioning tool, but hey
16:20:37 <cmurf> on that point we agree
16:20:43 <adamw> cmurf: which no-one's replying to.
16:20:52 <Viking-Ice> adamw, as well as alot of other things geoip wtf
16:20:55 <adamw> anaconda-devel-list: where threads go to die
16:20:58 <cmurf> i've argued custom needs to be pulled out into its own app, decoupled from the installer
16:20:58 <cmurf> it makes the installer unstable
16:21:05 <adamw> Viking-Ice: at least geoip's simple and the scope doesn't change over time...
16:21:23 <cmurf> and the real custom partitioning should be essentially as you described it, which is what i call an enhanced point and shoot installer
16:21:24 <Viking-Ice> adamw, leave that stuff up to firstboot or initial setup
16:22:02 <adamw> anyhoo, we're kinda in the weeds
16:22:15 <adamw> cmurf/me will post any proposals we come up with to the list so they can be discussed then
16:22:50 <cmurf> yeah i think a brief convo with dlehman is in order then proposals for discussion
16:22:50 <adamw> #topic Fedora 20 Beta status
16:22:58 <Viking-Ice> I personally frown upon any criteria changes in the midst of the cycle and prefer we just tackle these issues on issues bases
16:23:25 <cmurf> Viking-Ice: well read the minutes from last week's go/no-go where thinp came up
16:23:25 <adamw> so, uh, what is F20 beta status?
16:23:36 * adamw hasn't checked in since thursday or so
16:23:44 <adamw> #chair cmurf roshi
16:23:44 <zodbot> Current chairs: adamw cmurf roshi
16:23:53 <kparal> we will need another RC https://bugzilla.redhat.com/show_bug.cgi?id=1022206#c13
16:24:44 <kparal> also, I can't verify https://bugzilla.redhat.com/show_bug.cgi?id=1023556
16:24:56 * adamw brb, call of nature
16:25:00 <adamw> #chair kparal
16:25:00 <zodbot> Current chairs: adamw cmurf kparal roshi
16:25:19 <Viking-Ice> I've not yet filed that blocker bug that causes anaconda to crash when resizing ( large partition ) in the default autoparted stuff
16:25:26 * satellit minor bug? https://bugzilla.redhat.com/show_bug.cgi?id=1004621
16:25:58 <kparal> Viking-Ice: 1013586 ?
16:26:36 <cmurf> hmm yes resize bugs should not crash but I think the criteria was inteded for resize to not for sure work until final; this has come up before
16:27:43 <adamw> yeah, that was the intent
16:27:58 <adamw> still, crash when resizing any large partition sounds bad
16:28:18 <cmurf> if it crashes in the UI before "begin installation" is less bad by far than after
16:28:26 <Viking-Ice> kparal, well not sure this is the same one I think mine was due to altering 3 digit ( 100+GiB ) partition ( altering 2 digit partitions <99GiB seemed to work )
16:29:08 <cmurf> i've been resizing 3 digit windows/NTFS volumes for the Windows matrix test for some time and it's always worked in guided
16:29:22 <cmurf> it was busted in custom until TC5 I think, but was definitely working in TC6
16:29:48 <Viking-Ice> cmurf, I just took the default chosen standard partition layout and was resizing it ( anaconda puts way to much in / then is needed )
16:30:07 <cmurf> kparal's resize bug that happens with ext4 as well is a different bug instigated by something unique about the partition size that's confusing blivet
16:30:26 <Viking-Ice> cmurf, that was tc5 have not retested it with more recent bits
16:30:31 <cmurf> Viking-Ice: oh, ok so changing the size within custom, not resizing an existing volume
16:30:42 <cmurf> i think that's fixed
16:30:51 <cmurf> i haven't run into it with TC6
16:31:19 <cmurf> RC2 is being really fussy in qemu/kvm, I keep getting soft lockups on reboots but the installations are clean
16:31:28 <adamw> satellit: that one looks quite bad...
16:31:50 <adamw> at least worth an FE nomination
16:31:52 <satellit> adamw: KDE lives only works once installed
16:32:01 <cmurf> oh dear
16:32:21 <satellit> ok not my bug someone else should nominate it...
16:32:43 <adamw> #info there is at least one blocker known not to be resolved in Beta RC2: https://bugzilla.redhat.com/show_bug.cgi?id=1022206#c13
16:32:48 <satellit> cannot update live
16:33:01 <adamw> #info we also need information on https://bugzilla.redhat.com/show_bug.cgi?id=1023556 from dlehman
16:33:38 <adamw> #info https://bugzilla.redhat.com/show_bug.cgi?id=1023556 may possibly be worth considering for FE or blocker status
16:34:14 <adamw> #action viking-ice to check his possible resize issue in at least TC6 (ideally RC2)
16:34:26 <adamw> think that ought to cover everything we have?
16:34:27 <jreznik> jgrulich as far as I know is going to be away for a few days, just fyi for the plasma-nm one
16:34:40 <adamw> jreznik: sounds to be more in sddm than plasma-nm itself
16:34:49 <adamw> (i'm assuming it's a logind issue)
16:36:05 <cmurf> doesn't seem like it's consistent or it'd have been a big problem all of october yet nothing in the comments during that time
16:36:36 <adamw> true
16:37:17 <spstarr_work> hello
16:37:41 <satellit> I saw it in testing https://fedoraproject.org/wiki/Test_Results:Fedora_20_Beta_RC2_Desktop?rd=Test_Results:Current_Desktop_Test
16:37:52 <cmurf> someone volunteer to boot the current KDE live desktop and see if they have an internet connection?
16:38:03 <adamw> cmurf: it would be wireless-only, as I read it
16:38:13 <roshi> I'll do it - just let me d/l it
16:38:21 <cmurf> oh well isn't that normal?
16:38:44 <satellit> wireless works in other DE's live
16:38:46 <cmurf> i never have wireless working from live desktop because the proprietary firmware isn't installed
16:39:03 <roshi> really cmurf?
16:39:07 <cmurf> really
16:39:08 <satellit> and in anaconda 20.25.5-1 here
16:39:19 <roshi> it's always worked for me from live images
16:39:25 <spstarr_work> cmurf: I can test this
16:39:28 <cmurf> now, if i create a litd usb stick of live, with an overlay, and install the firmware, i persistently get working wireless between boots
16:39:40 <adamw> cmurf: the bug isn't to do with firmware afaict
16:39:45 <adamw> and most adapters don't need it these days
16:39:46 <spstarr_work> wifi?
16:40:09 * satellit permissions to connect?
16:40:16 <satellit> dbus?
16:40:24 <cmurf> well i only have Macs here that have Broadcom adapters and even the 2012 model has proprietary firmware required
16:40:50 <cmurf> so that may be why my wireless expectations are so low
16:40:52 <spstarr_work> i can boot my W500 in a KDE Live CD
16:40:59 <spstarr_work> but its a intel wifi chip
16:41:22 <Viking-Ice> cmurf, I had a dell with that broadcome problem but that hw has died on me so no worries no more about that ;)
16:41:25 <satellit> system 76 here with no proprietary drivers
16:41:27 <adamw> heh
16:41:33 <adamw> okay, we should ook into it a bit more i guess
16:41:47 <adamw> so anyone have any worries about 20 beta that haven't been covered yet?
16:42:22 <cmurf> no
16:42:29 <cmurf> well not more than the usual
16:44:12 * cmurf is out for the rest of this week at a conference, 50/50 chance of checking in
16:44:39 <adamw> rogert
16:46:59 <adamw> welp, then it looks like it's time for...
16:47:02 <adamw> #topic Open floor
16:47:12 <adamw> any other business?
16:47:33 <robatino> do beta FEs get automatically promoted to final FEs after beta gold?
16:47:51 <robatino> see https://lists.fedoraproject.org/pipermail/test/2013-November/118626.html (no response)
16:48:00 * handsome_pirate would be +1 for that
16:48:19 * handsome_pirate also thought he responded :(
16:48:22 * handsome_pirate blames the drugs
16:48:26 <adamw> that seems to come up every week
16:48:38 <robatino> maybe promote proposed FEs to proposed, and accepted to accepted
16:48:40 <adamw> but in practice, no, mainly because we have no mechanism for it and no-one wants to do it.
16:48:50 <cmurf> adamw: i forgot to respond to that
16:48:51 <Viking-Ice> well we should just skip promotion if we are going down that road
16:48:57 <cmurf> i think alpha to beta automatic is OK
16:49:01 <adamw> i wouldn't be opposed to it if someone wanted to write a way to do it and look after it.
16:49:01 <cmurf> beta to final is risky
16:49:04 <Viking-Ice> as in and FE remains an FE through milestones
16:49:14 <jreznik> and also fe that could be still ok for beta could cause more issues for final in some cases
16:49:26 <cmurf> jreznik: exactly my thought
16:49:40 <Viking-Ice> cmurf, FE are FE we dont have to pull them in
16:49:57 <cmurf> Viking-Ice: yes but they're allowed in, and can cause an RC to blow up
16:49:59 <jreznik> cmurf: but allows it
16:50:04 <handsome_pirate> It seems that accepted should be auto-promoted
16:50:04 <cmurf> so it's like, yeah we can regress but it can be a problem
16:50:08 <jreznik> cmurf: exactly my thought :)
16:50:20 <cmurf> if anything
16:50:27 <cmurf> FE's should be done by the last TC
16:50:31 <Viking-Ice> cmurf, but since people have started to pull in proposed FE regardless if they have been approved FE on blocker bug meetings why bother with this process et all
16:50:33 <cmurf> and then no more
16:50:54 <adamw> Viking-Ice: like i said that was a mistake
16:50:58 <cmurf> Viking-Ice: yes that horse has been beated to death and apologized from the grave at least two or three times now
16:51:09 <adamw> not intended to be a new policy or something
16:51:17 <cmurf> adamw: maybe we need to flog you, strip you, put you in the middle of a busy intersection and painted blue
16:51:19 <Viking-Ice> adamw, cmurf when and where ?
16:51:29 <adamw> earlier in this meeting, for a start, and in the bug report
16:51:42 <cmurf> Viking-Ice: adam apologized in the bug, and in here, and maybe on a list
16:52:02 * cmurf votes against flogging but in favor of painting blue
16:53:05 <handsome_pirate> tar and feather
16:53:10 <cmurf> overdone
16:53:23 * adamw checks if he has any more vacation time left
16:53:32 <Viking-Ice> ah it's there buried in comments
16:53:43 <cmurf> right, buried with all the other buried comments
16:53:53 <cmurf> okay! so we're done?
16:53:59 <adamw> i don't think you'd have liked it if i used non-existent secret Red Hat powers to make it bright yellow and bold, would you? :P
16:54:00 <Viking-Ice> well thunderbird craps it'self more then usual on large inboxes
16:54:30 <cmurf> adamw: gold plated and polished
16:54:35 <Viking-Ice> adamw, honestly I thought you had done this to try to not slip beta a week again
16:54:49 <Viking-Ice> due to release pressure
16:54:50 <adamw> Viking-Ice: nope, it wouldn't have blocked beta in the first place
16:54:51 <cmurf> well that didn't work out very well
16:54:57 <adamw> honestly i was just half-assing it before going on vacation
16:55:07 <cmurf> half asser
16:55:13 <adamw> 'oh shit i have to throw together a new TC request, this one this one this one DONE', screwed it up.
16:55:32 <Viking-Ice> well there was that 50/50% chance it would go un-noticed
16:55:44 <adamw> yeah, if it had actually worked no-one would've given a crap :P
16:55:51 <cmurf> 0% chance something not bootable would have gone unnoticed
16:56:21 <cmurf> ok wrap?
16:56:42 <adamw> sounds lik eit
16:56:56 <adamw> thanks for coming, folks
16:57:03 <adamw> #endmeeting