16:00:29 <adamw> #startmeeting Fedora QA meeting
16:00:29 <zodbot> Meeting started Mon Dec 2 16:00:29 2013 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:33 <adamw> #meetingname fedora-qa
16:00:33 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:37 <adamw> ahoyhoy, folks
16:01:01 * tflink is present
16:01:08 <kparal> is it roll call?
16:01:13 <kparal> topic is missing
16:01:23 <adamw> #topic Roll call
16:01:28 <adamw> DON'T KNOW WHAT YOU'RE TALKING ABOUT
16:01:29 * pschindl is here
16:01:30 * pwhalen is here
16:01:31 * satellit listening
16:01:35 * mkrizek is here
16:01:57 * nirik is lurking in the back
16:02:03 * kparal is here, but can't attend the blocker bug meeting in an hour. going to theatre. you now, culture.
16:02:15 * roshi is here
16:02:42 * jreznik is mostly here, needs three more minutes
16:02:56 <adamw> .fire kparal the only culture Fedora QA folks are allowed is 'to the suburbs' (oh snap! inside joke!)
16:02:56 <zodbot> adamw fires kparal the only culture Fedora QA folks are allowed is 'to the suburbs' (oh snap! inside joke!)
16:03:42 <kparal> fire me again for not getting that joke
16:03:55 <adamw> kparal: https://fedoraproject.org/wiki/QA:Testcase_audio_basic
16:04:13 <adamw> kparal: that's the example sound track. i know the first three seconds of it...pretty well.
16:04:19 <tflink> yeah, have heard that song a few times :)
16:04:33 <kparal> oh right, I thought we had stallman's free software song in that test case. should be replaced
16:04:38 <adamw> ! excellent plan.
16:04:41 <adamw> send a pathc
16:04:43 <adamw> also a patch
16:04:44 <brunowolff> I'm around if you need to ask about spin-kickstarts.
16:05:12 <adamw> brunowolff: thanks
16:05:15 <adamw> #topic Previous meeting follow-up
16:05:31 <adamw> brunowolff: that'll probably come up in the blocker meeting, which will be in #fedora-blocker-review, just so you know
16:05:51 <adamw> #info "adamw to draft a new test case and matrix row for validating cloud image checksums" - I totally didn't get around to doing this. too busy playing with tablets. my bad
16:06:16 <adamw> #action adamw to draft a new test case and matrix row for validating cloud image checksums
16:07:10 <adamw> #info "adamw to make sure the desktop tests are completed for TC2" - they're covered between TC2 and TC3, many thanks to roshi satellit and mkrizek for chipping in
16:07:29 <adamw> and pwhalen for arm
16:08:28 * Viking-Ice is here
16:08:40 <adamw> "jreznik to check in with KDE team if they're on top of the two proposed KDE blockers or if help would be appreciated" - jreznik, back yet?
16:08:41 <adamw> ahoy viking
16:10:22 <jreznik_> adamw: I'm here!
16:10:49 <jreznik_> the whole team works on arm one but without any success
16:10:53 <adamw> zoiks
16:11:16 <adamw> Fedora 20: ARM's A Primary Arch (As Long As You're Not Super Keen On Clicking On Things)
16:11:22 <jreznik_> one idea is to workaround the bug by moving that offending widgets to the desktop
16:11:45 <adamw> eeexcellent, it's hack time
16:11:45 <jreznik_> advanced panel test case would still fail in some way but at least basic usecase could be ok
16:12:08 <jreznik_> and seems like mouse events are broken on intel too, just not such horribly
16:12:44 <jreznik_> so plasma does something in a really bad manner
16:13:28 <jreznik_> and it's a question how you would like this hack, making it better, not fixed with a lot of stuff still broken...
16:13:56 <jreznik_> for the rest of kde bugs - it's more up to your testing with kdm based image, how does it look?
16:13:56 <adamw> sounds likes classic fedora to me
16:14:09 <adamw> seemed fine, I ran the whole desktop_login test case
16:14:20 <adamw> of course it'll hit TC4 and explode on impact, that's just a given
16:14:30 <roshi> yay
16:14:54 <jreznik_> adamw: what I don't get - upstream aims on arm based tablets, they are aware of this bug for a long time and it's still there... :(
16:15:04 <adamw> jreznik: yeah, seems weird
16:15:31 <adamw> maybe they figure it's not super important. if they have some discussion of it somewhere where they reached that conclusion, it'd be useful to have the reference, so we can use it to justify our inevitable fudge
16:16:07 <jreznik_> I can ask guys, they talked to sebas
16:17:08 <jreznik_> it's *still* arm... but at least one desktop should be somehow usable... if not primary one
16:17:51 <adamw> yeah, maybe we should've made xfce primary after all. quick change? :P
16:18:05 <pwhalen> the desktop is still very usable, more an inconvenience. xfce works well.. it was our original blocker desktop
16:18:45 <jreznik_> pwhalen: define "very"
16:19:01 <adamw> #info lots of firepower has been aimed at the KDE / ARM plasma systray widget bug - https://bugzilla.redhat.com/show_bug.cgi?id=969524 - without success so far. we'll keep working on it, but may need to fudge it for release
16:19:47 <pwhalen> besides the convenience of the plasma widgets, everything else seems to be okay.
16:20:26 <jreznik_> and if we could be able to make it at least a bit better, it would be win
16:21:17 <adamw> okay, sounds like we're on top of it.
16:21:25 <adamw> "cmurf to send a quick email to test-announce asking folks to test and karma critpath updates ahead of freeze tomorrow"
16:21:33 <adamw> well, we don't have a cmurf, but i believe he did that
16:22:04 <adamw> #info "cmurf to send a quick email to test-announce asking folks to test and karma critpath updates ahead of freeze tomorrow" - this was done: https://lists.fedoraproject.org/pipermail/test-announce/2013-November/000821.html
16:23:00 <Viking-Ice> pwhalen, hmm was that decided by fesco as an DE could block the ARM release
16:23:45 <adamw> Viking-Ice: we decided it at Flock, you were there
16:24:23 <Viking-Ice> I'm lucky if I can remember what happened last week
16:25:40 <jreznik_> Viking-Ice: lucky man, I have troubles to remember what happend day before sometimes!
16:25:45 <adamw> Viking-Ice: hehe :)
16:25:55 <adamw> #topic Fedora 20 Final status
16:26:18 <Viking-Ice> since fesco has started butting into our processes ( like they are doing with the EOL process ) it's harder to keep taps of where things got decided
16:26:23 <adamw> ...where am i? who are all you people? how do I work this machine?
16:27:03 <Viking-Ice> jreznik_, that does just happen to me after serious drinking the night before
16:27:17 <jreznik_> for other F20 bugs - I was able to get status for
16:27:32 <Viking-Ice> where you wake up in strange places wearing nothing but mankini
16:27:38 <jreznik_> other two heisenbugs are systemd ones, especially that lvm on bios raid
16:27:52 <adamw> #info test coverage for TC2+TC3 is looking fairly good, we're still missing some of the usual suspects on the install matrix (annoying cases like SCSI, iSCSI, hardware RAID and those icky kickstart deployment ones)
16:27:55 <jreznik_> systemd guys seems to be clueless for that one
16:28:03 <adamw> jreznik_: the instantiated service one?
16:28:07 <jreznik_> yep
16:28:08 <Viking-Ice> lvm issue most likely I would say
16:28:15 <Viking-Ice> race condition
16:28:30 <jreznik_> Viking-Ice: it's race and they are trying to help peter but no luck so far
16:29:05 <jreznik_> for journald - mschmidt was on PTO today but also seems like the proposed fixes are not enough :(
16:30:45 <jreznik_> for grubby bug, pjones says it's rfe, not a blocker as it's not supported configuration
16:31:16 <Viking-Ice> grubby has plenty of bugs
16:31:38 <pjones> jreznik_: right - the bug is specifically about /boot on a subvolume, which isn't something anaconda will allow you to do.
16:31:55 <pjones> Viking-Ice: wild categorizations of grubby notwithstanding, the question is if this bug is a blocker.
16:32:22 <jreznik_> so this is my status for currently accepted blockers I was able to collect so far
16:33:50 <jreznik_> for the proposed, I can share it at blocker review meeting
16:34:14 <Viking-Ice> pjones, 864198 got accepted as a blocker hence it is
16:34:22 <adamw> pjones: i thought you can do it in custom partitioning, but autopart doesn't do it.
16:34:33 * adamw checks the bug report
16:34:35 <jreznik_> from non bugs related side - we are getting pretty ready
16:35:07 <Viking-Ice> all docs an all workarounds documented in release notes ;)
16:35:09 <jreznik_> Viking-Ice: well, the maintainer is always one party to decide what should be blocker and not
16:35:17 <pjones> adamw: the bug specifically states that during installation he puts /boot on ext4
16:35:54 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=864198#c9
16:36:00 <adamw> "This bug is still alive, and anaconda will let the user create a layout as describe in comment 7"
16:36:26 <adamw> so, the obvious alternative here if you want this to be an unsupported configuration is don't allow it in anaconda.
16:36:43 <Viking-Ice> rifht
16:36:46 <Viking-Ice> mean right
16:36:57 <pjones> I really thought that was the case - let me check with dlehman, because he's the expert on that.
16:37:05 <adamw> i can do a quick test easy enough
16:37:29 <pjones> but in any case adding this to grubby is a fairly significant effort that's not going to happen at the last minute
16:37:33 <adamw> okay
16:37:45 <adamw> so basically the plan is: check if it's really allowed in anaconda, if so, patch it out
16:37:52 <adamw> seems fine to me
16:37:53 <pjones> (unless, you know, $mystery_coder shows up with some patches)
16:37:54 <jreznik_> seems like
16:38:01 <Viking-Ice> jreznik_, I would say more the input from developers is appreciated but the actual decision making if an bug is a blocker is not
16:38:29 <adamw> Viking-Ice: per policy it's supposed to be a shared decision between qa, devel and releng
16:38:38 <adamw> though lately it's mostly qa folks showing up to meetings
16:38:50 <adamw> #chair roshi viking-ice
16:38:50 <zodbot> Current chairs: adamw roshi viking-ice
16:38:51 <Viking-Ice> well historically speaking it has more or less been that case
16:39:03 <adamw> in the early days of meetings we did a better job at getting more people out...
16:39:17 <adamw> i think they found they couldn't stand the four hours of sheer excitement ;)
16:40:08 <adamw> eep. my 'quick test' produces an unrelated crasher bug. stand by
16:40:10 <Viking-Ice> in anycase anyone who actually shows up can have a say in a vote unless he has directly related or responsible for what is being discussed and voted upon
16:42:45 <adamw> so, https://bugzilla.redhat.com/show_bug.cgi?id=1036025 , fun. back to trying to check this.
16:43:56 <adamw> pjones: yeah, custom part happily let me out with just a btrfs /boot, btrfs /, and swap.
16:44:04 <pjones> ugh.
16:44:20 <adamw> install is running now. no warnings, even.
16:44:38 <adamw> okay, we know the status anyhow. two days to fix it, plenty of time :)
16:45:15 <Viking-Ice> or we simply slip if necessary
16:46:02 <adamw> sure
16:46:04 <adamw> updated the bug
16:46:39 <adamw> so, taking a look at the current blocker list...https://qa.fedoraproject.org/blockerbugs/milestone/20/final/buglist
16:46:42 <mkolman> adamw: looks like a duplicate
16:46:49 <mkolman> adamw: checking with vpodzime now
16:46:52 <adamw> it's quite long, but some of them are bureaucracy bugs
16:47:09 <jreznik> update for plasma arm one - guys are building fix right now
16:47:27 <adamw> yay
16:47:31 <jreznik> (like a real one, not a workaround but still nasty hack)
16:47:32 <adamw> we've mostly covered the most tricky ones
16:47:54 * pwhalen is watching the build
16:48:02 <adamw> we probably need to point some dcbw firepower at https://bugzilla.redhat.com/show_bug.cgi?id=1018317
16:48:25 <mkolman> adamw: 1036025 yep is a dupe
16:49:12 <adamw> ok
16:49:14 <adamw> dupe it
16:49:34 <jreznik> adamw: he should know how to fix it
16:49:35 <mkolman> dshea already did :)
16:49:55 <adamw> ah, cool
16:50:05 <jreznik> jklimes added a comment there - it seems like impact *could* be limited to only particular use cases but...
16:50:10 <adamw> jreznik: i just poked dcbw about it
16:50:40 <adamw> #info current blocker bug load is large, but work is progressing on most bugs; we still have a shot at on-time release
16:50:42 <jreznik> [15:55] <jklimes> danw, dcbw: jreznik pinged me to find out what happens, so that they could decide blocker/noblocker
16:50:43 <jreznik> [15:55] <jklimes> danw: if you have a solution (in mind), go for that
16:50:44 <jreznik> [15:55] <danw> it happens for some openvpn users, but not all, and it depends on how the openvpn server is configured, so there's no workaround on the client side
16:50:46 <jreznik> [15:56] <danw> i don't think we have any clue what percentage of openvpn users is affected
16:50:47 <jreznik> [15:56] <danw> and yeah, i think we know how to fix it
16:51:14 <adamw> we can discuss the %age thing in blocker review meeting
16:52:19 <jreznik> hmm, from the last two comments it looks like it's again unsupported config
16:52:19 <adamw> as far as TC4 goes...we have enough stuff queued up to do it today, probably
16:52:23 <adamw> sound ok to everyone?
16:52:31 <adamw> i'm hoping the next build after that may be RC1
16:52:38 <roshi> works for me
16:53:04 <jreznik> ok, still systemd bugs are the hard ones, but we will see
16:54:01 <Viking-Ice> so have we somehow magically moved this meeting to a blocker bug meeting
16:54:17 <jreznik> well, topic is status :D
16:54:37 <adamw> i'm trying to follow the agenda i wrote :P
16:54:40 <adamw> we're about done with it now
16:54:48 <adamw> 5 minutes of open floor then blocker review meeting time, sound goo?
16:54:50 <adamw> or good
16:54:56 <Viking-Ice> yeah
16:54:59 <jreznik> sure, goo
16:58:33 <adamw> #topic open floor
16:58:38 <adamw> sorry, forgot...anyone have anything?
17:00:19 <adamw> alrighty
17:00:30 <adamw> blocker review meeting should be starting up in #fedora-blocker-review shortly - see you folks voer there
17:00:33 * adamw sets quantum fuse
17:00:54 <adamw> thanks for coming, folks!
17:01:10 <adamw> #endmeeting