15:00:29 <adamw> #startmeeting Fedora QA meeting
15:00:29 <zodbot> Meeting started Mon Jul 28 15:00:29 2014 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:33 <adamw> #meetingname fedora-qa
15:00:33 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:36 <adamw> #topic Roll call
15:00:39 <adamw> ahoyhoy rolls
15:00:46 <adamw> you're being called
15:00:55 * mkrizek lurks
15:01:21 * kparal is here
15:01:42 * nirik is lurking around in the back
15:01:46 * satellit listening
15:02:04 <adamw> nirik: too bad, this week i anticipated you and put the back in the front
15:02:20 <nirik> dho! no wonder everything looks so up close.
15:02:38 * Southern_Gentlem lurking
15:02:41 * roshi is here
15:04:12 <adamw> morning morning
15:05:10 <adamw> alrighty then
15:05:17 <adamw> #topic Previous meeting follow-up
15:05:48 <adamw> #info "adamw to ask abrt devs about the journalctl bug seen by Robert Day" - I did dig into it a bit and appended to https://bugzilla.redhat.com/show_bug.cgi?id=1043670 , the bug's still outstanding, though
15:06:16 <adamw> #info "adamw to contact Product WGs and ask them to specify maximum images sizes (in their tech specs or elsewhere) for https://fedoraproject.org/wiki/QA:Testcase_Mediakit_ISO_Size to refer to" - whoops, I've completely forgotten that. let's put it back on the list
15:06:22 <adamw> #action adamw to contact Product WGs and ask them to specify maximum images sizes (in their tech specs or elsewhere) for https://fedoraproject.org/wiki/QA:Testcase_Mediakit_ISO_Size to refer to
15:06:35 <adamw> i think that's all, anything else?
15:06:56 <roshi> looks like it to me
15:07:38 <adamw> mooooooooooving on
15:07:50 <adamw> #topic Fedora 21 status
15:08:05 <adamw> ah yes, fedora 21 status.
15:08:08 <adamw> well...not great.
15:08:35 <adamw> we still don't have an official TC; a dry run for TC2 was built and uploaded but it's pretty incomplete.
15:08:39 <adamw> nirik: any news there?
15:08:58 <nirik> not from me.
15:09:14 <nirik> dgilmore was traveling, he should be back online today I think tho
15:09:21 * satellit testing in VB f21 boot.iso 0726 works
15:09:53 <adamw> thanks for soldiering on with the nightlies satellit
15:11:03 * satellit looks like f21 KDE live x86_64 works from todays 21.48.1.1
15:11:08 <adamw> i believe we still have the live image compose issue and the selinux labeling issue outstanding, we should really try and look into those a little harder
15:11:14 <adamw> nirik: do you know what else is causing compose issues?
15:11:37 <nirik> I'm not sure. I was out all last week doing datacenter work, so I couldn't follow the doom.
15:12:12 <adamw> heh.
15:12:21 <adamw> well, invoking dgilmore doesn't seem to be working
15:12:35 <adamw> but i guess we really want to make getting a viable TC out as pre-Flock priority #
15:12:36 <adamw> but i guess we really want to make getting a viable TC out as pre-Flock priority #1
15:12:50 <nirik> it would be nice to have one, yeah
15:14:57 <adamw> #info multiple issues (at least SELinux labeling and Workstation image compose fail) still affecting F21 Alpha TC compose. let's try to help get a viable TC built before Flock
15:15:46 <satellit> I am not needing to use enforcing=0 in 21.481-1 lives and boot.iso
15:16:01 <satellit> 21.48.1-1 *
15:16:09 <adamw> satellit: the mislabeling of lives seems to be somewhat random; sometimes it happens, sometimes it doesn't. it's not an installer issue
15:16:18 <satellit> k
15:16:30 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=1121301
15:17:48 <adamw> #topic Taskotron deployment
15:18:04 <adamw> so i believe we're in staging now, but there's a couple of unexpected obstacles for production
15:18:05 <adamw> ?
15:18:44 <kparal> I guess so. but resultsdb is not working anywhere at the moment
15:18:52 <kparal> I'm afraid it's going to have to wait for tflink
15:19:03 <kparal> we're not yet raptor-proof in that area
15:19:21 <roshi> reducing the bus factor is one of the higher priorities I think :)
15:19:26 <kparal> even though mkrizek is trying to learn all that stuff
15:20:03 <kparal> mkrizek: do you have any details?
15:20:16 <mkrizek> nope
15:20:35 <adamw> always look out for raptors driving buses
15:20:46 <roshi> those are the worst
15:20:59 <roshi> they never signal properly
15:23:09 <adamw> it's those dinosaur arms
15:23:33 <adamw> #info taskotron is now in staging, but production deployment may take longer than expected, resultsdb is waiting on tflink to return from travelling
15:23:47 <kparal> the development will slow down considerably now, because tim and josef are on vacation, then flock, then another vacation
15:24:38 <adamw> goddamnit, no vacations for anyone ever.
15:25:09 <adamw> anyone aware of any other f21 stuff we should be monitoring / taking care of?
15:25:32 <roshi> nothing really comes to mind
15:25:54 <satellit_e> wish boot.iso for f21 was always available and the dashboard had live for f21 and rawhide
15:26:29 * satellit_e now it only lists live for most recent in koji
15:28:25 <adamw> satellit: as the whole tree gets re-generated, keeping boot.iso when creating it fails in a given run is apparently hard
15:28:32 <nirik> satellit_e: on the dashboard can you file a ticket on it? (threebean is out this week)
15:28:41 <satellit_e> ok
15:28:57 <adamw> i actually already asked him and i think he thought he'd already done it
15:29:01 <adamw> but obviously it's not completely working...
15:29:31 <nirik> https://github.com/fedora-infra/fedora-releng-dash/issues
15:29:35 <satellit_e> but it is not created in http://dl.fedoraproject.org/pub/fedora/linux/development/21/x86_64/os/ I thin it is turned off
15:29:44 <satellit_e> think*
15:29:50 <nirik> it's not off, it's just failing. ;)
15:29:57 <satellit_e> ok
15:30:42 <adamw> satellit: each night the tree is built. boot.iso compose is attempted as part of that. if the compose fails for whatever reason, that day's tree has no boot.iso, and you have to wait for the next day.
15:31:02 <satellit_e> ok understand
15:31:19 <nirik> there's some weird yum errors... can try and investigate in my copious spare time. ;)
15:31:29 <nirik> http://koji.fedoraproject.org/mash/branched-20140728/logs/pungify-x86_64.log
15:31:36 <danofsatx-work> I'm here, but busybusybusy
15:32:06 <nirik> may be related to signing... ;( I guess I should stop trying to keep up with signing.
15:32:18 <adamw> nirik: you do that ;)
15:32:45 <adamw> #topic Flock
15:32:55 <adamw> so, obviously we have Flock coming up: http://flocktofedora.org/
15:33:14 <adamw> amita sharma will be doing a QA presentation there, which I need to review...
15:33:29 <adamw> roshi: did we get enough budget for you to go? i forget.
15:33:51 <roshi> I couldn't make those days
15:33:58 <adamw> oh, right. well, boo.
15:33:59 <roshi> so never asked for budget :)
15:34:18 <adamw> we have several folks attending, anyway - me, tflink, kparal, and i'm not sure who else, most of the brno folks?
15:34:28 <kparal> all of us
15:34:47 <adamw> yay
15:35:08 <adamw> we'll obviously take the chance to sync up on f21, with releng and whoever else is there
15:35:22 <adamw> kparal: who's giving talks?
15:35:56 <kparal> we don't have any own talks, sorry about that
15:36:28 <kparal> we're the free riders
15:36:29 <adamw> ah, well. i'm doing one on UEFI
15:36:30 <adamw> hehe
15:36:59 <kparal> I assume we'll help Tim with taskotron workshop
15:37:01 <adamw> so yeah, i guess the aim will be mostly to try and kickstart f21 and sync up with .next folks to fill out process issues and so on
15:37:08 <adamw> yup, and taskotron
15:38:14 <amita> adamw, oh meeting started
15:38:21 <adamw> amita: yup, sorry :)
15:38:23 <amita> everytime I calculate the wrong time :(
15:38:36 <adamw> amita: i'll try and look at your presentation this week...otherwise are you ready for flock?
15:38:49 <amita> adamw, you are there .. So I am ready
15:39:07 <amita> I just need to point the audience to right monkey ;)
15:39:12 <amita> adamw, ;)
15:40:42 <adamw> hehe
15:40:56 <adamw> well, make sure i'm not too hungover to show up, as well
15:41:05 <adamw> thanks for volunteering to do the talk
15:41:20 <adamw> allllrighty...i guess that's it for flock, unless i missed anything?
15:41:26 <amita> adamw, hehe your welcome
15:41:40 <amita> I want to know who all are coming from QA?
15:41:49 <amita> adamw, you and
15:41:57 <danofsatx-work> Sorry, I can't afford it - monetarily or timewise.
15:41:58 <adamw> amita: see up a bit - me, tflink, and the whole brno office
15:42:15 <adamw> i don't think many non-RHers unfortunately, a lot of our volunteers are in north america atm and it's a long trek
15:42:28 <danofsatx-work> company won't pay (this year), and my school schedule is too full.
15:42:37 <amita> adamw, ah ok
15:43:15 <amita> my talk is for a person who wants to contribute in QA and does not know much about it
15:43:41 <amita> adamw, I would appreciate if you can review it early this week so that I can incorporate the comments
15:44:05 <adamw> ah, handsome_pirate will be there, it looks like
15:44:10 <adamw> amita: will do for sure
15:44:17 <amita> adamw, ok
15:44:35 <amita> thanks :)
15:45:09 <adamw> alrighty, moving on
15:45:12 <adamw> #topic Open floor
15:45:16 <adamw> any other business, folks?
15:45:23 <brunowolff> The fix for https://bugzilla.redhat.com/show_bug.cgi?id=1115120 hit a snag.
15:45:33 <adamw> i know it kinda sucks that we don't have f21 to test, sorry :( and thanks for hanging on and trying nightlies, satellit and danofsatx etc
15:45:39 * adamw reads
15:45:41 <brunowolff> It turns out that the patch that fixes cryptsetup, breaks bluetooth.
15:46:20 <adamw> yeah, i see that :/
15:46:48 <adamw> it is an alpha blocker, so it does need to be fixed one way or another, do remind folks of that if it seems necessarsy
15:47:10 <brunowolff> I think Josh is aware of the importance.
15:47:24 <adamw> cool.
15:47:30 <adamw> thanks for the heads-up
15:47:45 <adamw> #info fixing Alpha blocker https://bugzilla.redhat.com/show_bug.cgi?id=1115120 is turning out to be tricky, but jwb is on it and brunowolff is monitoring
15:52:55 <adamw> welp, sounds like that's the lot
15:53:05 * adamw lights the quantum fuse
15:53:15 <danofsatx-work> to boom or not boom.....
15:54:07 <roshi> you know when a quantum fuse finishes because a netsplit happens somewhere on freenode
15:57:20 <adamw> also, kittens.
15:58:11 <roshi> wait - kittens *happen* or something happens *to* kittens?
15:58:32 <danofsatx-work> yes.
16:01:28 <adamw> also yes.
16:04:37 <adamw> thanks for coming, folks!
16:04:39 <adamw> #endmeeting