15:00:32 <adamw> #startmeeting Fedora QA meeting
15:00:32 <zodbot> Meeting started Mon Oct  6 15:00:32 2014 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:36 <adamw> #meetingname fedora-qa
15:00:36 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:38 <adamw> #topic Roll call
15:00:43 <adamw> ahoyhoy, QA folks, who's around for meeting fun?
15:01:01 * satellit listening
15:01:11 * pwhalen is here
15:01:14 * randomuser idles around, why not
15:02:08 <adamw> #action randomuser document all the things
15:02:26 <adamw> #undo
15:02:27 <zodbot> Removing item from minutes: ACTION by adamw at 15:02:08 : randomuser document all the things
15:02:28 * roshi is here
15:02:32 * randomuser chuckles
15:03:01 <adamw> #chair satellit roshi
15:03:01 <zodbot> Current chairs: adamw roshi satellit
15:03:19 <kparal> oh, meeting
15:03:22 * kparal is here
15:05:06 <adamw> hi kparal
15:05:25 <adamw> alrighty, let's go for it
15:05:29 <adamw> #topic Previous meeting follow-up
15:06:17 <adamw> #info "adamw to start F21 Common Bugs page, help would be welcome, ping adamw for details" - that's up and running, https://fedoraproject.org/wiki/Common_F21_bugs , many thanks to bitlord and pwhalen for helping out
15:07:00 <adamw> #info "adamw to ensure 21 Alpha release announcement has note about network install behaviour" - I wrote that in, it's part of the intro to the Products in https://fedoraproject.org/wiki/F21_Alpha_release_announcement
15:07:13 <adamw> "roshi and pwhalen to update ARM Test Day page" - roshi, pwhalen?
15:07:53 <pwhalen> adamw, still working on when it'll be rescheduled to. Peter is working on uboot and expect to rebase soon
15:07:56 <roshi> the arm folks decided to push the testday
15:08:04 <roshi> what pwhalen said :)
15:08:13 <adamw> #info "roshi and pwhalen to update ARM Test Day page" - new date for the event is still yet to be decided
15:08:17 <pwhalen> we did, the test day needs to happen when we have the latest uboot added to f21
15:08:27 <roshi> we'll tackle it as when it gets scheduled
15:08:31 <pwhalen> to determine newly enabled boards, functionality
15:08:51 <adamw> sounds good
15:09:09 <pwhalen> work is almost done, then it'll move to f21, we'll schedule the test day
15:09:11 <adamw> #info ARM Test Day will happen once latest uboot is integrated into F21
15:09:50 <adamw> moving swiftly on, as we have a packed agenda today...
15:09:52 <adamw> #topic Fedora 21 Beta status
15:10:10 <adamw> TC1 is out and folks have been testing it, TC2 is coming
15:10:54 <adamw> the blocker list is fairly long and we may need to start poking folks soon: https://qa.fedoraproject.org/blockerbugs/milestone/21/beta/buglist
15:11:39 <roshi> well, at least we don't have 25 to go through on wednesday
15:11:59 <adamw> the Product-y network install image issues still haven't been clearly resolved, i sent a poke email out about that recently
15:12:08 <adamw> anyone have any other Beta status notes/queries/concerns?
15:12:11 <randomuser> !
15:12:18 * danofsatx-dt is here, fighting USB bus lockups
15:12:22 <randomuser> Is the fedup situation considered a blocker?
15:13:21 <adamw> randomuser: https://bugzilla.redhat.com/show_bug.cgi?id=1099299 is on the blocker list
15:13:32 <randomuser> I'll read, thanks
15:13:41 <adamw> danofsatx: ahoy, i recommend getting the USB engine serviced...
15:15:13 <randomuser> adamw, I was referring more to the relationship of fedup to products, but I'm watching the discussion and we don't need to spend meeting time on it for my sake
15:15:46 * jreznik is around, thanks kparal for reminder :)
15:15:51 <adamw> randomuser: i believe sgallagh (iirc) is going to draft a criterion for the specific requirements for Product-y stuff to happen on upgrade
15:16:02 <adamw> as things stand the criteria are basically that upgrades have to *work*
15:16:21 <jreznik> randomuser: well, upgrade is fun, especially as some folks propose to have productized updates for beta...
15:16:23 <adamw> #info TC1 is out and in testing, TC2 is coming soon, blocker list is fairly long - all work towards getting blockers resolved would be welcome
15:16:37 <sgallagh> adamw: I sent a proposed version to the QA list on Friday, didn't I?
15:17:04 <adamw> sgallagh: it's not in my test@ folder, was it cross-posted?
15:17:19 <sgallagh> Oh, crud. I think I sent it to QA@
15:17:34 <adamw> i don't think that list exists :)
15:17:44 <sgallagh> Yeah; I wonder why it didn't reject it
15:17:56 <adamw> it's the secret qa cabal!
15:17:59 <adamw> viking-ice was right all along
15:18:36 <adamw> okey dokey, so we can look forward to that criterion for review
15:18:51 <adamw> #topic Release validation revisions
15:19:14 <adamw> just wanted to throw on a topic to note the changes i made to the release validation stuff and make sure there aren't any problems with it
15:19:23 <sgallagh> adamw: I'll dig it out of my sent-mail folder and send it along presently
15:19:27 <adamw> thanks sgallagh
15:20:07 <adamw> i've tweaked the layout of all the validation results tables - most obviously Installation, but all the others are full-width and collapsible and have references outside the tables and no hardcoded widths now too
15:20:35 <adamw> https://stg.fedoraproject.org/wiki/Test_Results:Fedora_21_Beta_TC1_Summary is sort of how they'll look for TC2 (but with more actual...results)
15:21:06 <roshi> for the record, the fix adamw came up with is pretty awesome, IMO
15:21:24 <adamw> the summary page is also new
15:21:46 * satellit nice
15:21:53 <adamw> i worry a bit that the template magic might not be quite raptor-proof, did anyone else follow how that all works or should i be extra careful for raptors?
15:22:28 <roshi> be careful of raptors
15:22:40 <adamw> hah, okay.
15:23:20 <adamw> you can *drive* it all pretty easily with relval, it knows all the right things to do, and adding new test cases to an existing matrix page (like https://fedoraproject.org/wiki/Template:Installation_test_matrix ) doesn't need any special sauce, just...add it
15:23:25 <roshi> I *kinda* know what you did, but I don't know if I could reproduce it easily if it all died
15:25:23 <adamw> adding a new test type is basically adding a new matrix template in the same naming style and as a member of the category - there isn't *much* special sauce in those pages, the <onlyinclude> tags just surround the content that will appear on the actual results pages, and i'm using integer numbers as category 'sort keys' (the bit after | in the category membership) to control how the summary pages are ordered when created by relval
15:25:46 <adamw> that's why installation has [[Category:QA_test_matrix_templates|00]] , Desktop has [[Category:QA_test_matrix_templates|04]]  etc
15:26:19 <adamw> and again you can edit the content in the 'validation instructions' template without worrying too much about how it works
15:26:38 <adamw> most of the magic is in the glue that makes an actual complete result page appear when you chant the right invocation with the right chicken
15:27:08 <kparal> the summary page is pretty cool
15:27:28 <adamw> so yeah, if anyone wants to become my Mediawiki Syntax Acolyte and learn how it all works i'd be happy to instruct :)
15:27:30 <tflink> bah, not watching the time. sorry for being late
15:27:34 <adamw> ahoy tflink
15:27:44 <adamw> kparal: yup, thanks to roshi for the idea
15:27:51 <adamw> don't know why we never thought of it before
15:28:46 <kparal> I guess I'll not use anything else than the summary page from now on
15:28:55 <roshi> I didn't think it would be possible :)
15:28:56 <adamw> i find it kind of long, but it's all in your preference
15:29:02 <roshi> you can walk me through it adamw
15:29:07 <adamw> it's nice that you can use either approach
15:29:18 <adamw> roshi: sounds good, let's try and find a quiet afternoon or something to work through it this week
15:29:22 <roshi> if we both get attacked by raptors at the same time, the world has bigger issues than our wiki
15:29:25 <adamw> haha
15:29:28 <roshi> works for me
15:29:34 <pwhalen> agreed, easier than having them open in tabs
15:29:35 <kparal> adamw: is there a redirect to Current Summary page?
15:29:35 <adamw> co-ordinated cross-continent raptor attacks...nooooo
15:29:54 <roshi> there goes the whole western NA seaboard...
15:29:57 <adamw> kparal: i don't recall if i set one manually for TC1, but relval will handle it from TC2 onwards
15:30:13 <kparal> awesome. where will I find the link?
15:30:35 <kparal> in the announcement, probably
15:31:26 <adamw> kparal: yeah, i'll work with robatino on the TC2 update to make sure it reflects changes
15:31:39 <kparal> thanks
15:31:49 <adamw> the page name will be "Test Results:Current Summary"
15:33:00 <adamw> #info all validation changes should be live for TC2, please report any issues on list
15:34:16 <adamw> #topic Fedora 21 Change testing status
15:34:31 <adamw> so one thing we didn't look at very hard for F21 is testing Changes
15:34:42 <adamw> in general we put less focus on this than i think we did for older releases
15:35:08 <adamw> obviously we don't have time for everything :/ but i thought now might be a good time to see if we're particularly concerned about any F21 Changes that we haven't done formal testing for
15:35:24 * handsome_pirate stumbles in late
15:35:29 <adamw> ahoy pirate
15:35:40 <adamw> we're just getting onto F21 Changes
15:35:47 <adamw> https://fedoraproject.org/wiki/Releases/21/ChangeSet is the list of accepted changes for F21, it's, er, long
15:36:00 <handsome_pirate> Sorry, folks, my sleep schedule has gotten out of sync from when I'd like it
15:36:55 <adamw> roshi: are you in the loop on the 'periodic updates to cloud images' thing?
15:37:01 <roshi> yeah
15:37:11 <roshi> it's being hammered out with releng
15:37:12 <jreznik> adamw: I'll be pinging for updates now
15:37:21 <adamw> roshi: is there a plan for testing it?
15:38:07 <roshi> smoke tests and running through the validation matrices for the new image
15:38:25 <roshi> that's something I'm working on with agrimm going forward
15:38:39 <roshi> and taking some of the tests oddshocks has in fedimg
15:40:09 <adamw> OK, sounds good
15:40:17 * adamw wonders about https://fedoraproject.org//wiki/Changes/PrivateDevicesAndPrivateNetwork , that one might be worth checking into
15:40:22 <adamw> "Just use the system as usual. If everything works as before then everything is good. " is not a test plan
15:40:35 <adamw> (we might want to talk to FESCo about accepting stuff like that as the 'how to test' section in future)
15:41:44 <handsome_pirate> roshi:  Will the cloud folks be supplying some warm bodies to help with the testing?
15:41:50 <adamw> i think the other possibly-sensitive changes will mostly get tested as part of release validation...
15:42:02 <roshi> yeah
15:42:06 <roshi> they will handsome_pirate
15:42:07 <handsome_pirate> Cool
15:42:21 <roshi> in fact we just got a full timer to work on it, aiui
15:43:01 <adamw> yay
15:45:01 <adamw> ok, anyone else see anything of concern while scanning the Change list?
15:45:16 <adamw> a lot of the 'recompile with X' things got done quite a while ago so they shouldn't have unknown consequences now
15:46:08 <roshi> there are plenty of changes there
15:46:16 <adamw> this is a true thing.
15:47:02 * nirik has something to mention in open floor when you get to it.
15:47:07 <adamw> let's motor on, then!
15:47:13 <adamw> #topic Taskotron status
15:47:25 <adamw> wanted to do a quick check-in on this as we haven't for a bit
15:48:06 <adamw> where's taskotron at?
15:48:18 <handsome_pirate> I think waiting on me
15:48:37 <tflink> we're waiting on a few fixes
15:48:46 <tflink> one is being reviewed, handsome_pirate is working on the other
15:49:06 <tflink> the current plan is to get stuff deployed tomorrow and decide on thursday whether or not to turn off autoqa
15:49:08 <handsome_pirate> Once I figure out a tap output problem, my work will be ready for review
15:49:52 <adamw> so, that's where we are regarding production deployment, right?
15:49:58 <tflink> there are some other bits that need to be finalized (monitoring, backup verification)
15:50:00 <tflink> yep
15:50:17 <adamw> #info we plan to deploy taskotron to production tomorrow (all appendages crossed) and then consider whether to turn off autoqa
15:50:27 <adamw> what's handsome working on?
15:50:33 <tflink> making depcheck more readable
15:50:56 <adamw> ah, right, what i was moaning about
15:51:52 <adamw> any interesting progress to report in other areas, or has all the work been on getting it to deployment?
15:52:12 <tflink> there has been some progress on our next big deliverable - disposable clients
15:52:16 <tflink> it's all still early, though
15:52:38 <roshi> was it decided to go with openstack or something else for that?
15:52:47 <tflink> still doing the investigation on that
15:53:02 <roshi> cool
15:54:04 <adamw> #info work continues on disposable test clients, but it's still at an early stage
15:54:14 <tflink> right now, teh priority is production before we hit freeze
15:54:14 <adamw> alrighty, thanks taskotron folks, good work getting (nearly) to deploymnet!
15:54:27 <tflink> once we hit freeze, we'll go back more to new features
15:54:45 <tflink> but the remaining question is whether or not to turn off autoqa right before freeze
15:55:03 <tflink> ie, how conservative to be
15:55:12 <adamw> eh, this is fedora, turn it off already!
15:55:44 <adamw> who's making that call, and how?
15:56:59 <adamw> well, let's move on then, want to get to open floor for nirik
15:57:00 <tflink> unless other folks are interested, it'll be the qadevel folks
15:57:03 <adamw> OK.
15:57:23 <adamw> remember we have limited 'enforcement' of autoqa in bodhi at present, so maybe sync up with releng/fesco about that
15:57:31 <adamw> #topic Open floor
15:57:35 <adamw> what'd you have for us, nirik?
15:57:42 <tflink> oh yeah, forgot about that
15:57:44 <nirik> tflink: did you see that one post on devel about autoqa being weird?
15:57:55 <tflink> nirik: no, I haven't looked at devel@ yet today
15:57:59 <tflink> thanks for the heads up
15:58:21 <nirik> adamw: just wanted to note to qa folks that releng is working on a setup for 'urgent' updates... https://fedoraproject.org/wiki/Urgent_updates_policy is the draft. Input from qa on how to test, etc welcome
15:58:31 <adamw> aha, thanks for the info
15:58:46 <adamw> #info releng is working on an 'urgent update' policy, and welcome input/review. draft is at https://fedoraproject.org/wiki/Urgent_updates_policy
15:58:51 <adamw> feedback to...mailing list?
15:58:53 <nirik> of course this is all early and has to go to fesco once we have things more fleshed out, etc.
15:58:58 <nirik> sure.
16:00:01 <adamw> so this would be about shipping stuff like the bash bug fix faster
16:00:04 <adamw> right?
16:00:05 <nirik> yep.
16:00:16 <adamw> cool.
16:00:18 <nirik> or openssl, etc.
16:00:22 * kparal needs to go
16:00:25 <adamw> alrighty, if folks can check that over and give feedback it'd be great
16:00:28 <adamw> cya kparal!
16:00:32 <adamw> any other business for open floor?
16:01:35 * roshi has nothing
16:01:51 <adamw> .fire roshi
16:01:51 <zodbot> adamw fires roshi
16:02:06 <handsome_pirate> There is the subject of QA bacon at the next Fedora shindig
16:02:15 <roshi> .fire adamw for not providing a reason for the firing
16:02:15 <zodbot> adamw fires adamw for not providing a reason for the firing
16:02:21 <handsome_pirate> lol
16:02:25 <adamw> .fire roshi
16:02:25 <zodbot> adamw fires roshi
16:02:36 <adamw> #agreed bacon
16:02:37 <handsome_pirate> .fire handsome_pirate for not remember bash
16:02:38 <zodbot> adamw fires handsome_pirate for not remember bash
16:03:08 <roshi> .fire zodbot for mindlessly following orders
16:03:09 <zodbot> adamw fires zodbot for mindlessly following orders
16:03:23 <adamw> this just in: i was ordered to fire roshi
16:03:25 <adamw> .fire roshi
16:03:25 <zodbot> adamw fires roshi
16:03:38 <handsome_pirate> lol
16:03:44 <adamw> alrighty folks, if anyone's still got a job...thanks for coming :)
16:03:52 <roshi> lol
16:04:12 <adamw> TC2 should be showing up soon, let's get some testing done and poke some blockers
16:04:16 <handsome_pirate> adamw:  If you fire me, does that mean I don't have to work on depcheck today?
16:04:35 <adamw> handsome_pirate: it means you have to work harder.
16:04:53 <roshi> nah, adamw firings are merely meant to make you feel bad getting you to work harder :p
16:05:08 <roshi> I got fired within a week of being hired
16:05:13 <danofsatx-dt> if TC2 were done an hour ago, I'd be testing it right now. but as it is....I'm booting TC1....
16:05:15 <roshi> perhaps before, even
16:05:17 <adamw> i don't know why he keeps showing up.
16:05:30 <roshi> lol
16:05:33 <adamw> danofsatx: all testing is good testing :)
16:05:40 <roshi> well, you get fired too and you're still here
16:05:43 <danofsatx-dt> 'cuz nobody took his red stapler yet
16:05:50 <handsome_pirate> roshi:  I got fired for getting hired by Red Hat
16:06:00 <roshi> and we were told not to talk about the chains keeping us at our computers
16:06:01 <handsome_pirate> Community involvement numbers or some such
16:06:10 <roshi> lol
16:06:38 * handsome_pirate puts on some banjos and slaves on depcheck
16:06:56 <adamw> =)
16:06:59 <adamw> thanks again, everyone
16:07:01 <roshi> thanks for running the meeting adamw
16:07:02 <adamw> #endmeeting