15:03:48 <adamw> #startmeeting Fedora QA meeting
15:03:48 <zodbot> Meeting started Mon Aug 17 15:03:48 2015 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:53 <adamw> #meetingname fedora-qa
15:03:53 <zodbot> The meeting name has been set to 'fedora-qa'
15:03:56 <adamw> #topic Roll Call
15:04:02 <adamw> morning folks! who all else is here?
15:04:18 * tflink is around
15:04:21 * satellit listening
15:04:30 <kparal> hi there
15:05:10 * kparal pokes pschindl
15:05:44 <adamw> try the whip
15:06:41 <adamw> welp, that should be enough to get started
15:06:47 <adamw> #topic Previous meeting follow-up
15:06:48 * pschindl is here
15:07:14 <adamw> I'm seeing no actions from previous meeting, so that's OK
15:07:18 <adamw> #info no actions from previous meeting
15:07:30 <adamw> #topic Flock outcomes
15:08:13 <adamw> I figured those of us who were both at Flock and here can give those of us who weren't at Flock but are here (and those who weren't at Flock and aren't here, via the minutes...) an idea of what went on and what future directions we got out of it
15:08:25 <adamw> sound cool? any specific questions before we start?
15:08:53 * kparal reads the sentence for the third time
15:09:17 * adamw continues his campaign to write for The Times in 1863
15:09:28 <adamw> me and tim are gonna tell y'all what happened at flock
15:09:29 <adamw> how's that?
15:09:49 <kparal> great
15:09:53 <adamw> =)
15:10:08 <adamw> so anything in particular anyone wanted to ask?
15:10:37 <kparal> are we changing to the BSD kernel?
15:11:23 <adamw> no, we decided on the hurd.
15:11:30 <kparal> yay
15:11:46 <adamw> also, we'll be rewriting all tools in PHP with a lesstif GUI
15:12:21 <kparal> I'm afraid any further news can't beat that
15:12:23 * tflink waits for phoronix article saying "fedora cannot tolerate more insults, moves to hurd and starts to rewriting tooling in php"
15:12:28 <adamw> =)
15:13:15 <kparal> any other big change decisions made on flock?
15:13:35 <adamw> not really
15:13:46 <adamw> this wasn't one where there was a 'big' idea like Fedora.next
15:14:18 <adamw> there was some discussion on moving forward the rings concept in some sense, and we all bailed on that in 20 minutes because oh god life's too short, but from what I heard after there weren't really any big decisions made
15:15:11 <kparal> anything QA specific?
15:15:38 <tflink> bodhi 2.0 is coming on Wednesday
15:15:43 <adamw> right
15:15:46 <tflink> changes to both blockerbugs and libtaskotron are needed
15:16:00 <adamw> well, allegedly. we have our suspicions as to whether they'll make it. but definitely soon
15:16:13 <tflink> the client was just released this morning
15:16:20 <tflink> i can confirm that blockerbugs noworky with the new bits
15:16:28 <adamw> there was an amusing point where lmacken was like "oh no, blockerbugs won't need any changes, it's totally cool...(looks at code for 20 minutes)...okay, so blockerbugs needs changes"
15:16:33 <kparal> I'll play with it tomorrow. is that an update to python-fedora, or a new package?
15:16:51 <tflink> the git repo is updated, threebean did a scratch build for el7 and rawhide
15:16:57 * tflink looks for links
15:17:21 <tflink> rawhide scratch build for new python-fedora: http://koji.fedoraproject.org/koji/taskinfo?taskID=10731280
15:17:38 <kparal> F22 build would be great
15:17:41 <tflink> el7 scratch build for new python-fedora: http://koji.fedoraproject.org/koji/taskinfo?taskID=10731255
15:17:53 <adamw> it's easy enough to grab the .src.rpm and fire an f22 scratch build...
15:18:02 * tflink is going to be busy working on blockerbugs today, will be asking for testers before long
15:18:16 * adamw has to spend some family time but will try to be around for testing at some points
15:18:22 <kparal> I'll try to rebuild, hopefully the deps will be satisfied
15:19:05 <adamw> there's also koji 2.0 coming at some point which might affect some things (it'll certainly affect fedfind), but the time scale on that is longer
15:19:21 <kparal> there's koji 2.0 in development? cool
15:19:33 <kparal> is it going to integrate taskotron as bodhi 2 does?
15:19:36 <adamw> http://sched.co/3rPn
15:19:58 <tflink> kparal: probably not, it's an update that mostly comes from the RH fork of koji AFAIK
15:20:08 <adamw> sure, i volunteered you to write it =) I don't know, that wasn't th focus of the talk. and yeah, it's coming from RH's fork, brew
15:20:19 <kparal> a bit off topic, are there recordings of flock talks somewhere?
15:20:30 <adamw> recordings were made, but i don't know if  they're up anywhere yet
15:20:31 <kparal> I didn't see any blogpost about it on fedora planet
15:20:34 <kparal> ok
15:20:41 <adamw> #info many Flock talks were recorded, but not sure if they were uploaded yet
15:20:58 <adamw> #info Bodhi 2.0 is planned to land this week and will require changes to blockerbugs and libtaskotron
15:21:11 <adamw> #action tflink to work on Bodhi 2.0 related tooling changes
15:21:22 <tflink> the patch to libtaskotron has been submitted, haven't looked at it in detail yet
15:21:58 <lmacken> adamw: blockerbugs needs changes because even though it uses the BodhiClient from python-fedora, it bypasses the query() method and just uses the underlying ProxyClient.send_request to hit the bodhi1 API endpoint directly ;(
15:22:10 * lmacken will submit a patch
15:22:46 <adamw> thanks
15:22:51 <kparal> tflink: submitted where? I haven't noticed anything in Phab
15:23:01 <tflink> kparal: pull request in bitbucket
15:23:05 <kparal> ah
15:23:13 <adamw> too...many...mechanisms...
15:23:15 <tflink> I didn't see it until lmacken told me about it, either
15:23:41 <kparal> yeah, too many mechanisms
15:23:55 <tflink> +1 for moving git repos into phab - no pull requests :)
15:23:57 <kparal> we'll need to do something about it in the future. thanks for mentioning it
15:24:09 <kparal> :)
15:25:09 <adamw> OK, so aside from that, the big thing i wound up talking about a lot was improving integration with releng particularly in the compose process
15:25:17 <kparal> tflink: that patch seems to affect only unreleased code - not even in dev yet
15:25:34 <tflink> kparal: move to #fedora-qa?
15:25:38 <kparal> ok
15:25:45 <adamw> thanks
15:27:18 <adamw> it definitely seems like everyone's thinking in the same CI-ish direction: i'd say the executive summary of the basic idea is we'll have nightly composes that look the same as TC/RC composes, better metadata and fedmsg messages from the compose process, and that'll allow some form of gating using our existing automated test stuff
15:27:38 <adamw> there was similar talk about improving the loop between releng and the taskotron depcheck test, for repo composes
15:28:23 <tflink> yeah, that seems like some relatively low-hanging fruit that'll help a lot
15:28:43 * tflink has a lot of tickets to file from Flock
15:29:03 <adamw> so far as the compose stuff goes, my basic read was that in a lot of ways we're waiting on the new pungi, which implements the 'nightlies look like real composes' and 'better metadata' stuff
15:29:17 <tflink> the idea is to run depcheck on the rawhide buildroot's repodata every time that changes (~ every 6 minutes) and check for borked repotrees
15:29:38 * Corey84 peeks in
15:29:42 <adamw> hi corey!
15:29:48 <Corey84> o/
15:29:53 <adamw> don't let all the tooling talk scare anyone off, we'll have other topics in a bit :)
15:30:16 <adamw> tflink: yeah, i think that's something we can sensibly do right now and should really try
15:30:21 <Corey84> adamw,  I need to learn that too its all good
15:30:45 <Corey84> 6 minutes  that  seems  quick
15:30:54 <tflink> adamw: yep, agreed. jskladan and I talked a bit about how to easily do that before we left Rochester
15:31:19 <adamw> Corey84: people do Rawhide builds *all the time*. so every few minutes, koji runs a task that updates the buildroot with the latest finished build
15:31:24 <tflink> the current plan is to do it a bit hacky for now to see if it's useful. if it is indeed helpful, we'll work on making that change less hacky
15:31:37 <adamw> Corey84: so if you want to build a new library version then rebuild all its deps, you don't have to wait a day for the new library build to land first
15:32:04 <adamw> Corey84: the idea is that instead of only doing depcheck daily when the actual repo compose happens, we do it for every run of the buildroot generation instead
15:32:05 <Corey84> makes sense but  lordy
15:32:29 <Corey84> like   a  --ref  on dnf update on a  "stable"   install
15:32:30 * tflink shrugs - that's what automation is for :)
15:32:35 <adamw> tflink: and then ten years from now we'll read the comment that says # we're going to make this less hacky next week if it's useful
15:32:39 <Corey84> lol
15:32:44 <tflink> adamw: pretty much, yeah
15:32:47 <adamw> =
15:32:49 <adamw> =)
15:33:04 <tflink> but it's either the hacky bits or wait until disposable clients are done
15:33:09 <adamw> hacky bits it is!
15:33:24 <Corey84> disposable  clients ?   the  buildroots?
15:33:47 <tflink> Corey84: disposable clients for taskotron
15:33:49 <adamw> #info For Rawhide, we will aim to have depcheck run on every buildroot generation task instead of daily on the repo composes, so we can see when things break faster and more precisely identify the culprits
15:34:22 <tflink> I'm hoping to have that in place in a few weeks - will depend on the fallout from bodhi2 and a few other things, though
15:34:30 <adamw> tflink++
15:34:30 <zodbot> adamw: Karma for tflink changed to 5:  https://badges.fedoraproject.org/tags/cookie/any
15:34:50 <tflink> yay! cookies!
15:35:07 <tflink> even if I suspect they were unintentional, never look a gift cookie in the mouth ...
15:35:10 <tflink> :-D
15:35:21 <adamw> =) no, not unintentional
15:35:56 <adamw> so, on the compose side of things, there's a lot of stuff i/we *could* do basically through fedfind
15:36:31 <adamw> fedfind already kinda exists as a fig leaf for all the inconsistencies in the compose process and I can add various bits to it to effectively figure out all the info we *ought* to be getting from releng
15:36:52 * tflink would love to see the output from a pungi4 run
15:37:05 <adamw> tflink: I've seen it somewhere and now i can't find the damn link
15:37:17 * tflink is asking releng
15:37:28 <adamw> dgilmore should have one though
15:37:41 <adamw> iirc there's a compose.json file with lots of useful info about what images the compose generated and where they are
15:37:58 <adamw> right now it's kinda incomplete because it doesn't include a lot of the images that are built in koji, but aiui they plan to fix that.
15:38:16 <adamw> basically, it does the stuff fedfind does, only from the correct end and hence far less stupidly.
15:38:55 <adamw> the other bit i'd like to have is composedb, at least as I understand it, which would cover the bit of fedfind that finds the actual composes.
15:39:35 <adamw> anyhow, yeah - tl;dr is we *could* do a bunch of stuff right now, but it'd all be somewhat hacky and probably need to be redone fairly soon anyway, so i'm not inclined to go *too* far down that path
15:40:20 <adamw> there are bits it makes more sense to work on, that maybe aren't as immediately visible but are more likely to be needed in the long term
15:40:46 <adamw> the specific thing i'm thinking of there is taskotron/openQA integration
15:41:19 <adamw> #info we could do various work around improving compose test integration already, but it'd all be hacky and need to be replaced with the new pungi, so we're inclined to wait on that
15:42:02 <tflink> on the taskotron front - folks seem excited about our plans around dist-git style tasks
15:42:17 <adamw> oh yeah, want to cover that before i talk taskotron/openQA integration?
15:42:35 <adamw> and indeed, people seemed to like the idea
15:42:36 <tflink> adamw: either way
15:42:56 <tflink> most of the other taskotron bits are somewhat low level
15:43:10 <adamw> OK
15:43:15 <adamw> is there anything really new-from-flock there?
15:43:22 <adamw> i got the impression flock business there was mostly evangelism
15:43:38 <tflink> yeah, there's a low level change that we'll be making soon
15:43:51 <tflink> it'll be significant to devs but other folks shouldn't notice
15:43:57 <tflink> to taskotron devs, rather
15:44:16 <tflink> we're planning ot go forward with ditching TAP
15:44:35 <adamw> ok
15:44:40 <adamw> maybe best for a qa-devel meeting, then?
15:44:43 <tflink> jskladan and I spent some time working out the new yaml-based format and writing out examples
15:44:44 <tflink> yep
15:44:58 <adamw> cool
15:45:24 * kparal noticed some of that already
15:45:40 <adamw> in fact openQA/taskotron integration is kinda similar, and we need to get to test days, so maybe i'll try and show up for a qa-devel meeting too or mail the list, if that's OK
15:46:01 * randomuser` talked to tflink about buildbot, has started epel7 packaging and identified a handful of deps that need packaging
15:46:06 <tflink> WFM
15:46:07 <adamw> very short version: we need an improvement to openQA before taskotron could schedule tasks in it (or a bad workaround), and i'm gonna try and work on that.
15:46:25 <adamw> in fact i already did, but didn't manage it yet. :)
15:47:47 <adamw> i'm also going to do some low-hanging work on compose stuff using the current process: basically i'm writing a thing that should generate a daily 'compose report' for Rawhide and Branched composes, listing significant missing images and images that have gone missing (or shown up) since the previous compose, and maybe some other interesting bits. it's not too hard or time-consuming so i figured it was worthwhile.
15:48:24 <adamw> oh! and there was one other flock thing I can think of - the talk from someone outside our team, that we weren't sure about
15:48:30 <adamw> 'mastering the art of open source testing', or something
15:48:53 <adamw> it turned out to be by a guy who does Mozilla testing, and he was basically outlining his personal approach to organizing exploratory testing
15:49:16 * Corey84 &
15:49:50 <adamw> he had some interesting ideas, and it's not an area we really focus on heavily, so it might be worth watching a recording (if there was one and it goes up), and/or his slides
15:50:01 <adamw> i'll try and find his slide deck and post it to the list later
15:50:19 <adamw> #action adamw to find slide deck from Flock 'exploratory testing' talk and post it to the list
15:50:39 <adamw> ok, anything else from flock before we move along?
15:52:32 <tflink> nothing I can think of, no
15:53:43 <adamw> rg
15:53:44 <adamw> rgr
15:53:58 <adamw> #topic l10n and NetworkManager test days
15:54:17 <adamw> so as a quick reminder - we have l10n (that's localization, basically translation testing) Test Day tomorrow, and NetworkManager Test Day on Thursday
15:54:36 <adamw> #info l10n Test Day is tomorrow 2015-08-18: https://fedoraproject.org/wiki/Test_Day:2015-08-18_L10N
15:54:48 <adamw> #info NetworkManager Test Day is Thursday 2015-08-20: https://fedoraproject.org/wiki/Test_Day:2015-08-20_NetworkManager
15:55:14 <adamw> I wanted to remind folks to come along and check if anything needed doing, and there's a more specific issue for the l10n Test Day too
15:55:43 <adamw> the l10n team have set up to use the 'testdays' webapp, but apparently that might be going away (or have gone away already) with the new cloud changes
15:55:52 <adamw> tflink?
15:56:11 <tflink> the old app is on the old cloud which was scheduled to go away a week ago or so
15:56:22 <tflink> if it's still up, I'm not sure how much longer that will be true
15:56:35 <tflink> we have a new testday app written but haven't gotten to deploying it yet
15:57:16 <adamw> it's still up at least *right now*
15:57:21 <adamw> if it makes it to tomorrow we'll be OK
15:57:23 <tflink> i think so, yes
15:57:36 * tflink doesn't know what the plans for killing off the old cloud are
15:57:45 <adamw> since it's still up right now, what i'll do as a backup plan is 'export' the wikicode right now so we can stick the empty tables back into the page and update the instructions if necessary
15:57:53 <tflink> last I heard, some bits of jenkins were blocking the kill-off process
15:58:01 <adamw> go jenkins!
15:58:05 <adamw> who would be involved in that process?
15:58:29 <adamw> #info l10n test day is set up to use the testdays webapp, which is living on an old cloud that will be going away soon (should have gone away already)
15:58:31 * tflink checks
15:58:48 <adamw> #action adamw to store the empty results wikicode for the l10n test day so we can fall back on manual result entry if necessary
15:58:58 * adamw has improved wikitcms to parse test day results, but not enter them yet :/
15:59:28 <tflink> i think nirik and pingou would know what's going on with jenkins and the old cloud
16:01:16 <adamw> OK, I stored the empty tables.
16:01:33 <adamw> i'll see if we can contact nirik/pingou later to see whether we'll get lucky
16:02:13 <tflink> i suspect that even if the decommissioning was planned for tomorrow, if we asked nicely it could be put off for a couple days
16:02:28 <tflink> but honestly, i think that people are pretty focused on getting bodhi2 ready for wednesday
16:02:34 <adamw> right
16:02:53 <adamw> so, other than that, any action items for the test days?
16:03:14 <adamw> l10n needed a live image, but it sounds like that's been built, might just need the page updating to link to if it hasn't been alreadyu
16:04:16 <tflink> at some point, we need to get the instance migrated to the new cloud
16:04:18 <kparal> pschindl built it, I uploaded it, apater said he will take it from there
16:04:34 <tflink> sorry, still thinking testdays app
16:05:18 <adamw> kparal: awesome
16:05:28 <adamw> tflink: what's the hold up with deploying the new one?
16:06:39 <apeter> thanks pschindl kparal :)
16:06:50 <tflink> adamw: spare cycles
16:06:55 <adamw> =)
16:06:58 <adamw> the usual answer
16:07:27 <tflink> i suspect that I'll be busy with blockerbugs and libtaskotron updating/testing for the next couple days
16:07:46 <tflink> we might be able to get it done later this week, not sure
16:07:53 * tflink didn't think it was a high priority
16:08:42 <adamw> no, not really, i was just curious
16:08:57 <adamw> i'd want to have *some* testdays app up, but having the old one up would be good enough.
16:09:16 <adamw> welp, we're nearly 10 mins over, so let's do a very quick:
16:09:18 <adamw> #topic Open floor
16:09:29 <adamw> any other business, folks? any Alpha stuff crop up while we were at Flock, or anything?
16:09:48 <kparal> I should probably not ask, but is there going to be a blocker bug meeting today?
16:10:07 <adamw> oh - for the record, Beta TC1 is scheduled for 08-25
16:10:45 <kparal> I haven't noticed any Alpha fires
16:10:46 <adamw> um. we do have blockers to review, but roshi's not around and I might suffer domestic violence if I sit here running meetings all day
16:10:50 <tflink> it sounded like roshi was planning on a meeting today
16:10:55 <adamw> oh, he is? funsies
16:11:01 * adamw may have to be absent for some/all
16:11:09 * satellit I have lockups with intel graphics in f23 workstation
16:11:16 <adamw> otherwise we could do it tomorrow or later in the week
16:11:25 <adamw> satellit: yep, we saw - sounds like the thing to do there is report an X or kernel bug.
16:11:26 * kparal is fine with that
16:11:33 <satellit> k
16:11:58 <adamw> we have 6 proposed beta blockers and 7 proposed final, so we should definitely do one.
16:12:07 <adamw> tflink: can you kick 'current' on blockerbugs over to beta?
16:12:16 <tflink> adamw: sure
16:12:23 <tflink> adamw: usual reminder that you have perms to do that, too
16:12:39 <adamw> usual reminder that i forgot :P
16:12:51 <tflink> so much forgetting
16:12:57 <tflink> we're obviously not elephants
16:13:12 <adamw> i'm sure it was nothing to do with that bottle of freeze exception
16:13:32 <tflink> because we're dwarfs digging for gems in a mountain
16:13:51 <adamw> oh god yes, the dwarf mountain
16:13:54 <adamw> wwoods needs to write a book
16:14:20 <adamw> alrighty, we're over time, so setting a very short quantum fuse
16:14:23 <adamw> thanks for coming, folks!
16:14:33 <apeter> am sorry I just saw the l10n testdayapp discussion (late for the meeting :(). So is it okay to go with http://209.132.184.193/testdays/show_event?event_id=28 ?
16:15:06 <tflink> blockerbugs/current is beta now
16:15:32 <adamw> apeter: basically, we don't know :)
16:15:39 <adamw> apeter: but i stored the empty wikicode in case it goes away
16:15:55 <adamw> apeter: if it goes away between now and tomorrow we can fall back to manual result entry
16:16:08 <adamw> apeter: i'll try and ask the relevant folks later today whether it's likely to stick around until tomorrow
16:16:21 <apeter> adamw, okay :)
16:16:28 <adamw> if we do wind up being able to use the app we'll definitely want to save the data from it regularly during the day in case it suddenly disappears
16:16:42 <adamw> you know how to export the data? it's really easy
16:16:52 <apeter> No I dont.. need to check
16:16:54 <apeter> okay
16:17:10 <adamw> go to 'admin interface', click 'export testday', and paste in the metadata URL (that's https://fedoraproject.org/wiki/L10N/TestdayApp/F23 ) and click Submit
16:17:18 <adamw> and you get the wikicode with whatever results are currently submitted
16:17:31 <adamw> it doesn't throw anything away afaik so it's safe to do it as often as you like
16:17:57 <adamw> i'll try and be around to do it too, but best if two of us are :)
16:18:09 <apeter> ah okay. got it.. thats pretty easy :)
16:18:12 <adamw> yup :)
16:18:34 <apeter> adamw, alright noted. I will be around too :)
16:18:37 <adamw> yay
16:18:40 <adamw> alrighty, thanks again everyone
16:18:40 <apeter> :D
16:18:52 <adamw> #endmeeting