16:00:11 <adamw> #startmeeting Fedora QA meeting
16:00:11 <zodbot> Meeting started Mon Nov 28 16:00:11 2016 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:11 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:00:24 <adamw> #meetingname fedora-qa
16:00:24 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:27 <adamw> #topic Roll call
16:00:44 <adamw> morning folks! who's around for qa meeting fun?
16:01:08 * a2batic is here
16:01:18 <a2batic> morning adamw :)
16:02:37 <adamw> hmm, anyone else? maybe i sent the announcement too late :)
16:02:52 * sumantrom is here
16:02:55 <adamw> coremodule: satellit: tflink: kparal: etc: ping
16:02:59 <adamw> hi sumantrom
16:03:03 * kparal is here
16:03:10 <sumantrom> hi admw :)
16:03:13 * tflink is around, having much fun with php
16:03:16 <adamw> satellit: ping
16:03:16 <zodbot> adamw: Ping with data, please: https://fedoraproject.org/wiki/No_naked_pings
16:03:18 * kparal is working on F25 brown paper bugs
16:03:20 <adamw> tflink: oh god, run away
16:03:26 * coremodule is here!
16:03:27 <adamw> what the heck possessed you
16:03:33 <tflink> adamw: phabricator
16:03:41 <tflink> and the need for a working login system after wednesday
16:03:52 <adamw> ah well, that one's all your own fault
16:03:54 * pschindl is here
16:04:01 <adamw> hmm, reminds me, i need to talk to puiterwijk about that and mediawiki...
16:05:35 <adamw> looks like we've got enough folks, anyhow!
16:05:40 <adamw> #chair sumantrom a2batic
16:05:40 <zodbot> Current chairs: a2batic adamw sumantrom
16:05:57 <adamw> #topic Previous meeting follow-up
16:06:28 <adamw> #info "adamw to look into USB writing tool coverage in the validation matrices, draft something up" - didn't get to that yet
16:06:35 <adamw> #action adamw to look into USB writing tool coverage in the validation matrices, draft something up
16:07:03 <adamw> #info "adamw to find someone to poke to make sure the mediawriter downloads for os x and windows on getfedora.org are up to date for release" - I pinged mattdm about that, and turns out it was all taken care of, we should've checked the staging instance of getfedora
16:07:21 <adamw> not sure if it's being updated with the new fmw releases that came out since f25 was released, though
16:07:38 <adamw> looks like it is
16:07:43 <puiterwijk> adamw: I'm pretty sure 4.0.7 is on the website
16:08:06 <adamw> #info "adamw to put up Retrospective page, or find someone else to do it" - sumantrom has been working on this, thanks sumantro! the page is ready to go, we're just drafting the announcement mail
16:08:17 <Kohane> Hello!
16:08:21 <Kohane> .fas lailah
16:08:21 <zodbot> Kohane: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
16:08:50 <sumantrom> adamw always my pleasure :)
16:09:58 <adamw> hi kohane!
16:10:22 <adamw> #info "adamw to talk to jwboyer and pwhalen about how secondary arch release validation runs and capturing the results in the HoF stats" - we've got a mail thread going about that, i'll maybe look into some wikitcms changes this week
16:11:24 <adamw> looks like no-one else had anything to do this week, hope you all enjoyed your vacations ;)
16:11:37 <adamw> kparal: what f25 brown paper bag bugs are you working on, btw? the upgrade login bug?
16:11:46 <kparal> the two upgrade login bugs, yes
16:12:01 <kparal> https://bugzilla.redhat.com/show_bug.cgi?id=1394755 and https://bugzilla.redhat.com/show_bug.cgi?id=1384508
16:12:06 <adamw> there's two? they're multiplying
16:12:17 <kparal> I was fortunate enough to hit them on multiple of my home computers
16:12:26 <adamw> kparal: btw, i added some new ones to CommonBugs? list last week, didn't add entries for them yet, but i will soon
16:12:26 <kparal> 2 out of 3, to be exact
16:12:30 <adamw> kparal: well, of *course* you did.
16:12:33 <adamw> you're kparal.
16:12:49 <adamw> i'm amazed your systems boot without the magic smoke coming out most days ;)
16:12:50 <kparal> sometimes I don't envy myself
16:14:23 <kparal> the second one is missing info in bugzilla, still collecting
16:14:36 <kparal> the first one is waiting for a gstreamer developer
16:15:29 <adamw> ah, so you're getting somewhere
16:16:40 <kparal> I'll also add https://bugzilla.gnome.org/show_bug.cgi?id=774557 to CommonBugs. seems to be widespread enough
16:17:26 <adamw> oh, yeah, that one's been mentioned inside rh quite a lot
16:17:40 <adamw> apparently lots of people have thinkpads they connect to dual monitors at their desk or something...
16:17:51 <kparal> who'd have guessed
16:17:57 <Kohane> Yeah, I already seen a lot of people complaining for this and similar bugs.
16:18:24 <Kohane> That after upgrading they can't login or have no graphical session
16:18:49 <adamw> Kohane: do direct them to the Common Bugs page and/or the relevant bugs, if you can :)
16:19:27 <adamw> so the next topic is Fedora 26 planning; before we dive into that, did anyone have other topics for the agenda or anything?
16:20:19 <Kohane> adamw: I would if I knew where it is...
16:20:30 <kparal> I'm still drafting an email for optical media importance discussion
16:20:35 <adamw> Kohane: just say it here :)
16:20:38 <kparal> nothing except that
16:20:46 <Kohane> Haha, okay. I said it.
16:20:55 <adamw> kparal: alright, we can probably consider it and the USB matrix change together if I draft that
16:21:07 <adamw> Kohane: oh sorry, I thought you were replying to the 'any topics' question, not the common bugs comment :)
16:21:16 <adamw> Kohane: the common bugs page is https://fedoraproject.org/wiki/Common_F25_bugs
16:21:30 <kparal> adamw: I think we can easily do it separately, if you prefer. it should not affect each other much I think
16:21:45 <adamw> the naming format is always like that, so you can find Common_F24_bugs , Common_F23_bugs , etc
16:21:58 <adamw> kparal: well, i just meant they're kinda in the same area and they'll probably hit the list together
16:22:11 <kparal> ok
16:22:38 <adamw> alrighty, so let's dive in
16:22:45 <a2batic> adamw, I saw the design ticket https://pagure.io/design/issue/483, just wondering the mockups should be bit more explanatory
16:22:59 <adamw> a2batic: we'll cover that
16:23:08 <adamw> #topic Fedora 26 initial plans
16:23:28 <adamw> so! this is kinda a big general topic, just wanted to give us a place to start thinking about what we'll be prioritizing in the F26 cycle
16:24:02 <adamw> we do have the F25 Retrospective page up: there'll be an email announcement soon, but you can start filling in thoughts on the F25 cycle at https://fedoraproject.org/wiki/Fedora_25_QA_Retrospective now if you like
16:24:07 <adamw> #info F25 Retrospective page is up at https://fedoraproject.org/wiki/Fedora_25_QA_Retrospective
16:24:52 <adamw> the intent of the retrospective page is to gather people's thoughts on what was good and bad about QA work in the previous cycle and use it to plan improvements for the next cycle, so please do leave your thoughts both good and bad there, we welcome ideas for improvement :)
16:25:59 <adamw> #info the Fedora 26 Change set page can be found at https://fedoraproject.org/wiki/Releases/26/ChangeSet - it is not yet complete, but a good guide to significant changes coming up we should be thinking about
16:26:33 <adamw> so, looking at the change set page it looks like we have some early 'factory 2.0' stuff coming down the pipe: "Modular Compose" and "Module Build Service"
16:27:12 <adamw> "Blivet-GUI in Anaconda" also looks rather important, and "Python 3.6" and "DNF 2.0" and "Retire Synaptics Driver"
16:27:34 * sumantrom looks forward for running test day :)
16:27:37 <kparal> more code paths in anaconda, yay
16:27:52 <Kohane> I thought Synaptics was already retired....
16:28:05 <adamw> Kohane: it's already not the default, but it hasn't been *retired* yet
16:28:18 <adamw> kparal: yeah, and a new python version and new DNF version at the same time
16:28:22 <adamw> i'm sure that won't cause any problems or anything
16:28:33 <kparal> never did
16:28:42 <adamw> DNF 2.0 is in Rawhide already and anaconda is at least kinda working; I haven't checked the latest openQA results in detail yet though
16:28:46 <Kohane> Oh! Thanks adamw
16:28:58 <adamw> sumantrom: looks like we're going to need some test days :)
16:29:31 * sumantrom yeeehh! I stand at the ready
16:29:50 <mpduty> hi everybody
16:30:17 <sumantrom> hi mpduty!
16:30:28 <mpduty> hi sumantrom
16:30:48 <adamw> hi mpduty
16:31:02 <mpduty> hi adamw
16:31:16 <adamw> so sumantrom is becoming our regular Test Day Person; anyone else want to help him out with that this cycle?
16:31:44 <coremodule> I'd be glad to help sumantrom!
16:31:59 <sumantrom> yess! :)
16:32:09 <mpduty> I have just started kernel testing, and I have a few things to ask, if that is possible now?
16:32:23 <adamw> alrighty, we can co-ordinate that by mail after the meeting i guess
16:32:30 <adamw> mpduty: can you hold it for Open Floor at the end of the meeting?
16:32:36 <adamw> i'll make sure there's some time.
16:32:43 <mpduty> oh sure
16:32:47 <adamw> thanks :)
16:33:10 <adamw> so, let me see
16:33:56 <adamw> we have some early 'factory 2.0' stuff coming in this cycle but i think in terms of release blocking stuff, it's still going to be more or less a traditional release, on the usual release cycle with a co-ordinated release of everything (except Atomic) and the usual release-blocking media
16:34:29 <adamw> so we have all the normal stuff to arrange in the normal ways: test days for critical changes, release validation, blocker review and so on is gonna happen as normal
16:34:59 <adamw> we have several ongoing projects to work on too, i guess
16:35:24 <adamw> kparal: tflink: what's planned for taskotron-land this release cycle?
16:35:45 <adamw> #info while some early F26 changes are landing, F26 cycle will mostly be a traditional one with usual release validation, blocker review, test day stuff
16:35:54 <Southern_Gentlem> adamw, a way for me to test updated isos?
16:36:02 <adamw> #info there are several significant Changes already which we will need to make sure are covered in Test Day and other testing
16:36:11 <adamw> Southern_Gentlem: when you say 'a way'?
16:36:23 <kparal> I haven't been too involved in taskotron recently, so I can't say exactly
16:36:24 <adamw> do you mean, like, validation pages? or something else?
16:36:33 <adamw> kparal: sorry, i need to update my standard ping list :)
16:36:37 <Southern_Gentlem> you said something about testing in the past like openqa or something
16:36:48 <adamw> Southern_Gentlem: yeah, it's languishing in my todo list :(
16:37:42 <adamw> Southern_Gentlem: https://www.happyassassin.net/temp/todo.png
16:37:49 <adamw> and that's just the ones I have written down! le sigh
16:38:18 * adamw should maybe probably start working on the ones from february
16:38:42 <adamw> oh, yours isn't even on that todo list. it's on another list. in other news, adamw may want to take some organizational skills classes
16:39:20 <Southern_Gentlem> lol
16:39:36 <Southern_Gentlem> well thats why i keep bringing it up so it makes the todo
16:39:39 <adamw> Southern_Gentlem: so yeah, it'd be great to do that, but as the respins still aren't really super-official things that Fedora officially Cares A Lot about it's hard for me to bump it up and do it ahead of other stuff
16:39:58 <Southern_Gentlem> i understand ]
16:40:13 <adamw> it would probably be an interesting entry point to openQA stuff if someone wanted to take it as a task, i could give some pointers maybe...
16:41:04 <adamw> tflink: so, uh, taskotron?
16:41:44 <Kohane> adamw: I can take it as task
16:42:30 <tflink> dist-git tasks mostly
16:42:37 <adamw> Kohane: that'd be great, i'll create a task in phabricator for it then so we can track
16:42:44 <tflink> for packages, docker images and modules
16:42:53 <Kohane> Excellent!
16:46:30 <adamw> Southern_Gentlem: kohane: I made https://phab.qadevel.cloud.fedoraproject.org/T870 for the openQA respin idea
16:47:03 <adamw> #info Main focus for Taskotron in F26 cycle is dist-git tasks (that is, support for running tests/tasks provided by package maintainers in dist-git)
16:47:35 <adamw> we do have the 'release validation NG' project as well, in terms of tooling work
16:47:44 <adamw> as well as ongoing work on blockerbugs etc.
16:48:03 <adamw> for anyone who missed it, the design ticket for the 'release validation NG' project moved to Pagure: https://pagure.io/design/issue/483
16:48:10 <adamw> #info 'release validation NG' ticket is now in Pagure: https://pagure.io/design/issue/483
16:49:30 * a2batic nods
16:50:20 * sumantrom bookmarks the link to revisit after the meeeting
16:50:49 <adamw> we're still working through the design, but we could probably start putting together some code too
16:50:54 <adamw> anyone seen handsome_pirate yet?
16:50:54 <Kohane> Yes, me too
16:51:01 <Kohane> No...
16:51:17 <adamw> welp, okay.
16:51:20 <Kohane> I didn't see handsome_pirate in a long while
16:52:05 <adamw> my very initial thought on this is we could have two components: a system which basically exists to accept manual test results, validate them against some configurable requirements, and submit them to resultsdb
16:52:27 <adamw> and then the actual user-visible webapp, which would just accept user input and pass it on the validator/submitter component
16:52:59 <adamw> that would give us some flexibility for transition stuff like accepting input from the 'relval' cli and maybe for sending results to both the wiki and resultsdb for a while if necessary
16:53:05 <adamw> and it'd help split the work up, i guess
16:53:43 <adamw> if we decide on a basic format for the messaging between the two, then people can work on either end without being blocked on the other. but we don't need to get into too much detail here
16:54:01 * satellit sorry I  am late
16:54:27 <adamw> can folks interested in the release validation NG project please sign up for the 'qa-devel' mailing list if you're not already on it?
16:54:37 <adamw> we should probably start discussions there before setting up infrastructure and so on
16:55:06 <adamw> #info 'release validation NG' project is in early planning stages, please sign up for qa-devel mailing list if you're interested and not already signed up, as we'll discuss it there
16:55:15 * a2batic subscribing
16:55:18 <adamw> great
16:55:35 <sumantrom> *me suscribed
16:55:37 <adamw> so, because I promised it earlier:
16:55:40 <adamw> #topic Open floor
16:55:55 <adamw> mpduty: sorry to make you wait :) you had a question?
16:56:01 <mpduty> oh yes
16:56:06 <satellit> mediawriter not updating f25 labs
16:56:19 <mpduty> my F24 installation fails to run kernel test with stress
16:56:24 <mpduty> stops midway
16:56:37 <adamw> these are the https://fedoraproject.org/wiki/KernelTestingInitiative tests?
16:57:27 <adamw> satellit: i'd report that to https://github.com/MartinBriza/MediaWriter . it's probably not technically the right place, but martin should pick it up and redirect it
16:57:36 <mpduty> yes
16:57:41 <adamw> does anyone know much about the kernel testing initiative stuff?
16:57:45 <adamw> i usually redirect folks to #fedora-kernel for it
16:58:08 <mpduty> fine
16:58:21 <adamw> if anyone here knows then that's great, but otherwise you'd be best asking there :)
16:58:24 <adamw> i just don't know much about those tests
16:58:53 <Kohane> adamw: me neither
16:59:10 <mpduty> oh thats just fine, I shall be asking in #fedora-kernel
16:59:17 <Kohane> Read about them and that's all my knowledge
16:59:18 <mpduty> didn
16:59:39 <mpduty> didn't know actually there was a channel that way :)
16:59:41 <adamw> anything else for open floor, folks?
17:00:18 <Kohane> Mmm... not from my side
17:00:47 <sumantrom> not from my side either
17:00:55 <adamw> btw, if anyone is looking for coding-ish tasks to work on aside from getting involved with release validation NG, there's lots of work available for taskotron and openQA and stuff :) https://phab.qadevel.cloud.fedoraproject.org/ is the primary place where we track tooling work and issues, so please check there, look at the tasks and if you see something interesting, someone will certainly be able to help you get started with it
17:01:23 <adamw> https://phab.qadevel.cloud.fedoraproject.org/maniphest/query/open/ is a list of all open tasks for all projects
17:01:47 <mpduty> looks interesting
17:01:53 <tflink> note that the url for phab will likely be changing soon
17:02:02 <adamw> thanks for the heads-up
17:02:03 <tflink> but redirects should take you to the correct place
17:02:26 <adamw> #info https://phab.qadevel.cloud.fedoraproject.org/maniphest/query/open/ is a list of most open tasks for 'coding-ish' QA work, for folks who are interested
17:02:29 <tflink> and the stupid issues of the 500 on login and https redirects should be resolved at the same time
17:03:31 <adamw> the person who filed the ticket is always a good person to ask for help in getting started with it, besides that you can always poke me or garretraziel for openQA stuff, and tflink or mkrizek or jskladan for taskotron/resultsdb stuff (i think that's right)
17:03:54 <tflink> pretty much, yeah
17:04:15 <adamw> we will have all the usual non-coding-y tasks for people to do, like test days and release validation, so hang tight for those :)
17:04:45 <adamw> looks like that's about it...
17:05:25 <adamw> thanks for coming, everyone!
17:05:36 <adamw> #endmeeting