15:00:10 <adamw> #startmeeting Fedora QA meeting
15:00:10 <zodbot> Meeting started Mon Apr 10 15:00:10 2017 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:10 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:14 <adamw> #meetingname fedora-qa
15:00:14 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:17 <adamw> #topic Roll Call
15:00:22 * sumukher is here
15:00:22 <marc84> morning everyone
15:00:26 * garretraziel is here
15:00:32 <adamw> morning!
15:00:33 <sumukher> morning adamw !
15:00:49 <adamw> hi sumukher
15:01:12 * a2batic is here
15:01:43 <sumukher> hi o/ adamw a2batic
15:02:11 <a2batic> Hi sumukher o/
15:02:37 <adamw> how's everyone doing today?
15:02:56 <sumukher> I am fine , how are you doing adamw ?
15:03:02 * roshi is here
15:03:21 * tflink is here
15:03:30 <adamw> oh, i'm good, thanks
15:03:34 <adamw> morning roshi, morning tflink
15:03:37 * pwhalen is here
15:04:27 <roshi> morning morning
15:04:32 * kparal is here
15:05:17 <adamw> alllrighty
15:05:22 <adamw> i know everyone is impatient to get to the fun times
15:05:26 <adamw> ....but first, the qa meeting!
15:05:35 <adamw> (ba-dum TISH)
15:05:42 * handsome_pirate bows
15:05:47 <kparal> where's my tomato
15:05:48 <adamw> heh
15:06:19 <adamw> oh boy, time for another exciting instalment of Stuff Adam Forgot This Week
15:06:23 <adamw> #topic Previous meeting follow-up
15:06:26 * coremodule is here!
15:06:32 <adamw> to save the day!?
15:06:48 * handsome_pirate wonders why there are tomatos
15:07:03 <adamw> handsome_pirate: kparal wishes to reward my hilarious jokes with a juicy treat
15:07:08 <handsome_pirate> :D
15:07:18 <adamw> that's what you meant, *right* kparal?
15:07:27 <kparal> tomato juice is very healthy I heard
15:07:38 <kparal> what better to offer than a tomato then
15:07:49 <adamw> exactly
15:07:59 <adamw> also, tflink, you might want to change the time on the qa-devel meeting announcements
15:08:05 <adamw> :P
15:08:10 <adamw> #info no action items from last week
15:08:21 <roshi> great work everyone!
15:08:33 <adamw> yes, it was tough but we made it through
15:08:39 <adamw> #topic Fedora 26 status
15:08:49 <adamw> soooo, we shipped an alpha
15:09:21 <kparal> and the delays weren't my doing this time
15:09:26 <adamw> woohoo
15:09:33 <kparal> I was... isolated
15:09:35 <garretraziel> *fanfare*
15:10:01 <adamw> kparal: oh, that reminds me, there's a couple of things you proposed for commonbugs I think that I wasn't confident writing up, do you think you could add them if you didn't yet?
15:10:13 <kparal> I'll look at it
15:12:57 * kparal replaces batteries in adamw
15:13:13 <adamw> sorry
15:13:15 <adamw> i was checking on a thing
15:13:16 <garretraziel> restart his service
15:13:36 <adamw> okay, that's it
15:14:07 <adamw> we don't have any Beta composes nominated for validation testing yet as it's been less than two weeks since Alpha and none of the 'significant' packages has changed yet, in case anyone was wondering.
15:14:28 <adamw> there's an anaconda update in testing but it has a bug in it for now.
15:14:33 <kparal> have we tried to run through all the testcases with Alpha?
15:14:36 * kparal checks
15:14:47 <kparal> meaning all all, including final
15:14:56 <adamw> i don't think we've got to full coverage, no.
15:14:59 <adamw> which means...work to do !
15:15:42 <roshi> there was ever a question of whether we have work to do?
15:15:46 <adamw> heh.
15:16:07 <adamw> sumukher: how were the results of the anaconda blivet-gui test day?
15:16:30 <sumukher> 28 testers and 12 bugs
15:16:41 <adamw> how bad are the bugs? i'm asking for f26 purposes
15:16:53 <sumukher> pretty bad!
15:16:54 <adamw> i.e. if it's really busted that can impact f26 beta / final
15:16:58 <adamw> hmm, okay
15:17:03 <mkolman_> adamw: that bug should be fixed
15:17:08 <adamw> mkolman_: yaay
15:17:18 <adamw> mkolman_: did you look at the results of the blivet-gui test day?
15:17:30 <mkolman_> adamw: and we plan to do a coordinated Anaconda & Blivet GUI update tomorrow
15:17:41 <adamw> okay
15:17:47 <mkolman_> adamw: I reported/hit about half of the bugs ;-)
15:17:58 <adamw> guess who didn't look too hard at the results page yet :P
15:18:09 <mkolman_> adamw: as I did all the test cases on physical hardware
15:18:12 <adamw> so, i'm thinking about the f26 release
15:18:45 <adamw> since the blivet-gui button sits right next to 'guided' and 'manual' partitioning, it's effectively as important as those two, there's no 'this is new and experimental' disclaimer or warning or anything
15:18:57 <mkolman_> not sure about concrete numbers, but youte a few should be fixed in the tomorrows update
15:18:57 <adamw> so we really need it to be working pretty well to release like that...
15:19:12 <mkolman_> *quite a few
15:19:35 <roshi> I think we might need to tweak our testcases for it as well
15:19:54 * roshi didn't look, but wonders if there are docs on what all you can/should do with blivet-gui?
15:20:06 <mkolman_> well, we just reused the custom spoke ones
15:20:35 <mkolman_> it would be certainly less confusing if they were specifying Blivet GUI
15:21:23 <adamw> yeah, we definitely should look at the whole test case...situation there
15:21:33 <adamw> roshi: maybe you and sumukher could look at that?
15:21:42 <adamw> ways to cover both interfaces in the test cases and matrices
15:21:42 <mkolman_> one testcase points to Fedora 11 installation guide ;-)
15:21:50 <roshi> sure
15:21:53 <adamw> WE ARE NOTHING IF NOT CUTTING EDGE!
15:21:59 <adamw> sumukher: ok with you?
15:22:05 <sumukher> yes adamw
15:22:06 <roshi> we get cut, but is it with the edge?
15:22:07 <sumukher> :)
15:22:41 <adamw> ok, i'll assign it to both of you, feel free to work it out between you :) please do post drafts of any changes before changing, though, you know i'm a bit obsessive about the wiki...
15:22:53 <roshi> it's your precious
15:22:56 <roshi> we know :p
15:23:04 * sumukher nods
15:23:12 <adamw> #action roshi and sumukher to look at making the test cases and install validation matrix cover both 'custom partitioning' and blivet-gui-in-anaconda
15:23:23 <adamw> mkolman_: is the long-term plan here for 'custom partitioning' to go away?
15:23:27 <adamw> mkolman_: or are we stuck with both?
15:23:44 <roshi> it'd be great to have just one ring to rule disks
15:24:39 * sumukher concurs with roshi
15:24:59 <mkolman_> adamw: there are no plans for that at the moment
15:25:08 <adamw> oh goody
15:25:16 <mkolman_> adamw: but it would certainly simplify things
15:25:50 <mkolman_> I guess we will see what feedback we will get from users for F26
15:25:59 <adamw> okay.
15:26:31 <mkolman_> it could very well be that "make space available" + automatic would be enough with Blivet GUI
15:26:33 <adamw> garretraziel: we should probably look at having openqa duplicate all the 'custom' tests with blivet-gui too, i gues....
15:26:57 <adamw> i'll file a phab for that
15:27:00 <garretraziel> yeah, I was thinking about doing it
15:27:06 <garretraziel> ok, feel free to assign me to it
15:27:11 <mkolman_> it's also possible to disable custom or blivet gui (or both)
15:27:12 <adamw> great
15:27:37 <adamw> mkolman_: yeah, i think we should re-evaluate closer to final if blivet-gui is in good enough shape to have there for final release with no warnings
15:27:40 <mkolman_> by dropping an appropriate user interaction config file to the compose
15:27:59 <sumukher> mkolman_, if you are looking for user feedback here is one "I just checked it out. I agree that this has been an insanely important missing feature in Anaconda since they changed the look and feel of it. I’m glad they’re finally including it.
15:28:00 <sumukher> I didn’t get a chance to test it on a dual-boot system, which is where I think it will really shine… but from what I’ve seen so far, two huge thumbs up."
15:28:52 <mkolman_> sumukher: cool, thanks! :)
15:29:07 <sumukher> mkolman_, you are welcome! :)
15:29:35 <adamw> alllrighty
15:29:40 <adamw> trying to think of anything else for f26 status
15:29:50 <adamw> i don't think there are any big problems or unusual things
15:29:51 <adamw> anyone?
15:30:13 <sumukher> Anaconda Blivet GUI test day went well. The next one be FMW for ARM image writing on 20th .. Pagure ticket https://pagure.io/fedora-qa/issue/502 . Also, Gnome 3.24 test day proposal as also been made !
15:31:27 <adamw> cool. are you and coremodule confident with all of those? need help with anything?
15:31:43 * sumukher and coremodule has not heard from DNF team from sometime now and has no clue what's going on!
15:32:22 <sumukher> adamw , I am :) I am sure coremodule is too , but if we need help we will reach out to you
15:32:31 <adamw> great
15:32:42 <adamw> hmm, i'll see if i can shake the tree for the DNF one
15:33:14 <adamw> #action adamw to try and get some response from the DNF team for https://pagure.io/fedora-qa/issue/495 (DNF 2.0 Test Day)
15:33:20 * sumukher cant thank adamw enough! :)
15:33:38 <adamw> #topic Criteria / validation test proposals
15:33:47 <adamw> so, just some space for the couple of proposals i have in at the moment
15:34:27 <adamw> one on moving the 'no broken packages' requirement to Final, one on splitting out the artwork test bits into a dedicated test case
15:34:38 <adamw> any notes / thoughts / questions on those?
15:34:44 <garretraziel> +1 on both of those
15:35:05 <sumukher> +1 on both
15:35:11 * roshi thinks he responded +1 to both on the list
15:35:30 <kparal> +1 both
15:35:47 <a2batic> +1
15:36:13 <tflink> +1 to both
15:36:35 <adamw> sadly the 'no broken packages' thing is kinda part of a bigger mess to do with dnf vs. yum behaviour and image composes...but the criteria change i think makes sense
15:36:47 <adamw> well, you people are boring :P where's all the exciting controversy?!
15:37:10 <garretraziel> I definitely don't agree and I think that your proposals are idiocy!
15:37:17 <garretraziel> because... reasons
15:37:25 <roshi> the worlds quota of controversy is pretty well tapped at this point
15:37:27 <adamw> there we go
15:37:30 <roshi> perhaps we're all running low :p
15:37:36 <adamw> that's the kind of response i'm used to
15:37:36 <adamw> :P
15:37:55 <adamw> #info no objections to the current proposals (except from garretraziel because he smells funny and no-one likes him)
15:38:04 <garretraziel> adamw: you are welcome :-)
15:38:05 <adamw> :P
15:38:09 <roshi> lol
15:38:17 <roshi> I laugh every time I smell garretraziel
15:38:20 <garretraziel> man, I definitely should wash myself
15:38:30 <adamw> #topic Atomic release process changes
15:38:40 <adamw> this one, i actually was planning to throw roshi under the bus
15:38:50 <adamw> it seems like...stuff is...happening regarding the atomic release process
15:38:57 <adamw> are you in on that? can you summarize details for us?
15:39:09 <roshi> so, the Atomic WG (which I guess I should note, I'm a part of) has +1'd both the PRD and the Release Criteria I wrote up
15:39:15 * roshi finds links
15:39:52 <roshi> RC: https://fedoraproject.org/wiki/User:Roshi/QA/Atomic_Release_Criteria
15:40:09 * tflink needs to duck out early, will read the minutes later
15:40:17 <roshi> https://fedoraproject.org/wiki/Atomic/PRD
15:40:22 <adamw> thanks tflink
15:40:22 <roshi> gl hf tflink
15:40:27 * adamw really ought to get around to reading that
15:40:47 <roshi> so now, we need to figure out how Atomic get treated during pre-release
15:40:57 <roshi> so, how freeze affects them
15:41:09 <adamw> okay
15:41:11 <roshi> I laugh every time I smell garretraziel like F26Alpha)
15:41:18 <adamw> haha
15:41:20 <roshi> what images get linked when we release a new branch (F26Alpha)
15:41:27 <roshi> scroll for the win!
15:41:41 <roshi> that kind of thing
15:42:13 <roshi> I think we're going to need a meeting with a larger group to determine that though
15:42:24 <roshi> because Atomic isn't blocking because it's got it's own release cadence
15:42:30 <roshi> and we've not done that before...
15:42:36 <roshi> so there's going to be pain points
15:43:00 <adamw> yeah
15:43:02 <roshi> because our infra and release tooling is kinda predicated on whole big batch releases of stuff
15:43:13 <adamw> so for now it's still in the 'planning' phase? no definite ideas / proposals yet?
15:43:14 <adamw> right
15:43:26 <roshi> we have to identify and determine fixes for the process issues as well as the technical issues
15:43:41 <roshi> and I don't know that we have a good idea of what all that's going to touch
15:44:02 <roshi> for the "what to do during pre-release?" yeah, that's still in the early planning phase
15:44:27 <adamw> so for now, the release criteria you wrote are for the post-stable 'two week' releases, right?
15:44:30 <roshi> I think for F26 we'll just have to make it up as we go, write down what happened and then codify it before F27
15:44:38 <roshi> pretty much
15:45:01 <roshi> so, any 2wk release candidate should be able to satisfy those requirements before GA
15:45:05 <roshi> in the 2wk sense
15:45:17 * roshi just imagines the normal process, really condensed
15:45:27 <adamw> ok
15:45:31 <adamw> thanks, roshi
15:45:44 <adamw> if anyone has questions, fire away while i write up some #info's
15:45:59 <adamw> roshi: is there anything you need from the rest of us at this point, or are you feeling on top of things for now?
15:46:03 <roshi> did all that spew make sense?
15:46:06 <adamw> sure
15:46:18 <roshi> nothing comes to mind right now
15:46:27 <adamw> #info the proposed Atomic release criteria and PRD are both approved now: https://fedoraproject.org/wiki/User:Roshi/QA/Atomic_Release_Criteria and https://fedoraproject.org/wiki/Atomic/PRD
15:46:29 <roshi> I have to do some more thinking and come up with some solid proposals
15:46:50 <roshi> but yeah, I guess I feel on top of this pile of mush that has little form at this point :p
15:47:27 <adamw> #info Atomic WG is in the process of figuring out a more concrete way of defining the Atomic release process in relation to the 'regular' Fedora process, particularly in the post-Branched / pre-GA phase of the regular Fedora cycle
15:47:32 <adamw> okay :)
15:47:50 <adamw> #info roshi continues to take point on this, please contact him if you're interested / have questions etc
15:48:33 <roshi> on taking point: https://68.media.tumblr.com/78682ed28e95443364f3211205454af8/tumblr_myolywNebR1tor0sfo1_250.gif
15:49:55 <adamw> hah
15:50:04 <handsome_pirate> ouch
15:50:28 <adamw> alrighty then
15:50:30 <adamw> #topic Open floor
15:50:33 <adamw> any other business, folks?
15:50:45 <coremodule> Heroes of Fedora post should be live sometime this week!
15:50:56 <coremodule> *concerning F26 Alpha
15:51:03 <adamw> yaay
15:51:09 <sumukher> coremodule, yeeh!
15:53:49 <adamw> welp, sounds like that's everything
15:54:00 <adamw> blocker meeting in six minutes in #fedora-blocker-review!
15:54:06 <adamw> thanks for coming, everyone
15:54:09 * adamw sets fuse
15:54:16 * roshi goes to refresh his coffee and will start the meeting when he gets back
15:54:43 <sumukher> adamw thanks for hosting the meeting ! :)
15:56:14 <adamw> #endmeeting