16:00:40 <adamw> #startmeeting Fedora QA meeting
16:00:40 <zodbot> Meeting started Mon Nov 6 16:00:40 2017 UTC. The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:40 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:00:47 <adamw> #meetingname fedora-qa
16:00:47 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:51 <adamw> #topic Roll Call
16:00:58 <adamw> morning folks, who's around for qa fun times?
16:01:03 * kparal is here
16:01:23 * sumantro is here
16:01:59 * coremodule is here!
16:02:10 * siddharthvipul1 is here
16:02:22 * tflink is here
16:05:07 * mkolman is hiding
16:05:09 <adamw> hi everyone
16:05:28 * adamw pulls mkolman out from behind the couch
16:05:45 <mkolman> @_@
16:06:34 <adamw> #topic Previous meeting follow-up
16:07:13 <adamw> #info "adamw to create separate blocker/fe tracking bugs for Server and update appropriate pages" - that's all done, we have server beta and final blocker tracker bugs and the tracking wiki page is updated
16:07:20 <adamw> also blockerbugs
16:07:26 <adamw> any other followup?
16:08:25 * kparal shrugs
16:08:50 <adamw> alrighty
16:08:56 <adamw> #topic Fedora 27 status
16:09:08 <coremodule> woot!
16:09:31 <adamw> so...we *should* have an RC-1.3 compose.
16:10:07 <kparal> 1.6
16:10:08 <adamw> aaand we do, yay.
16:10:12 <sumantro> 1.6
16:10:13 <adamw> ugh.
16:10:16 <adamw> right.
16:10:41 <kparal> but it was not announced in test-announce, has a script failed?
16:11:02 <adamw> yeah, was just looking at that.
16:11:31 <adamw> #info there is now an RC-1.6 compose, which we hope should be the final one. a validation event was not yet created for some reason, adamw will fix that
16:11:41 <adamw> #action adamw to create RC-1.6 validation event, investigate why automatic creation failed
16:12:30 <adamw> there is a new proposed blocker, note, so we'll do a blocker review meeting after this meeting.
16:13:44 <adamw> #info we failed go/no-go last week due to a messy situation involving bash, we are aiming to definitely get it done this week
16:14:10 <adamw> #info Modular Server is finally at the point of having a testable compose available, aiming possibly to sign off on Beta this week
16:14:19 <adamw> any other notes / news on F27 status?
16:14:43 <kparal> none here
16:15:45 <sumantro> nothing here , except for a small warning which happens during install from live boot 1.5 PID: 55 at driverss/gpu/drm/qxl/qxl_display.c:310 qxl_user_framebuffer_destroy+0x36/0x40 [qxl] [drm]
16:16:06 <kparal> sumantro: it's better to use virtio-vga in VMs now
16:16:35 <kparal> unless it's a kernel panics, I don't think we care about warnings
16:16:38 <adamw> sumantro: i'd report it maybe to freedesktop.org or so
16:16:39 <kparal> *panic
16:16:58 <sumantro> kparal, sure
16:17:17 <sumantro> adamw, will report
16:17:31 <adamw> okay then
16:17:40 <adamw> so the topic I had for the meeting...
16:17:41 <adamw> #topic Fedora 27 Modular Server validation test approach planning
16:18:03 <adamw> #info we now have an allegedly-testable Modular Server compose: https://kojipkgs.fedoraproject.org/compose/Fedora-Modular-27-20171105.n.3/
16:18:27 <adamw> so a question that came up during a recent blocker or go/no-go meeting (I forget which) - how do we want to handle actually testing these?
16:18:59 <kparal> can we run openqa on it easily, to test the basics?
16:19:42 <adamw> yes.
16:19:59 <kparal> great
16:20:02 <kparal> let's do :)
16:20:45 <adamw> yeah, i was doing it in parallel, except i've just found out the main worker host for openqa stg is dead.
16:20:49 <adamw> so...we're testing in production. :P
16:21:08 <Kohane> Hello all
16:21:18 <Kohane> .fas lailah
16:21:19 <zodbot> Kohane: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
16:21:25 <adamw> so the question here for me is essentially 'do we need to come up with some way to create a parallel official release validation event for Modular Server composes'
16:21:27 <kparal> about manual testing - perhaps we should add one or more test cases to test the differences between what we currently have as server test cases and what is new in modular release?
16:21:29 <adamw> hi kohane
16:21:36 <Kohane> hi adamw
16:21:41 <sumantro> hi Kohane :)
16:21:51 <Kohane> hi sumantro
16:21:57 <kparal> adamw: what exactly do you mean by that? wiki matrices or something else?
16:22:05 <adamw> kparal: yes, i believe i asked sumantro to look at writing test cases for the modularity bits
16:22:12 <adamw> kparal: yes, wiki matrices.
16:22:46 <adamw> it's actually a bit...weird to do
16:23:01 * sumantro is working in it. might need kparal and adamw's guidance :)
16:23:29 <adamw> there are quite a few points in the whole wiki validation system which kinda assume that we *don't* have parallel tracks of validation events like this.
16:23:33 <kparal> some of the instructions can probably be taken from the criteria proposal that landed in test list
16:23:52 <adamw> so since we're allegedly only doing this for one release, i'm inclined to *not* have wiki matrices
16:24:03 <adamw> it helps that openqa covers almost the entire criteria for server
16:24:19 <kparal> adamw: the problem is in hooking up openqa results and testcase_stats to a differently named wiki pages?
16:24:23 <adamw> it only really *doesn't* cover Active Directory realm client testing
16:25:01 <kparal> adamw: so, would we rely on automated testing only? or where would we file manual results?
16:25:07 <adamw> kparal: well, that's one consideration, yeah
16:25:23 <adamw> kparal: i'd say we could co-ordinate manual results via the mailing list, or just irc chat
16:25:43 <adamw> of course that's the kind of ad hoc way of doing it which rapidly *turns into* someone making a wiki page, but i think for just one release with two milestones it'd be okay
16:26:24 <adamw> kparal: other considerations - what about the 'Current' validation page redirects, where should Current_Server_Test or (better) Current_Base_Test point?
16:26:35 <kparal> well bugs can be filed into bugzilla with some blocks: tag to keep track of them (or under the modular server component). and pass results are not necessary, if everything is automated
16:26:39 <adamw> (and how much work is it to make relval/wikitcms actually implement that?)
16:27:04 <adamw> what categories do the new pages go in, and what's the consequence of that? (wikitcms decides what pages are related to which releases via categories, for e.g.)
16:27:18 <adamw> kparal: yes, bugs we need to track of course
16:27:22 <adamw> we already have blocker tracker bugs
16:27:25 <kparal> let's not do heavy code changes in our tools
16:27:46 <adamw> yeah, that was kinda my conclusion too
16:28:18 <adamw> which leaves say three options: create the pages mostly by hand and try to make sure they don't accidentally tread on wikitcms' toes in any way, just do it on the fly via irc and email, or come up with some new way of doing it.,
16:28:51 <kparal> well, let's first talk about how much manual testing is required in the first place
16:28:57 <adamw> sure
16:29:07 <kparal> the "put to usb and do a default install on bare metal" ones
16:29:11 <kparal> anything else?
16:29:17 <adamw> as I said, the AD client tests
16:29:35 <kparal> ok, is that it?
16:29:36 <adamw> and maybe modularity tool tests at least at first - though hopefully those will be straightforward to add to openqa
16:29:51 <kparal> is that "dnf module" or something else?
16:30:04 <adamw> whatever the tool is for sysadmins to interact with modules
16:30:08 <adamw> if that's 'dnf module' then yes. :PO
16:30:21 <kparal> I see that you have as much experience with modules as I have
16:31:36 <sumantro> how about testing for specific desktop environments and upgrade ?
16:31:40 <kparal> we could use the announce email (that you'll fix and send) and simply reply to test list once the 2-3 missing test cases are tested by someone
16:31:43 <kparal> easy enough
16:32:05 <kparal> for the rest, look into openqa
16:32:45 <kparal> maybe you could even list the necessary manual tests in the announcement email? so that we have a list somewhere
16:33:34 <adamw> sumantro: there are no desktop environments for server
16:33:45 <adamw> kparal: yeah, that's probably the best place to start
16:33:51 <adamw> sumantro: openqa tests upgrades
16:33:57 <adamw> (it currently fails)
16:34:23 <adamw> sumantro: so, now we have a 'testable' compose, it becomes quite urgent to get the module test cases
16:34:42 <adamw> sumantro: so if you're gonna need help with those can you ask for it soon? ideally we should have the test cases today or tomorrow.
16:35:40 <adamw> #info plan for Modular Server formal validation testing is to co-ordinate it via email / IRC, as adding a second 'stream' of wiki validation events has complex issues. most tests are covered by openQA in any case.
16:36:14 <adamw> #info we are still working on tests for the sysadmin tools for working with modules
16:36:25 <adamw> #action sumantro to complete the module test cases, ask for help if needed
16:36:51 <sumantro> adamw, I will ping you after the blocker bug meeting
16:37:16 <adamw> roger
16:38:01 <coremodule> sumantro, willing to help with test cases, let me know how I can help!
16:38:47 <sumantro> sure!
16:41:51 <adamw> okay, so sounds like we more or less have a plan there.
16:41:59 <adamw> anything else on modular server before I move on?
16:42:33 <kparal> nope
16:43:14 <Kohane> Not from my side.
16:43:25 <adamw> alrighty
16:43:28 <adamw> #topic Open floor
16:43:30 <adamw> any other business, anyone?
16:43:47 <adamw> problems, concerns, ideas, winning lottery numbers?
16:44:48 <tflink> yesterday's winning numbers, sure :)
16:45:01 <sumantro> We have fedora classroom tomo which coremodule and me will be co-coordinating
16:45:18 <Kohane> No lottery yesterday here. It's closed. xD
16:45:30 <adamw> .fire tflink
16:45:30 <zodbot> adamw fires tflink
16:45:31 <Kohane> tomo?
16:45:37 <adamw> tomorrow?
16:45:40 <coremodule> Yes! Tomorrow! 1500UTC
16:45:41 <coremodule> https://fedoraproject.org/wiki/Classroom
16:46:48 <sumantro> adamw, Kohane https://fedoramagazine.org/fedora-classroom-session-fedora-qa-101/
16:46:54 <adamw> awesome
16:47:17 <adamw> #info sumantro and coremodule are running a Fedora Classroom session on Fedora QA tomorrow: https://fedoramagazine.org/fedora-classroom-session-fedora-qa-101/ - come help out if you can
16:48:42 <Kohane> sumantro: thanks!
16:49:20 <adamw> of course, it'd be great if everyone can help validate RC-1.6 (and any other composes we hopefully don't have to run)
16:49:25 <adamw> i will get the event created in a minute here
16:50:36 <Kohane> Oh, good.
16:51:50 <adamw> other than that, the blocker meeting starts at the top of the hour in #fedora-blocker-review
16:51:52 <adamw> should be a short one
16:51:55 <adamw> (har har har)
16:53:17 <adamw> thanks for coming, folks!
16:53:18 * adamw sets fuse
16:54:31 <coremodule> Thanks for hosting adamw!
16:59:20 <Kohane> bye!
16:59:39 <x3mboy> !
16:59:52 <x3mboy> Is tere a how to get started with QA?
17:00:03 <Kohane> Yes, there's a wiki
17:02:51 <sumantro> x3mboy, and a 3 part blog post and wiki join page :)
17:03:34 <x3mboy> Cool!
17:03:39 <x3mboy> I should take a look at it
17:27:29 <x3mboy> a
13:00:43 <mizmo> mktg mtg?
13:01:28 <zodbot> x3mboy: Error: Can't start another meeting, one is in progress.
13:01:42 <x3mboy> Oh, the other meeting is not over yet
13:03:34 <x3mboy> Who is running this meeting?
13:04:11 <mizmo> looks like it was a qa meeting yetterday
13:04:14 <mizmo> adamw: ^^ ?
13:06:04 <x3mboy> mizmo, let's move to #fedora-meeting-4 while someone figure it out what happens here. It looks like the chairmen went out and none close the meeting
13:06:14 <x3mboy> wdyt?
13:06:28 <mizmo> ok
13:07:02 <skamath> x3mboy, maybe someone in the admin team can
13:07:25 <skamath> puiterwijk/ nirik , can you end meetings?
13:08:09 <x3mboy> skamath, Yeah, I ask in the admin channel
13:24:37 <puiterwijk> #endmeeting
13:25:12 <puiterwijk> skamath, x3mboy: we cannot. The only thing we could do is to restart zodbot
13:25:54 <x3mboy> puiterwijk, if there is no problem, please do it. I think we should ask at least one of the qa team members about why is the meeting still open
13:26:10 <puiterwijk> ack
13:31:06 <x3mboy> adamw, Kohane, sumantro, coremodule kparal tflink ?
13:31:55 <kparal> #endmeeting
13:32:14 <kparal> doesn't work
13:32:32 <kparal> the meeting should be over since yesterday. not sure why it's still running
13:33:47 <x3mboy> kparal, Well, so can puiterwijk restart zodbot to drop this meeting?
13:33:54 <kparal> sure
13:34:00 <x3mboy> puiterwijk, if you restart zodbot logs will be lost?
13:35:04 <puiterwijk> x3mboy: the logs won't be lost, but the current meeting won't be ended (aka, no logs published), same for any other in-progress meetings, and zodbot will be unavailable for +- 40 minutes
13:35:07 <puiterwijk> #chair puiterwijk
13:35:18 <puiterwijk> kparal: note that adamw never #chair'ed you
13:35:36 <kparal> aha
13:35:46 <kparal> .fire adamw
13:35:46 <zodbot> adamw fires adamw
13:36:32 <puiterwijk> zodbot: addchair #fedora-meeting freenode puiterwijk
13:36:32 <zodbot> puiterwijk: Chair added: puiterwijk on (#fedora-meeting, freenode).
13:36:34 <puiterwijk> #endmeeting