16:04:51 <adamw> #startmeeting Fedora QA meeting
16:04:51 <zodbot> Meeting started Mon Jan  8 16:04:51 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:04:51 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:04:55 <adamw> #meetingname fedora-qa
16:04:55 <zodbot> The meeting name has been set to 'fedora-qa'
16:04:59 <adamw> #topic Roll Call
16:05:02 <Kohane> Hi
16:05:06 <tflink> .hello tflink
16:05:06 <adamw> Happy New Year everyone!*
16:05:07 <sumantrom[m]> Hi adamw!
16:05:08 * siddharthvipul1 is here
16:05:12 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
16:05:13 <Kohane> .fas lailah
16:05:15 * sumantrom[m] is here
16:05:15 * kparal is here
16:05:15 <zodbot> Kohane: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
16:05:20 * tenk is here
16:05:25 <Kohane> Happy New Year everyone!
16:05:25 * coremodule is here
16:05:29 * Kohane is here
16:05:31 <adamw> * (who isn't on the lunar, Julian, Mayan or Illuminati calendar)
16:05:48 <Kohane> LOL
16:05:52 <sumantrom[m]> Happy New Year Everyone :)
16:06:12 <adamw> funny story, i live in vancouver where like half the people are chinese so i already do two new years
16:06:26 <adamw> now i started playing tennis with a guy who's on the Julian calendar so now i get three, heh
16:06:34 <tenk> Bonne annee !!
16:07:17 <adamw> how's everyone doing?
16:07:21 <tflink> adamw: now you just need to find people who are on the Mayan and Illuminati calendars!
16:07:42 <adamw> tflink: well, if i knew anyone on the illuminati calendar of course i couldn't tell you...;)
16:07:55 <tflink> fair enough
16:08:08 <Kohane> adamw: that must be confusing...
16:09:00 <adamw> Kohane: eh, you just great everyone with Merry Happy New Sam Dim Christmas Fai Lok Year and hope for the best :P
16:09:31 <Kohane> xD
16:09:36 <sumantrom[m]> Hi tenk!
16:10:08 * sumantrom[m] waves at coremodule tflink and kparal
16:10:35 <adamw> allllrighty
16:10:45 <adamw> let me remember what the hell i put on the agenda all the way back on friday night...
16:10:56 <adamw> #topic Previous meeting follow-up
16:11:23 <adamw> we had one action item:
16:11:24 * pschindl_wfh is late but here.
16:11:29 <adamw> "sumantro to create f28 milestones in pagure (and close old tickets/milestones as appropriate)"
16:11:33 <adamw> sumantro, did that go ok?
16:11:37 <adamw> morning pschindl
16:11:50 <sumantrom[m]> Yes that's sorted!
16:12:21 <adamw> excellent
16:12:30 <adamw> #info "sumantro to create f28 milestones in pagure (and close old tickets/milestones as appropriate)" - this is done
16:12:40 <adamw> anyone have any other follow-up from last time?
16:13:51 <Kohane> I can't remember what we discussed last time.
16:13:56 <Kohane> Or maybe I couldn't attend.
16:14:02 <Kohane> :-/
16:14:10 <adamw> Kohane: you can find the logs etc. on meetbot
16:14:18 <adamw> Kohane: https://meetbot-raw.fedoraproject.org/teams/fedora-qa/ is a handy URL to have around
16:14:29 <Kohane> Oh, good, thanks
16:14:33 <Kohane> I'm so clumsy with IRC
16:14:35 <adamw> you can find the records of *almost* all the meetings ever there (some very old ones aren't there)
16:15:11 <Kohane> Oh, okay, thanks
16:15:12 <adamw> blocker bug meetings are at https://meetbot-raw.fedoraproject.org/fedora-blocker-review/ , at least the ones since we started using a dedicated channel (older ones are harder to find)
16:16:51 <Kohane> Good. Thanks adamw !
16:17:27 <adamw> alrighty then, moving on
16:17:37 <adamw> #topic Meltdown / Spectre status / discussion
16:17:48 <adamw> so, since this is the big topic lately, i figured it might be a good idea to give it some space at the meeting
16:18:53 <adamw> the status as I understand it is that we have shipped the fix/mitigation for Meltdown to F26, F27 and Rawhide; we have not yet shipped any fix/mitigation for any form of Spectre
16:19:06 * satellit_ listening  late to join
16:19:34 <adamw> i believe kernel team considers it slightly less urgent to SHIP ANYTHING QUICK for spectre and wants to work with upstream to ship the right things
16:19:47 <adamw> jforbes: if you're around, is that accurate?
16:20:09 <adamw> (i'm assuming everyone knows what the hell i'm talking about here, if not, please yell)
16:20:21 <jforbes> Yes, that is correct
16:21:01 <adamw> thanks
16:21:06 <jforbes> adamw: I should have patches for variant 1 in the next builds. Variant 2 is a bit more difficult because we are dependent on microcode that intel hasn't shipped yet (a day or 2) and updates to gcc
16:21:32 <adamw> so should we expect first a kernel update for variant 1, then a combined kernel/microcode_ctl/gcc update for variant 2?
16:21:39 <jforbes> jakub said nothing would happen with Fedora GCC until those patches were posted upstream and discussed. They were just posted, so we will see
16:22:51 <jforbes> Yes, well, they won't be one update, if we build the kernel with retpoline and the compiler doesn't support it, the kernel will taint.  So gcc first, then kernel. I expect microcode will happen before gcc does
16:23:33 <adamw> well, you can build gcc, create a buildroot override for it, then build kernel with that gcc and submit a combined update. but they don't really *have* to be updated together, i guess.
16:23:55 <adamw> it'd just go faster that way as you don't have to wait for gcc to be pushed stable before building kernel.
16:24:34 <jforbes> But variant 2 is extremely hard to exploit, and made harder by how quickly our kernel moves. AFAIK an exploit has to be crafted for a particular kernel build and CPU combination
16:24:45 <adamw> roger.
16:25:07 <adamw> so for us, folks, the status is we have nothing to do right now, i'll try and stay in touch with the kernel team so i can flag up updates for testing as they appear.
16:25:18 <jforbes> Yes, I will do an override when that happens, but the updates aren't bound in any other way.  The kernel doesn't care if that gcc is installed on the system, only that it was used to build the kernel.
16:25:23 <adamw> gotcha.
16:25:57 <adamw> #info Meltdown fix has shipped to Fedora 26, 27 and Rawhide. Spectre fixes are pending, first for variant 1, then variant 2. adamw will stay in contact with folks working on the fixes and flag up updates for testing as they appear
16:26:09 <adamw> any other questions/concerns/thoughts on meltdown/spectre, anyone?
16:26:25 <pjones> we're all so very screwed.
16:26:31 <pjones> (hey, you asked for thoughts.)
16:26:31 <Kohane> Why?
16:27:10 <jforbes> Basically any kernel updates you see over the next couple of weeks, test and karma quickly. They aren't all tagged with the CVE bugs for them because we are only doing particular arches, etc.  Like right now, meltdown is coverred for x86_64 only. PPC patches should be posted today, arm64 are in mid discussion.
16:28:45 <adamw> ah, right.
16:29:18 <adamw> #info all kernel updates that land over the next couple of weeks should be tested urgently - they may address aspects of Meltdown/Spectre even if not marked with the relevant CVEs (e.g. fixes for ppc64 / aarch64)
16:29:44 <adamw> Kohane: pjones is the crusty old guy who's seen some things, man. he's seen some things.
16:29:52 <pjones> heh
16:29:53 <Kohane> Oh...
16:29:56 <Kohane> I see
16:29:57 <Kohane> LOL
16:30:09 <Kohane> Hi crusty old guy, nice to meet you
16:30:17 <pjones> uh, same, I think? ;)
16:30:54 <Kohane> xD
16:33:01 <adamw> alllrighty then - thanks, jforbes. moving along
16:33:18 <adamw> #topic Fedora 28 Change review and status
16:36:31 <adamw> so, quite a lot of the Fedora 28 Changes are landing on devel@ ATM
16:36:45 <Kohane> yeah
16:36:46 <adamw> i figured for the next few meetings we can have a topic to look through and take note of any significant ones
16:37:06 <Kohane> Sounds sensible
16:37:53 <sumantrom[m]> Adamw roger
16:38:21 <adamw> it would of course have been sensible for me to look through the list and have some primed and ready to go...
16:38:26 <adamw> ...so of course i have not done that!
16:38:33 <tflink> that sounds like work
16:38:33 <adamw> we'll just DO IT LIVE, man
16:39:17 <Kohane> Yeah!!  Let's do it live!
16:39:19 <Kohane> LOL
16:39:54 <adamw> so, one that got proposed back in december is https://fedoraproject.org/wiki/Changes/ReduceInitialSetupRedundancy
16:40:26 <adamw> that'd very obviously hit the release criteria, so assuming some version of it gets accepted/implemented, we'll need to re-check all the possible first boot flows on all the release-blocking images
16:40:28 <adamw> that might be a great test day
16:40:38 * adamw looks meaningfully at sumantro :P
16:41:04 <sumantrom[m]> Yes we will have it !
16:41:16 <sumantrom[m]> I am waiting for mass rebuild :)
16:42:51 <adamw> gret
16:42:53 <adamw> great
16:42:56 * adamw looks for others
16:43:56 <adamw> https://fedoraproject.org/wiki/Changes/StratisStorage may be relevant to release validation if support gets added to the installer
16:44:16 <adamw> aside from that it'd again be a good candidate for a test day, i suspect, if the support is advanced enough to be worht it
16:45:26 <Kohane> I don't know what is a Stratis Storage but I like that we're reducing setup redundancy.
16:46:09 <adamw> there's a description of Stratis on the Change page
16:46:15 <adamw> Kohane: it sounds good, but the devil is in the details :)
16:46:52 <Kohane> I know, I know.
16:47:05 <Kohane> But at least it's something I can test and fully understand
16:47:07 <adamw> https://fedoraproject.org/wiki/Changes/StrongCryptoSettings could well cause some messes, worth keeping an eye on. not entirely sure how we'd go about running a test day for it, as it could affect an awful lot of stuff
16:48:26 <adamw> https://fedoraproject.org/wiki/Changes/ThunderboltEnablement seems like another test day candidate, assuming we know anyone with testable hardware...
16:48:49 <adamw> (man, i should have been #info'ing all of these)
16:49:00 <Kohane> Actually, yes...
16:49:19 <adamw> https://fedoraproject.org/wiki/Changes/AnacondaModularization will obviously affect validation, but we'll naturally test it as part of the usual validation testing
16:50:02 <adamw> oh yikes, https://fedoraproject.org/wiki/Changes/AuthselectAsDefault will again affect validation, both anaconda and freeipa use authconfig
16:50:07 <adamw> this is gonna be a fun cycle!
16:50:20 <sumantro> you bet! :)
16:50:22 <Kohane> Looks like!
16:50:47 <Kohane> BTW, I don't have any Thunderbolt hardware as far as I can tell, so that's something I cannot test.
16:51:11 <adamw> oof, and https://fedoraproject.org/wiki/Changes/AArch64_Server_Promotion just showed up today...entirely missing the bit where we would need someone with aarch64 hardware to test it.
16:51:36 <adamw> well, pwhalen is a co-proposer, i guess.
16:51:38 * pwhalen raises his hand
16:51:43 <Kohane> What kind of computer is that? Never heard of before.
16:51:49 <adamw> Kohane: 64-bit ARM
16:51:56 <adamw> aarch64 is the 'official' arch name for it
16:52:10 <adamw> pwhalen: are you really volunteering to run all the Server tests manually?
16:52:21 <adamw> pwhalen: doing that is a gigantic pain, which is why i spent weeks teaching openqa to do it...
16:52:29 <Kohane> Ah, okay. Thanks adamw
16:52:38 <Kohane> Now it sounds familiar
16:53:04 <pwhalen> openqa works for aarch64 as well, but between myself and others we can also cover the manual testing
16:53:07 <adamw> pwhalen: it might be easier/better to add some aarch64 workers to openqa, we've already added ppc64 so we've kinda proven the process
16:53:14 <adamw> pwhalen: we'd need hardware to test in openqa
16:53:26 <pwhalen> right, we should have some hw for it
16:53:39 <adamw> pwhalen: do we have hw in phx?
16:53:56 <pwhalen> yes, already in place
16:54:01 <adamw> (note for others: phx is where the main fedora data center is, including our openqa deployment)
16:54:07 <adamw> pwhalen: aha, great. i'll follow up with you on that then
16:54:17 <pwhalen> great, thanks
16:54:24 <adamw> #action adamw and pwhalen to discuss adding aarch64 workers to openqa
16:54:55 <adamw> #info see logs for call-outs of several specific Changes for validation testing / Test Day purposes, sorry for not individually #info'ing them
16:56:06 <adamw> OK, we're running out of time, so moving on quickly - we can have this topic again next week for any further discussion
16:56:07 <adamw> #topic Test Day status
16:56:17 <adamw> sumantro: i guess the status is that you're waiting for a bit later in the cycle at present?
16:56:36 <sumantro> yes
16:56:40 <sumantro> exactly
16:57:16 <sumantro> we have the bits in place and many lined up as you marked but then we need to have the mass rebuild to complete
16:57:24 <adamw> roger, indeed
16:57:42 <adamw> #info most test day planning is waiting for later in the cycle, after the mass rebuild and when the Changes start to land
16:57:46 <adamw> #topic Open floor
16:57:51 <adamw> any other business, quickly? :)
16:58:00 <adamw> note, we have blocker review in #fedora-blocker-review at the top of the hour.
16:58:09 <tenk> quickly: HoF 26 and the HoF period (to short for me)
16:58:21 <adamw> i think coremodule was meant to be doing the HoF, right?
16:58:25 <Kohane> HoF?
16:58:32 <adamw> Kohane: Heroes of Fedora
16:58:36 <Kohane> Oh
16:58:49 <Kohane> I thought it was related to software, sorry.
16:58:58 <adamw> Kohane: we usually run some blog posts (in various places, lately it's been the community blog) which list out major contributors to testing
16:59:00 * Kohane smiles nervously ashamed
16:59:01 <tenk> for me the period is to focus on the final period and not relevant for people doing test all the year
16:59:06 <adamw> Kohane: don't worry :)
16:59:41 <adamw> tenk: indeed, it seems like only 27 Final HoF was run
16:59:48 <adamw> not Beta or pre-Beta
16:59:57 <tenk> i talk abouy the HoF 26 :)
17:00:04 <adamw> tenk: i think we did a full set for f26...
17:00:15 <adamw> or did we only do alpha? mm
17:00:26 <adamw> hmm, yes
17:00:30 <sumantro> we did alpha I suppose
17:00:37 <adamw> https://communityblog.fedoraproject.org/tag/heroes-of-fedora/ - it looks like every milestone from f26 alpha to f27 final is missing
17:00:46 <adamw> coremodule: do you think you could do some fill-in posts?
17:01:09 <tenk> and about the time to focus?
17:01:30 <adamw> tenk: we really want people to be testing all the time
17:01:59 <adamw> tenk: even for validation testing, it's really useful to know the status of the Final tests early in the cycle - it's much better to know something is broken and have it fixed in advance, than to find out late
17:02:43 <adamw> tenk: of course, if you have, say, a week or two that you can "spend" on really focused testing...it's always useful to have folks around for the time right around go/no-go
17:02:47 <tenk> yes of course but for me the time is to focus on the late test. Not o the early validation testing
17:03:46 <tenk> adamw: ok i understand, push people to do some test during this period if they can only do few weekds of test
17:04:11 <adamw> yeah,
17:04:22 <adamw> OK, we're a bit over time, so let's wrap it up :)
17:04:25 <adamw> thanks for coming everyone
17:04:26 * adamw sets the fuse
17:05:03 <sumantro> adamw thanks for hosting
17:05:45 <adamw> see you over in #fedora-blocker-review for some blocker reviewing fun times!
17:05:54 <Kohane> See you there!
17:06:12 <adamw> #action adamw to check with coremodule if he can write HoF posts for F26 Beta / Final and F27 Beta
17:06:19 <adamw> #endmeeting