15:04:29 <adamw> #startmeeting Fedora QA Meeting
15:04:29 <zodbot> Meeting started Mon Aug 20 15:04:29 2018 UTC.
15:04:29 <zodbot> This meeting is logged and archived in a public location.
15:04:29 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:29 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:04:31 <adamw> #meetingname fedora-qa
15:04:31 <zodbot> The meeting name has been set to 'fedora-qa'
15:04:33 <adamw> #topic Roll call
15:04:53 <adamw> morning folks! who's around for a QA meeting?
15:04:53 * coremodule is here and ready for QA fun!
15:05:11 * adamw notes that fun was not promised
15:05:20 <coremodule> :( buuuuuut
15:05:22 <adamw> and cannot be guaranteed
15:06:22 <lruzicka> .hello2
15:06:23 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:06:39 <frantisekz_> .hello2
15:06:40 <zodbot> frantisekz_: Sorry, but you don't exist
15:07:18 <adamw> .fire frantisekz_ don't you know existing is compulsory around here
15:07:18 <zodbot> adamw fires frantisekz_ don't you know existing is compulsory around here
15:07:52 <adamw> unless, of course, you're in a certain bar
15:07:52 <frantisekz_> :'(
15:08:18 <frantisekz> .hello2
15:08:19 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:08:22 <frantisekz> Yay! :D
15:09:31 <adamw> .hire frantisekz fiiiiiiine
15:09:31 <zodbot> adamw hires frantisekz fiiiiiiine
15:10:23 * adamw wonders where everyone else is
15:11:17 <lruzicka> you mean us, or the community, adamw?
15:11:28 <adamw> we're all us!
15:12:14 <lruzicka> adamw, of course ... so I cannot speak for all of us, but some of us are either sick or they have destroyed their computer by switching to F29 and cannot come :)
15:12:29 <adamw> but that's unpossible, everyone knows it has no bugs
15:13:21 <lruzicka> adamw, yes .. indeed. Cancel the blocker bug review today then?
15:13:32 <lruzicka> :
15:13:34 <lruzicka> :)
15:13:41 <adamw> uhhhhhhhh....
15:13:46 <adamw> .fire lruzicka for insubordination
15:13:46 <zodbot> adamw fires lruzicka for insubordination
15:13:50 <adamw> hi sumantro!
15:13:55 * lruzicka squeeks
15:14:46 <adamw> welp, i guess we can run through things
15:14:55 <adamw> #topic Previous meeting follow-up
15:15:13 <adamw> "lruzicka and sgallagh to discuss changes to proposed SSO GSSAPI test case on server@ list"
15:15:16 <adamw> wow, that's a blast from the past
15:15:21 <adamw> lruzicka: remember anything about that? :)
15:16:09 <lruzicka> adamw, yeah, Stephen suggested some changes, but I could not find any time to make them, because I started to work on those metrics
15:16:46 <lruzicka> adamw, I hope, I will be able to go on later this week.
15:16:54 <adamw> roger, gotcha
15:17:04 * Tenk sorry i am late
15:17:12 <adamw> #info "lruzicka and sgallagh to discuss changes to proposed SSO GSSAPI test case on server@ list" - sgallagh has proposed some changes but lruzicka has not had time to work on them yet, he hopes to get to it later this week
15:17:14 <adamw> morning tenk!
15:17:40 <adamw> anyone who still remembers the last meeting have anything else to follow up on from it?
15:18:42 <coremodule> I think I forgot but I can't remember
15:19:37 <adamw> .fire coremodule just cuz
15:19:37 <zodbot> adamw fires coremodule just cuz
15:19:43 <coremodule> gosh darnit
15:19:51 <adamw> alrighty then!
15:20:24 <adamw> lruzicka: did you go to flock?
15:20:57 <adamw> frantisekz: or you? actually, just, did anyone here go to flock? :)
15:21:29 <coremodule> I did!
15:21:43 <coremodule> sumantro did!
15:21:50 <frantisekz> adamw: no, I was having some fun in military ... :)
15:22:01 <lruzicka> adamw, Yes, I did.
15:22:02 * adamw still not sure if sumantro's here...
15:22:05 <adamw> alrighty then
15:22:14 <adamw> i'm going throw the three of you under the bus with a secret topci!
15:22:18 <adamw> #topic Flock news
15:22:24 <adamw> soooo, what all happened at flock that we should know about?
15:22:40 <coremodule> nothing to see here, move along
15:22:52 <adamw> #info Flock 2018 happened in Dresden from Aug 8th to Aug 11th
15:23:02 <lruzicka> One important thing, I would like to mention is connected with Fedora Server.
15:23:33 <lruzicka> There was one sesson, where sgallagh said that there is not any particular plan, where Fedora server should go next.
15:24:01 <sgallagh> That was at the beginning of the session :)
15:24:14 <sgallagh> The brainstorming session kicked off a lot of ideas
15:24:27 <lruzicka> He said that Fedora 28 was mainly to bring modularity into it and that we should start thinking about where to go next
15:24:38 <lruzicka> there was a home work to provide suggestions
15:24:58 <lruzicka> besides those presented at the session
15:25:27 <lruzicka> And if I remember correctly, one of the things mentioned was the functionality of Cockpit.
15:25:44 <adamw> mentioned how?
15:25:46 <sgallagh> Yeah, the big takeaways were that we should be rallying around Cockpit and Ansible
15:26:07 <sgallagh> That new Server features should be built around one or both of those primary technologies
15:27:15 <adamw> #info a session on the future of Fedora Server reported that its future direction is uncertain, there was a brainstorming session that provided lots of ideas. per sgallagh, main takeaway was that any future features should be built around Cockpit, Ansible or both
15:27:27 <adamw> thanks for that
15:27:49 <sgallagh> ack
15:28:28 <adamw> any other stuff of significance to QA?
15:28:46 <adamw> i have heard dark rumours of wild ideas involving bugzilla...
15:30:15 <coremodule> wasn't directly stated, but there could be more QA presence in ARM, with IoT becoming an official Fedora release
15:30:38 <lruzicka> I do not know anything about Bugzilla :(
15:33:10 <lruzicka> I mean anything wild ...
15:36:29 <adamw> alrighty
15:36:33 <adamw> sorry, just had to go rub cream on my cat...
15:36:39 <adamw> (today in things you never thought you'd say)
15:38:30 <adamw> #topic Fedora 29 / Rawhide status
15:39:41 <adamw> so, we have had both Rawhide and F29 composes, but there have been a few issues with package signing and mirrorlist
15:40:15 <adamw> it seems like there is something up with the compose process now, as all recent Rawhide and Branched composes have failed
15:40:25 <adamw> there've been a lot of attempts at Rawhide, suggesting releng is trying to fix it...
15:40:38 <adamw> nirik: mboddu: either of you can give us a quick update?
15:41:07 <nirik> there's a rawhide compose going now.
15:41:21 <mboddu> adamw: Signing issue should be fixed in next successful rawhide compose
15:41:42 <nirik> the last one failed due to a grubby dep. The N this weekend failed due to modules signing and a misconfig where rawhide was looking at f29-modular for modules.
15:41:51 <adamw> OK
15:41:55 <nirik> I have hopes and dreams this one will work.
15:42:13 <adamw> last branched seemed to hit the "Empty array 'rpms'" error - does it need re-running?
15:42:14 <nirik> we could fire a f29 also I guess
15:42:26 <nirik> yeah, it does, and it already doesn't have the grubby dep thing
15:42:31 <adamw> alrighty then
15:42:33 <nirik> mboddu: you want to fire another branched?
15:42:44 <mboddu> adamw: We could rerun it, I will update the productmd and pungi and rerun f29/branched
15:42:46 <mboddu> nirik: Will do
15:43:06 <nirik> I already updated those. it should be ready to run
15:43:38 <adamw> #info F29 branching is complete, we have had completed F29 and Rawhide composes since, but there were a few issues in each; next successful composes should resolve the known issues, but there have been some problems getting the composes to finish, releng is hopeful the current attempts will work
15:44:25 <lruzicka> sounds great
15:44:49 <adamw> #info as a regular reminder, if you were following Rawhide because you wanted to follow F29, you need to change your repo config now - Rawhide is now what will become f30 at the next branch point, f29 is separate. see https://fedoraproject.org/wiki/Releases/Rawhide#Questions_and_Answers
15:45:45 <adamw> #info several proposed blockers in f29 have piled up over the last week, we'll have a blocker review meeting at the top of the hour
15:46:42 <adamw> any other notes on f29/rawhide at this point?
15:46:59 <mboddu> adamw, nirik : started branched compose
15:47:06 <adamw> thanks
15:47:56 <adamw> alrighty then
15:48:01 <adamw> #topic Test Day update
15:48:11 <adamw> where are we with test days, mboddu? any other events to note?
15:49:11 <lruzicka> Tomorrow should be a Kernel Test Day, afaik
15:49:12 <mboddu> adamw: I guess you wanted to ask someone else?
15:49:18 <adamw> doh
15:49:20 <adamw> sumantro
15:49:25 * adamw is clearly not awake yet
15:50:11 <mboddu> adamw: Its Monday and you need more coffee :)
15:50:20 <adamw> i dooo
15:50:28 <adamw> i guess sumantro really isn't here...
15:50:55 <adamw> so indeed, tomorrow *is* kernel test day
15:51:25 <adamw> #info tomorrow, 2018-08-21, will be a kernel test day - join in over in #fedora-test-day! page is https://fedoraproject.org/wiki/Test_Day:2018-08-21_Kernel_4.18_Test_Day
15:52:18 <adamw> #topic Open floor
15:52:43 <adamw> so, any other topics to bring up? we should actually look at reviewing the current status of F29 Changes, but I forgot :(
15:53:17 <adamw> #info F29 Change process is around the 'testable' point, so we should review all the significant Changes, check they're really testable, and...test them. I'll send a mail about that
15:53:26 <adamw> #action adamw to send out mail about F29 Change review
15:57:16 <adamw> welp, if that's all...i'll set the fuse and we can meet again for blocker review in a few minutes, over in #fedora-blocker-review
15:57:19 <adamw> thanks everyone!
15:58:57 <lruzicka> thank you, adam
15:59:59 <adamw> #endmeeting