16:04:47 <adamw> #startmeeting Fedora QA Meeting
16:04:47 <zodbot> Meeting started Mon Feb  3 16:04:47 2020 UTC.
16:04:47 <zodbot> This meeting is logged and archived in a public location.
16:04:47 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:04:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:04:47 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:04:48 <cmurf> i have a dossier on adamw, i'm his stalker
16:04:59 <tablepc> There's something there where lots and lots of people move every year on the same day/
16:04:59 <cmurf> oops the evidence is now in the minutes
16:05:02 <adamw> #meetingname fedora-qa
16:05:02 <zodbot> The meeting name has been set to 'fedora-qa'
16:05:07 <adamw> #topic Roll call
16:05:11 <adamw> stop stanning me geez
16:05:22 <cmurf> .hello chrismurphy
16:05:24 <zodbot> cmurf: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
16:05:29 <tablepc> .hello2
16:05:30 <zodbot> tablepc: tablepc 'Pat Kelly' <pmkellly@frontier.com>
16:05:39 <adamw> tablepc: the 'everyone move on the same day' thing is quebec, i think
16:05:45 <ravindralakal> Hello
16:05:53 <adamw> we just moved when the new house was ready :)
16:05:55 <adamw> hi ravindra
16:06:17 <tablepc> moving is no fun at all
16:06:22 <adamw> tell me about it
16:06:34 <adamw> i feel like i live in a box factory
16:06:47 * kparal is here
16:06:55 <adamw> but the internet is back up! okay, via powerline ethernet from the one working outlet in the house, shared with the tv
16:06:57 <adamw> but back up!
16:07:07 * cmurf loves it so much he does it twice a year
16:07:14 <cmurf> kind proves my insanity
16:07:15 <adamw> yowch
16:07:17 <adamw> yes it does
16:07:26 <adamw> well, that and sticking around here so long :P
16:07:32 <cmurf> that's a given
16:07:42 <adamw> seriously, sorry i've been away, folks, was expecting this move not to involve quite so much craziness
16:07:44 <tablepc> I always view moving as a chance to donate all the stuff we don't use anymore so the box count can be kept down.
16:07:44 * pwhalen is here
16:07:54 <adamw> tablepc: see, the scary thing is we *did* that
16:08:02 <adamw> i also smashed our old bed with a lump hammer, which was satisfying
16:08:30 <adamw> anyhoo, slap like now on my youtube channel for more
16:08:38 <adamw> let's get back to the program :P
16:08:49 <lruzicka> It is better to burn down twice than move once.
16:08:59 <cmurf> my notes don't indicate you have a youtube channel
16:09:00 <cmurf> :P
16:09:12 <tablepc> I have some Python code handy will that do?
16:09:21 <adamw> sure! run it, what's the worst that could happen
16:09:34 <adamw> lruzicka: is that a czech saying? it sounds like a czech saying
16:09:44 <adamw> #topic Previous meeting follow-up
16:09:52 <lruzicka> adamw, yes :)
16:10:06 <adamw> heh :)
16:10:22 <adamw> soo, what do we have here
16:11:10 <adamw> #info "tablepc to rename the [unmount] draft to the final name and add it to the matrix" - this was done, it is now live at https://fedoraproject.org/wiki/QA:Testcase_base_reboot_unmount , and even automated thanks to lruzicka
16:11:21 <tablepc> Done
16:11:22 <adamw> thanks again to tablepc for working on that
16:11:37 <tablepc> I just sent a new proposal to the list
16:11:52 <adamw> #info "adamw to publish sponsor SOP drafts under final names and approve alciregi as a sponsor" - also done, see https://fedoraproject.org/wiki/Category:QA_SOPs
16:11:58 <adamw> cool, we have a proposals topic coming up
16:12:09 <adamw> any other follow up from last time?
16:13:34 <adamw> i guess not!
16:13:48 <adamw> #topic Fedora 32 status
16:13:56 <adamw> so, again, i've been basically out for a week
16:14:07 <adamw> but from what i've gathered the status is...kinda buggy
16:14:11 <adamw> anyone been looking into things?
16:14:13 <tablepc> It seems F32 has been sick
16:14:28 <adamw> (like, i did notice that if i plug in a yubikey, GNOME crashes...)
16:14:40 <tablepc> Anaconda ill.
16:14:51 <adamw> someone call the vet!
16:15:25 <tablepc> Live won't boot
16:15:42 <adamw> do we have blocker bugs filed on the issues?
16:16:06 <tablepc> I failed to do that.
16:17:45 <pwhalen> some selinux issues, but its not too broken (at least on arm/aaarch64)
16:18:39 <lruzicka> I am downloading the iso just to give it a try
16:18:44 <pwhalen> I have a bug I need to propose as a blocker, likely only affects 32 bit arches. Seccomp denial on ssh
16:19:36 <adamw> fun
16:19:49 <tablepc> I did sent a note to the list with my observations
16:20:17 <tablepc> as I recall 0127 and 0131 failed the same way
16:20:56 <cmurf> there's a glib2 problem that looks like an selinux problem
16:21:15 <cmurf> i.e. enforcing=0 makes the problems go away
16:22:02 <cmurf> i nominated a bug as a blocker, it's probably a dup but can figure that out in blocker review
16:22:25 <adamw> yeah, i think i had to boot with enforcing=0 too
16:22:50 <tablepc> I guess I need to figure out how to set enforcing=0 when trying to boot live.
16:22:56 <pwhalen> ah right, it is glib2 - https://bugzilla.redhat.com/show_bug.cgi?id=1795524
16:23:13 <cmurf> tablepc: TAB key then enforcing=0 then RETURN key
16:23:14 <pwhalen> lots of dups on that
16:23:31 <adamw> hah, this is a fun one in openqa: https://openqa.fedoraproject.org/tests/516544#step/_console_shutdown/3
16:23:34 <tablepc> Thanks
16:23:39 <adamw> "poweroff: command not found"
16:23:52 <cmurf> yeah i think that's related too
16:24:12 <cmurf> there's a bunch of traps that happen when selinux does denials as a result of the glib2 change (very loosely paraphrasing)
16:24:41 <cmurf> might even explain the flickering+crashing gnome-session bug that's also a blocker
16:24:58 <adamw> #info we are seeing various issues in Rawhide right now in both openQA and manual testing; several of them may be related to an SELinux denial on glib2 , https://bugzilla.redhat.com/show_bug.cgi?id=1795524 . we will continue to investigate these bugs and try to get them solved
16:26:10 <adamw> okay
16:26:14 <adamw> any other notes on f32 atm?
16:26:21 <lruzicka> So, I could not boot the live image, it hangs on Gnome display manager and before there were errors starting ModemManager
16:26:35 <cmurf> lruzicka: yeah same problem
16:26:45 <tablepc> Me too
16:26:47 <cmurf> enforcing=0 will get you past it
16:26:53 <lruzicka> ok
16:28:05 <kparal> I believe that's coremodule's bug right here: https://bugzilla.redhat.com/show_bug.cgi?id=1795524
16:28:07 <adamw> same bug, probably
16:29:39 <adamw> okay, moving along then
16:29:43 <adamw> #topic Desktop validation changes?
16:30:06 <adamw> pwhalen: kparal: you guys ok with kicking this around in the meeting or did you want more time to cook it?
16:30:36 <kparal> I didn't get around to writing some proposal yet
16:30:37 <pwhalen> no issues here
16:30:43 <kparal> no preferences
16:31:11 <adamw> i just wanted to have a kinda preliminary discussion, see what people think
16:31:19 <pwhalen> lets do it :)
16:31:21 <kparal> are we clear on what changes in release blocking media there will be in F32?
16:31:30 <kparal> I mean all of them
16:31:30 <adamw> i don't think so?
16:31:43 <adamw> i mean, i'm not :P is anyone else?
16:31:48 <adamw> are you expecting some changes?
16:31:57 <kparal> I know just about CoreOS and IoT
16:32:05 <kparal> becoming blocking
16:32:10 <kparal> well, editions
16:33:02 <adamw> ah, right. well, CoreOS yes, but as we talked with dusty, that doesn't exactly mean it slots right into release validation, it's kinda its own thing like two-week atomic was
16:33:18 <adamw> iot, sumantro and i are talking to pbrobinson about
16:33:46 <kparal> CoreOS major release cycle will be the same as Fedora one, just a month delayed
16:34:06 <kparal> two-week release updates are just Fedora stable updates analogy
16:34:14 <adamw> that was same for 2wa as well, i believe
16:34:35 <adamw> sooo to get everyone else up to speed :P
16:35:39 <adamw> while i was in brno for devconf we were talking about how we have new stuff like IoT and CoreOS coming on stream, and whether in that context we might look at reducing desktop testing requirements a bit
16:36:16 <adamw> specifically possibly not blocking on Xfce on 32-bit ARM any more (perhaps blocking on Workstation on 64-bit ARM instead), and maybe trying to trim how much of the KDE app set we commit to testing
16:36:19 <adamw> because KDE ships a *lot* of apps
16:36:46 <adamw> we don't have a firm draft proposal or anything yet, it was just a preliminary idea. anyone have thoughts?
16:37:22 <tablepc> Certainly a magnet for discussion
16:37:23 * kparal prepares rotten tomatoes for any opposition
16:37:27 <lruzicka> Yeah, I have proposed a similar thing a year or more ago, so I can proceed from there and try to write a draft.
16:37:43 <lruzicka> otherwise, I agree.
16:37:59 * cmurf stands next to kparal
16:38:11 <lruzicka> cmurf, so that he can hit you better?
16:38:34 <cmurf> lruzicka: no, so i can borrow tomatoes
16:38:43 <lruzicka> cmurf, heh :D
16:38:59 <tablepc> I've never been a KDE user, but I gave it a serious tryout once and IMHO it does have way too much stuff
16:39:17 <cmurf> how big is the ISO?
16:39:31 <tablepc> Haven't looked lately
16:39:55 <adamw> 1.8G
16:39:55 <lruzicka> cmurf, the iso is not much bigger than a workstation, but it consists of many small one task apps
16:40:03 <cmurf> gotcha
16:40:11 <adamw> the apps it ships aren't *big*, but there's lots of them :P
16:40:25 <cmurf> that's adorable
16:40:47 <pwhalen> heh
16:40:53 <lruzicka> yeah, I believe the KDE folks want to provide as much freedom as they can, so therefore it is a bit messy
16:40:53 <tablepc> Yeah that's what I saw
16:40:59 <kparal> the current idea is to define a set of essential KDE apps we will certainly try to test. the others would be best effort
16:41:08 <kparal> and a good option for community to participate(!)
16:41:12 <cmurf> seems reasonable
16:41:45 <kparal> XFCE will hopefully be solved by no longer having arm xfce as release blocking
16:41:51 <tablepc> Yeah KDE test days advertised on the Magazine
16:41:54 <pwhalen> are the KDE folks ok with the change? do they have a list of essentials?
16:41:55 <lruzicka> kparal, I would go further and define essential apps for all blocking desktopts (except Workstation)
16:42:11 <cmurf> I haven't previously heard of Workstation on ARM for blocking
16:42:11 <kparal> pwhalen: this is the first time we mentioned the idea publicly
16:42:22 <cmurf> ^release blocking
16:42:47 <tablepc> Yes, Good idea to define blocker apps on all
16:42:48 <adamw> pwhalen: we didn't ask yet :P hence this being a preliminary discussion
16:43:02 <kparal> lruzicka: as I said, there should be no other release blocking desktops, if things work out
16:43:08 <pwhalen> ok :) are we too late for f32?
16:43:23 <kparal> certainly not!
16:43:25 <kparal> ;)
16:43:28 <cmurf> haha
16:43:51 <cmurf> kparal has his surgeon's apron on
16:44:06 * kparal plays surgeon's simulator
16:44:24 <lruzicka> Well, we have already tried something like this, so this will not be the first time, we have mentioned it:
16:44:25 <lruzicka> https://lists.fedorahosted.org/archives/list/test@lists.fedoraproject.org/message/44O7RKA5RQVL4CHHPG63QOSSXWN3YYJ6/
16:44:52 <lruzicka> unfortunately, it did not get much attention at that time
16:45:07 <adamw> ok, so it sounds like folks are generally supportive of pushing forward with a proposal at least
16:45:17 <adamw> kparal, can i action you and pwhalen to work on it?
16:45:39 <kparal> sure
16:46:07 <kparal> who decides about which arm image is release blocking?
16:46:25 <adamw> ultimately ARM SIG, i guess?
16:46:43 <tablepc> Make a list for trial sent it out and see what happens
16:46:44 <adamw> as i read it pwhalen and pbrobinson are both happy with the idea of flipping it to be Workstation on aarch64
16:47:01 <kparal> ok
16:47:37 <adamw> i guess we can either make this two proposals (ARM switch, all-blocking-desktops app coverage reduction) and send the former to test@ and arm@ and the latter to test@ and the desktop lists
16:47:44 <adamw> or make it one big proposal and send to all of them
16:47:51 <adamw> former is more focused, latter includes all the context...
16:47:57 <kparal> pwhalen: would that image be the same as the IoT image?
16:48:18 <kparal> I'd personally first decide if we change something in arm space, and then submit the QA proposal
16:48:22 <kparal> but that takes more time
16:49:16 <adamw> i mean, for the ARM thing i'd say that if ARM SIG says 'we want to change this', there's nothing much to do on QA side
16:49:23 <cmurf> i'll send up a flare at tomorrow's Workstation WG meeting
16:49:24 <pwhalen> kparal, iot image is different
16:49:34 <kparal> pwhalen: ok
16:49:36 <cmurf> just so everyone's aware
16:49:44 <kparal> cmurf: thanks
16:49:44 <adamw> all we do is move some table rows around and maybe change a line of wording in the criteria (if we explicitly list the blocking desktops there, i don't remember)
16:49:51 <pwhalen> yes, we've long talked about dropping the desktop requirement. iirc it was needed for promotion once upon a time
16:50:49 <kparal> I think it's fine to keep it for x86_64 Workstation, it's our top product and we all use it regularly. But I believe we can't commit to everything else as well
16:51:06 <pbrobinson> adamw: yep, that works for me
16:51:49 <adamw> hey, it's official!
16:52:21 <adamw> okay, so, looks like we have a path forward here
16:53:08 <adamw> #action kparal and pwhalen to work on pushing forward desktop validation change proposals (switch ARM blocking desktop to be Workstation aarch64, and KDE or all-desktops app coverage reduction)
16:53:26 <adamw> so, we're a bit short on time, but:
16:53:27 <adamw> #topic Recent proposals
16:53:46 <adamw> so, unmount test case is done
16:53:53 <adamw> async blocker process is...still sort of outstanding
16:54:07 <tablepc> The onne I just sent was just an e'mail to the list on another Base test case
16:54:18 <adamw> yes
16:54:24 <lruzicka> adamw, lbrabec said the script was ready
16:54:27 <frantisekz> lbrabec made a huge progress on async blockerbugs
16:54:30 <adamw> nice
16:54:34 <kparal> we're waiting on new pagure deployment also need to figure out blockerbugs deployment to communityshift
16:54:34 <frantisekz> said ready to deploy
16:54:40 <frantisekz> which means it's blocking on me atm
16:54:47 <adamw> tablepc: for improving existing test cases, i'd say usually it's fine to just write up a draft of how you think it should look and post that for review
16:54:53 <adamw> you don't need to describe the proposed changes first :)
16:54:53 * cmurf needs a coffee b4 blocker review
16:54:54 <frantisekz> working on communishift port
16:55:34 <adamw> tablepc: note, i wrote the test to be intentionally a bit vague so it applies to multiple package managers
16:55:38 <adamw> it's a sort of testing process
16:55:49 <adamw> you can run it against dnf, or against GNOME Software, or against whatever KDE is using today
16:55:52 <tablepc> Okay
16:55:53 <adamw> that's why it doesn't give specific coommands
16:56:04 <adamw> we *could* include DNF commands as examples, though, i guess.
16:56:15 <adamw> just as long as it's clear they're not the *only* choice.
16:56:27 <tablepc> Okay
16:56:42 <adamw> btw, i have also been wondering why we don't have this test automated in openqa. i am almost sure i did it once. maybe that was a fever dream.
16:56:44 <lruzicka> adamw, dnf runs everywhere, so providing the commands as a guidelines to folks might be good
16:56:59 <lruzicka> adamw, which one exactly?
16:57:08 <adamw> lruzicka: package_install_remove
16:57:10 <adamw> at least for dnf
16:57:33 <lruzicka> adamw, oh my, I thought it only were not reporting
16:57:38 <lruzicka> adamw, I can work on it.
16:58:11 <adamw> #info for async blockerbugs: work on the technical side here is progressing, and frantisekz is working on porting the blockerbugs app to be deployable in communishift (infra openshift)
16:58:27 <adamw> lruzicka: maybe it is only not reporting? like i said i'm sure i wrote the test code once :P i don't remember any more!
16:58:53 <lruzicka> adamw, yeah, I wonder why we would not have such a test already.
16:59:11 <adamw> okay, so we're out of time before blocker review
16:59:14 <adamw> let's wind up there :)
16:59:18 <tablepc> So should I go ahead with a draft test case for install remove or  not?
16:59:21 <lruzicka> adamw, as I said, I can check and work on it if necessary
16:59:35 <lruzicka> tablepc, yes please
16:59:53 <adamw> #info tablepc proposed some changes to https://fedoraproject.org/wiki/QA:Testcase_package_install_remove , he will send a draft of the actual changes soon
17:00:15 <adamw> #action tablepc to draft up his proposed changes to https://fedoraproject.org/wiki/QA:Testcase_package_install_remove and send them to the list
17:01:51 <adamw> thanks for coming, everyone!
17:01:53 <adamw> #endmeeting