15:01:05 <adamw> #startmeeting Fedora QA meeting
15:01:05 <zodbot> Meeting started Mon Sep 20 15:01:05 2021 UTC.
15:01:05 <zodbot> This meeting is logged and archived in a public location.
15:01:05 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:05 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:01:07 <adamw> #meetingname fedora-qa
15:01:07 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:13 <adamw> #topic Roll Call
15:01:39 <adamw> ahoyhoy folks, who's around?
15:01:46 <tflink> morning
15:01:50 <bcotton> .hello2
15:01:50 <zodbot> bcotton: Something blew up, please try again
15:01:53 <zodbot> bcotton: An error has occurred and has been logged. Please contact this bot's administrator for more information.
15:02:07 * coremodule is present
15:02:10 <bcotton> wow, zodbot, i see how you are
15:02:13 <kk4ewt[m]> .hello2 jbwillia
15:02:14 <zodbot> kk4ewt[m]: Something blew up, please try again
15:02:17 <zodbot> kk4ewt[m]: An error has occurred and has been logged. Please contact this bot's administrator for more information.
15:02:27 <kk4ewt[m]> .hello jbwillia
15:02:28 <zodbot> kk4ewt[m]: Something blew up, please try again
15:02:31 <zodbot> kk4ewt[m]: An error has occurred and has been logged. Please contact this bot's administrator for more information.
15:02:33 <frantisekz> .hello2
15:02:34 <zodbot> frantisekz: Something blew up, please try again
15:02:37 <zodbot> frantisekz: An error has occurred and has been logged. Please contact this bot's administrator for more information.
15:03:32 <adamw> er
15:03:52 <adamw> nirik: what's wrong with the robot
15:04:03 <adamw> #info tap tap tap is this thing on?
15:04:05 <nirik> not sure. let me look?
15:04:10 <adamw> oh wait, different robot. eh, we're probably okay then.
15:04:27 <adamw> NO
15:04:59 <adamw> how's everyone today?
15:06:33 <bcotton> better than zodbot!
15:06:33 <adamw> heh, low bar
15:06:33 <nirik> thats my new band's name... :)
15:06:33 <adamw> you get back to blind debugging, mister
15:06:36 <nirik> I suspect it's only the fedora plugin thats having issues.
15:06:42 <nirik> the meeting functions should be fine
15:07:16 <nirik> ok, try now?
15:07:21 <nirik> .hello kevin
15:07:22 <zodbot> nirik: kevin 'Kevin Fenzi' <kevin@scrye.com>
15:08:03 <adamw> alright, i guess we'll let you off this time :D
15:08:03 <bcotton> .hello2
15:08:04 <adamw> thanks
15:08:04 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:08:18 <bcotton> it's a-me, Fiasco!
15:09:11 <frantisekz> .hello2
15:09:12 <zodbot> frantisekz: frantisekz 'FrantiĊĦek Zatloukal' <fzatlouk@redhat.com>
15:09:53 <adamw> #topic Previous meeting follow-up
15:11:39 <adamw> #info "adamw to figure out exact current state of pipewire session manager
15:11:39 <adamw> stuff (fresh install vs. upgrade, wireplumber vs. 'example session
15:11:39 <adamw> manager'" - that all got squared away a week or two back, it's all tested to be correct now
15:11:44 <adamw> grrrr line breaks
15:11:47 <adamw> #undo
15:11:47 <zodbot> Removing item from minutes: INFO by adamw at 15:11:39 : "adamw to figure out exact current state of pipewire session manager
15:12:27 <adamw> #info "adamw to figure out exact current state of pipewire session manager stuff (fresh install vs. upgrade, wireplumber vs. 'example session manager'" - that all got squared away a week or two back, it's all tested to be correct now
15:12:38 <adamw> any other followup?
15:14:12 <coremodule> beef its whats for dinner
15:14:13 <coremodule> no
15:14:22 <adamw> alrighty then
15:14:41 <adamw> #topic Fedora 35 status
15:16:07 <cmurf[m]> .hello chrismurphy
15:16:08 <zodbot> cmurf[m]: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
15:18:11 <adamw> hi chris
15:19:00 <adamw> #info overall, fedora 35 is in 'quite good' state right now. we missed the early date and the first real target date for beta, we've got another shot for go/no-go on thursday. the blocker list is getting small but not empty yet. in general things are mostly working
15:19:24 <adamw> any other notes on f35? any concerns that aren't already captured in blocker/fe lists?
15:20:17 <bcotton> i guess "matthew" had better get started drafting the release announcement
15:22:58 <adamw> "sure"
15:23:07 <adamw> #topic Startup time criteria
15:23:39 <adamw> so, we did wind up adopting the last draft of the criterion about initial setup startup delays, but i kinda think we could tweak it a bit
15:24:12 <adamw> i would like to make the text fuzzier - not state specific amounts of time, as these vary wildly across systems - and i think it should be more general. there's no reason to limit it to initial setup tools, really
15:24:34 <adamw> i'd want to cover something like startup to usable environment time being 'reasonable' or some such weasel wrod
15:24:48 <adamw> what do people think?
15:24:57 <frantisekz> yeah, the exact time might be complicated, something fuzzier sounds reasonable
15:25:11 <bcotton> so i could make arguments for both a more prescriptive or a more fuzzy case
15:25:13 <frantisekz> reasonable sounds reasonable... :D
15:25:21 <adamw> my idea would be to have the criterion worded quite loosely, and have some somewhat more detailed examples/ranges in the footnotes
15:25:41 <adamw> it feels like the kind of thing where we need room for interpretation, a too-precise rule could lead to odd decisions
15:25:53 <bcotton> but i am amused by the fact that i was the one advocating a well-defined time period and adam is being fuzzy. usually it's the other way around :-)
15:27:20 <bcotton> i don't oppose a fuzzier criterion. my main concern is the amount of time we'd spend arguing over "reasonable". if there's some way we can give it a rough meaning so we're all in the same chapter, if not on the same page, that'd be nice
15:27:48 <tflink> I think that's what adamw is thinking of WRT putting examples in the footnotes
15:28:14 <bcotton> like if we could give a time for reference hardware (e.g. openQA)
15:28:16 <adamw> yeah, that was the idea
15:28:54 <bcotton> wfm
15:29:21 <tflink> also sounds good to me
15:30:15 <adamw> ok, i'll draft something up, then
15:30:31 <adamw> #action adamw to draft vaguer and more general startup time criterion (but not too vague)
15:31:25 <adamw> #topic Test Day / community event status
15:31:31 <adamw> sumantro: around?
15:33:57 <adamw> i guess not! let me see, then
15:34:38 <adamw> we had kernel test week last week: https://fedoraproject.org/wiki/Test_Day:2021-09-12_Kernel_5.14_Test_Week
15:34:54 <adamw> jforbes noted turnout was slightly low, maybe our bad for not promoting it a bit, sorry
15:35:02 <adamw> 256 tests from 109 testers
15:35:29 <jforbes> I think I got the data I need from it
15:36:15 <adamw> great. i'll try and check in with sumantro on what was up with turnout and see if we can do better next time
15:36:19 <jforbes> That testers count can be deceiving though as I built a lot more kernels than I typically do. Usually there are 2-3 during a test week, this time there were 5, so a lot of those testers probably tested 5 times
15:36:46 <adamw> #info kernel 5.14 test week ran successfully last week - https://pagure.io/fedora-qa/issue/680
15:37:11 <adamw> #info audio test day ran successfully too - https://pagure.io/fedora-qa/issue/678
15:37:21 <adamw> we had several testers there and some bug reports generated
15:37:30 <adamw> 0000000000
15:37:53 <adamw> sigh, everyone welcome my cat's rear end to the meeting
15:38:23 <bcotton> hi, kitty
15:39:07 <adamw> #info GNOME test week also ran last week (busy week!) - https://pagure.io/fedora-qa/issue/670
15:39:15 <adamw> looks like that went well with good participation and found some bugs
15:39:27 <adamw> big thanks to everyone who came out and helped test!
15:40:11 <adamw> did anyone have notes, questions, concerns from the test days?
15:44:10 <adamw> i guess not!
15:44:13 <adamw> #topic Open floor
15:44:36 <adamw> any other business, folks? blocker review is at the top of the hour over in #fedora-blocker-review
15:45:06 <bcotton> how are we doing on nightlies testing?
15:45:30 <bcotton> that way when/if we get an RC soon, we have a head start
15:45:39 <frantisekz> looked at some stuff with kparal today, looked okay so far
15:47:29 <adamw> i have not had a chance to check the matrix, but good question
15:47:30 <adamw> let's see
15:49:07 <adamw> looking pretty solid overall
15:49:08 <adamw> we're missing 'real printer' desktop test
15:49:41 <adamw> we're missing the freaking AD tests for server - paging sgallagh ?
15:50:23 <adamw> and we don't have cloud tests run in a real cloud
15:50:45 <adamw> if folks can help out with those it'd be great
15:51:57 <cmurf[m]> Ohhh i did a printer test
15:52:02 * pwhalen will test aarch64 cloud images on aws
15:52:12 <cmurf[m]> Real world to an IPP printer. It worked
15:53:11 <StephenGallagher> adamw: Sorry, I actually have been trying to offload this to someone who still works in that space, but I haven't been successful yet.
15:53:14 <StephenGallagher> I'll get on those today.
15:54:36 <bcotton> Stephen Gallagher: if i can help chase up a responsible party, let me know
15:54:59 <adamw> sgallagh: rgr. sorry, i know they're a pain :( i wish we could get them automated somehow. maybe if not we'll have to just drop the requirement.
15:55:26 <StephenGallagher> adamw: It might be worth revisiting that, yeah.
15:55:29 <cmurf[m]> Date of this print test was 2021-09-16, and system was updated 2021-09-14
15:55:46 <StephenGallagher> Previously, we didn't have open licenses for it, which was part of the problem.
15:55:58 <adamw> cmurf: can probably just throw it on the matrix for the latest candidate...
15:56:10 <StephenGallagher> But I think they changed the licensing for Server 2019
15:56:14 <adamw> Stephen Gallagher: okay, we can follow that up in the server list i guess
15:56:15 <cmurf[m]> So we can take that to the bank :)
15:58:40 <adamw> alrighty, thanks everyone!
15:58:45 <adamw> let's shift over to the blocker review channel
15:58:49 <adamw> #endmeeting