16:01:19 <adamw> #startmeeting Special Fedora QA meeting: Wireplumber
16:01:19 <zodbot> Meeting started Fri Oct  8 16:01:19 2021 UTC.
16:01:19 <zodbot> This meeting is logged and archived in a public location.
16:01:19 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:01:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:19 <zodbot> The meeting name has been set to 'special_fedora_qa_meeting:_wireplumber'
16:01:21 <geraldosimiao> Ahoy captain
16:01:34 <adamw> #meetingname fedora-qa
16:01:34 <zodbot> The meeting name has been set to 'fedora-qa'
16:01:38 <adamw> #topic Roll Call
16:01:55 <geraldosimiao> .hello geraldosimiao
16:01:56 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
16:02:33 <adamw> who else is around?
16:02:44 * coremodule is here
16:03:13 <nirik> morning
16:03:27 * gkiagia also watching
16:03:27 <lruzicka2> .hello lruzicka
16:03:30 <zodbot> lruzicka2: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
16:05:57 <adamw> alrighty, anyone else can join in as we go, i guess
16:05:58 <adamw> we have just one topic for today!
16:06:02 <adamw> #topic Should we revert to the simple session manager, or stick with Wireplumber?
16:06:24 <adamw> so, thanks to gkiagia for working hard on this all week
16:06:53 <adamw> #info a new update with fixes for several of the issues that have been discussed was submitted recently: https://bodhi.fedoraproject.org/updates/FEDORA-2021-b70755fdc3
16:07:43 <adamw> so far two people have posted positive feedback indicating it does fix some of the relevant issues, but for one person the update apparently broke sound entirely. unfortunately he's not available to investigate further today.
16:07:57 <adamw> #info update has two positive responses, but one significant negative response we can't look into further today
16:08:38 <geraldosimiao> An user at the Brazilian community have both issues and the update fixed for him
16:08:58 <geraldosimiao> I tell him to give karma and describe at the ticket
16:09:09 <adamw> thanks
16:09:59 <adamw> looking quickly through the issues that have been referred to in the mailing list and the ticket, i see some that are not yet addressed
16:10:25 <adamw> #info some issues are not yet addressed:
16:10:41 <nirik> it seems working for me in a few minutes of testing, but nothing much tricky.
16:11:06 <adamw> #info playback delay on digital connections when stream contains passthrough-capable audio - https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/63
16:11:31 <adamw> #info (possibly) spotify audio output changing - https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/59
16:11:44 <lruzicka2> I am surprised that there are issues with wireplumber, because I am not seeing anything except the log out log in issue which I did not spot, as I am never logging out and in normally.
16:11:54 <adamw> does anyone use spotify from flatpak and can check on that? it sounds like gkiagia couldn't understand exactly what the issue is in that case
16:12:56 <adamw> i think that's it. https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/58 is not exactly solved, but from the description reads like it may be a general hardware/pipewire issue, not a wireplumber one.
16:13:40 <adamw> lruzicka2: audio is one of those things with a million different devices and use cases :D
16:14:03 <gkiagia> I use spotify from flathub daily (free account), but I cannot find any option within the application to change the output; changing the output from pavucontrol works
16:14:05 <lruzicka2> adamw, yes, I understand that and therefore we do not block on anything special, just common use cases
16:14:30 <nirik> google meet works seemingly, which was hit or miss recently.
16:14:45 <adamw> gkiagia: possibly it tries to do some sort of automatic switching when you plug in headphones or something?
16:15:14 <lruzicka2> I am downloading the AC3 stuff and will test the delay right now.
16:15:51 <adamw> lruzicka2: i don't think that needs re-testing, we know it's broken, by the sounds of it
16:15:54 <adamw> (pun intended!)
16:16:05 <adamw> gkiagiajust didn't get time to fix it yet
16:16:14 <gkiagia> regarding issue 58, it has been confirmed to happen with p-m-s too: https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/58#note_1095405
16:16:22 <adamw> aha, that's useful
16:16:26 <adamw> so switching won't help
16:17:02 <adamw> so, for concrete known issues, we're down to the passthrough delay.
16:17:03 <lruzicka2> adamw, I wanted to see it for myself. It loaded in 24 seconds.
16:17:10 <adamw> however, the whole 'audio broke on update' thing worries me. :D
16:17:22 <lruzicka2> adamw, but would something like that considered a blocking behaviour? I am not sure.
16:18:22 <adamw> lruzicka2: this is kind of different from a blocker meeting, we don't have nice solid rules to work with :D
16:18:30 <adamw> all we've got is, fesco asked us to pick a choice.
16:18:43 <adamw> so, looking at the bug tracker, there's one other bug it looks like hasn't been referenced...
16:18:44 <adamw> https://bugzilla.redhat.com/show_bug.cgi?id=2008645
16:19:05 <adamw> gkiagia: do you know anything about that one?
16:19:46 <gkiagia> it works for me, using gnome and firefox from flathub
16:19:47 <lruzicka2> adamw, I know but I am trying to map the grounds a little bit to form my opinion
16:20:10 <gkiagia> the user there is using sway, not sure if that has anything to do with the bug
16:20:19 <adamw> it'd be good to test with packaged firefox, i guess
16:20:44 <wtay> screencast also works with the python test app
16:20:59 <lruzicka2> I do not understand what screensharing he is talking about? in Zoom, for instance? or via Gnome?
16:21:30 <gkiagia> it is very easy to test, if you want to try yourselves: visit https://mozilla.github.io/webrtc-landing/gum_test.html and click on the screen capture button
16:21:44 <wtay> just tested that, work fine here
16:21:49 * nirik has to step away for a few, but right now I'd be inclined to stick with wireplumber as I think most of the critical issues have been addressed so far as I can see right now.
16:22:24 <adamw> gkiagia: i didn't reboot after installing the update yet, so i'd have to spend a minute rebooting to test it myself :)
16:22:36 <adamw> i'm currently looking through the pipewire bug list for anything that looks concerning which might be related to wireplumber
16:22:46 <adamw> wtay: great, thanks
16:22:59 <lruzicka2> it works on my packaged Firefox here, too
16:23:04 <adamw> unfortunately i didn't get kvolny to test with wireplumber in https://bugzilla.redhat.com/show_bug.cgi?id=2011737 yet
16:23:08 <lruzicka2> with wireplumber
16:23:11 <adamw> er, test with the pipewire manager, i mean
16:25:06 <adamw> so personally, yeah, i think we could live with the passthrough codec delay bug, though it'd be nice to get it fixed for release if possible
16:25:34 <geraldosimiao> gkiagia: tested here, all is fine
16:25:36 <adamw> the main thing that concerns me is oturpe's report that the upgrade broke his sound, it's unfortunate we can't have any data to look into that more :(
16:25:53 <Southern_Gentlem> we are seeing audio issue with f35B but cannot tell if its pipewire or wireplumber
16:26:22 <lruzicka2> Southern_Gentlem, which one?
16:27:44 <adamw> Southern_Gentlem: you can switch to pipewire-media-session to see if wireplumber is the issue
16:29:10 <gkiagia> for the record, I am close to fixing the codec passthrough issue (missing feature, actually), my wip branch is https://gitlab.freedesktop.org/gkiagia/wireplumber/-/commits/passthrough
16:29:41 <adamw> gkiagia: cool, thanks
16:29:48 <adamw> i'll throw an FE nomination at the bug
16:32:14 <adamw> there are a few other 'no sound' bugs on pipewire, but then there are some for f34 as well, i'm not seeing any clear indications they're linked to wireplumber atm
16:35:43 <adamw> looking at the test day results i see a couple more issues, but they're both listed as fixed in master last week so presumably in the update, i asked the reporters to test
16:36:06 <adamw> i am now gonna take a minute to reboot and see if my audio works, brb...
16:37:49 * bcotton is lurking on a school bus returning from a field trip
16:38:31 <adamw> I did not realize we employed kindergartners jeez
16:38:43 <lruzicka2> bcotton, shouldn't you pay attention to driving?
16:38:49 <geraldosimiao> 😂😂
16:39:16 <bcotton> adamw:  It should have been obvious by now
16:39:36 <StephenGallagher> adamw: Clearly you have not been reading memo-list lately...
16:39:52 <adamw> ahem
16:41:03 <adamw> fun trivia: at some concert in the mid-1990s i acquired an EP by a band called the 60 Foot Dolls
16:41:11 <adamw> it is not very good. i have listened to the whole thing like once
16:41:28 <adamw> but because it sorts alphabetically first in my artists folder, i have listened to the first five seconds of the first track, oh god, thousands of times
16:41:58 <lruzicka2> heh, I think I will check the band later :D
16:42:20 <bcotton> Does that mean your sound works?
16:42:32 <adamw> it does
16:43:04 <adamw> ship it!
16:43:15 <bcotton> 🛳
16:43:16 <lruzicka2> great :D
16:43:33 <adamw> does anyone have any more data, or shall we make up our minds?
16:43:41 <adamw> (or just ask a magic 8-ball, whichever you like)
16:44:17 <nirik> I wish we had data from beta testers, but oh well. ;)
16:46:17 <adamw> so, i'm kinda inclined to vote for 'let's stick with pipewire', i'm just worried about a nightmare scenario where 0.4.3 really does have a bug that breaks audio entirely for enough people that we have to yank it in a hurry on monday.
16:47:45 <adamw> what does everyone else think?
16:47:49 <wtay> I feel it will be fine
16:48:18 <lruzicka2> How long does a revert to pipewire-media-session take?  a new compose?
16:48:39 <lruzicka2> we might give wireplumber a chance and revert when it breaks.
16:49:13 <bcotton> I'm okay with moving forward. We still have the option to bail if it proves necessary (I'm not convinced we'll have a go/no-go on Thursday anyway)
16:49:15 <nirik> adamw: which does that mean? stick with wayplumber you mean?
16:49:18 <adamw> lruzicka2: iirc, it needs a comps change and a package update
16:49:33 <adamw> nirik: ugh. yes. darn names with 'wire' in them. :D
16:50:19 * nirik is with bcotton there. Perhaps I am also on the bus.
16:50:51 <adamw> nobody crash the bus or we'll never ship a fedora again
16:51:11 <lruzicka2> I'm in support of bcotton, too
16:51:19 <geraldosimiao> I vote to stay with wireplumber for now, me too I'm the opinion the go/no-go meeting will be a no-go
16:51:52 <geraldosimiao> adamw: 🤣
16:52:04 <Southern_Gentlem> +1 wireplumber  wait to see at g-ng
16:53:02 <adamw> wtay: gkiagia i guess you guys are ok with this, right?
16:53:17 <nb> I agree.  +1 wireplumber  wait to see at g-ng
16:53:19 <bcotton> Heck. Do I get the blame token since I spoke up first?
16:53:36 <wtay> adamw, yes
16:53:46 <lruzicka2> sure, it's like carrying the ring to Mordor, bcotton
16:53:50 <Southern_Gentlem> bcotton, because after you its mattdm
16:54:03 <geraldosimiao> the more wireplumber continues, the more testing it have
16:54:27 <adamw> Ben Cotton (he/him/his): you always get the blame! isn't it in your job description?
16:54:35 <gkiagia> my opinion has always been to stick with wireplumber 🙂
16:54:41 <nb> bcotton idk, it depends on who adamw .fire's
16:54:49 <adamw> ok, so, sounds like we have a consensus there
16:54:55 <geraldosimiao> if we swap now, testing wil drop cuz people wil not try it on their machines at beta...
16:55:17 <Southern_Gentlem> geraldosimiao, if they have not tried it by now, they wont
16:55:40 <adamw> proposed #agreed After reviewing the current status of the bugs that have been referred to, other bugs, and our own testing results, QA agrees to recommend that we stick with wireplumber for the Fedora 35 release
16:55:43 <geraldosimiao> yes, tahts my poitn
16:55:44 <geraldosimiao> point
16:55:50 <geraldosimiao> thats my point
16:56:02 <lruzicka2> ack
16:56:05 <Southern_Gentlem> ack
16:56:06 <geraldosimiao> ack
16:56:18 <bcotton> Ack
16:57:23 <nirik> ack
16:57:25 <adamw> #agreed After reviewing the current status of the bugs that have been referred to, other bugs, and our own testing results, QA agrees to recommend that we stick with wireplumber for the Fedora 35 release
16:57:30 <adamw> alrighty, thanks a lot folks
16:57:38 <adamw> since this was a special purpose meeting and we have achieved the purpose, we're done :D
16:58:17 <lruzicka2> ok, thanks for coming everyone and let's hope for the best :D
16:58:17 <bcotton> 🎉
16:58:37 <geraldosimiao> 😀🎉
16:59:18 <lruzicka2> I **want** to *try* something, do not respond :)
16:59:45 <lruzicka2> hmm, I wonder how Adamw got his slanted "ahem"
16:59:45 <wtay> thanks!
16:59:55 <adamw> lruzicka2: wrap it in asterisks
17:00:04 <adamw> oh huh, didn't work for you
17:00:11 <adamw> oh, if you're on irc side maybe it doesn't. i guess the bridge does something clever
17:00:17 <geraldosimiao> hey, the update is only for wireplumber? does not have to do one for wireplumber-libs-0.4.3-1.fc35.x86_64 too?
17:00:25 <adamw> aha, and oturpe said his problem was user error
17:00:34 <adamw> geraldosimiao: you have to update both, that's what oturpe got wrong :D
17:00:43 <bcotton> 🎉 again!
17:00:59 <adamw> alrighty, thanks again folks
17:01:01 <adamw> #endmeeting