15:00:53 <adamw> #startmeeting Fedora QA meeting
15:00:53 <zodbot> Meeting started Mon May  9 15:00:53 2022 UTC.
15:00:53 <zodbot> This meeting is logged and archived in a public location.
15:00:53 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:00:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:53 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:58 <adamw> #meetingname fedora-qa
15:00:58 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:02 <adamw> #topic Roll Call
15:01:07 <bittin> .hello2
15:01:08 <zodbot> bittin: bittin 'Luna Jernberg' <droidbittin@gmail.com>
15:01:08 <adamw> ahoyhoy everyone, who's around for qa meeting funtimes?
15:01:16 * bittin is
15:01:22 <coremodule> .hello2
15:01:23 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
15:01:31 <bcotton> .hello2
15:01:32 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:03:41 <lruzicka> .hello2
15:03:42 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:04:04 <tflink[m]> Morning
15:04:11 <bittin> afternoon
15:05:13 <adamw> how's everyone doing
15:05:24 <bittin> i am alright
15:06:27 <adamw> good good
15:06:46 <adamw> #topic Previous meeting follow-up
15:07:14 <adamw> #info "adamw to consider updating network criteria proposal to cover types of network connection (wired, wireless, security types...)" - still didn't get around to this thanks to f36 work, will do it now f36 is done
15:07:18 <geraldosimiao> .hello geraldosimiao
15:07:19 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
15:07:26 <adamw> #action adamw to consider updating network criteria proposal to cover types of network connection (wired, wireless, security types...)
15:07:31 <bcotton> but you did consider it, so it's okay
15:07:32 <adamw> any other follow-up?
15:08:37 <adamw> this is true, i definitely considered it!
15:08:52 <adamw> i considered so hard
15:09:57 * kparal somewhat present
15:11:01 <adamw> #topic Fedora 36 status
15:11:11 <adamw> so, we are releasing RC5 as F36 Final tomorrow
15:11:19 <adamw> #info RC5 was signed off last Thursday and will release tomorrow
15:11:35 <coremodule> woot!
15:11:44 <adamw> kparal: has been working on the common issues, thanks
15:11:50 <bittin> Ready for Release tommorow :) saw kparal and jgrulicz do the last work on Media writer 5.0 today also :)
15:12:13 <bittin> and helped out myself with some last testing and translations of various webpage/media writer things
15:12:15 <adamw> though looking at the front page of the common issues forum, i'm not...super happy with how it looks compared to our nice per-release curated wiki pages, honestly :|
15:12:59 <bittin> so guess its time to start F37/rawhide testing now if people are not already :p
15:13:57 <adamw> bittin: indeed it is
15:14:32 <adamw> #info common bugs are being listed at https://ask.fedoraproject.org/tags/c/common-issues/f36 , propose new ones at https://ask.fedoraproject.org/c/common-issues/common-issues-proposed/142
15:14:39 <adamw> #undo
15:14:39 <zodbot> Removing item from minutes: INFO by adamw at 15:14:32 : common bugs are being listed at https://ask.fedoraproject.org/tags/c/common-issues/f36 , propose new ones at https://ask.fedoraproject.org/c/common-issues/common-issues-proposed/142
15:15:14 <adamw> #info common bugs are being listed at https://ask.fedoraproject.org/tags/c/common-issues/f36 , draft new entries at https://ask.fedoraproject.org/c/common-issues/common-issues-proposed/142 , if there's any bug you think should be listed, add the CommonBugs keyword to it
15:15:40 <adamw> i don't think any terrible scares emerged over the weekend, right? testing of the new fmw seems to have worked out well
15:16:41 <kparal> FMW seem to be fine, I tested it again today
15:16:53 <kparal> not the official build, though, hmm
15:16:55 <bittin> had not had time to test fmw 5 over the weekend, but finished the Swedish translation for the release earlier today, also Online F36 Release Party this weekend \o/
15:17:04 <bittin> https://hopin.com/events/fedora-linux-36-release-party/registration
15:17:16 <adamw> cool!
15:19:06 <adamw> anything else on F36, folks?
15:19:34 <lruzicka> Not here.
15:19:56 <kparal> well
15:20:04 <kparal> adamw: the ibus common bug still needs to be documented
15:20:21 <adamw> yeah, don't worry, i'm doing it today
15:20:52 <bcotton> i'm going to be creating an F36 retrospective survey in LimeSurvey later today. if there are any specific questions you want included, let me know
15:21:50 <adamw> #topic Fedora 37 Change check-in
15:22:08 <adamw> so, on the topic of F37, let's see where we are with accepted changes
15:22:15 <adamw> #link https://fedoraproject.org/wiki/Releases/37/ChangeSet
15:22:48 <bittin> 24?
15:23:10 <coremodule> yay for retiring 32-bit arm
15:24:02 * kparal afk
15:24:20 <adamw> notables: dns over tls is back (we've tried this in each of the last couple of releases and it's broken stuff, we're trying again!), legacy xorg driver removal affects basic graphics mode so we'll need to focus on testing that in different cases, python 3.11 can affect installer, rpm 4.18 obviously can affect anything, "modular gnome keyring services" affects release-blocking functionality
15:24:30 <adamw> and yes, yay for those!
15:24:46 <adamw> any others to note that I missed?
15:28:16 <adamw> #info notables: dns over tls is back (we've tried this in each of the last couple of releases and it's broken stuff, we're trying again!), legacy xorg driver removal affects basic graphics mode so we'll need to focus on testing that in different cases, python 3.11 can affect installer, rpm 4.18 obviously can affect anything, "modular gnome keyring services" affects release-blocking functionality
15:29:27 <bcotton> Worth noting that System-Wide Change proposals are due 28 June and a lot of the most fun ones come in close to the deadline
15:29:55 <adamw> yes, true
15:30:08 <adamw> #info note this list is not yet complete, we will review it again after the deadline on june 28
15:32:01 <adamw> #topic Test Day / community event status
15:32:10 <adamw> don't know if we have anything here, it's usually quiet around this time
15:32:16 <adamw> sumantro: here, by any chance?
15:32:35 <LunaJernberg[m]> Online Release Party for F36 on Hopin this weekend 13-15th May
15:32:49 <LunaJernberg[m]> https://hopin.com/events/fedora-linux-36-release-party/
15:33:37 <adamw> thanks luna!
15:33:49 <adamw> #info there will be an online F36 release party May 13-15, see above link
15:35:14 <geraldosimiao> When exactly will freeze end?
15:35:23 <geraldosimiao> Utc time
15:35:53 <adamw> jednorozec: mboddu nirik do you know?
15:36:18 <adamw> actually, i think pushes already started?
15:36:37 <mboddu> adamw: releng freeze is over, infra freeze lifts on Wed
15:36:44 <bcotton> based on the BZ update emails over the weekend, that seems tob e the case
15:37:16 <adamw> yeah, indeed. update pushes to f36 stable already started. so if you see something that isn't pushed, it's not submitted.\
15:37:17 <mboddu> Releng freeze lifts off in couple of hours after we are Go on Thu
15:37:55 <nirik> well, the first stable push isn't until friday after all the packages in the release are tagged
15:37:57 <nirik> but yeah
15:38:03 <cmurf> tomorrow
15:38:12 <cmurf> oh interesting
15:38:57 <cmurf> so last friday
15:39:27 <mboddu> Yup
15:39:32 <cmurf> how long have i been doing this? i probably say the same things every cycle...
15:41:10 <adamw> alrighty then...
15:41:13 <adamw> #topic Open floor
15:41:19 <adamw> any other business, folks?
15:41:25 * bittin does not have anything currently
15:41:56 <geraldosimiao> Nope
15:42:03 <lruzicka> So, I think we need some guidance on the GUI application testing automation.
15:42:29 <lruzicka> I believe that there needs to be a solid required minimum that we will test.
15:42:57 <lruzicka> And this should be a group task.
15:44:23 <adamw> i kinda suspect whatever the line winds up being, it'll be 'a lot more than we have right now'
15:44:38 <adamw> and going for the apps we already explicitly list out in the criteria would be the obvious choice
15:46:04 <lruzicka> these only list a limited amount of applications -> with those we did not have problems
15:47:13 <adamw> not this cycle, but we might next time. (well, actually, we did catch a code highlighting bug in g-t-e)
15:49:04 <lruzicka> adamw, because we tested it, so we could catch it.
15:49:43 <lruzicka> For what exactly shall I test with Gnome Calendar? How? How many events should be added in a row, how many deleted?
15:50:21 <adamw> it's a good question, i'm not sure
15:50:47 <adamw> the more complicated we make the test, the harder it is to maintain and the more false failures we'll get
15:51:22 <adamw> and it doesn't feel right to write that level of detail into the criteria for every app...
15:51:53 <adamw> what's the action item here?
15:52:47 <lruzicka> I will send a question to the SiGs and let the make the choice?
15:55:15 <geraldosimiao> Remembered the Monty Phytons Holly Hand Granade:
15:55:15 <geraldosimiao> You should count to three, not four.
15:55:15 <geraldosimiao> To five you should not count, not even two...
15:55:26 <adamw> i guess it'd get rolled into the larger ongoing discussion about what we actually want the criteria to be
15:55:39 <adamw> excepting that you then proceed to three
15:57:17 <lruzicka> so we should start it as soon as possible :) we need some time to work on it, too
15:58:46 <adamw> well, i think we still have a lot of work to just test very basic operation of each listed app
15:58:53 <adamw> we can always tweak the tests from there afterwards
15:59:30 <lruzicka> ok, I have already started with Nautilus :)
15:59:41 <adamw> #action lruzicka to add question about exact required automated test coverage for desktop apps to one of the ongoing discussions with desktop team (mailing list or ticket)
15:59:44 <adamw> that ok?
15:59:48 <lruzicka> sure
16:00:08 <adamw> alright, well, that's time
16:00:12 <adamw> thanks for coming, folks!
16:00:15 <adamw> #endmeeting