15:00:39 <adamw> #startmeeting Fedora QA meeting
15:00:39 <zodbot> Meeting started Mon Mar 20 15:00:39 2023 UTC.
15:00:39 <zodbot> This meeting is logged and archived in a public location.
15:00:39 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:00:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:39 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:41 <adamw> grr
15:00:47 <lruzicka> .hello lruzicka
15:00:48 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:00:58 <adamw> #meetingname fedora-qa
15:00:58 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:58 * kparal is here
15:00:58 <LunaJernberg[m]> .hello2 bittin
15:00:59 <adamw> #topic Roll Call
15:00:59 <zodbot> LunaJernberg[m]: Sorry, but user 'LunaJernberg [m]' does not exist
15:01:00 <adamw> ahoyhoy folks
15:01:06 <LunaJernberg[m]> .hello bittin
15:01:07 <zodbot> LunaJernberg[m]: bittin 'Luna Jernberg' <droidbittin@gmail.com>
15:01:07 * kparal is still here
15:01:08 <kalev> oh, is the QA meeting an hour earlier?
15:01:14 <adamw> whew, existence retrieved
15:01:16 <kalev> I was hoping to hold the flatpak meeting now :)
15:01:20 <adamw> kalev: depends on your timezone.
15:01:21 <LunaJernberg[m]> kalev: summer time in the US not in the EU yet :p
15:01:21 <kalev> damn timezones.
15:01:33 <LunaJernberg[m]> so we will take #fedora-meeting-2 :D
15:01:37 <adamw> we're at the same time in NA, an hour earlier UTC
15:01:39 <LunaJernberg[m]> so who*
15:01:42 <adamw> sorry, i didn't think to check the schedule
15:02:42 <kparal> our meetings overlap in fedocal
15:02:52 <adamw> yeah, i don't know who took the slot first :P
15:03:26 <adamw> we can battle to the death, play rock paper scissors, or fuse into some sort of hybrid flatpak qa meeting
15:04:14 <lruzicka> adamw, cant we move to the fedora-blocker-review channel?
15:04:53 <adamw> this isn't a blocker review meeting...
15:05:04 <LunaJernberg[m]> they moved to Meeting 2 as i suggested
15:05:22 <adamw> ah, okay.
15:06:24 <adamw> i was looking forward to the battle to the death. what am I gonna do with all these pointy things?
15:06:43 <LunaJernberg[m]> put them down
15:06:50 <adamw> awwwwwwwww
15:06:51 <adamw> do i have to
15:07:01 <LunaJernberg[m]> maybe its for the best
15:07:07 <adamw> sheesh, fiiiine.
15:07:16 * adamw leaves the pointy things over here for next time
15:07:24 <adamw> #topic Previous meeting follow-up
15:07:38 <adamw> oh boy, i have a horrible feeling i forgot something again
15:07:39 <geraldosimiao> .hello geraldosimiao
15:07:40 <zodbot> geraldosimiao: geraldosimiao 'Geraldo S. Simião Kutz' <geraldo.simiao.kutz@gmail.com>
15:07:54 <adamw> oh yeah i did! what a surprise
15:08:13 <adamw> #action adamw to read up on how the matrix/irc bridging works for topic setting, and get sumantro appropriate rights to set topics on both sides in the test day channel
15:08:16 <adamw> let's try that one more time
15:08:22 <adamw> any other followup from last time?
15:11:01 <adamw> alrighty
15:11:12 <adamw> #topic Window manager release criterion proposal
15:11:21 <LunaJernberg[m]> have not had the time to read it
15:12:00 <adamw> #info kparal proposed a criterion covering window manager functionality on release-blocking desktops: https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/UDMAC7IGJGHG4TBN32BPBCJCZOLWTDQG/
15:13:15 <LunaJernberg[m]> LGTM over a quick look over it now
15:13:32 <adamw> Patch: insert "For each release-blocking desktop, " at the start
15:13:51 <lruzicka> patch is ok
15:15:04 <geraldosimiao> Kparal criterion looks good
15:15:12 <adamw> on the whole though i think it's a good idea and the wording is fine
15:15:29 <kparal> I haven't had time to read the feedback yet
15:16:43 <adamw> i do wonder if this might need to be split across milestones
15:16:46 <adamw> i think blocking beta on full-screen games would be a reach
15:17:55 <adamw> case in point, f38 beta has this bug and nobody is really mad
15:18:40 <adamw> but if window switching was broken we probably would wanna block beta on that
15:19:35 <adamw> i might want to split it into really core operations on pre-installed applications (basic/beta) and cover more operations and non-preinstalled apps at final?
15:19:52 <lruzicka> yeah, that sounds ok to me
15:20:07 <kparal> we could possibly postpone the milestone according to severity, as we often do?
15:20:36 <kparal> because it seems difficult to me to define what exactly block when
15:21:06 <adamw> i like it to be in the criteria if possible
15:21:17 <adamw> i think we're going too far lately towards being fuzzy and doing things on feeling
15:21:27 <adamw> accepting blockers without even talking about the criteria
15:21:51 <LunaJernberg[m]> wel in worse case you can install a second window manager while beta testing, if you want something stable run stable, but i agree that most/everything should work when a release is released and declared a stable release
15:22:28 <kparal> so, I'll add a paragraph to say non-preinstalled apps are only considered at Final. Do I need to split it, or a footnote is enough?
15:23:46 <kparal> and we can put the base criterion into beta
15:24:10 <adamw> the base criterion is probably basic for me, though it's not a terribly important distinction right now
15:24:40 <lruzicka> I think it's better to split so that it is available in the criteria overview when looking for it
15:24:55 <lruzicka> the base one into Beta, the rest into Final
15:25:25 <adamw> i can send a proposal for what my idea would look like as a reply
15:25:35 <geraldosimiao> I agree
15:28:38 <adamw> alrighty, sounds like we're done on this topic
15:28:40 <adamw> #topic Fedora 38 status
15:28:51 <adamw> #info Beta is out, thanks again to all who worked on it
15:29:17 <adamw> #info Final freeze is scheduled for April 4
15:29:31 <adamw> #info blocker review meeting follows this meeting over in #fedora-blocker-review
15:30:22 <LunaJernberg[m]> Beta has worked good so far for me the testing i had time to do, found some bugs thats been fixed, dnf5 (is missing some features but not sure if its gonna ship with F38 or F39? or later)
15:31:21 <adamw> it's definitely not becoming default in f38
15:31:27 <LunaJernberg[m]> missed the GNOME Apps Test days as there was a major bug and i got sick but starting to feel a bit better again and helped with all the others
15:31:34 <LunaJernberg[m]> adamw: ah alright then i know :)
15:32:54 <adamw> glad to hear you're feeling better
15:33:04 <adamw> so far the response to 38 beta seems pretty positive
15:33:15 <adamw> kparal, one thing i'm hearing is that the 20 minute suspend timeout thing...isn't really biting anyone
15:33:28 <kparal> except VM users
15:33:28 <adamw> any idea why that is? does it only actually affect fresh installs with that default, or something?
15:33:30 <kparal> just filing a blocker now
15:34:04 <adamw> what version of what package is the updated default supposed to be in?
15:34:21 <kparal> not sure, but if you fully-update, you should have it
15:34:46 <kparal> (it's 15 minutes, btw)
15:34:59 * neil is reminded he needs to test the beta
15:36:13 <adamw> right now i seem to only have updates scheduled for boxes, calendar, mpas and shell (all -2 builds, those backport builds i did) and it's only set to automatic suspend on battery power for me...
15:37:00 <lruzicka> I installed the latest iso and fully updated it, autosuspend was on for 15 minutes
15:37:07 <adamw> okay
15:37:26 <adamw> maybe i somehow have those settings changed from default already so it kept them on update
15:39:35 <adamw> anything else on f38? note it does look a lot like we'll have to waive the shim bug again, unfortunately
15:39:42 <lruzicka> adamw, I can also confirm that it has not been switched on with updates
15:40:45 <lruzicka> all my machines, that I installed some time ago, seem to be unaffected by the change
15:41:14 <kparal> adamw: dconf-editor can show you whether you've modified the default
15:41:31 <adamw> yes, it shows the relevant settings bold, but i don't recall ever setting them
15:41:43 <kparal> `org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type`
15:41:43 <adamw> i wouldn't have any reason to unless it was something other than 0
15:41:43 <kparal> `org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout`
15:41:43 <kparal> bold means changed manually
15:41:55 <adamw> and this is a relatively recent install
15:42:13 <kparal> perhaps you moved the toggle out of whim? 🙂
15:42:34 <kparal> not sure how that works. It would explain why few people complain
15:43:13 <adamw> i'm more wondering if somehow it gets marked as manually modified without people really manually modifying it, but...
15:43:13 <LunaJernberg[m]> is that the same thing that was discussed on the Fedora Server M-L ?
15:43:17 <adamw> yes
15:43:33 <LunaJernberg[m]> ah yeah makes sense to turn it off for servers as was discussed
15:44:44 <adamw> anything else on f38?
15:46:06 <adamw> alrightty
15:46:15 <adamw> #topic Test Day / community event status
15:46:35 <LunaJernberg[m]> Sumantro Mukherjee ?
15:46:44 <geraldosimiao> I really liked dnf5 test day
15:47:10 <adamw> great to hear!
15:47:11 <geraldosimiao> the devs are really helpfull
15:47:18 <LunaJernberg[m]> yeah same here :)
15:47:25 <geraldosimiao> and we opened some tickets upstream
15:47:38 <geraldosimiao> and changed ideas
15:47:58 <geraldosimiao> really a helpfull evening
15:48:00 <LunaJernberg[m]> @kotlajz was really helpful answering all my silly questions and gave me an email to one of his coworkers to email about something i found :)
15:48:43 <kparal> adamw: a new blocker will get synced at the top of the hour, just fyi
15:49:05 <adamw> yaaaay
15:49:37 <geraldosimiao> I'm looking forward to change dnf for dnf5
15:50:17 <LunaJernberg[m]> same liking the new status indicators and time and the layout of it
15:50:27 <adamw> #info several test days finished up since the last meeting, including DNF test day - https://testdays.fedoraproject.org/events/152 - and kernel 6.2 test week - https://testdays.fedoraproject.org/events/148
15:50:30 <adamw> we had great participation in the events, thanks to everyone who tested
15:50:45 <LunaJernberg[m]> and also GNOME 44 test weeks and l10n/i18n
15:51:20 <adamw> #info we also had the GNOME core - https://testdays.fedoraproject.org/events/150 - and apps - https://testdays.fedoraproject.org/events/151 test days, and i18n test week - https://testdays.fedoraproject.org/events/147
15:53:27 <adamw> not sure if the iot or coreos test weeks will happen
15:53:39 <adamw> #action adamw to check in with sumantro on status of iot and coreos test weeks
15:53:43 <adamw> #topic Open floor
15:53:48 <adamw> any other business ahead of the blocker review meeting?
15:53:52 * LunaJernberg[m] does not have anything
15:56:41 <geraldosimiao> nothing now
15:57:01 <adamw> alrighty, thanks for coming, everyone
15:57:58 <adamw> #endmeeting