18:03:48 <Oxf13> #startmeeting Fedora Release Engineering Meeting
18:03:48 <zodbot> Meeting started Mon Jan  4 18:03:48 2010 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:03:56 <Oxf13> #meetingname fedora-releng
18:03:56 <zodbot> The meeting name has been set to 'fedora-releng'
18:04:00 <Oxf13> #topic roll call
18:04:21 <Oxf13> ping: notting jwb lmacken wwoods rdieter dgilmore warren spot poelcat
18:04:31 <notting> aye
18:04:32 <warren> here
18:04:32 * nirik is here with a quick query for open floor later.
18:04:42 * lmacken is here
18:04:54 <rdieter> here
18:05:03 * wwoods liiiiives
18:05:29 * dgilmore is here
18:06:23 * poelcat here
18:07:47 <Oxf13> Ok
18:08:04 <Oxf13> looking at last meeting's notes
18:08:33 <Oxf13> Looks like I forgot to send one for the meetings in December
18:08:46 <Oxf13> I seem to recall zodbot issues.
18:08:59 <Oxf13> #topic dist-git
18:09:08 <Oxf13> Let me give a quick dump on where we are with dist-git.
18:09:09 <notting> Oxf13: i think zodbot wasn't back from the outage yet
18:09:14 <nirik> Oxf13: yeah, it died in the middle of the meeting.
18:09:16 <Oxf13> I've created a couple wiki pages regarding this
18:09:36 <Oxf13> https://fedoraproject.org/wiki/Dist_Git_Proposal
18:09:41 <nirik> Oxf13: http://meetbot.fedoraproject.org/fedora-meeting/2009-12-14/feodra-releng.2009-12-14-18.02.log.txt is the txt log, it didn't create any others.
18:09:43 <Oxf13> https://fedoraproject.org/wiki/Dist_Git_Project
18:10:25 <Oxf13> I'll be keeping the project page updated as I progress
18:10:42 <Oxf13> where we are at now is public, anon clone, and auth write git repos for all packages as of a few weeks ago
18:10:51 <Oxf13> subdirs are now branches
18:11:03 <Oxf13> per package, per branch ACLs are in effect
18:11:29 <Oxf13> I've stepped away from the git repo side of things, to work on fedpkg, the replacement for our Make system
18:12:06 <Oxf13> I made some really good progress over the break on it, and I should have something to commit/push to the upstream fedora-packager source repo today, that gives us some functionality to play with and a framework for filling in the rest of the targets
18:12:15 <warren> it will be named fedpkg?
18:12:26 <Oxf13> warren: that's the current working name.  fpkg was already taken by something else
18:13:05 <Oxf13> #info initial code drop of fedpkg should happen today
18:13:58 <warren> Oxf13: I mean, if that same tool can be used with any dist-git (not just fedora) might be better with a more generic name?
18:14:05 <warren> that remains easy to type with tab complete
18:14:37 <Oxf13> I currently have working code for gimmespec, sources, and srpm, with partial functional code for new_sources, clone, and clone_with_dirs
18:14:54 <warren> python?
18:14:56 <Oxf13> warren: it's going to be pretty fedora specific
18:15:00 <Oxf13> warren: yeah, python
18:15:12 <wwoods> pretty sure it's gonna be fedora-specific, and even if it isn't, a name-change could be done trivially with a wrapper program
18:15:13 <wwoods> so don't dwell on the name too much
18:15:44 <warren> well, I mean it need not be fedora specific, as it can recognize what is in the pwd
18:16:13 <warren> if <prominent north american distro> begins using dist-git in the future, then the same tool could be used for fedora
18:16:16 <Oxf13> if you're going to put in the work to make it like that...
18:16:43 <Oxf13> RHEL will need a lot of it's own tweaks and additions/removals, so I doubt all the same code would be used
18:17:08 <warren> ok
18:17:13 <Oxf13> however fedpkg is two parts.  1) a command line interface to gather options and arguments and to specify what task to do, and 2) a python library of tasks.
18:17:22 <Oxf13> so RHEL can replace #1 while re-using #2
18:17:23 <warren> Oxf13: so what is the proposed timetable for fedora?
18:17:39 <Oxf13> warren: as the wiki page states, right after F13 release, or later
18:19:10 <Oxf13> But enough about dist-git and fedpkg, lets move on
18:19:56 <Oxf13> #topic Fedora 13 releng Schedule
18:20:55 <Oxf13> The next thing on the schedule ( http://poelstra.fedorapeople.org/schedules/f-13/f-13-releng-tasks.html ) is wall paper package for ALpha, on the 12th
18:21:01 <Oxf13> that's not really us, but we need to be aware of it
18:21:23 <Oxf13> after that is the feature submission deadline of 1/26, which should also be the deadline for figuring out if we can pull off no frozen rawhide or not
18:21:36 <poelcat> yeah, the design schedule is not finalized at all
18:21:45 <poelcat> that was a roll forward from F12
18:21:50 <Oxf13> #topic no Frozen rawhide
18:22:03 <Oxf13> notting: ping; have you had any progress with speeding up composes?
18:22:14 <Oxf13> lmacken: ping; have you had any progress with adding features to bodhi?
18:22:20 <notting> no. we did tests with the hashed directories, and it didn't really make any difference
18:22:59 <lmacken> Oxf13: nope, haven't touched bodhi in a month
18:23:11 <Oxf13> #info hashed directory mashes do not seem to improve mash time
18:23:15 <wwoods> it's been a month?freeow.
18:23:17 <Oxf13> #info bodhi work not done as of yet.
18:23:29 <Oxf13> Ok.
18:23:36 <Oxf13> Moving on
18:23:38 <poelcat> lmacken: are you sure it can be done in time?
18:24:01 <lmacken> poelcat: when does it have to be done by?  just crit path support?
18:24:40 <Oxf13> lmacken: crit path blocking, and the ability to tag but not push are needed by feature freeze
18:24:59 <lmacken> and feature freeze is this saturday still?
18:25:19 <Oxf13> feature submission deadline is 1/26, feature freeze is a week later
18:25:20 <poelcat> 2010-01-26
18:25:42 <Oxf13> 2/09 for feature freeze
18:26:01 <lmacken> yeah, I should be able to hack that into the existing code base before then.  I'll bump it to the top of my TODO list
18:26:40 <poelcat> lmacken: cool :)
18:27:06 <Oxf13> #topic open floor
18:27:14 <Oxf13> nirik: I do believe you had somethign?
18:27:43 <dgilmore> Oxf13: i untagged todays glibc build as it broke tar or gzip
18:27:44 <nirik> yeah... so I have asked this before and been told no, but with no frozen rawhide perhaps it would make more sense...
18:28:10 <nirik> what would you think of making fedora-rawhide a subpackage in fedora-release... so only those people who explicitly install it get rawhide repos?
18:28:24 <notting> hm
18:28:31 <notting> makes 'yum --enablerepo=rawhide' not work OOTB
18:28:38 <nirik> yeah, true...
18:29:03 <nirik> also, it depends on if you want the default to keep being 'switch to stable release when it's available instead of staying on rawhide'
18:29:14 <Oxf13> notting: which is what nirik I think wants to prevent people from doing
18:29:54 <Oxf13> nirik: with NFR, I think if you're on rawhide you stay on rawhide.  If you install alpha/beta/whatever you stay on the pending release
18:30:05 <nirik> yeah, we still get people who: a) just enable every repo thinking it will get them more choices or b) install just one random newer thing from rawhide and can't go back to stable or c) deciding to just play with it for a bit and can't get back without re-installing.
18:30:15 <Oxf13> if you're on rawhide and alpha is released, you don't magically get moved over to the pending release, you'd have to manually move yourself over
18:30:32 <nirik> ok, so a 'rpm -e fedora-release-rawhide' would do that switch.
18:31:06 <nirik> anyhow, I thought I would toss it out there...
18:31:08 <Oxf13> aren't these the types of people who would install every package anyway?
18:31:41 <Southern_Gentlem> Oxf13,  and if they dont have the repo OOTB its so much the better
18:31:43 <Oxf13> I'm still not really keen on the idea, but I'm willing to listen to others
18:32:05 <nirik> I could write up a proposal/bug more clearly describing it...
18:32:20 <dgilmore> nirik: it might help us to visalise the workflow
18:32:39 <nirik> a lot of times it's new users that just see the repo... they wouldn't be the type that would install a non default package.
18:32:49 <nirik> they also enable all the source and debuginfo ones. ;)
18:32:54 <Oxf13> Southern_Gentlem: I meant they would be the type to install that sub-package at install time
18:33:16 <Southern_Gentlem> Oxf13,  who says it has to be on the install media
18:33:33 <nirik> some would, but many wouldn't... would just raise the bar, IMHO.
18:34:09 <Southern_Gentlem> it can sit in Everything for those want it
18:34:12 <nirik> I can write up something... what media would be best? bug? wiki?
18:34:31 <Oxf13> wiki I suppose, it's nearly a feature, since it'll require changing lots of documentation
18:34:37 <nirik> ok.
18:34:59 <nirik> thanks, thats all I had. ;)
18:35:14 <Southern_Gentlem> Oxf13,  i see this helping alot of the new user base
18:35:20 <Oxf13> #action nirik to draft a wiki page for fedora-release-rawhide subpackage idea
18:35:43 <Oxf13> Southern_Gentlem: *shrug* new users gotta learn some day (:
18:36:13 <Southern_Gentlem> Oxf13,  yes but sometimes it is easier the hide the big red button
18:36:27 <Oxf13> I know, I'm just being snarky.
18:36:32 <Oxf13> Any other open floor items?
18:36:34 <Southern_Gentlem> behind a access door
18:37:06 <Oxf13> (and really, that sounds like you want a feature in PackageKit to warn about rawhide enable actions)
18:37:21 <Oxf13> so that you can protect those that did happen to install the subpackage
18:37:33 <Southern_Gentlem> nope i just dont want rawhide in the fedora-release set
18:37:52 <Oxf13> Southern_Gentlem: no, you want to protect unaware uses from getting rawhide content.
18:38:08 <Oxf13> you see having fedora-release-rawhide as a subpackage as a possible ends to your goal
18:38:18 <Oxf13> however there are other ways to meet that goal
18:38:32 <Southern_Gentlem> and if they dont have the repo OOTB so much the better
18:38:55 <dgilmore> Oxf13: just that we need to get glibc/tar/gzip fixed
18:39:05 <Oxf13> dgilmore: so it was a bad glibc build?
18:39:33 <dgilmore> Oxf13: the response i got from jakub was that it was tar or gzip calling a function incorrectly
18:39:45 <dgilmore> 16:55 <jakub> andreas (who built that glibc) said it is likely a bug in tar or whatever calls futimens with wrong first argument
18:41:27 <dgilmore> Oxf13:ill see if i can work out hwere the problem is.
18:41:42 <Oxf13> fun, ok, thanks
18:41:54 <dgilmore> but tar and gzip were both built early december
18:42:14 <dgilmore> it seems to only effect tar.gz tarballs and not tar.bz2
18:43:50 <Oxf13> If there is nothing else, I'll close the meeting
18:47:48 <Oxf13> #endmeeting