18:17:50 <Oxf13> #startmeeting Fedora Release Engineering
18:17:51 <zodbot> Meeting started Mon Feb  1 18:17:50 2010 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:17:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:17:57 <Oxf13> #meetingname fedora-releng
18:17:58 <zodbot> The meeting name has been set to 'fedora-releng'
18:18:02 <Oxf13> #topic roll call
18:18:23 <Oxf13> ping: notting jwb lmacken warren rdieter_work wwoods poelcat spot dgilmore
18:18:29 <warren> here
18:18:33 <notting> yo
18:19:18 * wwoods lurking
18:20:22 * poelcat here
18:21:24 <jwb> meeting?
18:21:54 <Oxf13> yes meeting
18:22:17 <Oxf13> #info Present were Oxf13 warren notting wwoods poelcat and jwb
18:23:16 <Oxf13> #topic old business (Test images for QA)
18:23:34 <Oxf13> I had an action item to work with poelcat to update the SOP for symlink names
18:24:02 <Oxf13> https://fedoraproject.org/wiki/Composing_test_images
18:24:25 <Oxf13> That appears to be done.
18:24:39 <Oxf13> there was also a action item to let QA know the symlink names and that was done too
18:24:47 <Oxf13> #info action items completed, topic closed out
18:25:11 <Oxf13> #topic old business (SOPs)
18:25:28 <Oxf13> last week there was an action item to work on the Orphans SOP
18:25:37 <Oxf13> #info orphan SOP steps sent to poelcat
18:25:41 <Oxf13> I did that last week
18:25:59 <poelcat> https://fedoraproject.org/wiki/Purging_orphaned_packages
18:26:06 <poelcat> i thinks it's done?
18:26:37 <Oxf13> yes, I do believe it is done too
18:27:05 <poelcat> excellent, which one shall we do for this week? https://fedoraproject.org/wiki/Release_Engineering_Release_Tickets
18:27:23 <Oxf13> #info Orphans SOP reviewed, updated, and completed.
18:27:57 <Oxf13> There was another action item to review the SOps from 2 weeks ago, and that was done too
18:28:07 <Oxf13> #info previous SOPs reviewed and updated as well
18:28:41 <Oxf13> poelcat: lets pick one during new business
18:28:55 <Oxf13> which... is now.
18:29:02 <Oxf13> #topic Standard Operating Proceedures
18:29:16 <Oxf13> (that concluded all our action items)
18:29:34 <Oxf13> so again, we're working our way down https://fedoraproject.org/wiki/Release_Engineering_Release_Tickets
18:29:50 <Oxf13> sign packages for Alpha is next on the list, and I should start that work soon
18:29:54 <Oxf13> so I'll take that one on
18:30:05 <Oxf13> #action Oxf13 to work on documenting "Sign packages for Alpha" task
18:30:29 <Oxf13> and again, any of you who are doing releng tasks that you don't know of any documentation for, please please take the time to at least rough outline the steps you take
18:31:10 <Oxf13> anything further on this topic?
18:31:23 <Oxf13> great.
18:31:28 <Oxf13> #topic New /mnt/koji storage
18:31:37 <Oxf13> dgilmore: ping; any update on the new storage ?
18:32:37 <Oxf13> that's right, dgilmore didn't answer previous pings
18:32:47 <Oxf13> mmcgrath: ping; are you around and know anything about the new /mnt/koji storage?
18:33:48 <skvidal> Oxf13: Iv
18:33:56 <skvidal> Oxf13: I've heard it will be filled with ponies
18:34:03 <skvidal> dgilmore might know more about it, I think
18:34:07 <Oxf13> gender confused ponies at that.
18:34:54 <Oxf13> #info no new info on new /mnt/koji storage.
18:35:10 <Oxf13> #topic dist-git update
18:35:32 <Oxf13> #info Not much done here this last week, more coding on the build task
18:35:50 <Oxf13> The build task is proving to be difficult, as I'm trying to keep with the design of fedpkg being a library that multiple things could use
18:35:53 <Oxf13> like a webpage
18:36:14 <Oxf13> normally if we had to execute something externally we'd do it, log the results and return the return code
18:36:21 <Oxf13> then calling software could deal with the logging appropriately
18:36:33 <Oxf13> but the build task could actually attach to the terminal and provide ongoing feedback
18:36:55 <Oxf13> so I'm struggling with finding a way to allow this optionally, otherwise just log build info and return
18:39:19 <Oxf13> #info struggling with the build task and the way koji can connect to your terminal
18:40:38 <Oxf13> ok, moving on
18:40:48 <Oxf13> #topic No Frozen Rawhide
18:41:01 <Oxf13> #info Second releng compose system was setup for testing
18:41:20 <Oxf13> This will allow me to test multiple composes at the same time.  I did a baseline run to see time, I just haven't checked to see that it finished
18:41:32 <Oxf13> #action Oxf13 will test multiple concurrent composes to compare completion time
18:41:57 <Oxf13> any thoughts on NFR?
18:42:09 <notting> 'aaaaugh'
18:42:11 <warren> only a question
18:42:47 <Oxf13> warren: shoot
18:42:49 <warren> will users opt-in to a particular release like "F-13" and they'll have F-13 as it goes into stable, or they'll automatically go to F-14 when it forks?
18:43:06 <Oxf13> warren: people who are using rawhide will continue on rawhide
18:43:20 <warren> FESCo agreed this is the wisest course?
18:43:22 <Oxf13> warren: people who install from the Alpha or any later point of the forked tree will stay on the forked tree and continue on to th erelease
18:43:26 <warren> oh
18:43:28 <warren> hmm
18:44:05 <Oxf13> without freezing rawhide for a lengthy period I don't see any other way to direct current rawhide users into the forked tree
18:44:15 <Oxf13> and freezing goes against the proposal
18:44:19 <warren> Oxf13: how does it benefit anyone to go from rawhide pre-Alpha to rawhide-that-nobody-is-paying-attention-to?  isn't the smart default to upgrade into the fork?
18:44:49 <Oxf13> why is nobody paying attention to the rawhide that is moving on?
18:44:54 <warren> Oxf13: rawhide's yum.repos.d/* could use a config file somewhere else that specifies with release you want to stick with?
18:44:58 <Oxf13> that's F14 development, stuff that didn't make F13 or is too risky for F13
18:45:15 <warren> ok nevermind, just a thought, this is fine.
18:46:11 <Oxf13> #info people who are using rawhide will continue on rawhide
18:46:23 <Oxf13> #info people who install from the Alpha or any later point of the forked tree will stay on the forked tree and continue on to the release
18:46:55 <Oxf13> Ok, moving on.
18:47:08 <Oxf13> #topic Blocker bug review day
18:47:49 <Oxf13> There is a review day this Friday.  I've put a few things on F13Alpha, but I'm sure there are more things lurking
18:48:05 <Oxf13> if any of you know of issues that should be considered for the Alpha, please put them on the list
18:49:32 <Oxf13> #topic open floor
18:49:43 <Oxf13> any topics before we close the meeting?
18:51:05 <Oxf13> looks like not, thanks all for coming.
18:51:16 <Oxf13> #endmeeting