17:05:56 <Oxf13> #startmeeting Fedora Release Engineering
17:05:57 <zodbot> Meeting started Fri Apr 16 17:05:56 2010 UTC.  The chair is Oxf13. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:06:02 <Oxf13> #meetingname fedora-releng
17:06:02 <zodbot> The meeting name has been set to 'fedora-releng'
17:06:09 <Oxf13> #topic roll call
17:06:20 <smooge> /join #fedora-noc
17:06:41 <Oxf13> ping: notting jwb lmacken poelcat rdieter dgilmore wwoods (and anybody else)
17:06:45 * notting is here
17:06:50 <rdieter> yo
17:07:33 * dgilmore is here
17:08:36 <Oxf13> alright
17:08:53 <Oxf13> #info notting rdieter dgilmore and Oxf13 in attendance
17:09:00 <Oxf13> (and smooge is running away)
17:09:11 <Oxf13> #topic Beta!
17:09:27 <Oxf13> Beta got released, although it appears that even after careful checking, I fucked something up.
17:09:42 <dgilmore> :(
17:09:43 <Oxf13> #info i386 CDs and DVD torrents do not have signed CHECKSUM file
17:09:51 <Oxf13> somehow they wound up with the unsigned one
17:10:39 <dgilmore> at least thats fairly minor
17:10:50 <Oxf13> yeah, the signed one can be grabbed from the web
17:11:05 <Oxf13> I hesitated to regenerate the torrent because that would knock off the seeders and it would reset the stats
17:11:08 <smooge> Oxf13, is that something you need me to look at also with permissions?
17:11:19 <Oxf13> smooge: you wouldn't have been able to see it
17:11:24 <smooge> ah ok
17:11:28 <Oxf13> smooge: I just need to pay more attention really
17:12:04 <Oxf13> So the question is, is this bad enough to regenerate the torrents and lose the metrics, or do we just let it slide and post a note about it on the common bugs?
17:12:20 <dgilmore> i think its ok to slide
17:12:25 * notting is ok with sliding on it
17:12:36 <dgilmore> if it were a final release id say redo it
17:12:45 <Oxf13> ok, I am too, so I think that's a passing vote.
17:12:45 <dgilmore> but beta i think we document and move on
17:13:01 <Oxf13> #agreed OK to let torrent have unsigned CHECKSUM, but document it with common bugs
17:13:10 <Oxf13> #action Oxf13 to get it documented on common bugs.
17:14:11 <Oxf13> I've got nothing else on beta, any of you ?
17:14:38 <notting> not beta specifically, no
17:15:06 <dgilmore> no
17:16:17 <Oxf13> ok, moving on
17:16:25 <Oxf13> #topic Duplicate Updates
17:16:36 <Oxf13> notting: would you be so kind as to relay what's going on here?
17:17:00 <notting> so, we had two issues in F13 recently where 'older' builds ended up in the branched tree because multiple updates were in flight at once, receiving karma, etc
17:17:03 <notting> one was with gdm
17:17:07 <notting> the other was with libvirt
17:17:24 <notting> so i decided today to check how many cases of 'multiple updates in testing for a package' we have. it's over 40
17:17:47 <notting> i'm going through and cleaning these up now, will probably take a good chunk of the day
17:18:05 <Oxf13> Luke said he was ready to turn the obsolete code back on
17:18:16 <notting> #info we have many duplicate updates for F13. this can cause problems
17:18:23 <Oxf13> however it won't help in the case of an update being by itself, and a newer version of the package being grouped with another update set
17:18:26 <notting> #info notting is attempting to clean this up
17:18:37 <Oxf13> it'll only catch things that have the exact same package set, just different versions
17:18:49 <notting> Oxf13: that's most of them. if we can turn that on, that would be great
17:18:52 <Oxf13> #info lmacken to re-enable obsolete code soon, but still won't catch everything.
17:20:09 <Oxf13> ok, I have nothing else on this.
17:20:27 <Oxf13> #topic Oxf13 Schedule
17:20:41 <Oxf13> I'm going to be spending most of next week preparing for Linux Fest Northwest
17:20:50 <Oxf13> I've got two talks to give and prepare for
17:21:01 <Oxf13> and since it's a relatively quiet week this shouldn't be a problem
17:21:11 <Oxf13> but I won't be monitoring the releng queue much
17:21:23 <Oxf13> #info Oxf13 will be preparing for Linux Fest Northwest all week
17:21:42 <Oxf13> and I'll be out of the office part of Friday to travel
17:22:07 <Oxf13> that's all I have to say about that.
17:22:13 <Oxf13> #topic open floor
17:22:18 <Oxf13> any other topics?
17:23:12 <notting> i'm moderately concerned about the # of f13 updates that don't seem to be progressing. but that's probably more of a fesco issue
17:24:20 <Oxf13> is it any more/less than the amount of updates for any other release?
17:24:25 <wwoods> There might be maintainer confusion about what needs to happen for an update to land in branched/final
17:24:38 <wwoods> since the update hits branched once it hits testing
17:24:48 <Oxf13> uerm
17:25:03 <Oxf13> the update hits updates-testing when it goes testing
17:25:10 <Oxf13> but it doesn't get into the nightly branched tree until it goes stable
17:25:19 <notting> Oxf13: there are currently more test updates for f13 than for f12 or f11, yes
17:25:34 <Oxf13> notting: yeah, I'd expect that.
17:25:40 <wwoods> right, but from the user POV the packages appear on an 'F13' system as soon as they hit 'testing'
17:25:50 <Oxf13> wwoods: ah, yes if they have updates-testing enabled.
17:25:58 <wwoods> which is the default configuration for F13
17:26:12 <Oxf13> notting: I guess the real question is are there high impact bugfixes we're missing out on because they're stuck in updates-testing
17:26:21 <wwoods> (F13 branched, which is the only extant F13 tree)
17:26:25 <Oxf13> or are we succeeding in slowing down the bullshit and keeping branched more stable.
17:28:00 <notting> probably about half and half
17:28:12 * notting would encourage everyone to try fedora-easy-karma :)
17:28:55 <Oxf13> yeah, I slacked on that due to getting beta out, I'll update and start karma dancing
17:29:28 <Oxf13> #info concerned about the number of things in f13 updates-testing
17:29:50 <Oxf13> #info guessing at a mix of high value updates being delayed vs low value updates being held at bay
17:30:05 <Oxf13> #info need to get back into the swing of fedora-easy-karma on a regular basis
17:31:25 <Oxf13> anything else on this topic?
17:31:30 <Oxf13> or anything else in general?
17:34:00 <Oxf13> I'll take that as a no, thanks all!
17:34:02 <Oxf13> #endmeeting