17:00:22 <pboxHB> #startmeeting fedora-server
17:00:22 <zodbot> Meeting started Wed Jul  7 17:00:22 2021 UTC.
17:00:22 <zodbot> This meeting is logged and archived in a public location.
17:00:22 <zodbot> The chair is pboxHB. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:22 <zodbot> The meeting name has been set to 'fedora-server'
17:00:33 <pboxHB> #topic Welcome / roll call
17:00:41 <pboxHB> hi everyone!
17:00:48 <pboxHB> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:01 <pboxHB> I’ll post the agenda in a few minutes.
17:01:28 <jwhimpel> .hello jwhimpel
17:01:29 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:01:46 <dcavalca> .hi
17:01:47 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:01:50 <michel> .hello salimma
17:01:51 <zodbot> michel: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:02:58 <pboxHB> Welcome everybody. Let's start
17:03:05 <pboxHB> #topic Agenda
17:03:17 <pboxHB> 1. Status of ongoing activities
17:03:26 <pboxHB> 2. Fedora Server Documentation
17:03:35 <pboxHB> 3.  Work planning update
17:03:53 <pboxHB> 4. Fedora 35
17:04:06 <pboxHB> 5. Open Floor
17:04:17 <pboxHB> Any additions?
17:04:43 <pboxHB> #topic Status of ongoing activities
17:04:49 <pboxHB> Some information:
17:04:58 <pboxHB> #info Voting about our PRD is open until Friday, July 9. 14:00 UTC
17:05:08 <pboxHB> It uses a lazy approval approach, currently no objections
17:05:21 <pboxHB> There were no questions until now
17:05:32 <pboxHB> Any comments or ideas?
17:06:59 <pboxHB> OK, none I suppose. There are 2 + and no - at the moment
17:07:44 <pboxHB> Next issue
17:07:51 <langdon> .hello2
17:07:52 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
17:07:59 <pboxHB> #info We have one open issue, open for 3 months now.
17:08:10 <pboxHB> #link https://pagure.io/fedora-server/issues
17:08:26 <pboxHB> What can we do about that? 3 months is a long time
17:09:15 <langdon> well.. personally, having a limit means bloat is kept under control
17:09:19 <michel-slm> what's the DVD ISO limit we use?
17:09:26 <langdon> however, doing the package cleaning is sometimes painful
17:09:37 <michel-slm> if core packages are excluded, maybe they should be explicitly required and not recommended
17:09:49 <pboxHB> we limit the DVD currently to about 2 gb
17:10:32 <pboxHB> michel-slm: It's a matter of the maintainer, isn't it
17:10:52 <michel-slm> yeah, maybe worth filing an issue against the package in question
17:11:21 <michel-slm> short of that... is there a way to install all recommended packages that were not installed?
17:11:26 <pboxHB> I contacted them. Answer: we sould include recemmendations (as we do in net-install)
17:11:32 <michel-slm> via a dnf one-liner. if there is, maybe we can just document that
17:11:40 <dcavalca> aren't actual DVDs 4.7gb or something like that?
17:12:02 <langdon> i would like to weigh in that as a cutting edge distro, we want to encourage the use of containers not discourage..
17:12:09 <michel-slm> yeah, 4.7 single-layered and 8.5 double-layered
17:12:17 <langdon> the 2g is semi arbitrary.. and all the editions are about that (iirc)
17:12:25 <dcavalca> ah, I see
17:12:41 <langdon> but it can definitely be adjusted.. it was just the starting point from before the editions were created
17:12:42 <pboxHB> Our last discussion was: Eighth_Doctor checks jow big the iso will grow. And then decide how to preceed
17:12:49 <dcavalca> IMO as long as we stay below the physical media size, it's probably fine, though obviously the larger the image the longer it takes to download
17:12:56 <michel-slm> langdon++ agreed that we should not drop containerization. domain membership too
17:13:03 <michel-slm> since IPA is one of the key use cases
17:13:09 <dcavalca> yeah all the features mentioned there look pretty essential for server
17:13:21 <langdon> i can't believe that == 2g+
17:13:33 <michel-slm> I wonder how much is the Java stack
17:13:34 <langdon> i feel like maybe there are unintended optionals? or something
17:14:29 <pboxHB> One goal was to keep the sive small. due to download issues in some regions
17:15:22 <langdon> we can also work on net-install docs/promotion if that is a concern
17:18:05 <pboxHB> Question: Can anyone else figure out how big the ISO would get if we include all recommendations like we do with net-install?
17:18:50 <Eighth_Doctor> the only way to find out is to have releng spin the server dvd with all recommendations included
17:19:14 <pboxHB> Welcome Eighth_Doctor
17:19:34 <pboxHB> Did you try to get someone to do that?
17:20:01 <Eighth_Doctor> https://pagure.io/releng/issue/10102
17:20:07 <Eighth_Doctor> nothing has happened
17:20:18 <Eighth_Doctor> I can poke them again about it
17:20:24 <jwhimpel> I seem to recall Release Engineering saying they had no resources to do this, but would assist an interested party in trying.  Unfortunately, I can't seem to find that thread.
17:20:51 <pboxHB> Eighth_Doctor: ++
17:21:59 <pboxHB> I see, it's qualified as "low trouble". It prevents Cockpit from working correctly, our main graphical admin tool!
17:22:16 <pboxHB> Is that low trouble?
17:22:58 <langdon> releng "low trouble" means it is not much work for them to do i believe
17:23:01 <pboxHB> correction: It prevented, because Cockpit is fixed. But we don't know about other programs that might be affected.
17:23:07 <langdon> not a judgement on the importance of the issue
17:23:25 <Eighth_Doctor> yeah, the "low-" things are reference to effort to do it
17:23:39 <pboxHB> OK. Didn't know
17:24:01 <nirik> I'm not sure why you need releng to do this? it's just running pungi... basically releng is busy and hasn't gotten to it...
17:24:29 <pboxHB> Hi nirik!
17:24:52 <nirik> I can see if anyone has cycles for this, but dunno... I guess I can try and do it this weekend.
17:24:53 <Eighth_Doctor> nirik: well, I don't know _how_ to run pungi, and I think it'd make sense to have a nightly compose run with the flags set the way we want to see things look like
17:25:08 <Eighth_Doctor> last I checked, pungi required privileged koji access
17:25:50 <nirik> you can run it from your machine?
17:26:02 <nirik> sure, it downloads a bunch of stuff from koji, but... should work fine
17:26:23 <pboxHB> Eighth_Doctor: ++ having a nightly compose  would be good
17:26:39 <nirik> an entire compose will be a lot of resources.
17:27:10 <pboxHB> OK. what a pitty
17:27:41 <Eighth_Doctor> nirik: if you have some docs on how to do this locally, I can try to find somewhere to do it and try to run it
17:27:58 <Eighth_Doctor> (I don't have any local resources to run it either...)
17:29:08 <nirik> basically needs the fedora.conf from pungi-fedora repo cut down to just do the dvd/server parts... then 'koji-pungi' run with that config file.
17:29:16 <nirik> https://docs.pagure.org/pungi/ should have info
17:30:16 <langdon> i could probably get you some resources in MOC
17:30:34 <jwhimpel> https://www.mankier.com/1/pungi#Name has a man page, documentation and examples.  Have no idea how current all of this might be.
17:32:42 <pboxHB> Eighth_Doctor: Can you try to do a test compose?
17:33:08 <Eighth_Doctor> langdon: that'd be great
17:33:21 <Eighth_Doctor> pboxHB: I can try to find some time to do it...
17:33:34 <pboxHB> Thanks!
17:33:34 <langdon> let me know your or nirik's guess
17:34:05 <pboxHB> #action Eighth_Doctor tries to find someone  run a test compose with recommendations
17:34:13 <langdon> eating lunch so typing suffering
17:34:16 * nirik is just looking at running one on his laptop now... I can probibly tell you the config in a few.
17:34:24 <Eighth_Doctor> nirik: excellent
17:34:50 <pboxHB> OK. Some housekeeping in the mean time:
17:34:59 <pboxHB> #info Action: pboy contacts Matthew for further processing regarding the PRD – DONE
17:35:08 <pboxHB> #info Action: pboyHB will contact the web revamp initiative – DONE
17:35:17 <pboxHB> #info Action: michel adjust the calendar – DONE
17:35:31 <pboxHB> #info Action: Langdon will review the landing page – DONE (taken over by pwsmith)
17:35:40 <pboxHB> # info Action: pboyHB will sort out discussion about Ansible on the wiki page – IN PROGRESS
17:35:48 <pboxHB> #info pboyHB will set up a first version of subpage about "Improved support for off-premise Kickstart and pxe installation" -  Still to be done
17:36:15 <langdon> i did post a pr on some content
17:36:15 <pboxHB> #info Action: Langdon will contact Cloud WG – Status?
17:36:32 <pboxHB> #info Action: pboy, swefredde jwhimpel set up a wiki page about possible Ansible projects for further discussion – IN PROGRESS
17:36:35 <langdon> no change.. was trying to figure it out
17:37:35 <pboxHB> langdon: YES. I remember, I asked you a question in the comments
17:38:13 <langdon> for open floor...we really need to be using issues so we get some notifications
17:39:13 <pboxHB> x3mboy: Any news about hackmd?
17:39:53 <nirik> hum... so pungi has no config to do this it looks like. ;( So, we may need to punt to the pungi developers...
17:40:06 <langdon> no idea why im being so aggressively marked away
17:40:34 <pboxHB> langdon: ??? I don't understand that remark
17:40:40 <langdon> im pretty sure gepetto does this
17:41:00 <langdon> irc keeps ,arking me away...which usually notifies
17:42:17 <pboxHB> langdon: OK. I was afraid I was doing something wrong.
17:43:20 <langdon> no.. its something to do with me.. was just explaining if anyone was getting annoying notifies
17:43:47 <langdon> Eighth_Doctor, nirik do you want to ask gepetto? i think he would do composes for modularity in not-koji
17:43:49 <pboxHB> Thanks
17:44:02 <Eighth_Doctor> langdon: that'd be great!
17:44:06 <nirik> I updated the releng ticket asking the pungi upstream about it.
17:44:46 <nirik> if gepetto can do a test that would be great... but we would need pungi to support it to do it in official builds
17:45:14 <pboxHB> OK. So we should wait for now?
17:45:22 <langdon> i just meant he might know the "how"
17:47:20 <nirik> sure, doesn't hurt to ask
17:47:41 <pboxHB> Can we agree that Eighth_Doctor, nirik and langdon will look for a solution!
17:47:51 <pboxHB> not a ! but a ?
17:48:01 <Eighth_Doctor> I'm fine with that
17:48:24 <langdon> i will mostly provide cheering from the side line :)
17:48:50 <pboxHB> #agreed Eighth_Doctor, nirik and langdon will look for a solution to the compose question
17:49:01 <pboxHB> Including cheering. :-)
17:49:23 <pboxHB> #topic Fedora Server Documentation
17:49:30 <pboxHB> #info Status documentation: pboy filed a request to add server documentation to docs landing page
17:49:39 <pboxHB> #link https://pagure.io/fedora-docs/docs-fp-o/issue/169
17:49:47 <pboxHB> No reaction until today. How long should we wait, or what to do?
17:50:32 <langdon> i would give it at least a month
17:50:43 <langdon> many teams meet less often than weekly
17:51:12 <langdon> if you want to make it move faster, you could crash the meeting and ask for it to be considered during open floor
17:52:41 <pboxHB> Hm, OK, we'll discuss it next meeting. In the meantime I'll check their IRC meetings
17:53:33 <pboxHB> My question firm mailing list: should we replace 'legacyÄ with claccis in our announcemnt text for landing page?
17:53:48 <michel-slm> huh?
17:54:01 <michel-slm> 'legacy with claccis' - not sure what that means
17:54:12 <langdon> classic?
17:54:30 <pboxHB> Our text is: Fedora Server
17:54:30 <pboxHB> Empowers you to deploy the services you need, modern or legacy, under your own control, and adapted to your own needs
17:55:06 <langdon> so proposing: Empowers you to deploy the services you need, modern or classic, under your own control, and adapted to your own needs  ??
17:55:25 <pboxHB> legacy seems a bit discriminating (to my english understanding)
17:55:27 <michel-slm> ah. not sure we should distinguish between 'modern' and 'legacy'/'classic' -- who does the classification anyway?
17:55:45 <dcavalca> yeah, I think we should drop that
17:55:46 <pboxHB> It was us last meeting :-)
17:55:52 <michel-slm> ah woops
17:55:57 <dcavalca> lol
17:56:14 <langdon> i think the "legacy" or whatever word means "despite fedora being 'first', fedora-server can still run your old stuff"
17:56:22 <michel-slm> yeah, I wonder if we should drop it then. in case someone decided that 'legacy' means 'hey so my pre-systemd initscripts are ok then'
17:56:55 <pboxHB> #proposed Empowers you to deploy the services you need under your own control, and adapted to your own needs
17:57:10 <jwhimpel> +1 for dropping the terms "legacy" and/or "classic"
17:57:17 <langdon> typo / grammar: Empowers you to deploy the services you need, under your own control, and adapted to your own needs
17:57:17 <michel-slm> +1
17:57:23 <langdon> (missing comma)
17:57:25 <langdon> +0
17:57:42 <langdon> well.. +1 on the comma... neutral to -1 on the legacy :)
17:58:20 <pboxHB> langdon: where to place the comma?
17:58:21 <dcavalca> +1
17:58:33 <langdon> see my version ^^
17:58:37 <langdon> its after "need"
17:58:59 <pboxHB> #proposed Fedora server: Empowers you to deploy the services you need, under your own control, and adapted to your own needs
17:59:22 <pboxHB> 3
17:59:36 <pboxHB> 2
17:59:43 <pboxHB> 1
17:59:51 <pboxHB> #agreed Fedora server: Empowers you to deploy the services you need, under your own control, and adapted to your own needs
18:00:15 <pboxHB> Time is nearly up. I switch to open floor
18:00:30 <pboxHB> #topic  Open Floor
18:00:53 <pboxHB> there was: for open floor...we really need to be using issues so we get some notifications
18:01:11 <pboxHB> what can we do ?
18:01:16 <langdon> ok.. so i would like to propose that we start using issues to assign work.. cause i will never remember otherwise.. and it logs what we did
18:01:21 <x3mboy> I did what?
18:01:35 <langdon> x3mboy: what?
18:01:45 <x3mboy> Sorry, work has been aweful
18:02:10 <x3mboy> I had a mention asking for hackmd
18:02:18 <langdon> also, my wife thinks "Empowers you to deploy the services you need under your own control and adapted to your own needs" is more powerful.. if you want to beat that dead horse some more
18:02:22 <x3mboy> I lost track of my tasks
18:02:23 <x3mboy> Sorry
18:02:23 <pboxHB> x3mboy: Welcome! My question was: what about deleting the old versions (PRD) from hachmd ?
18:02:34 <langdon> hence "issues" :)
18:02:37 <x3mboy> Sure, I can do that
18:02:49 <x3mboy> Which one is the only we want to keep?
18:02:52 <michel-slm> langdon: +1 on using issues
18:03:33 <pboxHB> x3mboy: none on hackmd. Everything is now on wiki
18:03:42 <x3mboy> Oh cool!
18:03:49 <x3mboy> Sure, I will remove them.
18:03:51 <x3mboy> Mmm
18:04:00 <x3mboy> Better, I will put them private
18:04:02 <pboxHB> langdon: ++ fir issues
18:04:03 <x3mboy> JIC
18:05:11 <pboxHB> #agreed W'll use issues for work projects and actions
18:05:22 <pboxHB> I think, time is up now.
18:05:41 <pboxHB> Hope to see you in 2 weeks again!
18:05:45 <x3mboy> Can you check hackmd?
18:05:53 <x3mboy> It should be private now
18:06:09 <pboxHB> x3mboy: I'll do and send you a mail!
18:06:17 <pboxHB> #endmeeting