17:00:11 <pboy> #startmeeting fedora-server
17:00:11 <zodbot> Meeting started Wed Mar 16 17:00:11 2022 UTC.
17:00:11 <zodbot> This meeting is logged and archived in a public location.
17:00:11 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:11 <zodbot> The meeting name has been set to 'fedora-server'
17:00:19 <pboy> #topic Welcome / roll call
17:00:24 <cooltshirtguy> hello
17:00:28 <pboy> Same procedure as every year“ We'll give a few minutes for folks to show up
17:00:35 <pboy> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:00:43 <pboy> I’ll post the agenda in a few minutes.
17:00:52 <cooltshirtguy> .hello cooltshirtguy
17:00:53 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
17:01:15 <pboy> hi cooltshirtguy
17:01:30 <cooltshirtguy> hello pboy
17:01:31 <jwhimpel> .hello2
17:01:32 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:01:50 <pboy> hi jwhimpel
17:02:09 <jwhimpel> pboy: Good afternoon (here)
17:02:23 <pboy> good evening (here). :-)
17:02:35 <cooltshirtguy> hi jwhimpel
17:04:14 <pboy> Well, I'll give the agenda and hope there are still some participating
17:04:22 <pboy> #topic Agenda
17:04:29 <pboy> #link https://pagure.io/fedora-server/report/Meeting
17:04:36 <pboy> #info 1. Follow up actions
17:04:42 <pboy> #info 2. Fedora 36 tests
17:04:50 <pboy> #info 3. Planning Fedora 37
17:04:57 <pboy> #info 4. Open Floor
17:05:06 <pboy> Any additional topic ?
17:05:44 <pboy> OK none
17:05:53 <pboy> Some announcements
17:06:04 <pboy> #info startet to contact members who had not been with us for longer than a half year und didn’t contribute anything
17:06:14 <pboy> #info Tried to contact Subhendu Ghosh (sghosh). There is no FAS account and no mail address available.
17:06:28 <pboy> Does anyone has contact with him?
17:06:36 <pboy> Otherwise we should withdraw him from the list of approved members as long as we don’t have contact.
17:06:48 <pboy> Any objections?
17:07:02 <jwhimpel> No objection here
17:07:13 <pboy> #agreed Will withdraw Subhendu Ghosh from the list of approved members for the time being.
17:07:15 <cooltshirtguy> nope
17:08:00 <pboy> I've also contacted Nick Bebout, Matthias Houngbo and Ben Williams. Waiting for reply.
17:08:22 <pboy> #info We have a lot of =new= members who contributed various work. I will prepare a list of new members we can approve by voting (in about 4-6 weeks).
17:08:46 <pboy> as a replacement for inactive members
17:09:02 <pboy> Any comments?
17:09:17 <jwhimpel> Sounds reasonable
17:09:28 <pboy> OK, next topic
17:09:29 <cooltshirtguy> sounds good to me
17:09:39 <pboy> #topic 1. Follow up actions
17:09:47 <pboy> Currently, so far as I see, there are various action running as planned. There is nothing to touch in the moment.
17:09:56 <pboy> So we could save time and skip this topic? Or is there anything I missed? Or any objections to skip?
17:10:12 <jwhimpel> Somewhat aside, I think we need to recruit someone who understands and can teach us how to alter the Server Edition build processes.
17:10:51 <cooltshirtguy> that would be interesting
17:11:20 <pboy> We have  Stephen Gallagher  and Kevin Fenzi (nirik)
17:11:42 <pboy> But there should be more of us who are able
17:12:06 * sgallagh waves
17:12:10 <pboy> I currently try to learn.
17:12:30 <pboy> hi Stephen!
17:12:31 <sgallagh> Sorry I haven’t been more available. Work has been intense recently.
17:12:52 <pboy> But you were always abailable when we were in need.
17:13:10 <pboy> Much more as some others. Thank you a lot!
17:13:28 <pboy> Next topic?
17:13:53 <pboy> #topic 2. Fedora 36 tests
17:14:01 <pboy> #link  https://pagure.io/fedora-server/issue/64
17:14:19 <pboy> We have here a new quite surprising issue
17:14:29 <pboy> #link https://pagure.io/fedora-server/issue/80
17:14:37 <pboy> some time to read?
17:18:24 <jwhimpel> This illustrates the need for us to learn packaging procedures and have the ability to define our own meta-packages.
17:18:25 <pboy> In the meantime I've figured out and tested locally the list of packages we have to install. About 15, 12 alone for libvirt
17:18:41 <pboy> I'll publish the list in a comment after out meeting.
17:19:11 <pboy> jwhimpel +1
17:20:39 <pboy> What about the plan to modify virtualization-headless?  I think, sgallagh knows best, if that is a viable plan. I don't know enough about the build process.
17:21:23 <cooltshirtguy> less is better with headless in my opinion
17:21:42 <sgallagh> I haven’t looked at it too thoroughly except in relation to cockpit-machines
17:22:07 <sgallagh> But I can take a deeper look at that.
17:22:14 <pboy> cooltshirtguy: what do you mean with less?
17:22:22 <cooltshirtguy> less packages
17:22:45 <pboy> Ok, can we agree sgallagh and pboy work on it?
17:22:58 <jwhimpel> +1
17:23:04 <sgallagh> Sure
17:23:43 <pboy> #action  sgallagh and pboy work on #80
17:24:26 <pboy> Other test experiences (newer than last meeting)
17:25:08 <jwhimpel> The migration to the "next generation" of ansible seems to be working fine.
17:25:34 <pboy> That is very reassuring.
17:25:51 <jwhimpel> I had a bit of trouble with F36 VM's locking up with accessing though console on virt-manager, but recent updates seem to have cured those issues.
17:25:52 <pboy> We'll need Ansible a lot in the next months, I thin.
17:26:50 <cooltshirtguy> good chance to learn some ansible
17:26:50 <pboy> I read somewhere, that there are specific configuration of a VM for work with oVirt. Don't remember details.
17:27:37 <pboy> OK, no comments, switch topic.
17:27:40 <pboy> 3
17:27:44 <pboy> 2
17:27:52 <pboy> 1
17:28:01 <pboy> #topic 3. Planning Fedora 37
17:28:10 <pboy> #link https://pagure.io/fedora-server/issue/79
17:28:23 <pboy> we have a lot of ongoing plans.
17:28:36 <pboy> #link https://pagure.io/fedora-server/issue/51
17:28:44 <pboy> #link https://pagure.io/fedora-server/issue/53
17:29:01 <pboy> #link https://pagure.io/fedora-server/issue/54
17:29:10 <pboy> #link https://pagure.io/fedora-server/issue/65
17:30:21 <pboy> I would like to create a Server VM image as ad additional distribution file. (#53)
17:30:22 <cooltshirtguy> I like #54. espically about showing updates available on login
17:31:21 <pboy> We would have to change the build process. It is doable, but not that simple
17:31:36 <pboy> I would appreciate that much.
17:32:02 <cooltshirtguy> understandable
17:32:22 <jwhimpel> Hence my earlier suggestion of adding someone very knowledgeable from the Release Management team as a "volunteer consultant" to teach us how to DYI.
17:33:06 <jwhimpel> s/DYI/DIY/
17:33:23 <pboy> jwhimpel  +1 But is is primarly a matter of reading (and finding) the info
17:33:57 <pboy> Question is, how can we do that?
17:34:11 <jwhimpel> It could be, but my limited experience is the documentation is for those that already know how to perform these tasks.
17:34:51 <pboy> jwhimpel yes, in many cases. But reading 3 or 5 times helps.
17:36:03 <pboy> #proposed: I'll document the steps to fix #80 and cooltshirtguy will develop a plan how to do it, and we discuss it next meeting?
17:36:23 <jwhimpel> Mohan Boddu (mboddu) is the Fedora T/L for Release Management.  Perhaps contact him and ask for suggestions and ideas on how to proceed.
17:36:40 <cooltshirtguy> ok
17:37:13 <pboy> I think we have sgallagh who knows specifically about. server
17:37:41 * mboddu reading back
17:37:44 <pboy> I think we have sgallagh, who knows best specifically about server
17:38:04 <pboy> mboddu welcome
17:38:46 <sgallagh> Sorry, what’s the question?
17:38:48 <mboddu> Hello pboy
17:39:01 <mboddu> Yeah, I also dont follow the question
17:39:32 <pboy> sgallagh no question, just a statement (that you will help us)
17:39:44 <sgallagh> Okay
17:40:24 <jwhimpel> We would like to setup a new install group known as "headless server".  At least I have no idea how to find the procedures on how to go about this and get it into anaconda, etc.
17:40:28 <pboy> The problem / question is, we have new memvers (like me) who must / want learn about the build process, so we can make modifications to server distributable
17:41:27 <sgallagh> We actually have some groups like that already
17:41:31 <pboy> jwhimpel I learnt how to modify virtualization-headless, but I don't know it that is viable
17:42:01 <pboy> what groups? learning groups?
17:42:40 <eseyman> hi, folks. Sorry I'm late
17:42:45 <eseyman> .hello2 eseyman
17:42:46 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:42:54 <sgallagh> Groups in comps.xml for headless operations.
17:43:01 <pboy> eseyman welcome, late but not too late
17:43:46 <pboy> sgallagh yes, indeed. We will use that to fix virtualization installation
17:44:16 <pboy> OK, i think we use learning by doing.
17:44:49 <pboy> Next meeting we discuss (and learn) cooltshirtguy findings an plan.
17:45:31 <cooltshirtguy> woohoo
17:45:33 <jwhimpel> sgallagh: Unfortunately, it brings in a lot of GUI interface packages.  Many in our community only use CLI and ansible/puppet/chef/etc to maintain our servers.  This change could probably reduce our footprint considerably.
17:46:00 <sgallagh> Right, I understand the request. I just haven't had time to address it.
17:46:22 <eseyman> note that there is a usecase for all the GUI interface stuff
17:46:31 <pboy> OK. Any additional comment? Otherwise a switch topic
17:46:46 <pboy> 3
17:46:49 <pboy> 2
17:46:53 <pboy> 1
17:46:55 <pboy> #topic 4. Open Floor
17:47:11 <pboy> We never had to much time for this topic before.
17:47:12 <sgallagh> eseyman: We can easily do both
17:47:13 <jwhimpel> Honest question: Is the above change something reserved for Rel Mgmt or should we learn to do ourselves?
17:47:23 <eseyman> sgallagh: agreed
17:47:50 <sgallagh> jwhimpel: It's not reserved for Rel Mgmt, though it will usually be reviewed by them
17:48:29 <pboy> In the end it is the PR workflow which prevents the wrong changes from coming in.
17:48:45 <jwhimpel> That's why I was hoping to find a Rel Mgmt mentor to help us learn how to do this properly.
17:49:23 <sgallagh> I'm not formally a releng person, but I've got a lot of history with this, so I'll try to mentor you
17:49:45 <pboy> sgallagh +1 !
17:49:55 <jwhimpel> +2  :-)
17:50:08 <pboy> It is indeed very important that as many members of the WG as possible know how this works!
17:50:50 <cooltshirtguy> +3
17:50:51 <pboy> We are a lot on new members, who never had dealt with such things (including me)
17:51:32 <pboy> Any coments?
17:51:49 <cooltshirtguy> nope
17:52:05 <pboy> Otherwise it would the first time we are finishes so early.
17:52:22 <pboy> OK, see you next meeting or on thje mailing list.
17:52:25 <pboy> Bye bye
17:52:30 <eseyman> goodbye, folks
17:52:34 <pboy> #endmeeting