17:00:18 <pboy> #startmeeting fedora-server
17:00:18 <zodbot> Meeting started Wed Apr  6 17:00:18 2022 UTC.
17:00:18 <zodbot> This meeting is logged and archived in a public location.
17:00:18 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:18 <zodbot> The meeting name has been set to 'fedora-server'
17:00:29 <pboy> #topic Welcome / roll call
17:00:37 <pboy> Welcome to our Server WG IRC meeting today!
17:00:46 <pboy> „Same procedure as every year“ We'll give a few minutes for folks to show up
17:00:54 <pboy> I’ll post the agenda in a few minutes.
17:01:17 <pboy> It's the first after summer time switch. Looking forward.
17:02:07 <jwhimpel> .hello
17:02:07 <zodbot> jwhimpel: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:02:16 <cooltshirtguy> .hello
17:02:16 <zodbot> cooltshirtguy: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:03:07 <jwhimpel> .hello jwhimpel
17:03:08 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:03:30 <eseyman> .hello eseyman
17:03:30 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:04:05 <cooltshirtguy> so that's how it works
17:04:15 <cooltshirtguy> .hello cooltshirtguy
17:04:16 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
17:04:27 <pboy> Hurray, I'm not the only one who was able to manage summer time switch !
17:04:43 <cooltshirtguy> I need a feroda-server cheat sheet. :)
17:05:00 <pboy> Welcome jwhimpel cooltshirtguy eseyman
17:05:31 <pboy> Let's start with the Agenda
17:05:42 <pboy> #topic Agenda
17:05:52 <pboy> #link https://pagure.io/fedora-server/report/Meeting
17:05:59 <pboy> #info 1. Follow up actions
17:06:06 <pboy> #info 2. Fedora 36 tests
17:06:13 <pboy> #info 3. Cockpit file-sharing update Change Proposal follow up
17:06:20 <pboy> #info 4. Planning Fedora 37
17:06:26 <pboy> #info 4. Open Floor
17:06:33 <pboy> Any additional topic ?
17:08:04 <pboy> undo
17:08:14 <pboy> #info 5. Open Floor
17:08:32 <pboy> Obviously, I can not even count. :-)
17:08:51 <pboy> or correctly copy&paste
17:09:02 <pboy> #topic 1. Follow up actions
17:09:13 <pboy> As already announced, I startet to contact members who had not been with us for longer than a half year und didn’t contribute anything
17:09:27 <pboy> #info Had an IRC chat with Ben Williams (jbwillia). He is busy with other projects and we agreed he will withdraw from server WG. So I will remove him from our list.
17:09:38 <pboy> Any objections?
17:10:17 <eseyman> no
17:10:17 <pboy> #action Will withdraw Ben Williams from the list of approved members for the time being.
17:10:29 <pboy> #info DONE: Withdrew Subhendu Ghosh from the list of approved members for the time being.
17:10:37 <pboy> #info DONE: Resolved with sgallagh the installation issue with virtualization.
17:10:48 <pboy> As far as I see, we have no open actions (besides our various running tickets).
17:11:20 <pboy> Do I miss an outstanding one?
17:11:34 <sgallagh> .hi
17:11:35 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:11:50 <pboy> Welcome sgallagh
17:11:58 <eseyman> hi, sgallagh
17:12:21 <cooltshirtguy> hello
17:12:37 <pboy> #topic 2. Fedora 36 tests
17:12:46 <pboy> #link  https://pagure.io/fedora-server/issue/64
17:12:53 <pboy> The current change set
17:13:02 <pboy> #link https://fedoraproject.org/wiki/Releases/36/ChangeSet
17:13:09 <pboy> Our set of tracking item:
17:13:17 <pboy> #link https://pagure.io/fedora-server/issue/64#comment-783961
17:13:23 <pboy> #info Final Freeze - 2022-04-05  (yesterday)
17:13:30 <pboy> #info Fedora Linux 36 GA - Target Release 2022-04-19
17:13:37 <pboy> So there is not so much time left.
17:13:48 <pboy> Any new or additional findings about beta 1.4 ?
17:14:10 <eseyman> I'll probably install it this weekend
17:14:21 <sgallagh> I have one item for F36 testing.
17:14:35 <sgallagh> Specifically: Active Directory testing
17:15:12 <pboy> eseyman Was'nt it you who will address it?
17:15:16 <sgallagh> I have been carrying the responsibility for performing these tests for years
17:15:24 <pboy> I mean active Directory
17:15:27 <sgallagh> eseyman: Are you a Red Hat employee perchance?
17:15:34 <eseyman> no, I'm not
17:15:48 <eseyman> I will gladly test OpenLDAP 2.5 but not AD
17:16:19 <pboy> OK, I have mixed up
17:16:41 <sgallagh> Strictly speaking, Server only blocks on AD and FreeIPA enrollment
17:17:24 <sgallagh> I spent some time last week getting a new AD set up on a virtual host, but it's only acceptable to Red Hat employees for $REASONS
17:17:33 <sgallagh> Sorry acceptable->accessible
17:18:15 <sgallagh> So if we have anyone from RHT in the WG besides me that wants to be able to perform the AD tests, please identify yourself and I'll get you access to it.
17:19:01 <cooltshirtguy> sure why not. specifically which tests?
17:19:47 <cooltshirtguy> warning, i know enough about AD to be dangerous
17:19:54 <sgallagh> https://fedoraproject.org/wiki/Test_Results:Fedora_36_Beta_1.4_Server#Domain_joining_tests:_Active_Directory
17:20:02 <sgallagh> and https://fedoraproject.org/wiki/Test_Results:Fedora_36_Beta_1.4_Server#Domain_client_tests
17:20:29 <sgallagh> The domain is already set up for you, so there shouldn't be much you need to know on that end
17:20:43 <sgallagh> I'll get you access this afternoon, then
17:20:43 <cooltshirtguy> ok.
17:20:44 <sgallagh> Thanks!
17:21:42 <pboy> cooltshirtguy  thanks!
17:22:13 <pboy> I checked virtualization, postgres, general interactive installation. Found no issue.
17:22:34 <pboy> Even split DNS works now
17:23:14 <pboy> Someone else with findings?
17:24:00 <jwhimpel> My testing of ansible was registered in the Pagure issue
17:24:33 <pboy> jwhimpel yes, I read that. Looks good, I think.
17:24:42 <pboy> #info Annoncement Upgrade Test Day 2022-04-14 (next Thursday)
17:24:55 <pboy> #link https://fedoraproject.org/wiki/Test_Day:2022-04-14_F36_Upgrade_Test_Day
17:25:12 <pboy> Server Test list:
17:25:21 <pboy> #link Server Test items: https://testdays.fedoraproject.org/events/135
17:25:36 <pboy> We should carefully test upgrading. Issue: No ifcfg Files is part or release 36
17:25:46 <pboy> #link https://fedoraproject.org/wiki/Changes/NoIfcfgFiles
17:25:56 <pboy> But currently is no migration tool available in fedora (but exist now in upstream).
17:26:03 <pboy> When upgrading, the „old“ ifcfg plugin should remain active. Nevertheless, testing may be useful.
17:27:18 <pboy> And I'd like us to not just do the tests in private, but to show up at Testday.
17:27:25 <jwhimpel> I've been running my development work on F36 for several weeks.  I see nothing under /etc/sysconfig/network-scripts and all my network config done via nmcli.  Pretty simple network though.
17:27:38 <eseyman> +1 for a Testday
17:28:10 <pboy> jwhimpel Did you do updates 35 -> 36 already?
17:29:35 <jwhimpel> Fresh install of 36 in one VM and upgrade 35->36 in two others.
17:29:52 <pboy> OK, good to know that.
17:30:10 <pboy> Nevertheless, can  we agree, that everybody of us tests the upgrade with one of his „real life“ configurations and reports next Thursday to the result page?
17:30:38 <jwhimpel> +1
17:31:02 <eseyman> yes
17:31:17 <pboy> #agreed everybody of us tests the upgrade with one of his „real life“ configurations and reports next Thursday to the result page
17:31:27 <cooltshirtguy> ok
17:31:49 <pboy> Anything else?
17:32:19 <pboy> #topic 3. Cockpit file-sharing update Change Proposal follow up
17:32:27 <pboy> The file-sharing update is part of F36 and is obviously working. I suppose we can close issue #73.
17:32:36 <pboy> #link https://pagure.io/fedora-server/issue/73
17:32:56 <pboy> So we can close the issue now?
17:33:02 <pboy> And we can start to determine follow up actions.
17:34:05 <eseyman> I would vote +1 to that
17:34:33 <pboy> OK, no one objects, I'.. close it
17:35:06 <pboy> As to follow up, we already discusses localization and making it part of CP applications on mailing list
17:35:24 <pboy> Another topic: improve documentation about it.
17:35:52 <pboy> Maybe, we open a discussion on mailing list?
17:36:50 <sgallagh> I've got it on my backlog to add the Cockpit Application stuff to the file-sharing
17:36:54 <sgallagh> But my backlog is... large
17:37:15 <eseyman> maybe have a discussion on easy cockpit first-timers bugs?
17:37:22 <pboy> sgallagh wondering about that. :-)
17:37:52 <pboy> eseyman what first-timers bugs?
17:38:23 <eseyman> bugs that could be fixed by people who are new to cockpit
17:38:42 <pboy> OK.
17:38:46 <sgallagh> That's a question probably best directed at the Cockpit team
17:38:53 <eseyman> if this is going to be the thing Fedora Server users see, it should be good
17:39:08 <pboy> I look at the time, so lets open a discussion on mailing list. OK?
17:39:41 <sgallagh> That being said, check out https://github.com/cockpit-project/cockpit/labels/good-first-issue
17:40:05 <eseyman> yes, that looks like I was thinki
17:40:09 <eseyman> ng about
17:40:36 <pboy> Looks promising
17:41:01 <pboy> But, looking at the time
17:41:10 <pboy> action Open discussion about Cockpit and LookBut looking at the file-sharing update follow ups on mailing list
17:41:23 <pboy> #action Open discussion about Cockpit and LookBut looking at the file-sharing update follow ups on mailing list
17:41:56 <pboy> #toppic 4 Planning Fedora 37
17:42:35 <pboy> We have 2 candidates, 1 possible candidate and a hot discussion on devel about withdrawel of bios boot support.
17:43:07 <pboy> Comments about any of this?
17:44:13 <eseyman> not yet, I'm following the ml thread for now
17:45:05 <pboy> My problem with that: I know various data center with rental hardware that currently use bios boot.
17:45:23 <pboy> I myself had rented several there.
17:45:42 <pboy> And I don't like to switch to another distro
17:46:16 <cooltshirtguy> ok great
17:46:26 <cooltshirtguy> haha wrong window
17:47:58 <pboy> I wonder if we as a server WG should or perhaps must comment on this?
17:48:41 <pboy> There are many opposing opinions, but the maintainers seem determined and unimpressed by it so far
17:49:52 <eseyman> true but I think you should make your opinion known if you have one
17:50:10 <pboy> I have one and I already did. :-)
17:51:06 <pboy> OK, we should think about it. I hope there is some time for that.
17:51:23 <pboy> F37 actions of our own.
17:51:57 <pboy> I detailed my ideas about a Server VM image.
17:52:00 <pboy> #link https://pagure.io/fedora-server/issue/79#comment-790978
17:52:25 <pboy> Comments?
17:53:40 <pboy> cooltshirtguy I can summerize our discussion about update notification. Or do you want to make some notes about it in the ticket?
17:53:58 <eseyman> looks good to me
17:54:56 <jwhimpel> Were you planning to deploy via virt-install?
17:55:15 <pboy> yes, virt-install or cockpit
17:55:44 <cooltshirtguy> I'll make notes later
17:55:49 <jwhimpel> I do that now.  What do you think is currently missing?
17:56:51 <pboy> cooltshirtguy Thanks.
17:57:06 <pboy> jwhimpel I lost the context. :-)
17:57:25 <pboy> what mising?
17:58:18 <jwhimpel> virt-install can install VM's maintained by their project team.  I do that now for their sever image.  Is there something missing from their server image?
17:59:31 <pboy> Yes,  it is not Fedora Server Edition. I wrote a docu about it. wait a moment ...
18:01:11 <pboy> Currently, stg is unavailable. It their in doc about virtualisation.
18:01:41 <pboy> something like https://docs.stg.fedoraproject.org/en-US/fedora-server/server-virtualization/
18:01:57 <jwhimpel> pboy: We can follow up in mailing list tomorrow.
18:02:05 <pboy> OK.
18:02:11 <pboy> time is up.
18:02:23 <pboy> Thanks erveryone for comming
18:02:34 <pboy> And for our good discussion.
18:02:34 <eseyman> thank you, all
18:02:38 <eseyman> good evening
18:03:06 <pboy> #endmeeting