17:00:37 <pboy> #startmeeting fedora-server
17:00:37 <zodbot> Meeting started Wed Dec  7 17:00:37 2022 UTC.
17:00:37 <zodbot> This meeting is logged and archived in a public location.
17:00:37 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:37 <zodbot> The meeting name has been set to 'fedora-server'
17:00:45 <pboy> #topic Welcome / roll call
17:00:52 <pboy> Welcome everybody.
17:00:59 <mowest> .hello2
17:01:00 <zodbot> mowest: mowest 'Steve Daley' <mowest@vivaldi.net>
17:01:02 <pboy> Let's see who is here.
17:01:04 <eseyman> .hello2
17:01:06 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:01:15 * eseyman makes it with seconds to spare
17:02:12 <mowest> Can't stay long, special Christmas lunch today at work, and this is lunch hour in the US Eastern time zone
17:02:14 <cooltshirtguy> .hello2
17:02:15 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
17:02:43 <pboy> Welcome again
17:03:02 <pboy> Then let's start now. I'll post the agenda
17:03:10 <pboy> #topic Agenda
17:03:33 <pboy> #info 1. Discussion of the meeting start time
17:03:51 <eseyman> yeah, we really need to change this, imho
17:03:52 <pboy> #info  2.  Server critical path definition proposal
17:04:20 <pboy> #info  3. Server WG work program for upcoming year
17:04:33 <pboy> #info  4. Open Floor
17:04:46 <pboy> Anything to add?
17:05:03 <mowest> Red Hat is in the Eastern Time zone of the US, so perhaps we could catch a few more of the Red Hat people with an hour later.
17:05:31 <eseyman> pboy: I suspect that's quite enough as is
17:05:41 <pboy> mowest Yes, hopefully
17:05:47 <pboy> #topic  1. Discussion of the meeting start time
17:06:11 <jwhimpel> .hello2
17:06:12 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:06:24 <pboy> Would do you think to follow some other teams and to shift to 1 hour later?
17:06:39 <pboy> Would - What
17:06:41 <mowest> Yes, please if that time slot is open.
17:06:48 <jwhimpel> That would work a bit better for me.
17:07:00 <pboy> Yes, it is.
17:07:11 <pboy> For me, too
17:07:27 <eseyman> +1 for an hour later
17:07:37 <cooltshirtguy> i'm indifferent
17:07:51 <eseyman> the current schedule is fine for summer but impratical during winter
17:07:56 <pboy> cooltshirtguy would it be OK for you?
17:08:04 <cooltshirtguy> it's fine
17:08:17 <pboy> Ok, then
17:08:43 <pboy> #agreed  We'll start our meeting one hour later during winter time.
17:09:31 <pboy> #topic 2. Server critical path definition proposal
17:09:53 <pboy> I suppose, we missed that because of our meeting gap
17:10:54 <pboy> adamw Are you online? Ir there anything to do about this topic?  (I guess not).
17:12:35 <eseyman> "Merged 15 days ago"
17:13:04 <pboy> OK, so it's done.
17:14:00 <pboy> It's a bit unfortunate.
17:14:23 <eseyman> "this adds a Server critpath definition which is basically the
17:14:24 <eseyman> freeipa-server group, plus cockpit and postgresql."
17:14:55 <eseyman> honestly, this is fine by me
17:15:26 <eseyman> one could argue apache should be in there but apache's depchain is quite large
17:15:35 <pboy> Yes, but it is a bit few. We have much more items.
17:16:11 <pboy> E.g.we have Virtualization, Containerization, both quite important for Server
17:16:45 <pboy> free-ipa is more of a marginal use
17:16:46 <eseyman> mind you, perl being in critpath had cons but no pros so I'm glad it isn't in there anymore
17:17:11 <eseyman> pboy: agreed for birt and containers
17:17:16 <eseyman> s/birt/virt
17:18:03 <pboy> But may be we an open the discussion again when we discussed and decided our release and quality criteria
17:18:53 <eseyman> yes, I don't think revisiting this is going to be a problem
17:19:07 <pboy> By the way, I like perl. Was a great time doing everything about system admin in perl
17:19:36 <pboy> Full of surprises, after a year coming back to an issue. :-)
17:19:53 <pboy> OK, let's switch
17:20:20 <pboy> #topic 3. Server WG work program for upcoming year
17:20:35 <pboy> Well, the floor is open.
17:20:46 <pboy> What do you think?
17:21:19 <mowest> What documentation for F37 still needs to be reviewed?
17:21:45 <eseyman> I believe we had decided to choose 5 items and do them well instead of trying to do everything at once
17:22:20 <pboy> Yes, we wanted to choose the 5 oldest articles.
17:22:38 <jwhimpel> Did anyone find time recently to help diagnose my issue with letsencrypt certs and wildfly?  The problem is in how to change the config files to support ssl.
17:23:15 <cooltshirtguy> nope, I'll put it on my todo list for this weekend.
17:23:22 <pboy> jwhimpel A big sorry! It's on my todo, and first priority now after F39 is out.
17:23:26 <jwhimpel> Thanks!!
17:23:39 <eseyman> jwhimpel: same
17:23:42 <pboy> F39 -> F37. .-)
17:24:01 <cooltshirtguy> wow we jumped versions fast
17:24:06 <eseyman> sorry but recovering from Covid took longer than I had hoped for
17:24:26 <pboy> Let's put this as the first topic next meeting.
17:24:40 <cooltshirtguy> covid--
17:24:45 <eseyman> pboy: agreed
17:25:16 <mowest> I'm breaking for lunch, tag me if there is something that I can help out with that is docs related.
17:25:19 <jwhimpel> I'll monitor the mailing list for questions.
17:25:33 <pboy> I'm planning to work on Ansible/wildfly and on Reviewing installation media.
17:25:47 <pboy> mowest Have a nice evening
17:26:58 <pboy> And I'm considering if we should add an OSTree installation alternative to our Default file based install
17:28:12 <pboy> I'm trying to find out how much work it is, probably starting with a VM image version.
17:28:26 <pboy> SuSE had made it nicely.
17:28:34 <pboy> What do you think about it?
17:29:47 <eseyman> no opinion
17:29:53 <cooltshirtguy> I really don't have anything on it as a I havent used it
17:30:50 <pboy> I suppose I myself wouldn't use it. It's my curiosity.
17:31:21 <pboy> So it's certainly not a hight priority item.
17:33:00 <pboy> What about the web page revamp effort?
17:33:15 <pboy> I think, we can't postpone it anymore.
17:33:24 <pboy> Can anyone warm up to this?
17:33:51 <pboy> It's not so much about graphics, but about text and a good presentation of Server.
17:35:41 <cooltshirtguy> I wouldn't even know where to start
17:35:47 <eseyman> are we talking about https://getfedora.org/fr/server/ ?
17:36:22 <pboy> eseyman yes, a new version for that.
17:36:48 <pboy> as an example for the new design and presentation: https://design.penpot.app/#/view/d0c3eb90-430d-11ed-9050-cf2300df1f4f?page-id=d0c3eb91-430d-11ed-9050-cf2300df1f4f&section=interactions&index=0&share-id=637865d0-43c0-11ed-9050-cf2300df1f4f
17:37:46 <pboy> For my taste, this is too much marketing and not enough substance.
17:38:13 <pboy> The new Workstation page is even more marketing
17:38:32 <cooltshirtguy> well that's fancy
17:38:46 <cooltshirtguy> the coreos page
17:38:59 <eseyman> put politely, I guess I'm not the target audience
17:40:04 <pboy> me to. :-)
17:40:15 <cooltshirtguy> the real question is what is our target audience
17:40:23 <pboy> see Workstation: first cut was https://design.penpot.app/#/view/d24b8550-780f-11ec-b805-69e39b8fc2b7?page-id=d994e860-780f-11ec-b805-69e39b8fc2b7&section=interactions&index=0&share-id=7959a5c0-94c1-11ec-bd38-efdb6fa63305
17:40:47 <pboy> "The leading Linux desktop" hm....
17:41:07 <eseyman> I can see how one would argue that
17:41:08 <pboy> without documentation. (I just can't resist)
17:41:31 <eseyman> it shines compared to the coreos one
17:42:12 <pboy> yes, but for server I would prefer more substantial information and text.
17:42:15 <mowest> I'm willing to review the getfedora.org/server/ site. Currently the design of our page is very similar to Workstation, I think consistancy in design is important.
17:42:59 <pboy> mowest +1 !
17:43:44 <eseyman> it could use more color
17:43:55 <pboy> mowest I'll put together some information I've collected of the last year. But I need some days.
17:44:01 <mowest> The mockup you pointed to for CoreOS is very different in design. I'm not a designer, but I can review and propose some different text and make suggestions of for graphics.
17:45:12 <mowest> eseyman yes that would be my suggestion for graphics enhancements is more color favoring shades of blue since that color seems to be in the Fedora colorwheel.
17:45:16 <pboy> mowest That would be great! Our designers are good. But maybe, sometimes they get carried away with fancy graphics.
17:45:44 <pboy> Our role is, I think, to keep an eye on the substance.
17:45:55 <pboy> and maybe not to get too fancy
17:45:57 <mowest> I would also look at decreasing the amount of text and focus on a few key features.
17:46:38 <pboy> That's OK for me. Concentration of the most important items.
17:48:07 <mowest> I woofed down Christmas work lunch quick, everyone got through the line quicker than I thought, so they were cleaning up when I arrived. But I got back here faster as a result.
17:48:33 <pboy> very good for us !
17:49:25 <pboy> Well, there remains the question or release testing and probably a test week.
17:49:54 <pboy> Maybe, we postpone it to F39?
17:50:21 <pboy> Or is there someone to take the hat?
17:51:21 <mowest> I like the idea of a test week. Where would we report our "bugs"/issues though? I ended up doing some testing but ran into an issue and posted on Fedora Discussion and I got crickets or no responses at all during the F37 beta.
17:51:44 <pboy> mowest that's one of the issues.
17:52:16 <pboy> If we had a test week and the appropriate web site, we had a central and dedicated page to report results and issues
17:52:18 <cooltshirtguy> I had an issue with pipewire and got crickets in askfedora
17:52:31 <eseyman> I would love to but am commited to too much already
17:53:28 <pboy> cooltshirtguy  askfedora is fine! But for release testing, I think we need something more focused.
17:53:49 <cooltshirtguy> agreed
17:54:00 <pboy> eseyman what a pitty.
17:54:01 <mowest> I've always seen Ask Fedora as the spot to post user issues, and I thought Fedora Discussion was a quicker connection to the actual Fedora devs, but perhaps I'm mistaken in that view.
17:54:27 <pboy> mowest you are not, IMHO
17:55:27 <eseyman> mowest, that sounds about right
17:55:37 <pboy> Well, I think we have a good plan, and a realistic one.
17:56:03 <mowest> I spoke briefly with Ben Cotton in person at Ohio Linux Fest last week, and he recognized this issue too, but neither of us had a solution to propose.
17:56:11 <cooltshirtguy> does other groups have a test page? can we request for us. not sure how the process, just asking questions
17:56:51 <cooltshirtguy> *1 for us
17:57:00 <pboy> cooltshirtguy.  Yes, e.g. CoreOS and IoT wait, I look for links
17:57:21 <pboy> CoreOS. https://testdays.fedoraproject.org/events/131
17:57:29 <mowest> I was wondering how we get one of those fancy test pages too.
17:57:43 <pboy> IoT https://testdays.fedoraproject.org/events/132
17:58:31 <eseyman> mowest: this mostly requires giving a test suite to Fedora QA
17:58:45 <eseyman> and letting them roll with it
17:59:00 <pboy> mowest. We should make a plan and then propose is to adamw. They will help us to set up the page und to write the tests for items, that can to tested automatically
17:59:47 <pboy> We'll get help with the technical details. but we must provide the substance
18:00:12 <pboy> And we don't have to have everything complete from the beginning.
18:00:33 <pboy> We can stafrt with some items and expand with the following releases.
18:01:18 <adamw> pboy: sorry, just saw the ping. we can always add *more* things to critpath. i always assumed httpd was in there already, but surprisingly, it isn't. it's sort of implicitly required by cockpit and freeipa, though - unless you do a lot of tweaking to run them on nginx instead - so i'd support adding it...
18:02:01 <pboy> adamw from me no nginx. I'm fine with apache. :-)
18:02:08 <pboy> thanks for the info!
18:02:19 <eseyman> adamw: can we revisit this down the path?
18:02:28 <adamw> oh, hmm, i guess cockpit doesn't actually use httpd, it's a web server directly. yeah, sure
18:04:26 <pboy> I just see, we are running out of time.
18:05:21 <pboy> I would like to switch to open floor. at least for a short  time.
18:06:14 <pboy> #topic. 4. Open Floor
18:06:33 <pboy> Anything to discuss here?
18:07:30 <mowest> I have seen a graphic that shows the Red Hat pipeline as Fedora being first to innovate followed by CentOS Stream branching off of a Fedora version to stablize and roll towards the next Red Hat Enterprise. With that in mind is there a tech that we should be testing now for the benefit of that pipeline down the line?
18:07:58 <mowest> Something we could work on for F38?
18:08:31 <mowest> Perhaps a file system change, or a stack for containers...
18:08:58 <pboy> mowest Yes, that's the traditional role of Fedora, and especially Server.
18:08:59 <eseyman> I want to concentrate on indentity management for the coming weeks
18:09:40 <pboy> eseyman very good, we have currently a weak point there
18:10:06 <pboy> mowest that a good topic to discuss not to far in the future.
18:10:16 <mowest> Is there a link where I could learn more about indentity management? I'm unsure what this is.
18:11:00 <eseyman> I mostly learnt this stuff by doing it
18:11:18 <cooltshirtguy> i would think free-ipa has some stuff
18:12:05 <eseyman> it's one of the main features, yes
18:12:43 <mowest> pboy I would be very interested in this being one of our "5" things for F38 or F39. I would love to trial and test something that helps downstream from Fedora.
18:13:58 <pboy> mowest  I agree! Let's discuss that further.
18:14:14 <pboy> We are about 15 Mins overdue now.
18:14:33 <pboy> I think we should close and continue next meeting or on mailing list.
18:14:37 <mowest> Goodbye thanks pboy for a good meeting.
18:14:40 <eseyman> yes
18:14:56 <pboy> I summerize our planning on mailing list.
18:15:04 <pboy> Thanks everybody!
18:15:16 <pboy> #endmeeting