18:00:08 <pboy> #startmeeting fedora-server
18:00:08 <zodbot> Meeting started Wed Feb 15 18:00:08 2023 UTC.
18:00:08 <zodbot> This meeting is logged and archived in a public location.
18:00:08 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:08 <zodbot> The meeting name has been set to 'fedora-server'
18:00:15 <pboy> #topic Welcome / roll call
18:00:22 <eseyman> hello, folks
18:00:25 <pboy> Welcome to our Server WG IRC meeting today!
18:00:28 <eseyman> .hello2 eseyman
18:00:29 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
18:00:35 <mowest> .hello2
18:00:36 <zodbot> mowest: mowest 'Steve Daley' <mowest@vivaldi.net>
18:00:47 <eseyman> For once, I am on time. Rejoice!
18:00:49 <pboy> .hello2
18:00:52 <zodbot> pboy: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:01:44 <pboy> Let's wait some minutes.
18:02:48 <cooltshirtguy> .hello2
18:02:49 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
18:03:05 <eseyman> hey, cooltshirtguy
18:03:54 <cooltshirtguy> hello everyone
18:04:02 <cooltshirtguy> busy day, kind of distracted
18:05:31 <pboy> Welcome  eseyman,  welcome mowest, welcome cooltshirtguy
18:05:39 <pboy> Our highly acrive core is nearly complete again .
18:05:49 <pboy> missing jwhimpel, dearly. :(
18:06:02 <pboy> Hope, he will join us soon.
18:06:08 <jwhimpel> .hello2
18:06:09 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
18:06:43 <pboy> Hi John! The German saying is: When you speak from the devil, .....
18:07:03 <mowest> Americans say, "Speak of the devil."
18:07:22 <eseyman> hello, jwhimpel
18:07:22 <jwhimpel> Sorry, I lost track of time while dis-assembling a broken snow-blower. :-(
18:07:23 <pboy> Thanks, something learned again.
18:07:52 <pboy> You need a snow-blower, at these days?
18:08:05 <pboy> It's 10 degree here in Germany
18:08:30 <mowest> Midwest is 41 F and no snow on the ground, but it will come again.
18:09:01 <cooltshirtguy> Dallas is 71F. its lovely
18:09:25 <pboy> Ok, quite different for anybody of us .
18:09:34 <pboy> Let's start.
18:09:40 <mowest> @cooltshirtguy, that sounds so nice to me right now.
18:09:47 <pboy> #topic Agenda
18:09:57 <pboy> #info  Follow up actions
18:10:05 <pboy> #info  Fedora Website revamp – Fedora Server Edition pages
18:10:13 <pboy> #info  F38: Shorter Shutdown Timer
18:10:21 <pboy> #info  Using Ansible to install and configure Wildfly
18:10:29 <pboy> #info  Open Floor
18:10:39 <pboy> Anything to add?
18:10:56 <eseyman> no, that's fine for me
18:11:07 <pboy> OK
18:11:17 <cooltshirtguy> nope
18:11:21 <pboy> #topic  1. Follow up actions
18:11:31 <pboy> oth open actions, nirik and me, are part of the agenda items.
18:11:43 <pboy> So we sskip them here
18:12:01 <pboy> Anything else to announce / tr track?
18:12:19 <pboy> OK, none
18:12:28 <pboy> #topic  2. Fedora Website revamp – Fedora Server Edition pages
18:12:38 <pboy> #link Issue #66: https://pagure.io/fedora-server/issue/66
18:12:47 <pboy> #link Mailing List: https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/7QJHY6E422W6SGLMETH5VFOUY6IKJA3P/
18:13:00 <pboy> Thinks are moving fast here.
18:13:10 <mowest> Emma Kidney has put together some concept header art for our page here: https://gitlab.com/fedora/design/team/wwwfpo-2022/-/issues/23#note_1276926623
18:13:12 <pboy> mowest, your floor
18:13:30 <mowest> I have received some feedback on these concepts through the email list.
18:13:49 <mowest> No one likes my favorite :-) but that's okay.
18:14:16 <pboy> I forgot the laptop in my list, it's the administrative side.
18:15:02 <jwhimpel> I like three different images. 1) standalone server (upright box) 2) Small stack of servers like shown at the top of the example and 3) Server room.  Think all should be used somewhere on the entry page.
18:15:09 <mowest> So far the brick concept is the favorite of the two presented. I can ask Emma to consider giving us something that is has more the look of a server rack which has been mentioned by a few.
18:15:42 <pboy> jwhimpel +1
18:16:25 <pboy> I think the brick concept is a bit empty of content / meaning
18:16:43 <mowest> Remember that we do need graphic elements still for the "features" mentioned on the example page. Would a server rack fit better there? i don't want to make the header image to cluttered personally.
18:17:20 <mowest> Here is the example/demo page: https://fedora.gitlab.io/websites-apps/fedora-websites/fedora-websites-3.0/server/
18:17:21 <jwhimpel> I think small stack of servers s/b our primary image, but the others should be shown somewhere (perhaps further down the page).
18:17:35 <eseyman> +1 for that idea
18:17:56 <pboy> me too
18:18:18 <cooltshirtguy> currently not a fan of the 3 blocks together. maybe its just the use of the colors
18:18:55 <mowest> On the current demo page they just took the old image of a small server rack from getfedora.org/server landing page. I would like to see something with a bit more color than the current graphic on the demo page.
18:19:06 <cooltshirtguy> I agree with the server racks being used
18:19:09 <pboy> Maybe a network of these 3 types of servers?
18:19:21 <pboy> mowest +1. color is missing there
18:19:48 <eseyman> Adding color and a small Fedora logo on each server
18:19:57 <cooltshirtguy> great idea
18:20:01 <mowest> The colors relate to our edition colors. Server has had orange in our logo, and the blue is the nod to the Fedora blue.
18:21:24 <pboy> Why server it orange??
18:21:31 <cooltshirtguy> i didnt know about the orange, but the background is orange and so is the blocks in the back
18:21:31 <mowest> Ok, I will ask Emma to work up a concept that focuses more on a server rack for the header image. I will mention the idea of the network of 3 types of servers too, I just fear that might get a little crowded for the header image.
18:22:17 <pboy> Well, not more crowded as Cloud or CoreOS
18:22:23 <pboy> I thjink
18:22:58 <eseyman> that image could evoke micro-services which could help
18:23:03 <mowest> I don't know about the orange where it came from originally, but if you look on our original getfedora.org landing page our logo is 3 orange bricks stacked like a server rake I'm guessing is what they were going for in the logo.
18:23:46 <mowest> Cloud looks pretty clean and nice with the two hotair balloons and the simple cloud.
18:23:57 <pboy> Yes, but IoT and Cloud is the same color
18:23:59 <mowest> In my opinion.
18:25:15 <pboy> Yes, but a ensemble or 3 server types can look equally nice.
18:25:27 <pboy> (I hope)
18:25:45 <pboy> And there is orange, too, isn't it?
18:25:54 <pboy> (with cloud)
18:26:00 <mowest> So what would be the 3 server types again just so I have that concept straight.
18:26:48 <pboy> A datacenter rack, a small rack, and a (NAS like)  box, I think
18:27:00 <pboy> And maybe a SBC
18:27:20 <pboy> And everything in a network?
18:27:56 <mowest> @pboy, okay I think I can describe that for Emma. Thanks. Now any opinions about color?
18:28:01 <pboy> This explains our diversity and flexibility
18:28:36 <pboy> Regarding color: As I understand, blue is our main color.
18:28:46 <pboy> For all editions
18:29:15 <mowest> You are right the cloud logo and IoT logo both look purple to me, however, in the demo page for cloud I don't see their logo any longer, but IoT has their logo at the bottom of the page.
18:29:55 <pboy> Yeah, well.  if the design team wants to introduces a "sub-color" for each edition, it's OK for me
18:30:02 <mowest> You are right that blue is our main color, but should we have some hint of orange or a gradiant of blue to orange as a nod to our logo.
18:30:11 <pboy> (But hopefully not that awful orange.  :-). )
18:30:16 <cooltshirtguy> rofl
18:30:46 <mowest> Orange is my favorite color and the only reason I use Fedora Server....:-)
18:31:11 <mowest> I can mention that we are open to a new sub-color as well.
18:31:13 <pboy> Are we finished with color?
18:31:20 <cooltshirtguy> pink
18:31:37 <pboy> pinkg = last try (in German at least)
18:31:49 <mowest> What about additional wording tweaks.
18:31:53 <pboy> for older people to find a spouse
18:31:55 <cooltshirtguy> interesting. i learned something today
18:31:56 <eseyman> I think we've said everything we wanted to say
18:32:15 <pboy> OK eseyman is back to earnest
18:32:19 <pboy> :-)
18:32:36 <pboy> About the fron page / start page
18:32:38 <mowest> Okay I will take feedback and we can move on in the agenda if that is the desire.
18:33:09 <pboy> On the strt page, I would like to have "Documentation" in the top bar as well.
18:34:07 <pboy> And what about the order of the editions.  Until now, workstation always comes first, server next. We are the most downloaded deliverables.
18:34:21 <pboy> I wouldn't like to change that.
18:35:07 <pboy> mowest Kannst Du diese beiden Punkte einbringen?
18:35:20 <pboy> Sorry, ma translator
18:35:21 <pboy> mowest Can you bring in these two points?
18:35:49 <mowest> Yes, I will mention them as well.
18:36:00 <pboy> Thanks.
18:36:19 <pboy> What about the descriptive text snippets?
18:36:35 <pboy> I missed to start a thread about it.
18:36:59 <pboy> mowest When we have to deliver the text snippets?
18:37:39 <mowest> What is on the demo page was just my first stab at highlighting some "features" unique to Fedora Server or what might set Fedora apart as a Server OS.
18:38:08 <mowest> They can update those any time. Niko often takes care of those in just a few days.
18:38:30 <pboy> mowest +1 for the text snippets.
18:38:54 <pboy> Just instead server workloads on bare metal or in the cloud
18:39:16 <pboy> should be server workloads on bare metal or in virtualized contexts
18:39:24 <pboy> (or something like that)
18:39:38 <mowest> Yes, I have a request in to change to "bare metal or virtual machines".
18:39:53 <pboy> or virtual environments what eber is better english
18:40:27 <pboy> In my language understandig that are 2 different levels
18:40:31 <eseyman> VM is the standard abbreviation so I would go with virtual machines
18:40:47 <pboy> bare metal is a runtime environment
18:41:06 <pboy> and the opposite is a virutalized environement
18:41:10 <mowest> I'm trying to drop all references to "cloud". "Virtual Machines" is the terminology I hear the most in English speaking podcasts.
18:41:49 <pboy> the other dimenmsion is a machine, either real or physical or virtualized
18:42:31 <pboy> OK, whatever is common english is fine for me.
18:42:55 <pboy> Anyting else for this topic?
18:43:00 <mowest> In the English speaking podcasts that talk about servers and homelabs they normally use the terms installing on "bare metal" or "virtual machines" to distinguish the two different ways to install and use a server OS.
18:43:40 <pboy> mowest OK! Maybe I'm too much from the scientific world. :-)
18:43:53 <pboy> bare metal and virtual machine is it
18:44:35 <pboy> I see nothing here any more
18:44:52 <pboy> #topic 3. F38 - Shorter Shutdown Timer
18:44:59 <pboy> #link issue #96: https://pagure.io/fedora-server/issue/96
18:45:08 <pboy> #link Mailing list discussion: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/N6TW6EBPG5Q6D6SEV4FFGQH3E6HUTVE2/
18:45:31 <pboy> nirik was to clarify some questions / issues.
18:45:41 <pboy> nirik are you online?
18:46:01 <nirik> hum, yes, I'm around...
18:46:16 <nirik> what was I supposed to do? ;)
18:46:43 * nirik reads back up
18:47:09 <pboy> It was unclear for us, what is the current reals shutdown timer value.
18:47:30 <pboy> in /etc it is 90 secs. And in RHEL docu it is 90 secs as well.
18:48:31 <pboy> Ans the other question was: Do all our core service specify a proper shutdown value, or any value at all (and not depend on the default value)
18:48:32 <nirik> Yes, it should be 90s.
18:49:20 <pboy> Hm, it is was 90 sec in real, why did we discuss about 200 secs?
18:49:40 <pboy> in the mailing thread mentioned above
18:50:20 <nirik> No idea... it should be 90s from all I can see.
18:50:25 <nirik> do we have a list of those core services?
18:50:56 <nirik> I know for sure that postgresql and libvirt set it to infinity. I am not sure on others.
18:50:58 <pboy> nirik Do you know what was change a week ago, when it was said, the change has be done?
18:51:31 <pboy> nirik, our services are listed in the renewed technical specs
18:52:08 <pboy> #link https://docs.fedoraproject.org/en-US/server-working-group/docs/server-technical-specification/
18:52:08 <jwhimpel> The Fesco notes from Jan 17th indicate the new default timer s/b 45 seconds with editions may override.
18:52:23 <nirik> The change was to the compiled in default... so systemd in f38/rawhide now default to 45s
18:53:10 <pboy> And where could we override it if we want?  In the /etc config file?
18:53:26 <nirik> I am not sure. ;) I can try and find out... and check the core services...
18:53:32 <jwhimpel> Does anyone here run a heavily loaded transaction processor or database?  If so, is 45 seconds enough time?
18:54:11 <pboy> jwhimpel That's exactly the questions all the dicussion was about - databases and vm's
18:54:16 <nirik> jwhimpel: postgres already overrides to forever.
18:54:29 <ssmoogen> pboy: jwhimpel look above: postgresql and libvirt set it to infinity
18:54:30 <nirik> as does libvirtd
18:54:52 <nirik> they override the default and will wait until they cleanly shutdown.
18:55:01 <ssmoogen> basically the services that need it are in general already setting it to avoid other issues
18:55:08 <pboy> Thanks: those are the most important, I think.
18:55:16 <jwhimpel> Thx.  That's good news.
18:55:30 <nirik> right. I think this really won't affect much...
18:55:41 <ssmoogen> if they aren't now, then patches to the services which will need can be made
18:55:42 <pboy> As I read, CoreOS is discussing this as well P. Wolters is quite suspicious about the new value, too
18:56:26 <pboy> Is see, our time is nearly up.
18:56:47 <pboy> I'l make a list of our services, and we can see, which values are in use.
18:57:31 <pboy> #action pboy creates a list of our core services in the issue for further discussion.
18:57:34 <nirik> Yeah, would be good to know and see any we think might get affected.
18:58:05 <pboy> Anything else here at the moment?
18:58:18 <pboy> Our time is up.
18:58:32 <pboy> I'm really sorry about our Ansible / Wildfly topic.
18:58:42 <cooltshirtguy> it happens
18:58:46 <pboy> It is our pilot ansible project
18:59:07 <pboy> I'll put it on topic 1 or 2 next meeting.
18:59:09 <jwhimpel> Boo Hoo!  Last and least!  :-)
18:59:52 <pboy> jwhimpel yeah, but we urgently must make progress here. It is our most important topic on the working plan.
19:00:19 <pboy> OK, we are up now.
19:00:33 <pboy> Thanks for coming!
19:00:54 <pboy> Was a good and constructive meeting again!
19:01:11 <pboy> #endmeeting