17:00:29 <pboy> #startmeeting fedora-server
17:00:29 <zodbot> Meeting started Wed Apr  5 17:00:29 2023 UTC.
17:00:29 <zodbot> This meeting is logged and archived in a public location.
17:00:29 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:29 <zodbot> The meeting name has been set to 'fedora-server'
17:00:39 <pboy> #topic Welcome / roll call
17:00:44 <eseyman> let's go, let's go, let's go!
17:00:50 <pboy> Welcome to our Server WG IRC meeting today!
17:00:51 <eseyman> .hello2 eseyman
17:00:52 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:01:08 <pboy> Welcome eseyman!
17:01:39 <eseyman> and on time, too!
17:01:43 <cooltshirtguy> .hello2 cooltshirtguy
17:01:44 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
17:01:51 <pboy> congratiulation. :-)
17:02:25 <pboy> Mowest is prevented from participating today, maybe he'll make it later towards the end.
17:02:38 <pboy> Let's start anyway with the agenda
17:02:47 <pboy> #topic Agenda
17:02:54 <pboy> #info  Follow up actions
17:03:01 <pboy> #info  F38 Beta testing.
17:03:10 <pboy> #info  F38 Beta testing.
17:03:18 <pboy> #undo
17:03:18 <zodbot> Removing item from minutes: INFO by pboy at 17:03:10 : F38 Beta testing.
17:03:38 <pboy> #info F38 - Shorter Shutdown Timer
17:03:51 <pboy> #info  Fedora Website revamp – Fedora Server Edition pages
17:03:59 <pboy> #info  Using Ansible to install and configure Wildfly
17:04:06 <pboy> #info  Open Floor
17:04:18 <pboy> Anything to add ?
17:04:33 <eseyman> I'm good
17:04:38 <pboy> OK
17:04:40 <pboy> #topic 1. Follow up actions
17:04:48 <pboy> #info ACTION: pboy to open a thread about meeting time change on mailing list –  outdated by decision
17:04:57 <pboy> #info ACTION: pboy will write a info about changing the timeout value and nirik will review – still work in progress
17:05:06 <pboy> Any open action I forgot?
17:05:29 <copperi[m]> .hello copperi
17:05:30 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
17:05:33 <cooltshirtguy> dont think so
17:05:37 <pboy> OK
17:05:40 <pboy> #info No further open actions
17:05:52 <pboy> #topic 2. F38 Beta testing
17:06:02 <pboy> #link https://pagure.io/fedora-server/issue/99
17:06:16 <pboy> Lets spend about 15 min at max with this, most ist done now.
17:06:25 <pboy> I tested the various installation methods and virualization with branched 2023-03-31 and everything works.
17:06:34 <pboy> Expecially ServerVM which had an issue with the Beta version.
17:06:45 <pboy> Maybe, we have a new issue with IPA. See irc discussion Apr 4, 2023 15:42 (UTC) sgallagh / tflink
17:06:55 <pboy> sgallagh any news about it?
17:07:11 <cooltshirtguy> postgresql works perfectly with the beta
17:07:32 <pboy> cooltshirtguy Best, thanks.
17:07:34 <eseyman> installed last weekend, will play with postgresql, mariadb, apache and nginx this weekend
17:08:25 <pboy> eseyman good idea, we have freeze now, but in case of issues may still be able to do something.
17:08:40 <pboy> So it's worthwhile
17:09:15 <pboy> Hm, sgallagh seems to be busy.
17:09:36 <sgallagh> I'm here
17:09:47 <pboy> Oh, good!
17:10:05 <sgallagh> I was unable to reproduce the issue and Tim also couldn't reproduce it after we walked through it together.
17:10:17 <sgallagh> So we're assuming it was operator error at some point in his initial testing
17:10:37 <pboy> OK, that's the best outcome. :-)
17:11:22 <pboy> So, so guess we are fine with F38 and should not experience any surprises.
17:11:49 <pboy> any further comment?
17:12:27 <pboy> OK, next topic
17:12:39 <pboy> #topic 3. F38 - Shorter Shutdown Timer
17:12:47 <pboy> #link issue #96: https://pagure.io/fedora-server/issue/96
17:13:03 <pboy> #link Mailing list discussion: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/N6TW6EBPG5Q6D6SEV4FFGQH3E6HUTVE2/
17:13:15 <pboy> Current status: Kevin created a PR
17:13:24 <pboy> #link https://src.fedoraproject.org/rpms/fedora-release/pull-request/256
17:13:35 <pboy> It is basically the same as proposed by CoreOS / siosm (#249) that we missed to join due to a misreading (by me).
17:13:46 <pboy> We checked and provided karma before freeze time, but the merge couldn't be made in time.
17:13:55 <pboy> #link https://bodhi.fedoraproject.org/updates/FEDORA-2023-814ffcaf1b
17:14:04 <pboy> There is still a way to get it on the installation media as Kevin said.
17:14:20 <pboy> Question is, how do we have to proceed?
17:14:50 <pboy> nirik Do you take care of it?
17:15:59 <pboy> Well nirik is very busy these days with all the infra and release work.
17:16:06 <nirik> Yeah, it went in right before freeze I think
17:16:27 <nirik> yep. it should be in f38 now... testing welcome of course.
17:17:46 <nirik> so it should be all set.
17:17:51 <pboy> Oh yes, I see "This update has been pushed to stable." This means, we are done?
17:18:40 <pboy> nirik many thanks for you action fo fix my initial mistake !
17:19:26 <pboy> A successful last minute action. :-)
17:19:47 <pboy> Anythink else here?
17:20:32 <pboy> OK, next topic. We are quick today!
17:20:53 <pboy> #topic 4. Fedora Website revamp – Fedora Server Edition pages
17:21:03 <pboy> #link Issue #66: https://pagure.io/fedora-server/issue/66
17:21:11 <pboy> Current draft:
17:21:20 <pboy> #link https://fedora.gitlab.io/websites-apps/fedora-websites/fedora-websites-3.0/server/
17:21:30 <pboy> Developer discussion
17:21:41 <pboy> #link https://discussion.fedoraproject.org/t/fedora-server-front-page-revamp-looking-for-feedback/79037/9
17:21:51 <pboy> Text snippets
17:22:00 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/RUBKGEFG3OWHQXOZNBNDAE7VJJQ2YDA7/
17:22:07 <pboy> Graphics
17:22:16 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/42HPTYDERGRWVHJFKBMGO545C5WXYNDZ/
17:22:24 <pboy> Current status:
17:22:45 <pboy> The text descriptions are probably not yet optimal, various of our proposals are not included. But this is a minor issue, IMHO
17:22:54 <pboy> My biggest issue: A documentation button is still not in a prominent and highly visible position
17:23:02 <pboy> neither on our  our hero graphic nor in the top bar.
17:23:10 <pboy> A professionally usable server needs documentation as important as download.
17:23:25 <eseyman> +1 on that
17:23:33 <pboy> (That's all from me, so far. sorry for all the text)
17:24:40 <eseyman> that said, there's a lot to like in that page
17:24:45 <cooltshirtguy> agreed
17:25:17 <pboy> Yes, it is a great improvement
17:27:00 <pboy> Well, what do you think about my wish for a "documentation" button in the hero between Download and Community?
17:27:36 <pboy> Should we continue to ask for it?
17:28:17 <eseyman> that would be great
17:28:36 <cooltshirtguy> I think so
17:28:49 <pboy> OK, so we
17:29:27 <pboy> #agreed Server WG would like to get a "Documentation" button/link between Download and Community in the herfe graphic
17:30:18 <pboy> I'll discuss this with mowest later, how we can proceed. Probably open an issue about it.
17:30:53 <pboy> (Mowest said, he may be back from his errant at the end of our meeting)
17:31:26 <pboy> What about the descriptions?
17:32:46 <eseyman> I like them
17:33:37 <cooltshirtguy> their fine
17:34:05 <pboy> OK, so I suppose we agree to accept them as is, leaving maybe possible improvement to next version.
17:34:48 <pboy> #agreed Server WG is content with the feature list and descriptions.
17:35:26 <pboy> Anything else here?
17:35:46 <cooltshirtguy> nope
17:35:52 <eseyman> don't think so
17:36:03 <pboy> OK, next topic
17:36:12 <pboy> #topic 5. Using Ansible to install and configure Wildfly
17:36:21 <pboy> #link https://pagure.io/fedora-server/issue/60
17:36:36 <pboy> atest status:
17:36:53 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/AVVCF266QN43SRQ4LDCYITZC5ZVJFALD/
17:37:04 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/SYVECUPODIYQRS5IVQIMXRV7HFDRSYWB/
17:37:46 <pboy> Latest Action: We have a public test server (sisyphos.resdigita.eu) with a running  Wildfly and basically a Ansible script.
17:38:27 <pboy> jwhimpel Are you watching?
17:39:15 <pboy> The server is a VM on one of my server with the only purpose to serve as our test bed.
17:39:44 <pboy> I can provide anybody who wants to have a look with an (adminstrative) account.
17:41:30 <pboy> Well unfortunately, jwhimpel couldn't make it today, obviously.
17:42:35 <pboy> Any idea / any plan how to proceed? (besides postponing to next meeting when John hopefully can attend)
17:45:06 <eseyman> We should probably start thinking about how we're going to get these ansible roles/playbooks into our users' hands
17:45:23 <pboy> eseyman +1
17:45:46 <pboy> I really don't know what options we have.
17:46:26 <pboy> Should we create a kind of server admin package as a workstation rpm?
17:46:52 <eseyman> put them on ansible galaxy ? create an rpm ? both
17:47:11 <pboy> Or distribute it as part of server media do download the local part?
17:48:13 <eseyman> anyway, there's nothing urgent but we should think it through
17:48:19 <pboy> I'm not sure if ansible galaxy alone is "too far away" for every day server admin.
17:48:41 <pboy> Yes, we should make it a separate topic on one of our next meetings.
17:48:41 <cooltshirtguy> package to install for fedora server
17:49:40 <pboy> cooltshirtguy As fas as I know there are two parts, you need some support code on the server and some code on your workstation.
17:49:52 <pboy> But maybe I#m wrong with that
17:50:36 <eseyman> there's the control node (on which you run ansible) and the managed nodes (ansible connects to them via ssh and run python code on them)
17:51:06 <eseyman> the control node can be a server or a workstation
17:51:26 <pboy> OK, so I was not "so much" wrong. :-)
17:52:02 <pboy> What about a Mac as control node, do you know?
17:53:30 <eseyman> not sure
17:53:46 <pboy> OK, we'll learn
17:54:05 <cooltshirtguy> you'd have to install community ansible at least. then install the package with the roles
17:54:05 <eseyman> ansible has criteria on what makes a good control node; I know RHEL is a first-class citizen here
17:54:16 <eseyman> not sure for anything else
17:54:16 <pboy> I think, wie should make a break here and continue on mailing list and next meeting?
17:54:30 <cooltshirtguy> sure
17:54:43 <eseyman> I will give the issue some thought
17:54:55 <eseyman> but, yes, we can stop there
17:55:01 <pboy> eseyman 1+
17:55:26 <pboy> OK, next topic
17:55:35 <pboy> #topic  5. Open Floor
17:56:25 <pboy> I found some information that Fedora is planing an Event in Spain, beginning of August
17:56:37 <pboy> Does anyone know more details?
17:56:45 <pboy> Or is it misinformationß
17:56:52 <eseyman> it's news to me
17:57:10 <eseyman> beginning of August sounds like the Gnome conference to me
17:57:23 <cooltshirtguy> i have no idea
17:58:23 <pboy> There was some discussion in the Council matrix room.
17:58:30 <eseyman> Guadec is in Riga this year
18:00:44 <pboy> OK, let's look around, wheather there some planing.
18:00:50 <pboy> Anything else here?
18:01:10 <eseyman> not to my knowledge
18:01:51 <pboy> Well, I just found:  https://discussion.fedoraproject.org/t/fedora-council-tickets-ticket-426-flock-2023-finalize-dates-and-venue-for-our-next-in-person-contributor-conference/44620
18:03:45 <pboy> It would be Ireland, not Spain. More rain, less sun. :-)
18:04:43 <eseyman> August 1-4 2023 in Cork, Ireland
18:05:15 <pboy> Yeah, if it really will happen, we should participate with Server!
18:05:44 <pboy> But time is up. Let's continue in 2 weeks.!
18:05:59 <pboy> #endmeeting