17:00:39 <pboy> #startmeeting fedora-server
17:00:39 <zodbot> Meeting started Wed Apr 19 17:00:39 2023 UTC.
17:00:39 <zodbot> This meeting is logged and archived in a public location.
17:00:39 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:39 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:39 <zodbot> The meeting name has been set to 'fedora-server'
17:00:50 <pboy> #topic Welcome / roll call
17:01:00 <pboy> Welcome to our Server WG IRC meeting today!
17:01:15 <pboy> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:32 <jwhimpel> .hello2
17:01:33 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:01:37 <pboy> I’ll post the agenda in 2 minutes.
17:02:36 <pboy> Hi John. Glad you are back. I have in memory, your project needs you even longer.
17:04:40 <copperi[m]> .hello copperi
17:04:41 <zodbot> copperi[m]: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
17:05:00 <eseyman> .hello2 eseyman
17:05:01 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:05:01 * nirik is lurking in the back
17:05:33 <pboy> OK, we are not that many today, but let's start.
17:05:48 <pboy> #topic Agenda
17:05:57 <pboy> #info  Follow up actions
17:06:06 <pboy> #info  Fedora Website revamp
17:06:14 <pboy> #info  Each Edition has a story for each release
17:06:22 <pboy> #info  Fedora Server goal(s) for F39
17:06:44 <pboy> #info  Open Floor
17:06:53 <pboy> Any topic to add?
17:07:15 <eseyman> that already sounds like a lot, tbh
17:07:25 <pboy> yeh, it is. :-)
17:07:34 <pboy> topic 1. Follow up actions
17:07:42 <pboy> #info ACTION: pboy will write a info about changing the timeout value and nirik will review – still work in progress
17:07:50 <pboy> Will hopefully not become a running gag  :-)
17:08:00 <pboy> Any open action I forgot?
17:08:20 <pboy> Or anything else to announce here?
17:08:39 <pboy> Besides: Release 38 is finally out.
17:09:04 <eseyman> yes, I updated my laptop this morning
17:09:05 <pboy> Well, we proceed
17:09:13 <pboy> #topic 2. Fedora Website revamp
17:09:20 <pboy> #link Issue #66: https://pagure.io/fedora-server/issue/66
17:09:29 <pboy> Mailing List:
17:09:38 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/7QJHY6E422W6SGLMETH5VFOUY6IKJA3P/
17:09:49 <pboy> Current version:
17:09:57 <pboy> #link https://fedoraproject.org/server/
17:10:07 <pboy> We have to look at the final published pages to see if all our wishes and requirements are met.
17:10:15 <pboy> My opinion: The site is just great!
17:10:23 <pboy> Many thanks to mowest for his efforts.
17:11:29 <eseyman> I agree, this is verynice
17:11:33 <eseyman> mowest++
17:11:34 <zodbot> eseyman: Karma for mowest changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:11:51 <pboy> agreed!
17:11:56 <pboy> mowest++
17:11:56 <zodbot> pboy: Karma for mowest changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:12:18 <pboy> I'm still a little sad that we don't have documentation in a series with Download and Community in the Hero graphic as well. But that's a small thing.
17:13:08 <pboy> And it does not diminish the great success of the website revamp project.
17:15:14 <pboy> I see no opposite opinions
17:15:21 <pboy> So I think
17:15:37 <pboy> #agreed The new Server site is great as it is.
17:15:55 <pboy> Let's switch to the next topic.
17:16:06 <pboy> #topic 3.Each Edition has a story for each release
17:16:19 <pboy> #link https://pagure.io/fedora-server/issue/101
17:16:28 <pboy> Lets spend about 20 min at max. here
17:16:37 <pboy> Mailing Liste
17:16:48 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/VILYMWVJ7GVHOSLP3C3YC42S3G7JACM4/
17:16:56 <pboy> Original post:
17:17:06 <pboy> #link https://discussion.fedoraproject.org/t/objective-review-each-edition-has-a-story-for-each-release/79324/1
17:17:20 <pboy> Goal here: determine how we would like to proceed. The flor is open
17:21:40 <eseyman> humm...
17:24:21 <pboy> Yeah, it's a challenge ...
17:24:58 <pboy> First to consider: What are aour ideas for a possible abjective?
17:25:07 <eseyman> Matthew calls this "relatively simple", I'm inclinded to disagree
17:26:04 <eseyman> "More/Better documentation" is always a good thing but it's a recurring story, not one for a given release
17:26:14 <jwhimpel> I think Peter has made a significant start on improving the docs for install and configure of server vm's.  I think a cohesive set of network/storage/software docs for each release would be great.  Almost all web docs talk about debian and its derivities.
17:26:40 <eseyman> Same things go with "Updates are released swiftly"
17:27:04 <pboy> Well, I have created a collection of ides. in the mailing list posting.
17:27:15 <pboy> Is there something we can use?
17:27:23 <pboy> Or are there additional ideas?
17:28:28 <pboy> It is not such a problem to create a product. The problem is more the story.
17:30:21 <pboy> If we pick up Server VM and aim for more VMs, ready for AmazonAWS or Contabo.
17:30:27 <pboy> Goal: Easier use and distribution of Server.
17:30:41 <eseyman> I need to put some thought on this
17:30:44 <pboy> Would this be a possible "story"?
17:31:11 <eseyman> the issue I have with the concept is having to do it for each release
17:31:32 <pboy> Yeah, each release is a challenge, indeed
17:32:04 <pboy> For F40 I think of "Ansible Management the example of Wildfly"
17:32:53 <pboy> And If we have someone capable of Pathon, we could improve Cockpit management of NFS or Samba.
17:33:02 <pboy> For F42
17:33:35 <pboy> I see the challenge, but I also see we have a lot of options.
17:33:47 <jwhimpel> While I believe Wildfly is doable, it would require some support/consulting from someone who is very knowledgeable about wildfly configuration.
17:34:26 <pboy> jwhimpel yes, therefore we would have issues to complete it for F39, I think.
17:35:00 <pboy> Bt we have to resolve that anyway.
17:35:29 <jwhimpel> Agreed.  I found a google groups forum that I think could be helpful, but have not had time to ask for help there due to illness and other time-consuming issues.
17:35:43 <pboy> And the other thing is, a bit of marketing for Fedora Server is a good thing.
17:36:51 <pboy> jwhimpel That's good, di you have an address for that group?
17:37:58 <jwhimpel> https://groups.google.com/g/wildfly/?pli=1
17:38:58 <pboy> Thanks!  Looks good!
17:39:29 <pboy> Well, our time for this topic is going up.
17:39:36 <pboy> I'll take up eseyman " I need to put some thought on this".
17:39:50 <eseyman> I'll try and think up something for next meeting
17:39:56 <pboy> We should do this on our mailing list.
17:40:23 <eseyman> Humm, the people at PTS might have some insight for me
17:40:28 <pboy> OK, mailing list and next meeting.!
17:40:57 <pboy> #action eseyman will try and think up something for next meeting
17:41:11 <pboy> Lets switch to next topic.
17:41:27 <pboy> #topic 4. Fedora Server goal(s) for F39
17:41:36 <pboy> #link https://pagure.io/fedora-server/issue/102
17:41:49 <pboy> It's a bit similar.
17:42:00 <pboy> Goal: discuss proposals in the ticket, add posible options, discuss decision criteria, further detail selected proposals
17:42:51 <pboy> We should concretize our general working plan
17:44:44 <pboy> Well, the floor is open.  :-)
17:44:45 <jwhimpel> I would love to see a recommended ARM SBC that is actually delivering, that is supported by Fedora and can run either storage services, web services, email services, etc.
17:44:58 <eseyman> do we know of an ARM SBC that people can install Fedora Server on ?
17:45:46 <jwhimpel> I realize Peter Robinson works on this in his non-work hours, but progress is painfully slow and expertise is sparse.
17:45:58 <pboy> There are several. I'm testing Radxy Rock Pi 4, pine64 RockPro64 and LibreComputer Roc?? (just dont remember the name)
17:46:18 <pboy> All work well with Server
17:46:45 <pboy> My thesis: good for non-interactive services - in short.
17:47:01 <jwhimpel> I didn't mean my comment to disparage Peter Robinson, just additional resources don't seem to be forthcoming, therefore progress is slow.  Also the pool of experts is very limited.
17:47:17 <pboy> And I have a draft for a publication and a "product"
17:47:30 <pboy> I sent it around some time ago.
17:48:41 <pboy> I can upload it to hackmd.
17:49:27 <eseyman> I have to admit that I want the MiniPC route 2 years ago and don't see a compelling reason to switch to ARM
17:49:55 <pboy> jwhimpel yes, I relatively often discuss with Peter Robinson issues with one oranother SBC.
17:51:03 <pboy> eseyman the biggest argument is power consumption and device costs, I think
17:52:07 <pboy> I have tested ARM against an old zbox mini PC: the difference is impressive (Mini PC much more perform
17:52:21 <pboy> ance.
17:54:05 <eseyman> I'm working on a backup storage solution and ARM SBC don't seem to a solution here
17:55:00 <pboy> eseyman I think backup server is a solid contribution and a good task vor an ARM SBC
17:55:19 <pboy> Of course, depending on the model.
17:55:53 <pboy> As a backup server I think of pine64 Rock64Pro with the bis case and sata extension.
17:56:13 <pboy> bis -> big
17:56:27 <eseyman> Fedora Server isn't an option, sadly; My spouse has mandated it handle ZFS which means a FreeBSD-based solution
17:56:45 <eseyman> I will take a look at that option
17:57:45 <pboy> OK, ZFS is nothing for Fedora. But maybe we can transfer your solution with other file system?
17:58:16 <pboy> Well, our time is going up.
17:59:09 <pboy> What about: We evaluate 2 options: ServerVM support for various hosting services and Usage of SBC as a Server device?
18:00:08 <pboy> I see no objections. Therefore
18:00:33 <pboy> #agreed We evaluate 2 options for F39: ServerVM support for various hosting services and Usage of SBC as a Server device
18:00:39 <eseyman> yes
18:01:02 <pboy> Our time is up. Let's continue on mailing list.
18:01:21 <pboy> Many thanks to everybody for comming!
18:01:37 <pboy> #endmeeting