18:00:44 <pboy> #startmeeting fedora-server
18:00:44 <zodbot> Meeting started Wed Nov 15 18:00:44 2023 UTC.
18:00:44 <zodbot> This meeting is logged and archived in a public location.
18:00:44 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:00:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:44 <zodbot> The meeting name has been set to 'fedora-server'
18:00:55 <pboy> #topic Welcome / roll call
18:00:55 <pboy> Welcome to our Server WG IRC meeting today!
18:01:08 <pboy> Same procedure as every year“ We'll give a few minutes for folks to show up
18:01:18 <pboy> I’ll post the agenda in 2 minutes.
18:03:07 <eseyman> .hello2
18:03:08 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
18:03:21 <pboy> Hi eseyman
18:03:29 <eseyman> hello, pboy
18:05:44 <pboy> Thinly staffed today, it seems.
18:06:28 <cooltshirtguy> .hello2
18:06:28 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
18:06:41 <eseyman> yay, cooltshirtguy is here!
18:06:46 <pboy> Hi cooltshirtguy
18:07:04 <mowest> .hello2
18:07:04 <pboy> Yep, we have the quorum
18:07:05 <zodbot> mowest: mowest 'Steve Daley' <mowest@vivaldi.net>
18:07:16 <pboy> Hi mowest!
18:07:44 <cooltshirtguy> hello all!
18:07:55 <pboy> Well, I think we should start.
18:08:11 <pboy> #topic Agenda
18:08:24 <pboy> #info  Follow up actions
18:08:24 <pboy> #info  Fedora release 39 - State of Server media and Download Web page
18:08:24 <pboy> #info  Fedora Server release and quality criteria
18:08:24 <pboy> #info  Work program and goals for F40
18:08:24 <pboy> #info  Open floor
18:08:35 <pboy> Any topic to add?
18:08:38 <pboy> Or drop?
18:09:18 <pboy> OK
18:09:19 <pboy> #topic 1. Follow up actions
18:09:34 <pboy> #info No new outstanding actions
18:09:48 <pboy> Or did I miss something?
18:10:05 <mowest> This was my thought as well.
18:10:15 <pboy> Good. Let's go on
18:10:25 <pboy> #topic 2.  Fedora release 39 - State of Server media and Download Web page
18:10:40 <pboy> #link https://fedoraproject.org/server/download
18:10:55 <pboy> The situation is a bit better then 2 weeks abo.
18:11:27 <pboy> We now definitely know, you can't install ARM SBC using Fedora Server as host
18:11:40 <pboy> but it works with the desktops.
18:11:55 <pboy> Not nice, but it is as it is.
18:12:10 <eseyman> and this is solely due to us having xfs as a default fs?
18:12:45 <pboy> No, it seems to be a misture of several things.
18:13:07 <pboy> It looks like either anaconda or LVM changed something.
18:13:39 <pboy> So, the installer script as well as the image generation script work now diffterently.
18:13:52 <jwhimpel> .hello2
18:13:53 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
18:14:10 <mowest> I'm not sure I understand. Fedora Server ARM can't be installed on SBC, but Fedora Workstation can be installed?
18:14:50 <mowest> What about Fedora Core, Fedora IOT...?
18:15:01 <pboy> No trhe Problem is the install process, that transfers the image distribution file to the installation Hardware.
18:15:14 <jwhimpel> Adam and Kevin say they can do new installs on their sbc's, but they were not using LVM.
18:15:33 <pboy> If you use Fedora Server as the machine executing arm-image-installter you run into a failure.
18:15:52 <cooltshirtguy> that's interesting
18:16:15 <pboy> jwhimpel yes, if the use desktop, there is no problem, because desktop uses BTRFS, not LVM.
18:16:52 <pboy> It took some time until we discovered, that desktop ans Server are working different.
18:16:53 <mowest> Ok, so when you use a Fedora Server install as the host machine creating the bootable SD card or other media it fails, but if you use Fedora Workstation install it works.
18:17:10 <pboy> mowest YES
18:17:32 <jwhimpel> Does anyone on this list have the hardware to just do a Server install using a single XFS partition?
18:17:35 <pboy> So it is listed now as common bugs (at least ir should)
18:17:40 <mowest> My Fedora Workstation install is still using XFS because I have simply upgraded since Fedora 31 so I guess it would fail for me using Workstation as well.
18:18:15 <jwhimpel> But I think to get this resolved, we need to determine just exactly what the conditions are for failure.
18:18:35 <mowest> My original Fedora Workstation install is pre btrfs by default.
18:18:45 <pboy> Server should work, if you discard LVM and replace it with root on a partition instead.
18:19:23 <pboy> mowest if your workstation uses LVM you should run  into the issue, too
18:19:50 <jwhimpel> Pboy keeps saying the install doesn't work (a generality).  Adam and Kevin say it works if they don't use LVM.  Let's verify which condition is true.
18:20:44 <cooltshirtguy> I'd have to spin up a VM. not an issue though
18:20:49 <mowest> You can't have LVM running on the system that you are creating the ARM image on, I believe is what pboy is saying.
18:21:05 <pboy> jwhimpel I don't say install diesn't work in general. At the beginning we didn't make a difference between workstation and Server as installation machine.
18:21:56 <cooltshirtguy> I could do without LVM.
18:21:59 <mowest> I might have to test this, because my Fedora Workstation install is old enough that it was installed with the standard XFS and LVM subvolumes when I installed it on the latest SSD, I think Fedora 31.
18:22:13 <pboy> By the way, it was me whoi detected why differen people made different experiences / results  :-)
18:22:56 <jwhimpel> I'm confused.  Are you saying the install on the target host doesn't work if LVM is on the target host or are you saying the host generating the install medium fails if the generating host has LVM.
18:23:01 <pboy> mowest Would be good, if you could test, it you get the same failure.
18:23:20 <pboy> jwhimpel  the latter.
18:23:53 <jwhimpel> Then I misunderstood the issue.  Sorry about that.
18:24:13 <pboy> i could make it more confusing and say  B OTHJ  :-)
18:24:21 <pboy> Because, anywys
18:24:42 <pboy> Because anyway you get a LVM error on the target.
18:24:59 <pboy> You can't use any of the LVM admin tools
18:25:23 <pboy> You have first to delete the file in /etc/lvm/devices
18:25:57 <pboy> That's the second part of the problem and independent of the installation script (arm-image-installer)
18:26:19 <pboy> And the latter is a violation of our quality criteria
18:26:46 <pboy> But in the go/no-go session nobody wanted to tgake it, unfortunately
18:27:25 <pboy> mot nobody, but the majority
18:28:13 <pboy> pwhalen is working on a fix for the arm-installer-script
18:28:40 <mowest> Probably a rare bug for those who are running from an old install of Fedora or running Fedora Server as their day to day system for creating images for their RPi.
18:28:44 <pwhalen> pboy: it should be fixed with the latest version.
18:29:10 <pboy> pwhalen Thanks !!!
18:29:22 <pwhalen> The issue when using a server installation in F39 was because of the device file, it prevented the script from scanning the newly created disk image
18:29:23 <pboy> I'll test it.
18:29:27 <pwhalen> thanks!
18:30:02 <pwhalen> pboy: so when you test, ensure that file has been deleted from the host
18:30:05 <mowest> What is the easiest way to get the latest arm-image-installer?
18:30:26 <pwhalen> mowest: F39 it should be as easy as using dnf
18:30:37 <pwhalen> for F38, I just did a new build which I think is still in bodhi
18:30:48 <pboy> pwhalen Yes, I'll remove it manually
18:31:04 <pwhalen> mowest: https://bodhi.fedoraproject.org/updates/FEDORA-2023-59fe73a135
18:31:36 <pboy> pwhalen Do you know if someopne works on the image generation?  ARM meeting didn't happen yesterday, where I wanted to ask.
18:31:53 <mowest> Thank you. I haven't upgraded my main Fedora Workstation from 38, I usually wait a few weeks to make sure RPMFusion and other Repos have switched over.
18:32:16 <pwhalen> pboy: its done by rel-eng, what did you want to ask?
18:32:54 <pboy> I wanted to ask if and who is working on the image generation and if I could help.
18:33:13 <pboy> But if Rel-eng is doing it, even better
18:33:52 <pwhalen> right, rel-eng .. the image is GA so the lvm issue remains. but it also remains for any server installation with f39 media
18:34:21 <pboy> Yes, to summerize:
18:34:34 <pboy> The install script will get fixed by update
18:34:54 <pboy> With the Image issue we have to live with until F40
18:35:24 <pboy> I think, we have 2 things to consider:
18:36:10 <pboy> 1. We need to evaluate our testing procedures. I must admit I relied on the automatic tests
18:37:03 <pboy> 2. We should have a look on our download page. The ARM SBC script is probably not placed at the best location.
18:37:38 <pboy> It's really unfortunate, that we discovered the but so late in the Beta process.
18:37:44 <pwhalen> If writing an image using arm-image-installer on the server edition only, it will fail to do any disk manipulation until that file is deleted .
18:37:54 <eseyman> 1 means choosing a set of SBCs that we can test
18:38:32 <pboy> eseyman yes, and we have to better organize whp will test what.
18:38:40 <eseyman> indeed
18:39:05 <pboy> That's the next topic,
18:39:10 <pwhalen> Thankfully, I don't think many people use server to write disk images for use on arm. However, this issue does affect lv management of things not listed in the devices file.
18:39:30 <pboy> pwhalen Agreed.
18:39:43 <pwhalen> pboy: thanks for finding it!
18:39:50 <pboy> Therefore the script issue is not that of a problem.
18:40:21 <pboy> pwhalen Idid my best  :-) Unfortunately too late
18:40:56 <pboy> Regarding the download page
18:41:47 <pboy> I would suggest, to put the ARM SBC as a  5th section below the extisting 4
18:42:03 <pboy> Maybe with a short explanation.
18:43:04 <pboy> As it currently is, the difference and "speciality" of ARM SBC ist too hidden.
18:43:07 <eseyman> we're talking about https://fedoraproject.org/server/download, right?
18:43:18 <pboy> YES
18:43:28 <eseyman> that sounds fine, then
18:44:08 <pboy> And the repition of "Fedora Server 39" is also not that informativ
18:45:05 <pboy> E.V instead of QEMU  better VM or Virtual Machine
18:45:44 <pboy> And DVD -> full hardware install
18:45:53 <pboy> And something like that.
18:46:23 <pboy> And as 5th section: ARM based Single Board Computers (SBC)
18:47:44 <pboy> Any objection regarding the (slight) modifications?
18:47:50 <eseyman> Yes to the latter, I have no opinion on the former
18:48:46 <mowest> DVD -> "full hardware install" a bit long, just DVD -> ISO would match a little closer to other edition download pages.
18:49:18 <mowest> I like idea of 5th section with a link to documentation or something about arm-image-installer
18:49:29 <pboy> mowest Yes, but how it is it is a bit unclear, what is the difference
18:49:47 <mowest> QEMU matches other editions.
18:49:55 <pboy> Yes, I tink that way is gets more visible.
18:50:14 <mowest> QEMU -> VM makes sense in my head though.
18:50:21 <pboy> mowest That make the lack of information not better  :-)
18:50:49 <pboy> OK, any objection against QEMU -> VM ?
18:51:00 <eseyman> no
18:51:24 <pboy> Well, now my big question   :-)
18:51:57 <pboy> mowest, could you use your connections from the website development and take this into your hands?
18:52:11 <mowest> I will attempt to do so.
18:52:21 <pboy> Thanks!
18:52:48 <pboy> I'm sure you get it done. You made it with the page redesign, much more complicated.
18:53:20 <pboy> So it is: 5.th section SBC, QWMU -Y VM and Link / hint to documentation for further information.
18:53:36 <mowest> I will have to see if they want my to just issue a PR or if they will want me to send them the edits in a different way to review. I will figure it out.
18:54:15 <pboy> #action Mowest will take care ot disussed modifications of the Server download page.
18:54:31 <pboy> Well, what now?
18:54:44 <pboy> We are nearly at the end of our time.
18:55:54 <pboy> Let's skip to topic 4 and have a short discussion.
18:56:04 <pboy> #topic 4. Work program and goals for F40
18:56:32 <pboy> We still not done with our F39 project. Nvertheless, what about 40? Any idea?
18:56:39 <pboy> Any preference?
18:57:58 <eseyman> I have too much on my plate to think about F40 right now. I'll give it some thought for the next meeting
18:58:29 <pboy> Yes, probably a good idea. Or mailing list.
18:58:50 <mowest> I would like to discuss for F40 a reorganization of our server docs. To create quick access to docs organized for Installation, Post Install, then maybe Function Categories: HomeLab, File Server...
18:59:31 <mowest> As I look at the current structure, I'm unsure what docs are needed, and where to put new topics.
18:59:59 <pboy> Mowest, agreed. It would move away form the book format with content navigation to a categorized system.
19:00:26 <mowest> Yes, pboy, I think that is what I'm trying to express.
19:00:57 <pboy> And it allowse to put one articel to several categories. It is often not as unique, as it seems now with navigation page.
19:01:10 <pboy> page -> bar
19:01:47 <pboy> We try rthat with Quick Docs, currently
19:01:50 <mowest> Yes, that would be good for some pages to be edited once, but available under different categories. That is a good point.
19:02:38 <pboy> OK, time is up. Let's meet again in 2 weeks ans use the mailing list in the mean time.
19:02:56 <pboy> Bye bye and thanks to everybody!
19:03:09 <mowest> A while back someone got disgusted with Fedora Server on I think the old "Ask Fedora" because they couldn't figure out how to install software on Fedora Server, because we didn't have a link to a page about dnf.
19:03:21 <mowest> Bye, bye.
19:03:23 <eseyman> bye, folks
19:03:37 <pboy> #endmeeting