18:00:30 <pboy> #startmeeting fedora-server
18:00:30 <zodbot> Meeting started Wed Dec  6 18:00:30 2023 UTC.
18:00:30 <zodbot> This meeting is logged and archived in a public location.
18:00:30 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:30 <zodbot> The meeting name has been set to 'fedora-server'
18:00:43 <pboy> #topic Welcome / roll call
18:00:52 <pboy> Welcome to our Server WG IRC meeting today!
18:01:06 <pboy> „Same procedure as every year“ We'll give a few minutes for folks to show up
18:01:20 <pboy> We have to coninue with topics we skipped last meeting.
18:01:26 <eseyman> humm... I was in #fedora-meeting-1 wondering where everybody was
18:01:30 <eseyman> hi, folks!
18:01:31 <pboy> I’ll post the agenda in 2 minutes.
18:01:48 <jdubby> .hello2
18:01:50 <zodbot> jdubby: Sorry, but user 'jdubby' does not exist
18:01:56 <eseyman> .hello2
18:01:57 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
18:02:06 <pboy> Hi eseyman! Yes, sometimes quick to get the wrong cxhannel
18:02:43 <jdubby> .hello2
18:02:44 <zodbot> jdubby: Sorry, but user 'jdubby' does not exist
18:04:58 <pboy> Hi John: zodbod seems to be a bit disoriented today.
18:06:18 <pboy> We are obviously „thin provisioned“ today. But we met the quorum and can start.
18:06:30 <pboy> #topic Agenda
18:06:42 <pboy> #info  Follow up actions
18:06:42 <pboy> #info  Fedora Server release and quality criteria
18:06:42 <pboy> #info  Work program and goals for F40
18:06:42 <pboy> #info  Test planning for F40
18:06:42 <pboy> #info  Open floor
18:06:53 <pboy> Any topic to add?
18:07:09 <eseyman> I'm good
18:07:13 <pboy> OK, let's go on
18:07:27 <pboy> topic 1. Follow up actions and announcements
18:07:33 <pboy> #topic 1. Follow up actions and announcements
18:07:42 <pboy> A still running gag is:
18:07:53 <pboy> #action pboy will write a info about changing the timeout value and nirik will review – still work in progress
18:08:04 <pboy> And we have a new one, I guess ongoing, too?
18:08:16 * pboy Mowest will take care of discussed modifications of the Server download page.
18:08:37 <pboy> Mowest is unable to attend today, so
18:08:46 <pboy> #action Mowest will take care of discussed modifications of the Server download page.
18:08:57 <pboy> For all to know:
18:09:09 <pboy> Next big OSS meeting: FOSDEM, 3 & 4 February 2014 Brussels, Belgium, Europe
18:09:20 <pboy> Fedora will be present with a stand and is planing some actions.
18:09:37 <pboy> Unfortunately, the deadline for submitting proposals for contributions was very short and has passed.
18:09:46 <pboy> Would be nice if we could contribute to the Fedora stand and presentation and hopefully some of us can take the opportunity to meet.
18:09:58 <pboy> And by the way: France and Germany are close by and also a worthwhile destination for a visit before or after.
18:10:07 <pboy> Any thjoughts?
18:11:27 <eseyman> it's complicated
18:12:09 <pboy> Yeah, probably for anyone to think about it.
18:12:18 <pboy> I'll attend in any case.
18:12:51 <eseyman> I'll attend if I can convince my SO
18:13:04 <pboy> What is SO?
18:13:25 <eseyman> SO == Significant Other
18:13:42 <pboy> Oh yeah, fortunately I could manage that already  :-)
18:14:00 <pboy> Well, Last one here: Next meeting?
18:14:10 <pboy> roposal: xskip Dec 20 and Jan 3  and start with Jan 17
18:14:23 <pboy> into new year
18:14:32 <eseyman> sounds like a good call
18:15:21 <pboy> OK I guess jdubby is still struggeling with zodbot, but would agree, too.
18:15:34 <pboy> #agreed Next meeting will be held January 17, 2024
18:15:54 <pboy> topic 2. Fedora Server release and quality criteria
18:16:00 <pboy> #topic 2. Fedora Server release and quality criteria
18:16:17 <pboy> I must practise copy&paste, obviously
18:16:34 <pboy> #link https://pagure.io/fedora-server/issue/63
18:16:43 <pboy> #link https://pagure.io/fedora-server/issue/61
18:17:02 <pboy> One special topic here: naming of distribution media, the "DVD topic"
18:17:16 <pboy> We agreed upon std instead, but that has a unfortunate connotation as well, as we detected later.
18:17:55 <pboy> new idea: a) maybe full  or  fullinst  (like netinst)  or full and just net  (and kvm)
18:18:06 <pboy> b) same naming convemtion for full install and vm install
18:18:29 <pboy> c) one checksum file for all variants (currently 2 separate, but the same name)
18:19:32 <pboy> Any thoughts?
18:21:21 <eseyman> not a lot, tbh
18:22:32 <pboy> Yeah, and we need native speakers, I think.  Last time, if I remember, Nirik came up with the bad connotational meaning
18:22:55 <pboy> OK, we discuss that on server list.
18:23:46 <pboy> jwhimpel are you with us?
18:23:50 <jwhimpel> yes
18:23:58 <pboy> Thanks!
18:24:30 <pboy> The other think is to review and to extend our quality and release criteria.
18:25:13 <pboy> I suppose, we need someone of us who takes on the organisation and to encourage the discussion.
18:25:42 <pboy> Sgallagh madew some suggestion a long time ago.
18:26:39 <pboy> For sure, he will work with us, but we need a "discussion lead".
18:27:46 <pboy> I see, no idea here.
18:28:26 <pboy> Does anyone know, what we have to do to extend those criteria?
18:29:04 <jwhimpel> no idea
18:29:26 <pboy> OK. me neither
18:29:55 <eseyman> same
18:30:06 <pboy> So, I'll contact Stephen to help us out.
18:30:46 <pboy> #topic 3. Work program and goals for F40
18:30:59 <pboy> #topic 3. Work program and goals for F40
18:31:14 <pboy> #link https://pagure.io/fedora-server/issue/102
18:31:14 <pboy> #link https://pagure.io/fedora-server/issue/101
18:31:37 <pboy> Problem, we did not finish our goal for F39 yet.
18:32:40 <pboy> Nevertheless, I would like to start with another one, e.g. the installation in virtual environments
18:33:14 <pboy> Hopefully, we can provide new installation media so will produce something new.
18:33:38 <eseyman> 'Fedora Server Edition on SBC' can by recycled for F41
18:34:02 <pboy> eseyman, good idea!
18:34:15 <pboy> specifically, the installation issues are not resolved yet.
18:35:42 <pboy> I see no objections about 'installation in virtual environments'
18:36:09 <pboy> But I think, we should this put on mailing list as well.
18:36:27 <pboy> So let's switch here.
18:36:36 <pboy> #topic 4. Test planning for F40
18:36:57 <pboy> We should discuss and organize 2 topics, I think
18:36:57 <pboy> a) What do we want to manually test? I suppose, at least a regular "smoke test" of the mist important features
18:36:57 <pboy> b) What are the potentially critical changes that we should specifically monitor and test?
18:37:13 <jwhimpel> I don't know if this is off topic now, but it appears anaconda changes (first boot) and Unified Kernel Support may both affect us.  We need to test often and early.
18:37:24 <eseyman> agreed
18:37:49 <pboy> jwhimpel, it is not off topic. but paet of b)
18:37:58 <pboy> And there are others:
18:38:06 <pboy> announced change in Anaconda, allthough not yet for F40
18:38:06 <pboy> UKI image
18:38:06 <pboy> change in cron
18:38:37 <pboy> And we will get a new Anaconda install GUI, not in 40 I gues, but later.
18:39:03 <pboy> We should start to cooperate early. We want to update the installationmenues anyway.
18:39:21 <jwhimpel> We probably need to test new install as well as upgrade.  Also test ARM as well as Intel/AMD.
18:39:43 <pboy> jwhimpel agreed
18:40:34 <pboy> I'm trying to set up virtualisation on my m1 Mac so i can at least limited the aarch64 distrib
18:40:59 <jwhimpel> Should we test DVD (or other media) install along with netinstall?
18:41:13 <pboy> I think, yes.
18:41:26 <pboy> I think, one of us should take the organisation of this in his hand.
18:41:26 <pboy> Someone should watch the devel list, bring potentially disruptive changes to our attention (mailing list) and collect them in a ticket.
18:41:39 <jwhimpel> I don't have any ARM architecture at the moment, but I hope to procure a Pi5 soon.
18:42:15 <jwhimpel> We also need to monitor the workstation meeting logs as they seem inclined lately to assume how changes will affect server.
18:42:26 <pboy> Yeah, but as far as I know, the Pi5 has the same boot methods as Pi4.
18:42:44 <pboy> So you can 't test dvd and netinst
18:43:18 <pboy> On a new Mac that would be possible, at least virtually
18:43:43 <jwhimpel> I think I can test ARM stuff if I don't try to use LVM.  But I could be very wrong.
18:45:10 <pboy> The problem is, that Pi5 / aarch64 SBCs dont have a BIOS or a "system ready" firmware. As far as I know.
18:45:46 <pboy> So it will not boot our standard installation media / isos
18:47:15 <eseyman> do people actually do this? I suspect that vast majority of Pi5 users are going to burn Fedora to an SD card and plug it in
18:48:22 <jwhimpel> esseyman: I agree
18:48:38 <pboy> eseyman Yes I think so, because it is the only way, currently. There is a kind of system ready stand in but unsupported in Fedora.
18:49:31 <pboy> For information: The current installation problem with Pi and other SBCs has not yet been resolved.
18:49:46 <pboy> It is probably an LVM problem. (with lvscan)
18:49:59 <pboy> I am working on it with the ARM sig and releng
18:50:35 <eseyman> I would really like the testing to focus on stuff that Fedora users will actually use
18:50:58 <pboy> eseyman agreed!
18:51:05 <jwhimpel> That is why I volunteered to test NOT using lvm.  Just raw partitions.
18:52:00 <pboy> jwhimpel currently LVM is our default method for "real" Fedora Servers. Do you propose to change that?
18:52:36 <jwhimpel> Not necessarily.  Just wanted to offer a way to use Fedora Server until the issue is resolved.
18:52:54 <pboy> OK. yeah.
18:53:31 <pboy> I think it will be resolved soon via update (I'm an optimistical guy)
18:53:58 <pboy> Well, let's continue on mailing list and switch
18:54:01 <jwhimpel> I also seem to remember an article on phoronix that btrfs has some patches that make it perform better under typical server loads.
18:54:14 <pboy> #topic  5. Open Floor
18:54:51 <pboy> What do you think about setting up one of our next meetings as a video meeting?
18:55:02 <pboy> instead of IRC
18:55:13 <jwhimpel> I was able to get ansible to deploy wildfly with ssl certs.  Then use maven to deploy a simple quickstart app.
18:55:31 <pboy> jwhimpel ++1
18:55:36 <vazsingh> pboy That would be so much better for those of us observing!
18:55:39 <eseyman> I spent the day at the Open Source Experience event in Paris
18:55:46 <jwhimpel> pboy:  Video meetup sounds good to me.
18:56:09 <eseyman> my attempts to convince the Centreon guys to add Fedora Server as a supported platform was a bust
18:56:27 <pboy> eseyman what a pitty
18:56:45 <eseyman> if it's one-time-only, a video meeting sounds good
18:57:27 <pboy> eseyman, yes, one time at least at the moment. And a test how it works for us.
18:57:51 <pboy> I'll try it either for our January meeting of the firstr February.
18:58:46 <pboy> jwhimnpel regarding Wildfly, we should discuss that on our next meeting!
19:00:00 <pboy> OK, time is up now.
19:00:11 <jwhimpel> pboy: I'll try to be prepared.
19:00:36 <pboy> I wish a good christmas and a happy new year.!
19:00:54 <eseyman> same here, see you in 2024, folks!
19:01:09 <pboy> And see you in January in new freshness and energy
19:01:30 <pboy> #endmeeting