16:43:26 <hiemanshu> #startmeeting
16:43:26 <zodbot> Meeting started Sat Feb  6 16:43:26 2010 UTC.  The chair is hiemanshu. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:43:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:43:30 <hiemanshu> #chairs Subfusc franciscod
16:43:38 <hiemanshu> #chair Subfusc franciscod
16:43:38 <zodbot> Current chairs: Subfusc franciscod hiemanshu
16:43:44 <hiemanshu> #topic Who's here
16:43:49 <Subfusc> I am!
16:43:51 * hiemanshu 
16:44:08 <Subfusc> franciscod: ?
16:44:08 <hiemanshu> franciscod: take over now
16:44:34 <franciscod> I am too !
16:44:40 <Subfusc> I can take first topic, if noone has nothing to say?
16:44:47 <hiemanshu> he was way more busy in -social
16:44:51 <franciscod> Subfusc: all yours #topic and go
16:44:53 <hiemanshu> Subfusc: hit it!
16:44:53 <Subfusc> >_>
16:45:04 <Subfusc> #topic syntax and commenting
16:45:23 * franciscod saw that coming :P
16:45:25 <Subfusc> I think we should uniform it, so it would be easier for everyone to read
16:45:26 <Subfusc> ;)
16:45:49 <franciscod> Subfusc: define a format? start all them points with #idea for the log
16:45:49 <Subfusc> personaly i have only used epydoc, anyone else got something they preffer?
16:46:08 * franciscod is zapped about this stuff
16:46:32 <franciscod> i know coding.. thats all i know in py right now
16:46:33 <Subfusc> Anyone know the stadard python syntaxing then?
16:46:47 <franciscod> Subfusc: you mean the one on the py net ref?
16:46:52 <Subfusc> yes
16:47:04 <franciscod> i did read it.. follow is as much as i can [as much as i can remember too]
16:47:23 * hiemanshu hasn't read it
16:47:24 <franciscod> idea : follow py ref coding style strictly?
16:48:04 <Subfusc> wait. the guidlines from the offical python.org crew is the same, right?
16:48:25 <franciscod> Subfusc: #link http://www.python.org/dev/peps/pep-0008/
16:48:28 <franciscod> check that?
16:48:52 <franciscod> author is Guido himself, so should be the standard ;)
16:49:37 <Subfusc> yes
16:49:54 <Subfusc> as for filenames i think it should reflect the main class'es name
16:50:02 <franciscod> #idea follow http://www.python.org/dev/peps/pep-0008/ strictly
16:50:11 <Subfusc> eg MainWindow.py not main_window.py
16:50:18 <franciscod> #idea filenames should reflect main classes' names
16:50:31 <franciscod> #agreed MainWindow.py and not main_window.py
16:50:42 <Subfusc> as for the comment, anyone got any objections if we follow the epydoc standard?
16:50:57 <franciscod> nope.. but ill have to see what that is ;)
16:50:59 <Subfusc> its pretty close to the Python standard
16:51:16 <Subfusc> but with some small adjustment for epydoc to parse it to a readable document
16:51:38 <franciscod> #idea follow epydoc standard for commengint
16:51:40 <Subfusc> franciscod: i can give a short intro afterwards
16:52:07 <Subfusc> okay, then we got that settled
16:52:09 <franciscod> Subfusc: http://epydoc.sourceforge.net/using.html ?
16:52:16 <franciscod> is that what youre talking about
16:52:17 <franciscod> ?
16:52:23 <Subfusc> franciscod: that is correct
16:52:32 <franciscod> #link http://epydoc.sourceforge.net/using.html <- epydoc
16:52:35 * hiemanshu stares blank mouth at the code talk
16:52:45 <hiemanshu> s/mouth/face
16:53:05 <Subfusc> next topic, anyone?
16:53:30 <franciscod> one min..
16:53:44 * franciscod is googling for something
16:53:58 <Subfusc> or is it more to say on syntax?
16:54:02 <franciscod> #link http://www.lmgtfy.com/?q=UML+tutorial <- for noobs
16:54:15 <franciscod> http://www.lmgtfy.com/?q=UML+notation <- for bigger noobs
16:54:21 <franciscod> Subfusc: ^^ thats all..
16:54:36 <franciscod> we havent done UML yet.. just begun software eng this sem.. the crappy part..
16:54:38 <Subfusc> #link http://epydoc.sourceforge.net/epytextintro.html <-- epydoc howto
16:54:50 <franciscod> Subfusc: do we want to make a proper SRS etc for our project?
16:54:52 <franciscod> DFD etc?
16:55:18 * franciscod is high on SE right now.. damn thing is bugging to study for tests
16:55:41 <Subfusc> I dont think we need it for this kind of project
16:55:53 <Subfusc> but if you want to make one you are more than welcome too
16:56:23 <franciscod> Subfusc: is it helpful? or is SE BS ?
16:56:39 <franciscod> it looks like a load of HS to me right now..
16:56:48 <Subfusc> tbh i dont know what SE is
16:56:48 <franciscod> ( HS = horse S )
16:56:52 <franciscod> heh..
16:56:59 <Subfusc> i only know what SRS is
16:57:00 <Subfusc> :P
16:57:18 <franciscod> Subfusc: okay, so is an SRS helpful? ;)
16:57:26 <franciscod> and a DFD ? = Data flow diagram?
16:57:36 <franciscod> #link http://en.wikipedia.org/wiki/Software_engineering
16:57:56 <Subfusc> Not realy. They are realy meant for companies charting what they need for projects specified by other companies
16:58:00 <Subfusc> we dont work that way
16:58:18 <franciscod> actually .. *how* do we work?
16:58:18 <Subfusc> we are more what you call an extreme programming project
16:58:28 <franciscod> #topic other things
16:58:35 <Subfusc> if you know what that is
16:58:44 <franciscod> Subfusc: decide and code
16:58:46 <franciscod> ?
16:58:50 <franciscod> no planning BS etc?
16:58:52 <franciscod> ;) ?
16:58:59 <Subfusc> #link http://en.wikipedia.org/wiki/Extreme_programming
16:59:00 <franciscod> er.. why dint the topic change?
16:59:08 <franciscod> hiemanshu: ^^ ?
16:59:16 <Subfusc> probably because the channel isnt -t
16:59:37 <franciscod> er.. zodbot topic i meant
16:59:58 <hiemanshu> franciscod: yes channel should be +t or +o zodbot
17:00:01 <Subfusc> lets discuss that afterwards
17:00:01 <Subfusc> ;)
17:00:13 <franciscod> oay..
17:00:17 <franciscod> next on the agenda?
17:00:48 <Subfusc> #topic progress and jobs
17:01:13 <franciscod> #task franciscod menuobject : date of submission 14th
17:01:22 <Subfusc> franciscod: i know you have exams and real world issues comes first. But how is the tour menu comming along?
17:01:45 <franciscod> hardly done anything.. but ill have it up by the 14th for sure..
17:02:09 <Subfusc> as i said, if it interferes with your exams, you should prioritice that!
17:02:11 <Subfusc> ;)
17:02:22 <franciscod> im taking off sometime from studies tomowwow.. (sunday) ;)
17:02:33 <Subfusc> hiemanshu: do you feel confident in your python knowledge to take a part in the programming part?
17:02:41 * franciscod chuckles
17:03:19 <Subfusc> franciscod: i wish i could say the same. I will program about an hour or two today, got a test on monday >_>
17:03:47 <Subfusc> #task subfusc touroubject fileparser : date of submission 13th
17:03:58 <franciscod> i think its better to set ourselves deadlines? that we can decide how to manage our time etc?
17:04:06 <Subfusc> yepp
17:04:12 <Subfusc> i just wanna know how its going
17:04:13 <Subfusc> =)
17:04:25 <Subfusc> hiemanshu: ping!
17:04:49 <franciscod> rrix: PING
17:04:52 <franciscod> rrix: PING
17:04:52 <franciscod> rrix: PING
17:04:53 <franciscod> rrix: PING
17:04:53 <franciscod> rrix: PING
17:05:07 <Subfusc> ping fail!
17:05:19 <franciscod> heh.. he was here sometime ago..
17:05:31 <franciscod> wonder why he vanishes just at meeting time..lol
17:05:45 <franciscod> Subfusc: moving on.. what else do we need?
17:05:46 <Subfusc> probably one of those that never can sleep at the right time of day :P
17:06:01 <franciscod> +1
17:06:16 <Subfusc> we need an example file for what we want to put in tourobject and tourviewer
17:06:27 <Subfusc> so we have something to work with
17:06:31 <hiemanshu> Subfusc: pong
17:06:46 <franciscod> Subfusc: you mean "what we're gonna parse" ?
17:07:00 * hiemanshu was on a phone call
17:07:00 <Subfusc> yes
17:07:01 * franciscod is still a little muddled with the design.. hence all the BS about SRS etc..
17:07:12 * hiemanshu can help with design
17:07:17 <hiemanshu> thats what I am good at :)
17:07:24 <franciscod> hiemanshu: dont mean mockups wala design..
17:07:26 <Subfusc> franciscod: dont concerne yourself to much about the UML, its only guiding
17:07:38 <franciscod> design of the entire software is what i meant
17:07:46 <hiemanshu> franciscod: Yes, I even know about software design :P
17:08:01 <franciscod> Subfusc: but it does help me remember what im supposed to  do.. i forgot half way last time.. :P
17:08:02 <Subfusc> the only thing you need is to return the correct tour object when your menu is finished
17:08:11 <franciscod> Subfusc: ay
17:08:12 <franciscod> e
17:08:33 <Subfusc> hiemanshu: i asked a question further up, could you answer that?
17:09:37 <hiemanshu> Subfusc: I am just learning, I am confident about my programing skills, have to get used to a little python programming
17:10:02 <Subfusc> hiemanshu: do you take it as a learning challange then if we push some work on you?
17:10:06 <Subfusc> =)
17:10:11 <hiemanshu> Subfusc: Sure I will
17:10:22 <hiemanshu> Subfusc: but dont mind the time taken then
17:10:49 <Subfusc> well no, i dont mind
17:11:01 <franciscod> hiemanshu: youll have to decide a miletone yourself and fulfill it :P
17:11:10 <franciscod> you aint getting the entire month :P :P :P
17:11:19 <hiemanshu> franciscod: I can *try* my best
17:11:28 <hiemanshu> franciscod: and take some help when I am at GNUnify from you
17:11:45 <hiemanshu> Give me something that might be used in the later stages
17:11:52 <hiemanshu> SO I can start now and have it ready by the time you reach there
17:12:02 <Subfusc> hiemanshu: you want gui or backend?
17:12:10 <franciscod> Subfusc: youre one clear on the parts.. give him something please?
17:12:22 <hiemanshu> Subfusc: GUI
17:13:10 <Subfusc> if your up for a challenge, you could take the Text Renderer
17:13:45 <Subfusc> Its the hardest part of the program, but i dont see anything else we can do without desiding on a gui design
17:14:06 <Subfusc> Wich reminds me, we have to settle for a gui design soon.
17:14:09 <franciscod> hiemanshu: youll have to play around with pyclutter etc too for this..
17:14:13 <Subfusc> so we can actually do something
17:14:15 <franciscod> Subfusc: right ^^ ?
17:14:30 <Subfusc> franciscod: that is correct
17:14:41 <franciscod> Subfusc: the mockups? no response from the design team.. you people can open a ticket and comment?
17:14:46 <hiemanshu> Subfusc: by when you do expect it to be ready?
17:14:48 <Subfusc> the job of the TextRenderer is to parse a html file and translate it to clutter objects
17:14:56 <hiemanshu> franciscod: THEY DONT LOOK AT TICKETS!
17:15:08 <franciscod> hiemanshu: i was talking about tickets on the fedora-tour track :P
17:15:19 <franciscod> i mailed the design list after changing to font..
17:15:29 <hiemanshu> Subfusc: I know that part :)
17:15:38 <franciscod> theyre pretty busy with the f13 artwork.. so am not sure theyll have much time
17:16:06 <Subfusc> franciscod: that is why i suggest we go for a simlistic design the first time around
17:16:08 <hiemanshu> Subfusc: by when do you expect it ready?
17:16:46 <franciscod> Subfusc: simpler than the mockups?
17:16:57 <Subfusc> hiemanshu: oh i dont know. We have to write the TourMenu gui and the MainTour gui for us to check if it works properly, so i would say it could take a couple of months
17:17:11 <hiemanshu> Subfusc: I am game then!
17:17:20 <Subfusc> franciscod: tbh, i was thinking of my simple design first.
17:17:25 <Subfusc> with just text
17:17:45 <Subfusc> just to get the system up and running
17:18:22 <hiemanshu> Subfusc: you want it HTML -> pyclutter right?
17:18:29 <Subfusc> hiemanshu: yes
17:18:35 * hiemanshu is gonna take a crash course from franciscod on this soon
17:19:02 <Subfusc> the UML suggest you extend the XML parser in python for that
17:19:09 <Subfusc> just so you know
17:19:26 <hiemanshu> Subfusc: I dont know how to have a cool reply to this but "Great, I'll do it"
17:19:43 <hiemanshu> Subfusc: btw why not XML -> pyclutter?
17:19:54 * hiemanshu thinks that would be easier and better
17:20:02 <Subfusc> hiemanshu: if we do it HTML, we dont need to define our own language
17:20:11 <Subfusc> so noone have to learn anything new
17:20:28 <hiemanshu> use XML with custom tags wont be too tough
17:20:29 <franciscod> Subfusc: okay.. the mockups you did /
17:20:30 <franciscod> ?
17:20:31 <Subfusc> also it would be more consisten with allready written software
17:20:44 <hiemanshu> awrite
17:21:00 <Subfusc> franciscod: just a suggestion. They are simple but they work, then we can work on better designs later
17:22:01 <Subfusc> if we do it with no effects too, it should be a good way to test the system
17:22:14 <franciscod> Subfusc: aye
17:22:21 <Subfusc> agreed then?
17:22:26 <franciscod> #agreed switch to simple UI first
17:22:33 <franciscod> #agreed flashy it up later
17:22:53 <Subfusc> #task hiemanshu TextRenderer
17:23:01 <Subfusc> anyone got anything more to add?
17:23:10 <hiemanshu> #agreed franciscod to give hiemanshu a Crash course at GNUnify
17:23:24 <franciscod> #task Subfusc hiemanshu franciscod kick rrix 's ass
17:23:28 <franciscod> ^ ?
17:23:29 <Subfusc> lol ;)
17:23:37 <Subfusc> yeah, we would need to do that
17:23:41 <hiemanshu> so if anyone reading the log wants to join us at GNUnify it would be nice
17:23:51 <hiemanshu> franciscod: Count me in
17:24:14 <Subfusc> anything more?
17:24:32 <Subfusc> no?
17:24:38 <franciscod> nope..
17:24:40 <Subfusc> kk
17:24:42 <Subfusc> #endmeeting