18:38:14 <Subfusc> #startmeeting
18:38:15 <zodbot> Meeting started Sun Feb 14 18:38:14 2010 UTC.  The chair is Subfusc. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:38:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:38:34 <Subfusc> #topic Todays agenda
18:38:42 <Subfusc> #chair franciscod hiemanshu
18:38:43 <zodbot> Current chairs: Subfusc franciscod hiemanshu
18:39:03 <Subfusc> franciscod: got something for us today?
18:39:10 <Subfusc> or hiemanshu ?
18:39:11 <franciscod> not much. working on the code..
18:39:25 <franciscod> we can discuss what else we gotta do..
18:39:31 <Subfusc> like?
18:39:45 <franciscod> should commit it by tomorrw..
18:39:53 <franciscod> Subfusc: what else do we gotta do?
18:40:09 <Subfusc> we should discuss the big changes i have made, wich i hope you have reviewd
18:40:10 * rrix stubmles in
18:40:20 <Subfusc> #chair rrix
18:40:21 <zodbot> Current chairs: Subfusc franciscod hiemanshu rrix
18:40:38 <Subfusc> rrix: welcome. this is a rare plesure
18:40:39 <Subfusc> =)
18:40:43 <franciscod> Subfusc: have.. not in detail but have read through it
18:40:51 <franciscod> rrix: sup?
18:40:58 * rrix sticks his tongue out at Subfusc
18:41:01 <Subfusc> and we should have the usuall progress meeting
18:41:28 <Subfusc> anything more?
18:42:22 <Subfusc> no?
18:42:24 <Subfusc> k
18:42:32 * franciscod is blank
18:42:34 <franciscod> :|
18:42:40 <franciscod> rrix: speak up!
18:42:47 * rrix would love having something to hack on ;)
18:43:17 <Subfusc> #agreed agenda: what we are going to do, main line commit, usuall progress discussion
18:43:31 <franciscod> Subfusc: im still not clear on how we're taking input, ie data from the docs teams etc?
18:43:47 <Subfusc> franciscod: yeah
18:43:53 <Subfusc> take that in 2 sec
18:44:03 <Subfusc> #topic what we are going to do
18:44:15 <Subfusc> franciscod: what are you not clear on?
18:44:36 <Subfusc> we take html files from the doc team
18:44:53 <franciscod> once they put on the wiki?
18:44:54 <Subfusc> wich will be parsed in the html -> clutter part
18:44:57 <franciscod> for release etc?
18:45:20 <franciscod> are we doing to use the same sources? or ask them to give us info separately?
18:45:33 <franciscod> s/once/ones
18:45:46 <Subfusc> we would probably need other sources, because it has to scale in a diffrent way than the sites
18:46:06 <franciscod> Subfusc: shouldnt we start discussing this with them?
18:46:18 <Subfusc> that is a good idea
18:46:38 <franciscod> because it would be crappy if we began something and they said "nope, not like this"?
18:46:40 <Subfusc> #idea discuss how docs are going to be transported to us with doc team
18:47:05 <franciscod> we'll have to talk to sigs too? like FEL? and KDE sig etc? for the separate tours?
18:47:10 <Subfusc> franciscod: but a lot is allready defined in backend, but we should discuss how we can make it easy for them
18:47:29 <franciscod> we havent discussed any of that with them
18:47:47 <Subfusc> the BACKEND doc is discussed with the doc team, right rrix?
18:47:54 * franciscod looks at rrix
18:47:58 * franciscod doesnt think o
18:47:59 <franciscod> so
18:48:04 <Subfusc> rrrr
18:48:04 <rrix> yeah
18:48:07 <rrix> we haven't
18:48:10 <franciscod> lol
18:48:17 <franciscod> i thought yeah =  we have
18:48:18 <Subfusc> then we have to do that
18:48:19 <franciscod> lol
18:48:23 <rrix> the docs team is usually "LOL IGNORE" with anything we throw at them
18:48:39 <Subfusc> rrix: have you discussed it with marketing then?
18:48:49 <rrix> what about specifically?
18:48:57 <franciscod> rrix: then we gotta *hunt* them down :P
18:49:15 <Subfusc> the BACKEND doc you made describing packages
18:49:19 <franciscod> rrix: the content descriptors et all, which is the formate we take input for parsing
18:49:32 <rrix> Subfusc: I talked to mel way back when about it
18:49:44 <Subfusc> i think we are safe on that part then
18:49:52 <Subfusc> he seems pretty plugged in
18:50:24 <franciscod> i stil think we need to catch hold of someone from the doc team..
18:50:28 <rrix> +1
18:50:32 <Subfusc> +2
18:50:34 <franciscod> since theyre the ones that will finally be giving us the info
18:50:48 <Subfusc> #agreed Hunt down someone from Doc team
18:50:55 <franciscod> lol
18:50:59 <franciscod> #task go hunting
18:51:03 <rrix> #action rrix to file a ticket for docs team support
18:51:09 <franciscod> kinda nice, in sync with supernatural
18:51:11 <franciscod> :P
18:51:46 <Subfusc> move on to next topic ? or do we have more on this?
18:52:29 <franciscod> i gave one topic to talk about :P
18:52:34 <franciscod> your guys turns :P :P
18:52:50 <Subfusc> franciscod: i have allready decided the agenda for today
18:52:51 <Subfusc> ;)
18:52:57 <Subfusc> #topic mainline commit
18:52:57 <franciscod> yap then :)
18:53:19 <franciscod> Subfusc: yap more :P
18:53:29 <Subfusc> This is where we should discuss where we are going with our codebase
18:53:40 * franciscod is listening
18:53:47 <Subfusc> has anyone commited any significant in their branches lately?
18:54:05 <franciscod> not yet, will tomorrow probably, the menu object
18:54:32 * rrix still needs a task
18:54:56 <Subfusc> k, now for the question, have anyone reviewed or has comments on the changes i have made?
18:55:33 * franciscod looks with magnifying glasses
18:56:09 <Subfusc> if not, i suggest i pull franciscod branch tomorrow to get the menu object, and push it to main
18:57:23 <Subfusc> that way we get some progress in main too
18:58:08 <franciscod> okay,
18:58:20 <franciscod> why isnt diff -u yourfolder myfolder giving me nothing?
18:58:31 * franciscod is doing something wrong
18:58:48 <Subfusc> can you do diffs on folders?
18:59:03 <Subfusc> without -r option
18:59:19 <franciscod> If you're going to edit many files, one easy method is to copy the whole subdirectory underneath BUILD, and then do subdirectory diffs; once you're in BUILD/whatever, you can:
18:59:22 <franciscod> cp -pr . ../PACKAGENAME.orig
18:59:25 <franciscod> ... many edits ...
18:59:26 <franciscod> from packaging wiki :P
18:59:28 <franciscod> diff -u ../PACKAGENAME.orig . > ~/rpmbuild/SOURCES/PKGNAME.REASON.patch
18:59:51 * rrix would rather just keep two branches :)
18:59:58 <rrix> too messy
19:00:03 <Subfusc> rrix: what is?
19:00:52 <rrix> ./fedoar-tour/foo ./fedora-tour-rrix/foo
19:01:03 <Subfusc> ah
19:01:04 <Subfusc> yeah
19:01:05 <rrix> diff -Nur ./fedora-tour ./fedora-tour-rrix
19:01:17 <Subfusc> franciscod: the diffs are found in gitweb
19:01:56 <rrix> eh, fuck, my dad is making me go help him in the back yard
19:01:58 <Subfusc> but the big changes is that Splash is now Selfsufficent (it doesnt require all the other classes you made wich i didnt realy see the point of having)
19:02:08 <rrix> digging holes and whatnot :(
19:02:20 <Subfusc> rrix: could you make him wait for like 10 min?
19:02:32 <rrix> yeah, trying
19:02:39 <franciscod> Subfusc: reading
19:02:58 <Subfusc> if you guys dont have an opinion of it now
19:03:13 <Subfusc> we will take it the next meeting, since people are in a hurry and/or tired
19:03:27 <franciscod> Subfusc: not a lot of diff in the splash code
19:03:32 <Subfusc> #task rrix franciscod have an opinion about mainline
19:03:33 <franciscod> or ive just forgotten what i had written
19:03:35 <Subfusc> franciscod: no
19:03:39 <franciscod> :|
19:03:52 <franciscod> what else did you change? major i mean?
19:04:11 <Subfusc> franciscod: all the other files are mostly redundant now
19:04:12 <franciscod> apart from filenames
19:04:15 <Subfusc> eg. they will be deleted
19:04:18 * franciscod noticed that :P
19:04:50 <Subfusc> the three frontend files we have now is MainWin.py Splash.py and Example.py
19:04:56 <franciscod> Subfusc: roger
19:04:58 <Subfusc> and Utils.py
19:05:16 <Subfusc> allthou it should be a backend thing
19:05:24 <Subfusc> but that would be a diffrent story
19:05:26 <franciscod> utils is still the same,
19:05:30 <Subfusc> yes
19:05:37 <Subfusc> but those are the only ones in use now
19:05:48 <rrix> gone....
19:05:55 <Subfusc> rrix: have to go?
19:06:11 <Subfusc> moving to next topic
19:06:19 <Subfusc> rrix: you should be here if you want something to do
19:06:26 <Subfusc> #topic progess and tasks
19:06:26 <franciscod> hehe
19:06:49 <Subfusc> i am mostly finnished with the tour objects, so i can take a new task
19:06:56 <franciscod> #idea rrix choose next meeting timing
19:06:56 <Subfusc> how faar have you come franciscod ?
19:07:13 <franciscod> Subfusc: will have it done by tomorrow max
19:07:15 <Subfusc> #agreeed rrix chooses next meeting time
19:07:19 <Subfusc> #agreed rrix chooses next meeting time
19:07:41 <franciscod> i get confusd coding since i aint sure of how the object is actually gonna get filled up..
19:07:57 <Subfusc> franciscod: you want a new task, or do you want to clean your code / improve a week before you move to anohter?
19:08:13 <franciscod> Subfusc: new task please
19:08:24 <Subfusc> franciscod: how have you done it now?
19:08:38 <franciscod> Subfusc: the object?
19:08:41 <Subfusc> the uml suggested a .ini file, i left it up to you to define the content of it
19:09:19 <franciscod> uhm.. see thats what im bad at..
19:09:42 <franciscod> the html is for info only? and the ini is to make the layout and stuff?
19:10:03 <franciscod> im dumb at this part.. :|
19:10:10 <Subfusc> franciscod: its only you who has an ini file, and its the name of the subjects + where to find it
19:10:21 <Subfusc> layout has nothing to do with it
19:10:21 <Subfusc> ;)
19:10:46 <franciscod> by subjects you mean?
19:10:54 <Subfusc> something like:
19:10:57 <Subfusc> [gtk-tour]
19:11:10 <Subfusc> topic = "GNOME TOUR"
19:11:23 <Subfusc> file = "package/gtk-tour.xml"
19:11:50 <Subfusc> where Gnome tour is the menu option you will get displayed in the menu
19:11:58 <franciscod> dumb q: then what are the content descriptor things for?
19:12:05 <Subfusc> and file is the place the tour object can find its contentdescriptor
19:12:19 <franciscod> crap.. now i get it..
19:12:24 <Subfusc> ;)
19:12:27 <franciscod> :D
19:12:29 <franciscod> ^_^
19:12:52 <franciscod> ill have it done by tomorrow for sure then
19:13:00 <Subfusc> still want a new task?
19:13:28 <franciscod> yep
19:13:40 <Subfusc> how about starting to design the frontend part for the menu ?
19:14:00 <franciscod> design = according to mockups?
19:14:09 <rrix> back for a few
19:14:17 <rrix> sorry
19:14:22 <franciscod> Subfusc: looked at mockups yet?
19:14:31 <Subfusc> franciscod: yes i have
19:14:36 <Subfusc> atleast a few of them
19:14:47 <franciscod> look okay? comment?
19:14:58 <Subfusc> franciscod: tbh, whatever you feel you will be able to make in a reasonable timeframe is fine by me
19:15:15 <rrix> 20:12 ( Subfusc) and file is the place the tour object can find its contentdescriptor
19:15:20 <franciscod> okay, ill make a "first draft" and we an edit it around
19:15:30 <rrix> Why not just have it iterate through all xml files in packages/ ?
19:16:15 <Subfusc> franciscod: sounds good. Only thing thou, we should use the same background for consistency, i suggest the default background for given fedora release
19:16:37 <franciscod> Subfusc: il use the mozaic? same as splash?
19:16:40 <Subfusc> rrix: lot of unecessary code, cpu cycles and such
19:16:58 <franciscod> and we can replace that with the default one later
19:17:00 <Subfusc> if we find the ini's unecessary they are easy to suspend later
19:17:29 <Subfusc> franciscod: yes, but you get a backroung from "MainWin" so whatever we decide, the code goes there for background
19:17:32 <Subfusc> ;)
19:17:59 <rrix> Subfusc: but a lot cleaner for maintainers
19:17:59 <franciscod> Subfusc: aha.. okay, its from the config file right?
19:18:09 <rrix> packages/ should only have stuff that is going to be used on tour anyways
19:18:49 <Subfusc> franciscod: no, i didnt do it like that. But if you want it to be i can make it so, or you can make it so =P
19:19:29 <Subfusc> rrix: perhaps, but i still think we can phase it out later if we find that the ini is to difficult to maintain
19:19:58 <Subfusc> it is better to get something working and get the details later, than details now and nothing working
19:20:01 <Subfusc> IMHO
19:20:09 <franciscod> Subfusc: IIRC thats why rrix had written the utils.py thing?
19:20:21 <franciscod> so we could dump it all in a config and get it from there?
19:20:27 <franciscod> easier to change per release etc?
19:20:39 <rrix> the Utils.py was to load different frontends, iirc
19:20:49 <Subfusc> franciscod: yes, i just didnt include it in my MainWin yet. I can make that my weeks task if you want
19:20:50 <rrix> dynamic class loader was the only thing in there
19:21:00 <rrix> oh, it had the ocnfig code, too huh
19:21:02 * rrix shuts up
19:21:21 <franciscod> rrix: dint we also use the config to provide bg path etc?
19:21:31 <franciscod> and you wrote the "makepath" ethod etc?
19:21:40 <rrix> yeah :)
19:22:04 <Subfusc> okay
19:22:13 <Subfusc> #task Subfusc make MainWin use configs
19:22:15 <franciscod> "bg: ../data/Constantine_Perspective_Mosaico_small.png" :P
19:22:31 <franciscod> Subfusc: i think itll be easier if we used the config?
19:22:40 <franciscod> wont have to change the code? just the config file?
19:22:45 <franciscod> rrix: Subfusc : what say?
19:22:50 <rrix> i wrote code to load the system's wallpapers, i think that's better than shipping our own
19:22:50 <Subfusc> franciscod: that was my plan
19:23:03 <Subfusc> to use rrix Utils code and
19:23:04 <rrix> bg: constantine-mosaico
19:23:05 <Subfusc> ;)
19:23:21 <Subfusc> rrix: +1
19:23:33 <franciscod> +4
19:23:39 <Subfusc> the splash can be spesial thou
19:23:51 <franciscod> +5
19:24:17 <Subfusc> franciscod: you take the Main Menu frontend then?
19:24:47 <franciscod> oaky, ill make it like the mockups for the time being
19:24:57 <Subfusc> sounds good
19:24:59 <franciscod> and we can cut/slash/hack it up  later
19:25:02 <Subfusc> yepp
19:25:12 <Subfusc> make it without fancy transitions first
19:25:20 <Subfusc> so we get an idea what we have to do
19:25:25 <franciscod> wireframed ? :P
19:25:37 <Subfusc> if that is what you call it
19:25:37 <Subfusc> =P
19:25:49 <franciscod> mizmo and nicu taught me that :P
19:25:52 <Subfusc> #task franciscod make Menu Frontend
19:26:00 <Subfusc> rrix: you want to start on the main tour frontend?
19:26:05 <rrix> shore
19:26:23 <Subfusc> we agreed to make it simple first time around, so something like the mockups i made
19:26:41 <Subfusc> offcourse you guys are the writers, so you have the creative rights
19:26:41 <Subfusc> ;)
19:26:50 <Subfusc> #task rrix start maintour frontend
19:27:04 <Subfusc> anything else?
19:27:14 <Subfusc> questions?
19:27:15 <Subfusc> comments?
19:27:39 <Subfusc> rrix: franciscod ?
19:27:44 <franciscod> uhm..
19:27:47 <franciscod> uhhhmmmmm
19:27:53 <franciscod> XD
19:28:18 * rrix is good
19:28:32 <Subfusc> every subclass will take a config object from main windows, so we dont have to parse the configfile multiple times
19:28:35 <Subfusc> sound good?
19:28:48 <franciscod> +10
19:29:11 <Subfusc> then i will rewrite mainwindow and UML this week
19:29:12 * rrix &
19:29:19 <rrix> just talk at me, i'll be back :)
19:29:29 <Subfusc> meeting is ajourned
19:29:30 <franciscod> rrix: you sux
19:29:32 <Subfusc> #endmeeting