17:00:37 <trishnag> #startmeeting fedora_atomic_wg
17:00:37 <zodbot> Meeting started Wed Nov 16 17:00:37 2016 UTC.  The chair is trishnag. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:37 <zodbot> The meeting name has been set to 'fedora_atomic_wg'
17:00:40 <bowlofeggs> .hello bowlofeggs
17:00:41 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
17:00:41 <trishnag> #topic Roll Call
17:00:49 <trishnag> .hello trishnag
17:00:51 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:00:53 <sayan> .hello sayanchowdhury
17:00:57 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:00:59 <dustymabe> .hello dustymabe
17:01:00 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:01:02 <kushal> .hellomynameis kushal
17:01:03 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:38 <jbrooks> .fas jasonbrooks
17:01:39 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:02:04 <kushal> trishnag, before we get into meeting, I want to say something :)
17:02:08 <trishnag> #chair bowlofeggs sayan dustymabe kushal jbrooks
17:02:08 <zodbot> Current chairs: bowlofeggs dustymabe jbrooks kushal sayan trishnag
17:02:11 <kushal> * meeting tickets etc
17:02:14 <trishnag> kushal: sure go ahead
17:02:53 <kushal> What about we dedicate next meeting about the features/topics relevant to atomic working group during F26 release?
17:03:17 <kushal> That should be after the release date.
17:03:41 <dustymabe> kushal: i'd like to see an agenda proposed for that
17:03:46 <trishnag> kushal: +1
17:03:54 <dustymabe> if there hasn't been one already put forth
17:03:56 <kushal> dustymabe, yup, we can work on the agenda from tonight :)
17:04:06 <dustymabe> i.e. let's query the list and get input
17:04:15 <dustymabe> and formulate an agenda and invite interested parties
17:04:30 <dustymabe> kushal: next week might not be good because of holidays in the US
17:04:35 <dustymabe> following week may be best
17:04:44 <kushal> dustymabe, Oka
17:04:45 <kushal> Okay
17:04:51 <kushal> Holidays are good.
17:04:53 <kushal> always good :)
17:04:59 <trishnag> hehe :)
17:05:00 <dustymabe> but certainly let's query the list and start to prepare an agenda
17:05:03 <kushal> Yes.
17:05:07 <kushal> dustymabe,  I will drop a mail
17:05:08 <sayan> Right
17:05:26 <kushal> #action kushal will write to list for the agenda of the features meeting for Atomic group
17:06:34 <trishnag> kushal: Can I move to action items? or you have anything else? :)
17:06:42 <maxamillion> .hello maxamillion
17:06:43 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:06:43 <kushal> trishnag, sorry, go ahead :)
17:06:56 <trishnag> cool
17:07:02 <trishnag> #chair maxamillion
17:07:02 <zodbot> Current chairs: bowlofeggs dustymabe jbrooks kushal maxamillion sayan trishnag
17:07:07 <trishnag> #topic Action items from last meeting
17:07:20 <trishnag> * jbrooks to file issue on kube situation w/ f25 atomic
17:07:37 <jbrooks> https://pagure.io/atomic-wg/issue/176
17:07:40 <dustymabe> trishnag: jbrooks filed a very detailed issue
17:07:40 <jbrooks> that's it
17:07:44 <dustymabe> jbrooks: thank you
17:08:01 <trishnag> jbrooks: Thanks.
17:08:30 <kushal> We will have to make a lot noise in social media + blogs + docs
17:08:49 <dustymabe> kushal: right, but we still don't have an actual answer yet
17:08:56 <dustymabe> system containers are "coming"
17:09:06 <jbrooks> dustymabe, we don't need those
17:09:13 <trishnag> kushal: Also we need people to review the docs.
17:09:14 <dustymabe> in the mean time I am working on getting the openshift-ansible installer to work against F25 atomic host
17:09:15 <maxamillion> but they'd be cool to have :D
17:09:17 <jbrooks> we can use package layering for etcd and flannel
17:09:23 <maxamillion> dustymabe: +1
17:09:42 <jbrooks> dustymabe, how does that look? that's probably going to be the best fully fedora solution
17:09:51 <maxamillion> dustymabe: openshift-ansible is an impressive pile of ansible but omg it's *giant*
17:10:09 <jbrooks> We can doc how to use kube w/ upstream containers, but we don't have them from fedora itself
17:10:11 <maxamillion> dustymabe: the rabbit hole is impressive in depth ;)
17:10:13 <dustymabe> jbrooks: yeah package layering could work, but I hate the solution of boot your machine, run a command, reboot your machine, then you can run
17:10:24 <jbrooks> Yeah
17:10:32 <maxamillion> dustymabe: +1
17:10:33 <jbrooks> It is what it is
17:10:36 <maxamillion> :/
17:10:53 <jbrooks> The system containers do work fine
17:10:58 <jbrooks> kube is a bigger issue, though
17:11:27 <jbrooks> We just need to add those etcd and flannel system containers to Fedora-Dockerfiles, the rpms they need are in the repos
17:11:31 <dustymabe> jbrooks: did you get an update on newer kube in F25?
17:12:23 <jbrooks> dustymabe, I'm still working on testing it -- I'm trying w/ etcd, flannel and kubelet via pkg layering, and the rest in containers, based on what rhel does
17:12:27 <jbrooks> But it's not working yet
17:12:39 <jbrooks> That has to do w/ the dockerfiles
17:12:51 <jbrooks> But we don't have those dockerfiles in fedora anyway
17:13:10 <jbrooks> That's why I think origin on fedora might be the best story for now, assuming that works
17:13:27 <dustymabe> jbrooks: so giuseppe is working on adding some system containers to projectatomic/ on docker hub
17:13:34 <jbrooks> Or, using upstream containers and like kubeadm does work, it's just not all home-built
17:13:54 <dustymabe> so we could possibly use those
17:13:59 <jbrooks> Fine with me
17:14:06 <jbrooks> Is that legit fedora enough for us?
17:14:15 <dustymabe> jbrooks: yeah, that is a good question
17:14:34 <dustymabe> I think longer term (once system containers are more legit) we can make them more of a real thing produced by fedora releng
17:14:48 <dustymabe> maxamillion: do you have an opinion on this?
17:14:50 <jbrooks> Does releng produce any containers at this point?
17:15:17 <maxamillion> I've kind of struggled with this myself about how in a containerized world with things coming from all sorts of external places, is it still "Fedora" (similar questions for things like Flatpak apps and such)
17:15:59 <maxamillion> jbrooks: technically? yes ... just not in production yet for roughly another couple weeks
17:16:28 <maxamillion> I mean, we can in production now, but only in limited capacity
17:16:28 <dustymabe> maxamillion: yes. things are certainly starting to get a lot more blurry
17:16:43 <dustymabe> part of me is scared. part of me is not
17:16:50 <jbrooks> :)
17:17:06 <jbrooks> dustymabe, Maybe I'll shift to origin and we can try and make that work
17:17:10 <jbrooks> First
17:17:21 <maxamillion> dustymabe: I think it rounds back to the question from Alexander Larssen of "where does the operating system end and the application begin?" and if Fedora only caters to the operating system side of that question, do we particularly care where the application comes from?
17:17:23 <dustymabe> jbrooks: well I got it working using the installer
17:17:37 <jbrooks> dustymabe, Cool, just w/ those workarounds?
17:17:45 <jbrooks> the issues you linked
17:17:50 <dustymabe> jbrooks: pretty much
17:18:42 <jbrooks> OK, that's good, I'll keep going on kube stuff. I figure we want to document: here's plain docker, here's origin, here's kube
17:18:53 <dustymabe> jbrooks: yep
17:19:19 <kushal> maxamillion, do you know what other layer imaged builds are coming in the next release?
17:19:30 <jbrooks> Once I get the 1.4.5 pkgs actually working, I'll step up my poking about getting them available for f25
17:21:06 <maxamillion> kushal: I'm going to be doing capacity planning shortly so we'll know what we can actually handle but I'd like to target everything currently in Fedora-Dockerfiles github repo
17:21:29 <kushal> maxamillion, that is a great news.
17:21:40 <kushal> maxamillion, and still within Fedora packages, correct?
17:21:40 <scollier> .hello scollier
17:21:41 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:21:44 <kushal> and scollier is here :)
17:21:48 <scollier> dang, sorry about that
17:21:51 <maxamillion> kushal: I don't understand the question
17:21:52 <scollier> it's been soooo long.
17:21:52 <trishnag> #chair scollier
17:21:52 <zodbot> Current chairs: bowlofeggs dustymabe jbrooks kushal maxamillion sayan scollier trishnag
17:22:09 <dustymabe> scollier: hiya, you haven't missed much - we were just chatting about https://pagure.io/atomic-wg/issue/176
17:22:14 <kushal> maxamillion, I mean only the containers with official packages inside
17:23:49 <maxamillion> kushal: correct
17:24:17 <kushal> Okay, thanks :)
17:24:48 <maxamillion> kushal: curated content from external sources is unfortunately way down the priority list and it's not a small amount of work to accomplish
17:25:03 <kushal> maxamillion, True, I was just asking.
17:25:11 <kushal> Anyway our build systems do not allow that iirc.
17:26:12 <maxamillion> kushal: right, no part of koji builds allow that today so we targeted that initially
17:27:35 * walters bets no one would notice if someone started backing up their vacation pictures in the lookaside cache
17:28:03 <dustymabe> :)
17:28:12 <dustymabe> icloud - go
17:28:13 <walters> anyways, just a quick note i'm looking at the ISO thing now
17:29:13 <maxamillion> walters: that's probably fair
17:29:43 <maxamillion> walters: however, we could at least audit it better than 'curl https://foo.io/install.sh | bash' in a Dockerfile
17:31:31 <trishnag> Ok Let's move to meeting items.
17:31:42 <trishnag> #topic Fedora Cloud Base Vagrant Boxes Don't Allow Vagrant User To su To Other Users https://pagure.io/atomic-wg/issue/173
17:32:14 <trishnag> We have no assignee for this ticket.
17:33:25 <dustymabe> trishnag: this will have to wait until after F25
17:33:53 <dustymabe> so either someone can volunteer, or we can wait
17:34:05 <dustymabe> trishnag: this would be a good thing to add to the tests
17:34:13 <trishnag> dustymabe: ack. I am going to add on_hold tag to it.
17:34:41 <trishnag> dustymabe: cool. I will create an issue to tunirtests for the same.
17:35:29 <trishnag> #action trishnag will create an issue on tunirtests for https://pagure.io/atomic-wg/issue/173
17:36:05 <trishnag> moving to next ticket.
17:36:07 <trishnag> #topic Finish new Fedora Cloud PRD https://pagure.io/atomic-wg/issue/170
17:36:48 <trishnag> jberkus doesn't seem to be around.
17:37:55 <trishnag> #topic Spec for IRC bot to notify about blockers https://pagure.io/atomic-wg/issue/169
17:39:16 <dustymabe> i don't think anyone has anything for this ticket
17:39:27 <trishnag> Looks like this is on-hold as well.
17:39:51 <trishnag> #topic Ship fedora-motd in F24 atomic image https://pagure.io/atomic-wg/issue/160
17:40:14 <trishnag> rtnpro: kushal Update on this?
17:40:16 <walters> i'd say rather than irc, we have a mechanism to assign a person to failures or something like that
17:41:35 <rtnpro> trishnag, I did not manage to work on it based on walters feedback. I will update on it once I have the fixes
17:41:47 <trishnag> rtnpro: ok thanks.
17:42:27 <trishnag> #topic Proposed website changes for Cloud Base → Atomic Host switch https://pagure.io/atomic-wg/issue/158
17:43:21 <trishnag> dustymabe: Thanks for the comment.
17:43:21 <dustymabe> trishnag: mattdm and I are going to meet with robyduc today on this
17:43:40 <dustymabe> i also gave feedback on the atomic download page
17:43:58 <dustymabe> some of my suggestions won't make it in until after F25 release. but we are getting things fixed that were "wrong"
17:44:15 <dustymabe> I'm going to create a few new tickets for the websites team based on our discussion today
17:44:23 <dustymabe> i'll update this issue with that information when it happens
17:45:06 <trishnag> dustymabe: great!
17:45:30 <trishnag> #topic make Fedora Atomic download page clearer https://pagure.io/atomic-wg/issue/154
17:46:17 <dustymabe> trishnag: i think these were comments on the F24 download page
17:46:41 <dustymabe> which is about to be obsolete - I'll update this ticket to say that and that josh will have to give new feedback on the new download page
17:46:41 <trishnag> yup https://fedoraproject.org/wiki/Cloud/getfedora_update
17:47:05 <trishnag> dustymabe++
17:47:07 <zodbot> trishnag: Karma for dustymabe changed to 5 (for the f24 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:47:44 <trishnag> #topic design, deploy and document Fedora OpenShift Playground (FOSP) https://pagure.io/atomic-wg/issue/153
17:48:37 <trishnag> scollier: Do you have anything to say for this ticket?
17:48:43 <scollier> trishnag, looking
17:49:33 <scollier> trishnag, no, i haven't had a chance to sync with misc on this, looks like he's working with puiterwijk on some auth issues.
17:49:40 <trishnag> the recent update was from misc and walters.
17:49:44 <scollier> trishnag, I will follow up with them and update the ticket.
17:50:00 <trishnag> scollier: Cool Thanks :).
17:50:38 <trishnag> #topic vagrant boxes fixups https://pagure.io/atomic-wg/issue/136
17:51:48 <jbrooks> I suggested a fix for this, Ian commented in irc, he was ambivalent about my solution, not sure what the next step might be
17:53:08 <dustymabe> jbrooks: did you open a PR?
17:54:05 <jbrooks> dustymabe, No, I can though
17:54:22 <dustymabe> that would be the logical next step. and the discussion can be public
17:54:37 <trishnag> dustymabe: +1
17:55:06 <jbrooks> https://github.com/redhat-imaging/imagefactory/pull/392
17:55:49 <dustymabe> jbrooks: might be good to add a description to the commit that describes why this change is useful
17:55:59 <dustymabe> for those browsing history in the future :)
17:56:24 <trishnag> also a link to the issue https://pagure.io/atomic-wg/issue/136 :)
17:57:10 <jbrooks> done
17:57:22 <trishnag> Awesome!
17:57:38 <trishnag> We can probably move to Open floor now. :-)
17:57:46 <trishnag> #topic Open Floor
17:59:03 <dustymabe> scollier: ^^
17:59:14 <scollier> trishnag, how long do we have, couple of min?
17:59:21 <maxamillion> 60 seconds ... ish
17:59:22 <trishnag> scollier: yes we have
17:59:36 <scollier> not long enough, but for next meeting, i'd like to come to decision on fedora-dockerfiles
17:59:53 <scollier> right now it's suffering from bit-rot, and it's not fair to the folks opening PRs
18:00:21 <trishnag> or we can move the discussion to our channel scollier
18:00:35 <scollier> trishnag, happy to do so.
18:00:41 <trishnag> scollier: cool
18:00:51 <trishnag> ending the meeting as we are running out of time :)
18:00:55 <trishnag> 5
18:00:56 <trishnag> 4
18:00:58 <trishnag> 3
18:01:00 <trishnag> 2
18:01:02 <trishnag> 1
18:01:04 <trishnag> #endmeeting