17:03:19 <dustymabe> #startmeeting fedora_atomic_wg
17:03:19 <zodbot> Meeting started Wed Jun 21 17:03:19 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:03:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:03:19 <zodbot> The meeting name has been set to 'fedora_atomic_wg'
17:03:28 <dustymabe> #topic roll call
17:03:34 <jbrooks> .fas jasonbrooks
17:03:39 <dustymabe> .hello dustymabe
17:03:40 <sayan> .hello sayanchowdhury
17:03:47 <jbrooks> .hello jasonbrooks
17:03:55 <jds2001> .hello jstanley
17:04:04 <roshi> .hello roshi
17:04:07 <dustymabe> hiya jon
17:04:08 <ksinny> .hello sinnykumari
17:04:17 <rubao> .hello rubao
17:04:31 <jds2001> wait a sec - is this hte atomic meeting or the one-off server sig meeting?
17:04:36 <jds2001> or is it one and the same? :)
17:04:47 <dustymabe> jds2001: this is atomic meeting, but we'd love to have you involved :)
17:05:00 <maxamillion> .hello maxamillion
17:05:09 <nirik> the server meeting is in #fedora-meeting
17:05:16 <jds2001> ahh, got it :)
17:05:31 <jds2001> dustymabe: i'll watch both, how's that? :D
17:05:51 <dustymabe> jds2001: :) sounds good
17:06:08 <dustymabe> ok all meeting items are here: https://pagure.io/atomic-wg/issues?status=Open&tags=meeting
17:06:20 <dustymabe> #topic  Fedora OSBS RFE: install go-md2man to buildroot image
17:06:25 <roshi> welcome jds2001 :)
17:06:28 <dustymabe> #link https://pagure.io/atomic-wg/issue/284
17:06:38 <mnguyen> .hello mnguyen
17:07:22 <dustymabe> so maxamillion what is this ticket trying to get  us to do?
17:08:23 <maxamillion> so I wanted to bring this up because there's a whole conversation around documentation files for containers and I don't know that is something we've addressed here
17:08:48 <maxamillion> dustymabe: ultimately, the only thing this ticket wants is a new update to the buildroot container in FLIBS, which I can pretty easily do
17:09:00 <maxamillion> dustymabe: I just wanted to find out what the plan here was
17:09:29 <dustymabe> i think our plan was to link to external url for documentation
17:09:42 <dustymabe> for help - unless the help was extremely simple
17:10:19 <dustymabe> jberkus would know more
17:10:50 <maxamillion> alright, there's apparently a competing plan but I've not seen much in the way of publicly accessible details about it ... I've heard of a mojo document referenced, but that doesn't exist to Fedora
17:10:53 <dustymabe> this ticket has a lot of discussion about 'help'
17:10:56 <dustymabe> https://pagure.io/atomic-wg/issue/256
17:11:28 <maxamillion> dustymabe: this was added, but I don't remember any discussion about it https://fedoraproject.org/wiki/Container:Guidelines#Help_File
17:11:28 <dustymabe> this comment tries to summarize a lot of it
17:11:31 <dustymabe> https://pagure.io/atomic-wg/issue/256#comment-436537
17:11:37 <maxamillion> dustymabe: but it's possible I just missed something
17:13:02 <dustymabe> maxamillion: ^^ read that comment
17:13:11 <miabbott> .hello miabbott
17:13:57 <zodbot> dustymabe: [hellomynameis dustymabe]
17:14:00 <zodbot> sayan: [hellomynameis sayanchowdhury]
17:14:03 <zodbot> jbrooks: [hellomynameis jasonbrooks]
17:14:06 <zodbot> jds2001: [hellomynameis jstanley]
17:14:10 <zodbot> roshi: [hellomynameis roshi]
17:14:12 <zodbot> ksinny: [hellomynameis sinnykumari]
17:14:15 <zodbot> rubao: [hellomynameis rubao]
17:14:18 <zodbot> maxamillion: [hellomynameis maxamillion]
17:14:23 <dustymabe> wow zodbot, late much?
17:14:34 <dustymabe> #chair maxamillion rubao ksinny roshi jds2001 jbrooks sayan
17:14:34 <zodbot> Current chairs: dustymabe jbrooks jds2001 ksinny maxamillion roshi rubao sayan
17:14:43 <maxamillion> o.o
17:14:50 <dustymabe> #chair miabbott mnguyen
17:14:50 <zodbot> Current chairs: dustymabe jbrooks jds2001 ksinny maxamillion miabbott mnguyen roshi rubao sayan
17:15:05 <dustymabe> maxamillion: did you read that comment?
17:15:44 <maxamillion> dustymabe: no, sorry, I'm in multiple meetings
17:15:49 <maxamillion> dustymabe: just a sec
17:16:01 <maxamillion> dustymabe: ah ok
17:16:06 <maxamillion> alright, I'll get that fixed up then
17:16:13 <zodbot> mnguyen: [hellomynameis mnguyen]
17:16:17 <maxamillion> dustymabe: we can move on
17:16:23 <dustymabe> so i'm not sure what this ticket is proposing, but maybe something better exists?
17:16:31 <dustymabe> i say we can evolve over time as that becomes true
17:16:37 <maxamillion> dustymabe: yeah, that should be fine
17:16:41 <dustymabe> maxamillion: thanks please add a summary to the ticket if you would
17:16:47 <maxamillion> dustymabe: will do
17:16:56 <zodbot> miabbott: [hellomynameis miabbott]
17:17:11 <dustymabe> #action maxamillion to add summary to ticket https://pagure.io/atomic-wg/issue/284
17:17:21 <dustymabe> I just realized I forgot action items from last meeting
17:17:28 <dustymabe> #topic action items from last meeting
17:17:41 <dustymabe> * dustymabe to propose a VFAD for wiki and docs discussion
17:17:43 <dustymabe> * maxamillion to update container guidelines to enforce ENV and label
17:17:45 <dustymabe> maintainer usage https://pagure.io/atomic-wg/issue/277
17:17:47 <dustymabe> * jberkus to update wg on final approval of PRD
17:17:49 <dustymabe> * jberkus to create new issues, specs for docs.projectatomic.io
17:17:51 <dustymabe> publication
17:17:53 <dustymabe> * create ticket to plan docs VFAD
17:17:55 <dustymabe> * dustymabe to create SIG page for wiki
17:17:57 <dustymabe> * walters to update https://pagure.io/atomic-wg/issue/282 with the
17:17:59 <dustymabe> discussed points
17:18:18 <dustymabe> #action dustymabe to propose a VFAD for wiki and docs discussion
17:18:30 <dustymabe> jberkus is not here
17:18:38 <dustymabe> #action jberkus to update wg on final approval of PRD
17:18:48 <dustymabe> #action jberkus to create new issues, specs for docs.projectatomic.io publication
17:19:08 <maxamillion> dustymabe: the update to guidelines is done
17:19:39 <dustymabe> #info dustymabe did create the SIG page for the wiki https://fedoraproject.org/wiki/Atomic_WG
17:19:57 <dustymabe> #info maxamillion updated the container guidelines to enforce ENV and label for https://pagure.io/atomic-wg/issue/277
17:20:19 <dustymabe> there was a disuccsion in #282 so I think walters part is done
17:21:01 <dustymabe> ok moving on to next ticket
17:21:12 <dustymabe> #topic Atomic Host images omit many common locales that all other flavors include
17:21:20 <dustymabe> #link https://pagure.io/atomic-wg/issue/282
17:21:42 <dustymabe> seems like discussion continues in this ticket
17:21:56 <dustymabe> and there isn't an easy answer
17:22:05 <dustymabe> please add your input to the ticket
17:23:07 <dustymabe> moving on in a minute unless anyone has input
17:23:36 <dustymabe> #topic talk/workshop proposals for Flock
17:23:40 <dustymabe> #link https://pagure.io/atomic-wg/issue/279
17:23:48 <dustymabe> did everyone get their talks submitted?
17:24:23 <maxamillion> I did, yhes
17:24:24 <maxamillion> yes*
17:24:30 <dustymabe> i got my two things in
17:24:34 <jbrooks> yep
17:24:35 <dustymabe> i know jberkus was working on a few
17:24:44 <dustymabe> cool - good jobs folks
17:24:51 <dustymabe> I'll close the ticket
17:25:27 <maxamillion> dustymabe: +1
17:25:34 <dustymabe> #topic  Set architecture label in the base container image
17:25:42 <dustymabe> #link https://pagure.io/atomic-wg/issue/276
17:26:41 <dustymabe> maxamillion: what's the discussion here? the original description or the label vs ENV question/
17:26:44 <dustymabe> ?
17:27:52 <maxamillion> dustymabe: I was hoping hhorak would be here, but I'll follow up in ticket
17:27:58 <maxamillion> dustymabe: we can move on
17:28:13 <dustymabe> should we talk about the proposal?
17:28:52 * roshi needs to read the proposal
17:29:00 <roshi> I been slacking on the tickets we have :(
17:29:36 <maxamillion> dustymabe: my biggest thing is I don't understand what's being asked here or why hhorak thinks we need to set the arch in every Dockerfile
17:30:01 <jbrooks> I think he's saying we don't need to do that
17:30:15 <dustymabe> i think what he is saying is that if we do want to set arch as a label or env then let's do it in the base image
17:30:21 <dustymabe> so every layered image inherits it
17:30:32 <dustymabe> and disallow setting that label/env in layered images
17:32:08 <maxamillion> jbrooks: oh ok, nvm ... I follow
17:32:12 <maxamillion> yeah ... hrm
17:32:35 <maxamillion> I'll have to look at the koji-containerbuild plugin ... that might be a requirement in the code
17:32:56 <dustymabe> can we talk about if the proposal seems reasonable?
17:33:01 <dustymabe> and comment in the ticket?
17:33:44 <dgilmore> hola
17:33:56 <maxamillion> dustymabe: "the proposal" ... I don't understand what you mean by that
17:33:56 <dustymabe> #proposed Discussed in the atomic working group meeting today. The proposal in the description sounds reasonable. Assuming we need to set an architecture label, then making layered images inherit from the base image makes sense.
17:34:11 <dustymabe> dgilmore: hola
17:34:18 <maxamillion> dustymabe: ah ok
17:34:21 <dustymabe> #chiar dgilmore
17:34:25 <dustymabe> #chair dgilmore
17:34:25 <zodbot> Current chairs: dgilmore dustymabe jbrooks jds2001 ksinny maxamillion miabbott mnguyen roshi rubao sayan
17:34:40 <dustymabe> acks?
17:34:52 <jbrooks> +1
17:35:08 <maxamillion> this might require a code change, there are labels required by the containerbuild plugin
17:35:21 <maxamillion> let me check
17:35:40 <dustymabe> maxamillion: sure - i don't think we are voting on whether it should be done, just that if it can be done, then it seems reasonable.
17:35:56 <maxamillion> dustymabe: does it seem reasonable? absolutely
17:36:13 <dgilmore> dustymabe: seems reasonable
17:36:21 <roshi> makes sense to me
17:36:24 <dustymabe> #proposed: Discussed in the atomic working group meeting today. The proposal in the description sounds reasonable. Assuming we need to set an architecture label, then making layered images inherit from the base image makes sense. This assumes that there is not some technical reason why this can't be achieved.
17:36:36 <roshi> ack
17:36:40 <dustymabe> ok I'll add it to the ticket
17:37:29 <dustymabe> #topic fedimg: don't use 'builder' instance for uploading AMIs
17:37:34 <dustymabe> #link https://pagure.io/atomic-wg/issue/269
17:37:56 <dustymabe> so sayan got one of the fedimg tickets resolved, but this one is still outstanding
17:38:03 <dustymabe> he is hoping to have this fixed in the next month
17:38:27 <dustymabe> i'll move on to the next ticket
17:38:39 <dustymabe> #topic clarify policy on atomic host support for older Fedora "number" releases
17:38:40 <sayan> yes, I am right now working on the AMI issue that dustymabe filed
17:38:47 <dustymabe> sayan: thanks
17:38:53 <dustymabe> #link https://pagure.io/atomic-wg/issue/228
17:39:09 <dustymabe> still waiting on fedmag post for this?
17:39:39 <jbrooks> dustymabe, Oh, yeah, I was forgot to ping you about it -- I guess I just need to poke someone about my pitch
17:39:58 <dustymabe> jbrooks: yeah, hit up stickster
17:40:34 <dustymabe> #topic open floor
17:40:43 <dustymabe> ok who all has something for open floor
17:40:57 <dustymabe> - roshi can we get a short report from test day?
17:41:06 <roshi> sure
17:41:10 <roshi> testday went well
17:41:13 * dustymabe was running around like a chicken with his head cut off during test day
17:41:24 <roshi> dustymabe and I were there, had a decent turnout for it
17:41:49 <roshi> (considering it's cloud, which is already niche, and then compound that with atomic which is niche of niche (IMO, at least))
17:42:14 <dustymabe> they'll both become less niche hopefully :)
17:42:24 <roshi> we had 5 people report results
17:42:37 <dustymabe> roshi: yeah, and I still have to report my results
17:42:38 <roshi> dustymabe is not in that list, but he was there :p
17:42:46 <maxamillion> yeah, I 100% missed it because I'm bad at things
17:42:52 <roshi> so 6 people participated
17:43:00 <roshi> no notable issues found
17:43:11 <dustymabe> ok i have something for open floor
17:43:12 <roshi> so things are looking solid
17:43:28 <dustymabe> There are several CVEs that came out recently
17:43:28 <roshi> #info testday went well, no notable issues found. Good work!
17:43:38 <dustymabe> we are holding the f25 atomic release until those are in
17:43:56 <dustymabe> the sudo rpm hit stable already, the glibc rpm will hit stable today
17:44:08 <dustymabe> the kernel rpm was bad and they had to put out a new one
17:44:16 <dustymabe> so at best case it would hit stable tomorrow
17:44:37 <dustymabe> which means the first images we'll have to be able to test will be on Friday
17:44:45 <roshi> sounds good
17:45:10 <dustymabe> we might not be able to release on Friday, though
17:45:18 <dustymabe> which means we'll slip a week
17:46:04 <dustymabe> anywho - that's all from me
17:46:10 <dustymabe> dgilmore: did you have something for open floor?
17:47:14 <dustymabe> roshi: forgot to mention - one bad thing did come out of test day
17:47:38 <dustymabe> we realized non us-east-1 AMIs aren't accessible to the public: https://pagure.io/atomic-wg/issue/286
17:47:44 <roshi> ah
17:47:45 <roshi> right
17:48:14 <roshi> but that wasn't an issue with the images themselves, so I forgot about them
17:48:16 <dustymabe> good to find that out now and not on release day
17:48:18 <roshi> :p
17:48:20 <dustymabe> :)
17:48:22 <maxamillion> I need to step afk to get some food before I head out for physical therapy
17:48:27 <dustymabe> maxamillion: k
17:48:29 <dustymabe> we're mostly done
17:48:29 <maxamillion> dustymabe: thanks for hosting
17:48:33 <maxamillion> o/
17:48:42 <roshi> \o
17:48:43 <dustymabe> will end meeting in 2 minutes unless more discussion takes place
17:50:02 <dustymabe> #endmeeting