17:02:11 <dustymabe> #startmeeting fedora_atomic_wg
17:02:11 <zodbot> Meeting started Wed Oct  4 17:02:11 2017 UTC.  The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:11 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:02:11 <zodbot> The meeting name has been set to 'fedora_atomic_wg'
17:02:15 <dustymabe> #topic roll call
17:02:15 <jbrooks> .fas jasonbrooks
17:02:15 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:02:20 <dustymabe> .hello dustymabe
17:02:21 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:02:29 <dustymabe> jbrooks: always beats me to be first
17:02:30 <ksinny> .hello sinnykumari
17:02:31 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
17:02:36 <dustymabe> hi ksinny :)
17:02:41 <strigazi> .hello strigazi
17:02:42 <zodbot> strigazi: strigazi 'Spyros Trigazis' <strigazi@gmail.com>
17:02:42 <ksinny> dustymabe: Hey :)
17:03:08 <miabbott> .hello miabbott
17:03:09 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
17:04:26 <dustymabe> #chair jbrooks ksinny strigazi miabbott
17:04:26 <zodbot> Current chairs: dustymabe jbrooks ksinny miabbott strigazi
17:04:32 <dustymabe> jberkus around today?
17:04:45 <dustymabe> seems as if maxamillion is out as well
17:05:57 <dustymabe> hi davdunc
17:06:05 <dustymabe> we're in roll call
17:06:06 <davdunc> hello!
17:06:59 <davdunc> .hello davdunc
17:07:03 <dustymabe> welcome jberkus :)
17:07:03 <jberkus> .hello jberkus
17:07:09 <zodbot> davdunc: davdunc 'David Duncan' <davdunc@amazon.com>
17:07:12 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:07:38 <dustymabe> ok let's get started with topics
17:07:55 <dustymabe> #topic this weeks 26 atomic host release
17:08:11 <dustymabe> FYI we had one user report an issue with this weeks 26 atomic host candidate
17:08:22 <dustymabe> #info we had one user report an issue with this weeks 26 atomic host candidate https://pagure.io/atomic-wg/issue/345
17:08:50 <dustymabe> it seems to be somewhat isolated
17:09:27 <dustymabe> I believe the current goal is to go ahead and release and chase down the issues related to the minnowboard
17:09:55 <dustymabe> any thoughts/objections?
17:10:47 <jberkus> dustymabe: did we test on another UEFI device?
17:10:59 <jberkus> I haven't seen confirmation of that
17:11:07 <dustymabe> jberkus: check the issue - ksinny, miabbott, and myself tested on 3 different platforms
17:11:22 <sayan> .hello sayanchowdhury
17:11:23 <jberkus> dustymabe: none of those say anything about UEFI
17:11:23 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:11:32 <ksinny> jberkus: I ran test on UEFI and it installs fine. Sorry, I didn't mentioned explicitly in comment. Will do it now
17:11:36 <dustymabe> jberkus: sorry - intel NUC is UEFI
17:11:42 <jberkus> ok, thanks, then let's go ahead
17:11:47 <miabbott> jberkus: i did vm install with uefi
17:12:06 <jberkus> miabbott: yah, but we established last year that VM UEFI can succeed and HW UEFI fail
17:12:13 <dustymabe> jberkus: and miabbott did a BIOS install on bare metal
17:12:21 <jberkus> seems like it's the minnowboard
17:12:32 <jberkus> so let's release
17:12:33 <dustymabe> jberkus: let's do some diagnostics on that after the meeting
17:12:34 <miabbott> jberkus: i figured it was only kinda worthwhile, but did it anyway
17:12:40 <dustymabe> most likely kernel issue again
17:12:45 <dustymabe> we'll narrow down which kernel it was
17:12:57 <jberkus> miabbott: well, if it had failed, it would have been really useful
17:13:16 <dustymabe> #info plan to go ahead and release F26AH today and investigate minnowboard issues and report back upstream.
17:13:46 <dustymabe> #topic fedora 27 blocker/important bugs
17:13:51 <dustymabe> #link https://pagure.io/atomic-wg/issue/331
17:14:12 <dustymabe> just an FYI this is where we are tracking issues related to Fedora 27 Atomic Host
17:14:29 <dustymabe> #info we are tracking issues related to Fedora 27 Atomic Host in this issue: https://pagure.io/atomic-wg/issue/331
17:14:56 <kushal> .hellomynameis kushal
17:14:57 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:15:07 <dustymabe> that includes an issue related to automatically extending the root filesystem on cloud images
17:15:16 <dustymabe> https://pagure.io/atomic-wg/issue/343
17:15:17 <strigazi> dustymabe when i sthe test day for f26AH?
17:15:23 <dustymabe> we are working through that issue
17:15:30 <jberkus> btw, my kubernetes upgrade test for f26-->f27 failed, but I don't think it's Fedora's fault.  I need to do it again with jbrooks' help
17:15:32 <dustymabe> strigazi: you mean f27 AH ?
17:15:32 <strigazi> s/f26/f27
17:15:41 <strigazi> yes
17:15:51 <dustymabe> strigazi: we already had it last friday - but you can still participate
17:16:28 <strigazi> dustymabe: ok, sorry about that, I missed it.
17:16:34 <dustymabe> https://fedoramagazine.org/fedora-27-atomic-cloud-test-day/
17:16:37 <dustymabe> strigazi: no worries
17:16:55 <dustymabe> some people were out on holiday too so they've been reporting results later
17:17:14 <strigazi> jberkus from which kubernetes version to which?
17:17:19 <dustymabe> #topic test day report for f27 atomic host
17:17:40 <dustymabe> as just mentioned we had quite a few people show up and help us test cloud/atomic images last friday
17:17:45 <jberkus> strigazi: no change in kube version
17:17:46 <dustymabe> we had quite a few results reported
17:18:00 <dustymabe> #link http://testdays.fedorainfracloud.org/events/27
17:18:09 <jberkus> strigazi: but again, I think my kube setup was broken, not the upgrade
17:18:13 <dustymabe> no major issues were found, which is great news
17:18:36 <dustymabe> any new issues that are found between now and final release should be tracked - so please let us know when you find some
17:19:17 <dustymabe> anybody have any broad level topics before we kick to open floor ?
17:19:36 <dustymabe> also thanks to everyone who participated in test day!!
17:20:21 <strigazi> jberkus: I'll try this week to upgrade f26 -> f27 with kube 1.7.x in system containers.
17:20:45 <dustymabe> I'll do one more broad level topic
17:21:01 <jberkus> strigazi: great.  do deploy an app on kube first
17:21:01 <dustymabe> #topic how ready are we for fedora 27?
17:21:13 <jberkus> strigazi: what happened with me is that the upgrade succeded but the app went away
17:21:24 <dustymabe> what are high level things that are missing that we need done before we release fedora 27 ?
17:21:33 <dustymabe> jberkus: strigazi maybe move to #atomic?
17:21:55 <jberkus> dustymabe: we should update the plan for rolling upgrades
17:22:23 <dustymabe> jberkus: let's chat about that
17:22:44 <dustymabe> due to some technical limitations we still don't have a unified repo
17:22:56 * dustymabe finds link
17:23:05 <strigazi> dustymabe: a repo for what?
17:23:22 <jberkus> dustymabe: ok.  are those likely to get resolved in the f28 timeline?
17:23:27 <dustymabe> jberkus: yes
17:23:35 <jberkus> then we can update the plan with that
17:23:43 <dustymabe> #link https://fedoramagazine.org/fedora-27-atomic-cloud-test-day/
17:23:47 <dustymabe> sigh
17:23:49 <dustymabe> #unfo
17:23:51 <dustymabe> #undo
17:23:51 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2089fcd0>
17:23:56 <dustymabe> #link https://pagure.io/releng/issue/6984
17:24:17 <dustymabe> basically we realized we needed some finer grained control for pruning in ostree before we could create a unified repo
17:24:22 <dustymabe> some of that work has recently landed
17:24:28 <jberkus> great
17:24:32 <dustymabe> jberkus: do you have a link to the *plan* handy?
17:24:46 <jberkus> dustymabe: trying to remember where we put it.   blog, most likely
17:25:11 <dustymabe> while he searches - any other high level items we need to address before f27 release?
17:25:11 <jbrooks> https://www.projectatomic.io/blog/2017/06/future-plans-for-fedora-atomic-release-life-cycle/
17:25:39 <dustymabe> i.e. containerized kube work/docs, coordination with FLIBS on containerized kube ?
17:25:56 <dustymabe> is everything good to go from that perspective?
17:26:23 <jbrooks> Basically, we could use more predictable container image updates
17:26:33 <strigazi> +1
17:26:34 <jbrooks> But things are working
17:26:58 <jbrooks> The thing is, if a bug surfaces, it could take a long time to get an image out
17:27:09 <dustymabe> jbrooks: indeed. so most of the gaps are covered or known already?
17:27:23 <jbrooks> Esp since we only do it every two weeks, and if we miss the date, the default is to push it off for another two weeks
17:27:28 <jbrooks> Yeah
17:27:34 <dustymabe> if a bug surfaces we'll just have to work with adam for now to get an update out
17:27:40 <dustymabe> depending on how bad it is
17:27:47 <jbrooks> I really don't see the point of not doing image updates automatically
17:27:57 <dustymabe> i think that is the goal??
17:28:00 <jbrooks> I mean, other than that there's no automated way to do it :)
17:28:20 <jbrooks> OK, I thought we were married to the two week cycle
17:28:27 <dustymabe> ok, docs/versions/etc.. ?
17:28:54 <dustymabe> anything else we are missing
17:28:58 <jbrooks> I guess we need to decide where we want the docs
17:29:03 <dustymabe> jberkus: we should probably plan a few blogs around release time
17:29:14 <jberkus> yes
17:29:25 <jberkus> when's release expected?
17:29:31 <dustymabe> jberkus: if we have a bulleted list of what we want those to be we can probably assign them to people\
17:29:33 <strigazi> the blog are cool but it is becoming difficult to find them after some time
17:29:36 <jbrooks> Also, the whole question of kubeadm vs ansible and all the issues I talked about at flock -- not much discussion has happened on all of that
17:29:44 <strigazi> s/blog/blogposts
17:30:14 <dustymabe> strigazi: i don't disagree there. i think the new docs project will help with that
17:30:38 <jberkus> jbrooks: ... and I discussed this with the openshift installer team and things aren't going to get better
17:30:42 <dustymabe> jbrooks: release is expected end of this month
17:30:47 <dustymabe> or nov 7th if we slip a week
17:31:09 <strigazi> for f27ah right?
17:31:11 <dustymabe> s/jbrooks/jberkus
17:31:17 <dustymabe> strigazi: right
17:31:17 <jbrooks> dustymabe, I tell people to use ansible, ansible just works w/ system containers
17:31:28 <dustymabe> jbrooks: then go with that
17:31:35 <dustymabe> i don't have any objection there
17:31:59 <strigazi> I can contribute to a more manula version
17:32:09 <strigazi> with ansible is too much magic
17:32:18 <dustymabe> I forgot to do action items during the meeting
17:32:22 <strigazi> I think docs should be more educational
17:32:37 <dustymabe> #action dustymabe to update the rolling release plan with info about f27ah
17:32:46 <dustymabe> any other actions I missed
17:32:59 <dustymabe> darn I forgot to do action items at beginning of meeting too
17:33:04 <dustymabe> will circle back
17:33:46 <dustymabe> #action jberkus to identify and create issue with list of blog posts we want around f27 release time
17:33:58 <dustymabe> jbrooks: strigazi any action items for you?
17:34:18 <jbrooks> From this meeting? I guess
17:34:34 <jbrooks> #action jbrooks to go through remove-kube items and update
17:35:02 <strigazi> I can verify the upgrade f26 -> f27
17:35:19 <dustymabe> #action strigazi to do some testing around upgrades from f26 to f27 with kubernetes
17:35:28 <dustymabe> ok moving to action items from last meeting
17:35:28 <strigazi> thanks
17:35:33 <dustymabe> #topic previous meeting action items
17:35:50 <dustymabe> * jbrooks to submit asciibinder pkg for review
17:35:52 <dustymabe> * jberkus to follow up on partial container images from Flock
17:36:00 <jberkus> also docs
17:36:16 <dustymabe> jberkus: that one has been carried forward from previous meetings because you were on the road
17:36:39 <jbrooks> dustymabe, so, I got an asciibinder rpm building, I'm testing now w/ the openshift docs container, and I'm falling down a hole of ruby deps
17:36:46 <jbrooks> 7 more rpms needed so far
17:36:57 <jbrooks> They've all built easily in copr, but...
17:37:22 <jbrooks> I don't know if I want to take on maintainership of like 8 new ruby packages
17:37:29 <jberkus> jbrooks: feh
17:37:41 <jberkus> jbrooks: there is an official package, but it uses gem rather than rpm
17:37:50 <jberkus> er, official container
17:37:54 <jberkus> which is CentOS
17:38:05 <jberkus> so, how much do we care about having a fedora-based container?
17:38:22 <jbrooks> I personally don't care
17:38:30 <dustymabe> i leave that up to the maintainer to decide on
17:38:55 <dustymabe> i think we should have 'rings of copr'
17:39:03 <jberkus> my vote is that we mark it as an issue,and leave it up to a new contributor to take on
17:39:27 <dustymabe> jbrooks: i'd be interested in what the community thought about this problem
17:39:42 <dustymabe> would you consider a mail to fedora-devel about it?
17:40:01 <jbrooks> Yeah
17:40:06 <dustymabe> jbrooks: any update on your action item?
17:40:32 <dustymabe> #action jbrooks to email fedora-devel with issue of needed deps for asciibinder container in fedora proper
17:40:39 <jbrooks> you mean jberkus?
17:40:42 <dustymabe> jbrooks: yes
17:40:50 <dustymabe> *fail*
17:41:03 <jberkus> wait, fedora-devel?
17:41:24 <dustymabe> jberkus: yes, this is essentially a fedora issue
17:41:37 <dustymabe> new rpm maintainers hit this issue all the time
17:41:43 <jberkus> why would I email them?  I don't even know which deps are missing
17:41:58 <dustymabe> it's jbrooks' action item
17:42:01 <jbrooks> jberkus, me
17:42:10 <jbrooks> But then dusty was asking for an update on your item
17:42:18 <dustymabe> jbrooks: there was another message meant for you
17:42:30 <dustymabe> jberkus: any update on your action item?
17:42:41 <jberkus> which one?
17:42:47 <dustymabe> * jberkus to follow up on partial container images from Flock
17:42:58 <jberkus> ah, misunderstood your reply
17:43:08 <jberkus> this is my first week in the office, so starting follow-up not
17:43:10 <jberkus> now
17:43:31 <dustymabe> jberkus: i'll re-action?
17:44:08 <dustymabe> #action jberkus to follow up on partial container images from Flock
17:44:11 <dustymabe> #topic open floor
17:44:19 <dustymabe> anyone with any open floor topics?
17:44:31 <strigazi> more of a question
17:44:42 <jberkus> yes
17:45:02 <strigazi> we are going to move to a rolling model in fedora like in centos?
17:45:27 <strigazi> like the continuous repo in centos-atomic
17:45:44 <strigazi> if I understood the blogpost correctly
17:45:56 <strigazi> is there a timeline for that?
17:46:09 <strigazi> I'm refering to https://www.projectatomic.io/blog/2017/06/future-plans-for-fedora-atomic-release-life-cycle/
17:46:18 <jbrooks> strigazi, the centos continuous is a bit different, since it builds a bunch of things from source, rolling
17:46:41 <dustymabe> strigazi: more or less we are going to move to a model where people can track the latest fedora atomic host without having to do a rebase
17:46:43 <jbrooks> It will be more like how regular centos and rhel are -- they roll from point version to point version
17:46:55 <jberkus> strigazi: we discussed that earlier in the meeting ... we're planning on it for f27->28, there were technical issues which prevented it for this release
17:47:04 <jbrooks> I mean regular centos atomic and rhel atomic
17:47:54 <dustymabe> strigazi: does that answer the question?
17:47:57 <dustymabe> anyone else?
17:48:19 <strigazi> dustymabe: yes, thanks
17:48:42 <dustymabe> i'll wait a few minutes and then close out
17:48:45 <dustymabe> ooh actually
17:48:54 <dustymabe> i'll open a can of worms
17:49:31 <dustymabe> tomas and eliksa would like to join use for our meetings (they have been doing some work on containerizing more apps for FLIBS), but they have a conflict since this meeting is at 7pm at night for them
17:49:59 <dustymabe> it would be really good if we can get this meeting earlier in the day for them (and ksinny/kushal and others as well)
17:50:18 <dustymabe> the problem is that the mornings are busy for a lot of us
17:50:31 <dustymabe> with other meetings with teams in other countries
17:50:51 <dustymabe> so the best solution I can think of is to try to have the meeting earlier in the day and on a day where a lot of meetings aren't already scheduled
17:50:52 <jbrooks> Hmm
17:50:55 <jbrooks> How early?
17:51:09 <dustymabe> jbrooks: probably as soon as you wake up
17:51:12 <dustymabe> unfortunately
17:51:19 <jbrooks> So what time?
17:51:33 <dustymabe> i.e. 11AM eastern, so 8AM for you
17:51:41 <jbrooks> That's fine
17:51:51 <jbrooks> I do wake up a bit before that ;)
17:51:58 <jbrooks> Not much though :)
17:52:10 <dustymabe> :)
17:52:37 <strigazi> what is that in utc?
17:52:40 <dustymabe> another thing to note is that we don't switch with daylight savings
17:53:02 <dustymabe> so for people who observe daylight savings the meeting will move 1 hour here soon
17:53:07 <jberkus> dustymabe: earlier on wednesdays woudl be good for me
17:53:19 <jberkus> dustymabe: this timeslot is actually conflict-heavy now
17:53:21 <jberkus> so, +1
17:54:00 <strigazi> 15:00 UTC I guess
17:54:15 <dustymabe> $ date --utc --date="11AM EDT"
17:54:17 <dustymabe> Wed Oct  4 15:00:00 UTC 2017
17:54:29 <ksinny> +1
17:54:35 <jbrooks> So soon it'll be 7am
17:54:53 <dustymabe> jberkus: the goal would be to have it on a day where meetings aren't common, but I fear that depends on who you ask what days those are
17:55:38 <dustymabe> i have a conflict during that timespot on fridays
17:55:57 <ksinny> dustymabe: creating a doodle with various days and time option might help?
17:56:00 <dustymabe> either way it's not an easy problem to solve
17:56:10 <dustymabe> ksinny: yes, a doodle or whenisgood is probably required
17:56:28 <dustymabe> #action dustymabe to open ticket to consider changing meeting time of atomic wg meeting
17:56:42 <dustymabe> that's it for that topic and we are mostly out of time
17:56:53 <dustymabe> will close meeting in 2 minutes
17:58:23 <dustymabe> #endmeeting