19:30:18 <rbergeron> #startmeeting Fedora Board
19:30:18 <zodbot> Meeting started Wed Nov 21 19:30:18 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:30:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:30:22 <rbergeron> #meetingname Fedora Board
19:30:22 <zodbot> The meeting name has been set to 'fedora_board'
19:30:29 <rbergeron> #topic Who's here?
19:30:41 * abadger1999 here
19:30:45 * inode0 glances in
19:30:53 <rbergeron> #chair abadger1999 inode0
19:30:53 <zodbot> Current chairs: abadger1999 inode0 rbergeron
19:31:13 <gholms> Hai
19:31:50 <rbergeron> ke4qqq, nb, cwickert, jreznik, meety time
19:31:55 * quaid chilling
19:32:03 * jreznik is here
19:32:05 * pingou lurks around
19:32:08 <rbergeron> #info pbrobinson, sparks out for today
19:32:19 <rbergeron> #chair gholms jreznik
19:32:19 <zodbot> Current chairs: abadger1999 gholms inode0 jreznik rbergeron
19:33:03 <rbergeron> any other board peeps? not yet it looks like
19:33:07 * rbergeron will move on to agenda-ish things
19:33:11 <rbergeron> #topic Agenda for today!
19:33:11 <gholms> rbergeron: rackerhacker?
19:33:18 * gholms isn't sure when he starts
19:33:31 <rbergeron> gholms: everyone gets seated after the whole election thing
19:33:36 <gholms> Thanks
19:33:54 <rbergeron> otherwise toshio wouldn't be here ;)
19:34:00 <rbergeron> he'd be, like, partying or something.
19:34:01 <rbergeron> ;)
19:34:14 <abadger1999> Mm... pnot such a bad idea ;-)
19:34:22 <inode0> like it was 1999?
19:34:30 <abadger1999> You know it ;-)
19:34:52 <rbergeron> #info Today's agenda: Announcements, Open Q&A (bring us your questions/comments/flammable items!), FUDConny things, EOF.
19:35:01 * rbergeron has a hard stop in 1hr
19:35:21 <rbergeron> coolio?
19:35:27 <rbergeron> #topic Announcements
19:35:42 <rbergeron> jreznik: do you want to handle any schedule/release related notes here :)
19:36:25 <rbergeron> orrr... alternately.. inode0: are you interested in giving an election update?
19:36:36 <jreznik> rbergeron: for release related notes - the Go/No-Go is still scheduled for tmrw (even we have a big conflict with Thanksgiving)
19:37:07 <jreznik> one concern is secure boot - see https://fedorahosted.org/fesco/ticket/975
19:37:47 <rbergeron> #info Go/No-go is still scheduled for tomorrow (despite thanksgiving) - secure boot may still be an issue - pending voting on fesco ticket #975
19:37:52 <jreznik> otherwise we have one potential blocker bug (under testing right now) and of course, more teste coverage for fedup is still needed
19:38:20 <rbergeron> #info currently one potential blocker bug atm (in testing) and more coverage for fedup still needed
19:38:31 <jreznik> #info Fedora 18 Beta RC1 already available
19:39:14 <jreznik> that's the current status
19:39:18 <inode0> not much to report about elections - we have candidates, candidates have returned questionnaires, negotiating townhalls is in progress now
19:39:28 <inode0> seems to be on schedule as far as I can tell
19:39:28 * rbergeron nods
19:40:02 <rbergeron> #info Election stuff is on schedule per https://fedoraproject.org/wiki/Elections#Committee_Elections_Schedule - town halls will start approx. 26th so keep your eyes out for announcements
19:40:31 <jreznik> for SB - seems it could be Board bussines again for the worst case scenario in case we would not have signed shim for final...
19:40:47 <gholms> It could?
19:40:58 <gholms> That sounds more like a fesco thing to me.
19:41:05 <rbergeron> okee dokee. any other announcements? if not we'll move on
19:41:11 <rbergeron> #topic Open Q&A
19:41:43 <rbergeron> #info This is the fun part of the meeting where we take questions (and other things, comments, etc) from anyone in the meeting - feel free to raise your virtual hand and ask questions!
19:41:56 <quaid> !/?
19:41:57 * rbergeron officially opens the open floor
19:42:08 * rbergeron hands the microphone to one karsten wade
19:42:27 <rbergeron> go for it :)
19:42:34 <quaid> so I'm not sure what the question is here exactly, but it's in the form of "mother may I?"
19:42:40 <quaid> quick background is:
19:43:10 <quaid> my team at Red Hat was approached by a GNOME developer (Marina Z.) to see if we wanted to sponsor internships through GNOME's Outreach Program for Women
19:43:35 <quaid> we got some funds together with a few other groups at Red Hat (more on that eventually, when they want to decloak)
19:44:00 <quaid> for us, the ideal part is we open a PO to GNOME Foundation (already a vendor) and pay them, and GNOME Foundation handles all the hard part of the internships
19:44:28 <quaid> GNOME Foundation asked us to fund internships for Fedora, JBoss, DeltaCloud, and GNOME itself (iirc, off the top of my head)
19:44:39 <quaid> we said yes and pushed ahead
19:44:56 <quaid> and forgot that for Fedora involvement as a sponsor we should be bringing it to the Board first/early
19:46:11 * rbergeron tries to stick that into an info line somehow mentally
19:46:21 <quaid> tl:dnr for me about OPW: studies show that targetting groups specifically that are underrepresented helps them get involved, and we're at a state with women in FOSS where they are very underrepresented. This program has had good success in the last few years in greatly increasing short-term and ongoing participation by women in GNOME and FOSS in general
19:46:30 <quaid> rbergeron: totally!
19:46:49 <rbergeron> #info notes from quaid on the Fedora sponsorship of the gnome women's outreach program
19:47:08 <quaid> so at this point it's a done deal, Red Hat has agreed to do the internship and have the interns in the specificed projects
19:47:17 <quaid> s/specificed/specified/
19:47:50 <quaid> I'm pretty sure it's fine for us to troll around for mentors and projects, akin to GSOC and Google Code-In
19:48:08 <quaid> (and other get-new-people-involved Fedora initiatives)
19:48:11 <abadger1999> +1 to quaid's mother, may I :-)
19:48:13 * inode0 thinks it is better to act in good faith and worry about the fallout (if there is any later)
19:48:54 <quaid> question: Will the Board approve Fedora as a named 'sponsor' of GNOME OPW 2013, which includes use of the trademarked logo etc.?
19:49:03 * rbergeron nods - the one thing that concerns me with these situations sometimes is whether or not there are people actually available to do the mentoring and whatnot
19:49:06 <quaid> and also accept my aplogies for doing this backwards :(
19:49:33 <rbergeron> so we don't set people up for failure
19:49:51 <jreznik> I think it was already announced Fedora is part of the program, or not? /me saw such announcement
19:49:54 <inode0> Could we have a ticket opened for this?
19:49:54 <quaid> rbergeron: I'm not recalling specifically, but I think Marina has been doing some work in that regards; I can get back to you all to let you know how that works; don't want to cannibalize other efforts, etc.
19:50:10 <rbergeron> jreznik: yes, see all of quaid's above statements
19:50:24 <inode0> Mainly so folks can be on the record about anything they want to be on the record about.
19:50:40 <quaid> inode0: +1 will do
19:50:53 <quaid> #action quaid to file a ticket formally requesting the sponsorship of GNOME OPW 2013
19:51:01 <rbergeron> #chair quaid
19:51:01 <zodbot> Current chairs: abadger1999 gholms inode0 jreznik quaid rbergeron
19:51:15 * rbergeron isn't sure if actions work without chairings but gholms will answer that at any second
19:51:16 <gholms> rbergeron: You don't need to be a chair to use #action.  ;)
19:51:23 <gholms> rbergeron: Good guess.
19:51:23 <rbergeron> #info Robyn is psychic
19:51:25 <rbergeron> #undo
19:51:25 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x1083a950>
19:51:28 <quaid> jreznik: and I'm sorry about that, those of us involved who knew better never remembered to bring this to the Board
19:51:28 <gholms> Haha
19:51:40 <jreznik> rbergeron: it was hard to decrypt - well I don't see it would be good to our community to step back, so yeah - I think I'm +1 but next time it would be really great to know about it before it happens
19:51:41 <quaid> the fact that two of us are former Board members is even sillier
19:52:24 * abadger1999 decides not holding former-Board members' memories to higher standards is in his best interest ;-)
19:52:34 * rbergeron lols
19:52:34 <gholms> Heh
19:52:35 * jreznik heard very different feedback about the results of outreach program from different people, from positive to very negative...
19:52:51 <quaid> jreznik: I'll make a point that our team gets the "talk/ask Fedora Board" in to the proper slots in our process; we have some holes there still
19:52:55 <abadger1999> I think that mizmo asked if there were any infra coders that would be willing to mentor and had at least two who said they had time.
19:53:14 * rbergeron will go on the record to say that serving on the board is not necessarily the cause of memory issues
19:53:17 <abadger1999> So I think we have people on that front.
19:53:33 <inode0> I don't really want to make a strong point about talk/ask the board before acting - that pretty much goes against they way I think we should work.
19:54:13 <abadger1999> <nod>
19:54:23 <quaid> inode0: thanks, we needed to get the $ lined up anyway, but there's a reason somethings should be checked in - big announcements with our name being one.
19:54:41 <abadger1999> Do we want to vote now on: Will the Board approve Fedora as a named 'sponsor' of GNOME OPW 2013, which includes use of the trademarked logo etc.?
19:55:15 <inode0> sure, I agree this one talking with the board is a good way to proceed because of the advertising/trademark issues if not some political issues.
19:55:19 <rbergeron> yes, but i tihnk there's a fine line between "fedora is participating" (by virtue of the fact that someone is willing to do tihngs) and "fedora is a sponsoring organization of a wider effort" which implies a bit more organizationally - and if nothing else the logo is being used and whtanot
19:56:06 <quaid> inode0: do I read this correctly, I file a ticket by emailing advisor-board@? i.e. one of you with perms will make the actual Trac ticket?
19:56:24 <rbergeron> abadger1999: I think inode0 wanted to have it more on the record in a ticket - i could have misinterpreted that though
19:56:26 <inode0> you can open a trac ticket I believe
19:56:36 <quaid> https://fedorahosted.org/board/ ?
19:56:44 <abadger1999> quaid: yep
19:56:48 * gholms nods
19:56:48 <quaid> I don't have a [New Ticket] link
19:56:53 <abadger1999> quaid: login ?
19:57:01 <quaid> yep
19:57:14 * ke4qqq shows up late
19:57:42 <rbergeron> #chair ke4qqq
19:57:42 <zodbot> Current chairs: abadger1999 gholms inode0 jreznik ke4qqq quaid rbergeron
19:57:50 <rbergeron> hey there meeting secretary
19:58:01 <abadger1999> quaid: I'll create one and CC you on it.
19:58:38 <rbergeron> alrighty, shall we move on to other questions if we have any?
19:58:53 <rbergeron> #info thanks to quaid for bringing some questions/commentary :)
19:59:00 <ke4qqq> did I say I was here out loud?
19:59:06 * rbergeron saw pingou pop in at the beginning
19:59:13 <quaid> thx abadger1999
19:59:18 * pingou lurks has no real questions
19:59:21 <pingou> +but
19:59:22 * rbergeron dangles the bus keys in front of ke4qqq
19:59:31 <mjg59> Quick followup
19:59:38 <mjg59> The board is fine with fesco delaying F18 for Secure Boot?
19:59:38 <rbergeron> #chair mjg59
19:59:38 <zodbot> Current chairs: abadger1999 gholms inode0 jreznik ke4qqq mjg59 quaid rbergeron
19:59:46 <mjg59> (Should that become necessary)
20:00:06 <rbergeron> #info Question: is the board fine with fesco delaying F18 for secure boot (should that become necessary)?
20:00:14 <rbergeron> mjg59: I assume you mean "all of it" and not just the beta
20:00:26 <mjg59> Right
20:00:36 <mjg59> Obviously hoping that it won't be necessary
20:00:49 <mjg59> And we're now working on an alternative plan if RH legal continues to be a blocker
20:00:51 * jreznik would say beta and final are two different cases
20:00:52 <rbergeron> thankfully legal hell isn't a bureaucracy or anything
20:00:54 * ke4qqq thought that was why we had things like feature freeze so that delayed features wouldn't delay the release.
20:01:05 <gholms> I'm fine with that.  It isn't like the landscape has really changed since we last talked about it.
20:01:07 * abadger1999 is fine with fesco deciding to block or not block on Secure Boot getting its final pieces.
20:01:26 <mjg59> jreznik: How so?
20:01:44 <ke4qqq> jreznik: isn't delaying beta also delaying final?
20:01:59 <mjg59> ke4qqq: Well, we can certainly release an OS that won't install on any new computers, but it doesn't seem like a useful thing to do
20:02:19 <inode0> mjg59: I'm fine with fesco making that decision
20:02:33 <jreznik> ke4qqq: that's what I want to say - we can release beta without signed shim and in case we will get shim in time between beta/final, we can spin a new compose for testing
20:02:42 <abadger1999> mjg59: eh... that's still useful for all the non-new computers... and for people who fiddle things before trying to install.
20:02:48 <jreznik> so it does not automatically leads to final slip
20:03:01 <ke4qqq> jreznik: ahh I understand now.
20:03:07 <jreznik> but final is different case - I'd say, we really need SB
20:03:08 <abadger1999> so it seems like weighing the pros and cons of finishing feature vs slip more at that point.
20:03:12 <mjg59> abadger1999: If that's the board's idea of our target audience, we can do that
20:03:30 * jreznik has to admit there are so many W8 laptops around... expected slower start for @8
20:04:23 <jreznik> as I said - we can make it with unsigned beta... we can't with unsigned final
20:04:39 * inode0 doesn't want to define the board's target audience again - the project's target audience is defined
20:04:45 * rbergeron is okay with fesco dealing with it - i just hope to not have it be the case that we are still blocked on legal in 6m.
20:05:00 <ke4qqq> I am fine with letting fesco decide as well - though I have to say that some of the problems we've seen this release have led me to question whether fesco is handling the (admittedly less than perfect) feature process rigidly enough to produce the time-based releases that fedora is supposed to be shipping.
20:05:18 <abadger1999> mjg59: yeah, I'd rather have something that works on those computers, but I wouldn't slip F18 indefinitely for the subset of all the computers that F18 can be used on.
20:05:26 <pjones> ke4qqq: seriously?
20:05:40 <mjg59> ke4qqq: Turns out that shipping without an installer isn't an option
20:05:46 <abadger1999> mjg59: Do you happen to know whether legal is blocking for some specific concern vs "we just haven't looked at it hard enough" ?
20:05:56 <ke4qqq> mjg59: we had a perfectly functioning installer in f17
20:06:01 <jreznik> abadger1999: +1 to indefinite slip...
20:06:09 <pingou> ke4qqq: read devel recently?
20:06:20 <mjg59> abadger1999: My understanding is that they have specific concerns which are entirely related to Red Hat rather than Fedora
20:06:28 <mjg59> ke4qqq: Yes, and it doesn't run on F18
20:06:34 <gholms> ke4qqq: Yeah, and that installer doesn't work with F18.
20:06:35 <jreznik> abadger1999: contract negotiation
20:06:45 <mjg59> ke4qqq: So unless fesco's suddenly gained the ability to force people to do work that they don't want to do...
20:06:52 <ke4qqq> yes, but that's the point - massive change is theoretically controlled by fesco
20:06:54 <abadger1999> mjg59:  <nod>  thanks.
20:07:00 <ke4qqq> gated rather
20:07:14 <pjones> no, that's not actually true.
20:07:16 <mjg59> ke4qqq: We could have blocked newui landing in F18. And then we'd have had no installer.
20:07:20 <pjones> Features are gated by fesco.  Other changes are not.
20:07:44 <pjones> (not that I think that's at all relevant.)
20:08:49 * rbergeron thinks that secure boot seems to be a bit different - i think the feature from a technical and everything else standpoint was reasonably okay for feature freeze - the legal dramz are new, afaik.
20:08:59 <mjg59> ke4qqq: Secure boot has not delayed any part of the process so far. Deciding not to slip for it is equivalent to the feature having been rejected. The outcome is the same in both cases - F18 doesn't install on new hardware.
20:09:00 <jreznik> well - let's back to the question - a) do we require SB enabled beta, b) do we require SB enabled final, if yes - are we willing to wait "forever" for the resolution?
20:09:00 <drago01_> mjg59: "entirely related to Red Hat rather than Fedora" why does that block fedora then?
20:09:23 <mjg59> drago01_: Because Fedora isn't a legal entity with the ability to sign the contract
20:09:25 <jreznik> drago01_: contract is sign by Red Hat
20:09:36 <drago01_> mjg59: ok
20:09:44 <jreznik> so I expect there would be one contract for both Fedora/RHEL
20:09:47 <ke4qqq> jreznik: I don't think either are board issues - both seem well in domain of fesco
20:10:29 <jreznik> ke4qqq: on the other hand - it's not only technical issue but also about impact on the whole project
20:10:55 * rbergeron does have concern about if we don't have it at beta if it will be well-tested for final but knows fesco is dealing with those topics in ticket
20:11:14 <ke4qqq> yes, but many technical issues have that same impact - despite my frustrations that I voiced, I don't think the board can make a better decision than fesco can.
20:12:01 * abadger1999 agrees that these sem to be fesco issues.
20:12:09 <jreznik> rbergeron: yep, this is more technical issue for fesco (spin a test compose etc.) - for Board the question is - do we stand behind the decision to slip the release?
20:12:11 * gholms agrees as well
20:12:26 <abadger1999> The Board could get involved with helping to rewrite the Feature Process and how the Schedule matches up with the Feature process.
20:12:34 <inode0> at this point I prefer leaving this stuff to fesco, there may come a time where the board might want to nudge things along but I'm not there
20:12:37 <ke4qqq> abadger1999: +1
20:13:13 <abadger1999> but not the specifics of Feature X lagging behind in the schedule (IMHO)
20:13:20 <rbergeron> abadger1999: agreed, hence the "fudcon" item on schedule for this meeting but we're not quite there yet :)
20:13:33 <abadger1999> :-)
20:13:42 * pingou has some thoughts to write down
20:14:20 <pingou> (on a blog post or so)
20:14:21 <rbergeron> so are we all agreed that fesco has the ball here
20:14:24 * jreznik is ok to let fesco decide if the rest of Board is ok with that
20:14:36 <jreznik> but still... :)
20:14:46 <abadger1999> rbergeron: +1
20:14:48 <rbergeron> or is there a need for a disclaimer if we are a year out and we still don't have anything that we might nudge things along :)
20:15:09 <ke4qqq> we can always change our mind down the road :)
20:15:22 <abadger1999> heh, if it takes a year and fesco hasn't said ship anyway, we might have a new feature process to apply ;-)
20:15:33 <rbergeron> anyone -1?
20:16:03 <jreznik> rbergeron: well, we should communicate it to the community...
20:16:04 <rbergeron> #agreed FESCo has the ball on calling ship/block wrt secure boot in F18 for beta/final
20:16:20 <mjg59> Thanks
20:16:23 <rbergeron> mjg59: thanks for bringing it up.
20:16:36 <mjg59> No problem
20:16:40 <mjg59> Thanks for the feedback
20:17:15 <rbergeron> jreznik: did ou want to elaborate on that point for a moment before we move on
20:17:21 * rbergeron has to bail in 13m
20:17:41 <rbergeron> (though y'all are welcome to go on sans robyn, of course)
20:17:46 <jreznik> rbergeron: go on
20:18:02 * jreznik will think about it more :) and let you knwo
20:18:04 * gholms returns, apologizes for poor wireless connectivity
20:18:06 <rbergeron> Any other questions? :)
20:18:14 <rbergeron> going once, going twice...
20:18:33 <rbergeron> #topic FUDCon
20:18:49 <rbergeron> #info Hopefully everyone is signed up and has their hotel room booked for FUDCon Jan. 18-20
20:19:11 * pingou gloups
20:19:16 <rbergeron> #link http://fedoraproject.org/wiki/FUDCon:Lawrence_2013
20:19:35 <rbergeron> as abadger1999 mentioned: the whole "feature process revamp" ... well, it could use a nudge.
20:20:10 <rbergeron> And I think that FUDCon is a good place to do that wrangling, or at least put toether a reasonable option to bring to the community.
20:20:47 <rbergeron> So I guess the question is: Is anyone willing to spearhead that effort right now?
20:20:55 <rbergeron> gathering some steam around it, doing some pre-work, etc.
20:21:05 <rbergeron> Becaues I suspect there will be plenty of people around who are interested.
20:21:08 <rbergeron> :)
20:21:56 * rbergeron coughs and looks around
20:22:03 * ke4qqq would volunteer - but not sure I'll make fudcon
20:22:22 * jreznik is trying to do the pre-work
20:22:23 * gholms may not make it to fudcon in time
20:22:24 * rbergeron will be super jealous if it is becaues you are at devopsdays but... anyway
20:23:08 <rbergeron> jreznik: perhaps a blog post might move that along or gather some additional help?
20:23:09 <jreznik> well, I'm ok with taking care of it (suicide but) as feature wrangler
20:23:19 <rbergeron> lol
20:23:28 <gholms> Does that make you the feature wrangling wrangler?
20:23:47 * gholms apologizes for the horrible joke
20:24:01 <jreznik> rbergeron: yep, that's the plan - to blog about it, after the crazy beta sprint
20:24:44 * jreznik got fudcon budget ack today, wooohooo
20:24:48 * rbergeron nods
20:24:52 <rbergeron> jreznik: good ;)
20:25:41 <rbergeron> okay, so aside from that - i think people rae starting to do some self-organization as far as planning, so i hope to just see more :)
20:25:47 * rbergeron grins
20:26:30 <rbergeron> #topic Other business?
20:26:50 <rbergeron> #action jreznik to be pushing the feature process revamp post-beta time
20:27:39 <rbergeron> going once, going twice
20:27:54 * rbergeron wishes everyone a happy turkey day in teh US and a happy... thursday to everyone else :)
20:28:08 <pingou> happy thanksgiving to you
20:30:09 <gholms> Have a great Thursday either way!  :)
20:30:16 <rbergeron> okay folks - next board irc meeting is on.... dun dun dun....
20:30:17 * rbergeron looks
20:30:38 <rbergeron> #info Next board IRC meeting on 2012-12-05
20:30:58 <rbergeron> thanks to everyone for coming today :)
20:31:15 <abadger1999> thanks for running the meeting!
20:31:24 <inode0> darn, I had other business - see you next week
20:31:35 <abadger1999> meeting's not ended yet.
20:31:39 <gholms> I don't think it's ended yet.
20:31:46 <rbergeron> inode0: if you want to bring it up - go ahead
20:31:49 <inode0> people need to leave though, so it can wait
20:32:01 <inode0> sponsoring cobbler was the topic
20:32:08 <rbergeron> I'm the only one who has the urgent need to bail - you guys can handle the rest of it
20:32:19 * rbergeron is totally kosher with doing so for hte record
20:32:42 <rbergeron> but i need to be out the door right now so... if someone else can shut this down if you guys decide to discuss :)
20:33:27 <inode0> does anyone object to Fedora sponsoring Cobbler (a one time contribution for needed infrastructure) if there are no legal blockers?
20:34:20 <ke4qqq> cost?
20:34:33 * ke4qqq thinks it odd - one RHT-funded project sponsoring another RHT-funded project
20:34:37 <inode0> up to us - I was going to suggest $500
20:34:44 <inode0> RHT doesn't sponsor Cobbler any more
20:35:21 <inode0> they are working on raising $4000 for equipment, Euca is matching up to $2000
20:35:30 <ke4qqq> ahhh then by all means - we should sponsor - cobbler is awesome
20:37:47 * gholms nods
20:38:42 <gholms> So, do we vote on this / open a ticket / discuss this on the list / etc?
20:39:07 <ke4qqq> don't we still have a quorum here? if so lets decide here
20:39:27 <inode0> I'll open a ticket I guess so we can get legal feedback since there was a hint there might be some issue there.
20:40:09 <gholms> #action inode0 will open a ticket about funding Cobbler
20:41:05 <gholms> Anyone have anything else?
20:44:50 <gholms> I guess not.
20:44:59 * gholms will close in 1 minute
20:46:10 <gholms> Thanks for coming, everyone!
20:46:13 <gholms> #endmeeting