15:14:36 <davdunc> #startmeeting fedora_cloud_meeting
15:14:36 <zodbot> Meeting started Thu Mar 31 15:14:36 2022 UTC.
15:14:36 <zodbot> This meeting is logged and archived in a public location.
15:14:36 <zodbot> The chair is davdunc. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:14:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:14:36 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
15:14:50 <davdunc> #topic Roll Call
15:15:21 <davdunc> need more coffee.
15:16:09 * mhayden will be here until half past the hour
15:16:21 <davdunc> #chair mhayden
15:16:21 <zodbot> Current chairs: davdunc mhayden
15:18:02 <cmurf> .hello2
15:18:03 <zodbot> cmurf: cmurf 'Chris Murphy' <chris@cmurf.com>
15:18:14 <davdunc> #chair cmurf
15:18:14 <zodbot> Current chairs: cmurf davdunc mhayden
15:18:27 <davdunc> anybody else right now?
15:18:36 <davdunc> okay then...
15:18:57 <davdunc> #topic Action items from last meeting
15:19:09 * davdunc davdunc to track the 5.17 rebase and verify os-build is functional with ELN. (davdunc, 15:21:09)
15:19:54 <Eighth_Doctor> 👋
15:19:56 <Eighth_Doctor> .hello ngompa
15:19:57 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
15:19:57 <davdunc> There's nothing to report from the AWS side on the issue that caused the need for the change.
15:20:06 <davdunc> #chair Eighth_Doctor
15:20:06 <zodbot> Current chairs: Eighth_Doctor cmurf davdunc mhayden
15:21:54 <davdunc> so I don't have anything to report there except that the Xen team hasn't completed the updates. The need to revert the MSI-X patch is the same. As soon as they have completed the updates to 4.11, we no longer require the fix.
15:21:55 <dustymabe> .hi
15:21:56 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
15:22:03 <davdunc> #chair dustymabe
15:22:03 <zodbot> Current chairs: Eighth_Doctor cmurf davdunc dustymabe mhayden
15:22:36 <dustymabe> davdunc: do you know if the team is at least on the original schedule for the updates to 4.11 to be completed?
15:22:51 <davdunc> dustymabe: they have not changed their original dates.
15:23:40 <davdunc> so we should be on target for well before May.
15:24:44 <davdunc> next previous action item
15:24:53 * davdunc davdunc to package img-mash for the uploads (davdunc, 15:45:46)
15:25:14 <davdunc> I am still working on it. it's not hard, just time-constrained right now.
15:25:33 <davdunc> i think everything related to the F36 beta releases is more important right now.
15:26:15 <davdunc> but I'm not blocked on the effort, just the time.
15:26:41 <davdunc> so effort continues.
15:26:57 <davdunc> #action davdunc to package img-mash for use in the uploads.
15:27:03 <davdunc> reactioning this.
15:27:13 <davdunc> probably needs an issue filed. I'll do that too.
15:27:52 <davdunc> let's move on to the business side.
15:28:16 <davdunc> #topic F36 Release Checklist
15:28:21 <davdunc> #link https://pagure.io/cloud-sig/issue/357
15:28:35 <davdunc> What's on our readiness list?
15:28:41 <davdunc> We need a test day.
15:28:51 <davdunc> We don't have a scheduled testing day.
15:29:10 <mhayden> Let's do it -- happy to promote it
15:29:35 <davdunc> bcotton gave us a right scolding for not having images up for beta testing and I don't want to let that drop ever again.
15:29:56 * bcotton is not angry, just disappointed ;-)
15:30:17 <davdunc> I'll commit to ensuring that the images are in place in our cloud accounts within 24 hours of release.
15:30:40 <davdunc> bcotton: it's much appreciated. We want you to be happy.
15:31:05 <bcotton> davdunc: i don't want to to derail this meeting, but if it would be helpful to have tasks for Cloud on https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html, let's chat later
15:31:22 <davdunc> bcotton: this is perfect timing.
15:32:38 <davdunc> So we need the uploads completed (that's what img-mash is for so the priority is higher for me. I'll get that done tomorrow then.
15:32:40 <davdunc> )
15:32:58 <davdunc> we need a coordinated test day activity. I need help with that.
15:33:27 <davdunc> I honestly have just depended on the testing team to help us with that in the past.
15:34:31 <davdunc> We need a "call to action" announcement for the test day(s) to be published.
15:34:45 <davdunc> Anyone who can take up the former?
15:35:07 <davdunc> The validations are done, but we need to add additional ones for btrfs.
15:35:22 <mhayden> I can take up the announcement -- just need to dig up how the announcement was done last time
15:36:56 <davdunc> mhayden: In the past one of the QA team members updated the blog and added it there.
15:37:13 <davdunc> then we had it go out to the cloud and QA lists.
15:37:50 <mhayden> ah i see https://pagure.io/fedora-qa/issue/673
15:37:56 <davdunc> So I think we need to 1) establish a date. 2) update the testing details. 3) Announce it.
15:37:58 <davdunc> thanks.
15:38:09 <davdunc> yea. That's great.
15:38:18 <davdunc> #link https://pagure.io/fedora-qa/issue/673
15:38:24 <mhayden> oh my there's even a FAQ: https://fedoraproject.org/wiki/QA/Test_Days
15:38:30 <mhayden> i can tackle that one, davdunc
15:38:43 <dustymabe> mhayden++
15:38:44 <davdunc> mhayden: thanks! much appreciated.
15:38:45 <dustymabe> davdunc++
15:38:45 <zodbot> dustymabe: Karma for davdunc changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:38:55 <mhayden> ++dustymabe
15:38:59 <mhayden> 👀
15:39:07 <davdunc> no doubt!
15:39:17 <mhayden> davdunc++
15:39:17 <zodbot> mhayden: Karma for davdunc changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:39:45 <davdunc> okay, so now we know what needs to be completed to get us there. We need a release announcement too.
15:40:14 <davdunc> that's not for the beta though. we should cook something up in the cloud-sig repo.
15:40:34 <mhayden> CoreOS test days are Apr-04 to Apr-11
15:40:44 <davdunc> #mhayden to facilitate the testing day for cloud images
15:40:51 <mhayden> 👍🏻
15:41:00 <davdunc> #info CoreOS test days are Apr-04 to Apr-11
15:42:22 <davdunc> #action davdunc to publish beta images to ensure images are available in all our expected cloud providers
15:42:50 <davdunc> #action mhayden to facilitate the testing day for cloud images
15:43:03 <davdunc> okay.
15:43:33 <davdunc> #action to write or delegate a blog post for f36 release
15:43:45 <davdunc> #action davdunc to write or delegate a blog post for f36 release
15:44:18 <davdunc> okay. who can take on updating the tests to include the btrfs validations?
15:44:32 <davdunc> cmurf or Eighth_Doctor ?
15:44:40 <davdunc> i would really need your help there.
15:45:20 <davdunc> alright. we'll table that for now.
15:45:41 <davdunc> #info NEED: updated test cases for btrfs validations in cloud tests.
15:46:06 <cmurf> Yeah I can help with that
15:46:16 <davdunc> thanks cmurf
15:46:25 <davdunc> that would be fantastic.
15:47:10 <Eighth_Doctor> sorry I'm swamped still :(
15:47:12 <davdunc> #action cmurf to work on btrfs tests for cloud test day
15:47:49 <cmurf> Any quick "for instance" ideas?
15:47:51 <davdunc> Eighth_Doctor: we know you are working as hard as you can. :)
15:48:30 <davdunc> cmurf: just verifying partition sizes and ensuring that there isn't duplicated metadata would be great.
15:48:57 <cmurf> What do we want validated? Is btrfs t/f. Has subvolumes xyz t/f. Has btrfs-progs t/f.
15:49:12 <davdunc> yea. that's perfect.
15:49:49 <davdunc> also "is the size of the created volume t/f"
15:49:53 <cmurf> I'm not sure the image tools have a toggle for mkfs options
15:50:17 <davdunc> if not, we should add that to the things we need to produce.
15:50:26 <cmurf> I'll look into it but since btrfs-progs 5.15.0 the default is dup metadata
15:51:36 <davdunc> we need to make it work.
15:51:58 <cmurf> It's not bad, maybe not even suboptimal... They understanding these days is it's very small overhead to have self healing rather than a faceplant
15:52:14 <davdunc> indeed.
15:52:44 <cmurf> But I guess what are the expectations for cloud operations? Maybe a fail fast is better
15:53:13 <cmurf> Because your cloud provider having issues like this is bad :)
15:53:18 <davdunc> it is a fail-only architecture, to quote the handbook.
15:54:49 <Eighth_Doctor> I wouldn't worry about how the cloud provider is doing :)
15:55:34 <cmurf> single metadata will detect the problem, dup has a chance to correct with some small overhead
15:55:59 <cmurf> I can open a ticket and discuss the various issues there
15:56:00 <davdunc> we can try to maintain functionality, but it's true that there is always mirroring behind the scenes and failover disks behind every "block storage" device in the respective clouds.
15:56:31 <davdunc> dup is good as long as we can grow the fs to match the size of the volume the user creates.
15:56:49 <cmurf> No issue there
15:56:58 <davdunc> okay cool.
15:57:15 <davdunc> alright, we are close to time.
15:57:19 <davdunc> I have a hard stop.
15:57:46 <davdunc> anything else on the test requirements and f36 release calendar we need to include here?
15:58:12 <davdunc> #topic Open floor
15:58:24 <davdunc> anything anyone wants to discuss this week?
15:58:45 <mhayden> 🙊
15:58:56 <davdunc> :)
15:59:06 <davdunc> okay then.
15:59:17 <cmurf> Quick question, do we care about bootloaders other than grub? Yes no is fine
15:59:24 <cmurf> Can discuss details later
15:59:36 <davdunc> don't think so, not at this point.
15:59:54 <davdunc> dustymabe ^^
15:59:59 <cmurf> All archs too?
16:00:20 <davdunc> we have some internal to Red Hat owners for the power images.
16:00:31 <davdunc> they usually just tell us when things go wrong.
16:00:45 <cmurf> Oh right petitboot
16:01:04 <cmurf> Ok this is fine for now
16:01:07 <cmurf> Hard stop
16:01:14 <davdunc> we can get feedback on that and even bring on some testing if we need to.
16:01:20 <davdunc> yep. Thanks cmurf
16:01:30 <davdunc> okay everyone thanks for attending.
16:01:50 <davdunc> #endmeeting