15:03:48 <davdunc> #startmeeting fedora_cloud_meeting
15:03:48 <zodbot> Meeting started Thu Jul 21 15:03:48 2022 UTC.
15:03:48 <zodbot> This meeting is logged and archived in a public location.
15:03:48 <zodbot> The chair is davdunc. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:03:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:48 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
15:03:52 <dustymabe> .hi
15:03:55 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
15:03:57 <themayor> .hi
15:03:58 <zodbot> themayor: Sorry, but user 'themayor' does not exist
15:04:00 <davdunc> #chair dustymabe themayor
15:04:00 <zodbot> Current chairs: davdunc dustymabe themayor
15:04:57 <davdunc> matrix is getting you down themayor ?
15:05:04 <davdunc> #topic roll call
15:05:32 <themayor> Indeed. Figuring out why zodbot doesn’t know me
15:06:23 <dduffey> .hi
15:06:24 <zodbot> dduffey: dduffey 'None' <david.duffey@treeotech.com>
15:07:03 <jdoss> .hi
15:07:04 <zodbot> jdoss: jdoss 'Joe Doss' <joe@solidadmin.com>
15:08:46 <davdunc> chair dduffey
15:08:53 <davdunc> #chair dduffey
15:08:53 <zodbot> Current chairs: davdunc dduffey dustymabe themayor
15:09:00 <davdunc> long time dduffey !
15:09:09 <davdunc> #chair jdoss
15:09:09 <zodbot> Current chairs: davdunc dduffey dustymabe jdoss themayor
15:09:11 <dduffey> Just short of 18 months :)
15:09:14 <davdunc> :D
15:09:33 <davdunc> did I miss anyone?
15:09:35 <jdoss> hello all
15:09:55 <davdunc> jdoss: o/
15:10:29 <jdoss> davdunc: are you going to be at DevconfUS? if so I'd love to meet up.
15:10:41 <davdunc> #topic Action items from last meeting
15:11:00 <davdunc> jdoss: I will indeed. I'll be running a gameday for fun and prizes.
15:11:17 <jdoss> I'll holler at ya then. :)
15:11:31 <davdunc> I look forward to it!
15:11:48 <davdunc> so I was on vacation for a couple of weeks here. I am still playing catchup.
15:13:10 <davdunc> The image deployment tool mash is something I am working on , but I got stuck in a security escalation for the better part of a month related to the marketplace. That's over and everyone is reading the RHSA's and using the OVAL data to find the right fix for their CVEs.
15:13:47 <davdunc> I planned to file some tickets for the skds and libs that are missing, but that will just be forwarded to this week.
15:14:09 <davdunc> #action davdunc to file an issue in cloud-sig with the missing sdks and libs for mash
15:14:51 <davdunc> mhayden is busy today, so I am going to reaction his last action item too.
15:14:59 <davdunc> #action mhayden to make a first pass at a cloud image guidelines doc in the wiki marked as draft/RFC
15:15:32 <davdunc> and on the packaging group. mhayden created a group for us and now we need to determine what packages are a part of that group.
15:15:40 <mhayden> howdy -- I sent the first draft to the ML a few weeks ago 😉
15:15:48 <mhayden> (still on vacation here)
15:16:14 <davdunc> mhayden: enjoy the vacation. I'll catch up on the list and comment there. Everyone else please do the same.
15:16:27 <mhayden> 🫂
15:16:36 <jdoss> I wish I was still on vacation :|
15:16:45 <davdunc> seriously!
15:17:53 <davdunc> alright...
15:18:20 <davdunc> #topic Fedora 36 x86_64 Cloud Base AMIs
15:18:41 <davdunc> #link https://pagure.io/cloud-sig/issue/385
15:19:12 <davdunc> this is an issue that we had with the website.
15:19:45 <davdunc> but it brought up that we have some big gaps in our testing requirements and so I set up a testing category on the wiki.
15:20:04 <dustymabe> davdunc: what was the fix?
15:20:55 <davdunc> I pinged the website team and they were already aware of the miss on their process for slurping up the image ids and they had a fix in the works.
15:22:09 * davdunc so they fixed the issue themselves. I offered assistance, but they were in good shape.
15:22:32 <davdunc> (themayor I did that thing that works in slack but doesn't work in irc)
15:22:51 <themayor> yup i see
15:23:57 <davdunc> so the big deal that I saw was that the QA team just simply doesn't have enough tests from us. We could learn a thing or two from dustymabe and the fedora-coreos team on how to get a more diverse set of tests out there to get more reporting done.
15:24:11 <davdunc> so I would like to do that.
15:24:27 <dustymabe> davdunc: you still talking about the website?
15:25:24 <davdunc> dustymabe: really no. I am saying that we are an edition now and we need to act accordingly. adamw and team need us to build a better suite for the next generation of images.
15:25:44 * davdunc and that needs to be a strong priority for us.
15:25:48 <dustymabe> davdunc: ahh. I was confused because the $topic didn't change
15:26:21 <davdunc> it was really the same topic b/c it was the lack of testing that made that a user discovery instead of a team or QA discovery.
15:26:57 <dustymabe> hmm. I guess it depends on what the issue was.. but I doubt testing (at least automated testing) would verify the webiste had AMIs listed
15:27:10 <jdoss> Are we still using the same old method for creating images?
15:27:31 * davdunc not automated, no. The QA team has people who are following steps and reporting on success/failure. We need to set them up for success.
15:27:45 <davdunc> can't keep my finger off that control button.
15:28:23 <davdunc> I'll step off my soapbox and we can move onto the next topic.
15:28:38 <davdunc> dduffey themayor how would you like to title this
15:28:42 <davdunc> ?
15:29:03 <davdunc> #topic Cloud Images for Azure compute
15:29:08 <davdunc> how's that?
15:29:27 <themayor> sounds good
15:29:38 <davdunc> themayor: would you set the stage?
15:30:47 <themayor> yes sure. so Azure recently launched what is called 'Community Galleries'
15:30:49 <themayor> https://azure.microsoft.com/en-us/updates/communitygallerypreview/
15:31:04 <themayor> well, actually https://docs.microsoft.com/en-us/azure/virtual-machines/azure-compute-gallery#community
15:31:11 <davdunc> #link https://azure.microsoft.com/en-us/updates/communitygallerypreview/
15:31:28 <davdunc> #link https://docs.microsoft.com/en-us/azure/virtual-machines/azure-compute-gallery#community
15:31:35 <themayor> yes, sorry
15:31:40 <davdunc> all good!
15:32:00 <davdunc> #link https://src.fedoraproject.org/rpms/WALinuxAgent
15:32:23 <themayor> this is akin to Community AMIs and allows anyone to publish images for community consumption without the marketplace in the middle
15:32:36 * davdunc nice!
15:33:01 <themayor> After much discussion, it seems like all the barriers to getting Fedora images have no been removed and so all that's left to do it just build the bits
15:33:17 <themayor> s/no/now
15:33:51 <davdunc> well you just gave us a high priority target themayor
15:33:56 <themayor> correct, the major requirement for the images is WALinuxAgent to enable the provisioning to work properly
15:34:39 <themayor> If someone can help with the bits, I can help with lots of the other things, including a *nice* marketing announcement
15:35:35 <davdunc> super. I think I can pull together a ks.cfg for this pretty quickly. if I run into any blockers, I know I can beg Neal for help.
15:35:45 <dduffey> I can help.
15:35:55 <themayor> dustymabe and I submitted a CfP to Flock/Nest as well to talk about it
15:35:56 <davdunc> dduffey: do you want to jump in there?
15:36:16 <davdunc> excellent.
15:36:30 <davdunc> do we already have an issue in the queue?
15:36:45 <themayor> I haven't opened one, not sure if dustymabe has or not
15:36:56 <dduffey> My team works on cloud-init, but we work closely with the walinuxagent and gallery team
15:36:56 <dustymabe> I haven't opened any issues
15:37:04 <davdunc> themayor: I can put it on the list.
15:37:56 <dduffey> walinuxagent is not technically required but you would be missing some Azure functionality
15:38:00 * davdunc dduffey: that makes sense. How about we collaborate? It gives me an excuse to bug you some and we get more hands.
15:38:31 <davdunc> dduffey since the agent is already packaged and we can just bring it in, it only seems reasonable.
15:38:33 <themayor> dduffey is correct on walinuxagent, but I think it would be a *far* better experience with it
15:39:01 <themayor> davdunc: yes might as well, there isn't a tremendous amount of effort that needs to be done
15:39:07 <davdunc> part of the reason we have a cloud edition is to manage and maintain the requirements for the specific cloud providers.
15:40:13 <davdunc> if we aren't doing that, It's just an image without a firewall.
15:40:36 <davdunc> okay.
15:41:00 <davdunc> #action Add Azure Images to the build for cloud edition
15:41:13 <dduffey> Agree.  We are also thinking about bringing some functionality from walinuxagent into cloud-init (like firewall).  We are open to ideas.
15:42:05 <davdunc> dduffey: I like the idea of making the functionality of walinuxagent portable to cloud-init and the cloud.cfg for sure.
15:42:43 <davdunc> but I will have to review it more to give a longer commentary. Happy to jump in there and give you my $0.02
15:43:16 <davdunc> dustymabe: do you think we need to vote on this or do you think it's just basically in our PRD?
15:43:53 * davdunc looks around the room and thinks there's nobody that isn't +1 to the idea.
15:44:45 <dustymabe> davdunc: i'm ok with what is being discussed I think
15:45:02 <davdunc> I personally don't think that we are missing any support here and I don't think it falls outside of the cloud edition charter.
15:45:43 <dduffey> I think it makes sense to have walinuxagent included in CE / gallery, if that is the question.
15:46:32 <davdunc> thanks dduffey I think so too, but I am going to introduce that as a separate topic as I don't want to step on any packager's toes since this is in flight already.
15:46:51 <davdunc> I hate it when people make decisions for me like that.
15:47:37 <davdunc> so I want to have vittyvk in the voting and make sure that we are including the maintainer
15:47:59 <dduffey> sounds great
15:48:51 <davdunc> #action davdunc to invite vittyvk to the next fedora_cloud_meeting for including the walinuxagent in the CE packages
15:49:30 <davdunc> themayor: I'll add a link and start working on the ks.cfg tomorrow.
15:49:48 <dduffey> #action dduffey to invite Christopher P. to the next fedora_cloud_meeting for including the walinuxagent in the CE packages
15:49:54 <davdunc> then we can add the credentials and do a video on manually adding the images - dustymabe that sound good to you?
15:50:44 <themayor> Thanks davdunc
15:50:46 <davdunc> themayor dduffey thanks for being here today and making this happen. This is great!
15:51:08 <davdunc> #topic open floor
15:51:19 <davdunc> Anything else we need to cover today?
15:52:14 <davdunc> #link https://communityblog.fedoraproject.org/nest-with-fedora-2022-registration-now-open/
15:52:28 <davdunc> #info Nest with Fedora 2022 registration is open
15:52:35 <dustymabe> davdunc: sounds good
15:52:41 <davdunc> thanks dustymabe
15:53:27 <davdunc> I am looking forward to Nest this year. I may be able to use our lightboard at work for my presentation!
15:54:12 <davdunc> okay then ... I am excited and happy about this meeting. I feel like we have some fun times just ahead!
15:54:26 <davdunc> Thanks everyone for coming!
15:54:43 <davdunc> themayor++
15:54:43 <zodbot> davdunc: Karma for jack changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:54:48 <davdunc> dduffey++
15:54:48 <zodbot> davdunc: Karma for dduffey changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:55:04 <davdunc> #end_meeting
15:55:09 <themayor> Thank You all!
15:55:14 <davdunc> I did that wrong.
15:55:18 <davdunc> #endmeeting