16:02:53 <davdunc[m> #startmeeting fedora_cloud_meeting
16:02:53 <zodbot> Meeting started Thu Jan 19 16:02:53 2023 UTC.
16:02:53 <zodbot> This meeting is logged and archived in a public location.
16:02:53 <zodbot> The chair is davdunc[m. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:02:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:53 <zodbot> The meeting name has been set to 'fedora_cloud_meeting'
16:02:55 <themayor> Hi all
16:03:16 <cmurf> .hello2
16:03:16 <davdunc[m> #topic roll call
16:03:16 <zodbot> cmurf: cmurf 'Chris Murphy' <chris@cmurf.com>
16:03:18 <davdunc[m> excellent to see you cmurf !
16:03:20 <cmurf> do we have a bot?
16:03:25 <cmurf> .hello
16:03:25 <zodbot> cmurf: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
16:03:26 <davdunc[m> #chair cmurf
16:03:26 <zodbot> Current chairs: cmurf davdunc[m
16:03:43 <davdunc[m> looks like we are missing the bot.
16:03:52 <mhayden> .hi
16:03:54 <zodbot> mhayden: mhayden 'Major Hayden' <mhayden@redhat.com>
16:04:01 <cmurf> nirik we seem to be missing the bot
16:04:08 <spotz> .hi
16:04:09 <zodbot> spotz: spotz 'Amy Marrich' <amy@redhat.com>
16:04:13 <cmurf> no bot, no log
16:04:16 <spotz> :)
16:04:32 <mhayden> 😢
16:04:43 <davdunc> yea.
16:04:51 <cmurf> here we go
16:05:00 <davdunc> #chair cmurf mhayden
16:05:03 <cmurf> maybe it's just slow?
16:05:03 <nirik> no? it's just the irc<->matrix bridge is slow
16:05:06 <davdunc> #chair spotz
16:05:09 <cmurf> oh
16:05:26 <davdunc> #chair themayor
16:05:46 * davdunc yea. I moved back to the irc for the meeting.
16:05:47 <Eighth_Doctor> .hello ngompa
16:05:49 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
16:05:54 <davdunc> #chair ngompa
16:06:09 <Eighth_Doctor> that's probably  not going to work :)
16:06:40 <themayor> Lol
16:06:55 <davdunc> #chair Eighth_Doctor
16:06:59 * davdunc will that?
16:07:10 <Eighth_Doctor> well, it should
16:07:28 <Eighth_Doctor> but zodbot doesn't seem to be responding to you?
16:07:56 <davdunc> that's weird.
16:08:36 <davdunc[m> #chair Conan Kudo
16:08:36 <zodbot> Current chairs: Conan Kudo cmurf davdunc[m
16:08:52 <Eighth_Doctor> there we go
16:08:57 <davdunc[m> ah. My alias is wrong on irc.
16:09:04 <davdunc[m> frustrating!
16:09:12 <Eighth_Doctor> oh interesting
16:09:21 <Eighth_Doctor> zodbot did a weird
16:09:27 <Eighth_Doctor> #chair Eighth_Doctor
16:09:30 <davdunc[m> #chair spotz mhayden themayor
16:09:30 <zodbot> Current chairs: Conan Kudo cmurf davdunc[m mhayden spotz themayor
16:09:41 <davdunc[m> who am i missing?
16:09:43 <Eighth_Doctor> okay, not a chair still
16:09:56 <Eighth_Doctor> try using Eighth_Doctor (that's what IRC knows this ID to be)
16:10:17 <davdunc[m> #chair Eighth_Doctor
16:10:17 <zodbot> Current chairs: Conan Eighth_Doctor Kudo cmurf davdunc[m mhayden spotz themayor
16:10:26 <Eighth_Doctor> there we go
16:10:36 <Eighth_Doctor> #unchair Conan Kudo
16:10:36 <zodbot> Current chairs: Eighth_Doctor cmurf davdunc[m mhayden spotz themayor
16:10:39 <davdunc[m> ah. "Conan" and "Kudo"
16:10:55 <Eighth_Doctor> we need a Matrix native bot :)
16:10:55 <davdunc[m> :) okay it's looking better.
16:11:09 <davdunc[m> true.
16:11:20 <Eighth_Doctor> maybe a GSoC idea?
16:11:22 <davdunc[m> Okay!
16:11:42 <davdunc[m> Welcome!
16:12:07 <davdunc[m> #topic action items
16:13:42 <davdunc[m> well, there are a lot of action items.
16:13:56 <davdunc[m> I am having difficulty getting to the list.
16:15:17 <davdunc[m> I'll give an update on the work on integrating mash
16:15:46 <davdunc[m> working on refactoring for plugins, but want to find a fast way to completion.
16:16:32 <themayor> Can someone link the agenda?
16:17:12 <davdunc[m> https://pagure.io/cloud-sig/issues?tags=meeting
16:17:21 <davdunc[m> that's after the action items.
16:18:34 <davdunc[m> #info davdunc working on the mash integration for image uploads.
16:18:43 <davdunc[m> okay.
16:19:59 <davdunc[m> it doesn't install cleanly on Fedora as there are a lot of packages that don't match up with the Fedora requirements just yet.
16:21:16 <davdunc[m> other previous action items:
16:21:22 <davdunc[m> #info Images for the Azure Marketplace
16:21:22 * dustymabe lurks
16:21:36 <davdunc[m> #chair dustymabe
16:21:36 <zodbot> Current chairs: Eighth_Doctor cmurf davdunc[m dustymabe mhayden spotz themayor
16:21:49 <davdunc[m> Glad to have you here dustymabe
16:22:14 <davdunc[m> themayor: lets discuss what we need to do to get the Azure images up.
16:22:24 <davdunc[m> dduffey: are you around?
16:23:21 <davdunc[m> dustymabe: do you have creds you can use to push those up already?
16:24:12 <dustymabe> davdunc[m: we have an Azure account (subscription) that we're using for FCOS. It's intended to also be used for cloud stuff
16:24:36 <dustymabe> I hesitate to do things manually, though
16:24:54 <davdunc[m> okay. Great. Let's determin if we can use the same process you are using now to get it done.
16:24:59 <dustymabe> would be nice if we had some automation in place and do the uploads from that (less human error)
16:25:57 <davdunc[m> and human timelines
16:26:39 <davdunc[m> okay
16:27:27 <davdunc[m> #action davdunc to work with dustymabe to upload images to Azure Marketplace
16:27:40 <davdunc[m> did that work?
16:28:09 <davdunc[m> #topic 394 cloud-init output not displayed on aarch64
16:28:53 <davdunc[m> I haven't reproduced this, but does this stick out as an obvious problem to anyone?
16:29:03 <dustymabe> davdunc[m: right now for FCOS we're just creating images and testing them, but not sharing them. So we have the ability to create the images, but we haven't got to the point where we are implementing the community gallery/sharing just yet
16:29:15 <dustymabe> it's on our list of things
16:29:39 <davdunc[m> dustymabe: I see.
16:29:47 <dustymabe> https://github.com/coreos/fedora-coreos-tracker/issues/148#issuecomment-1156644573
16:29:52 <themayor> Yes
16:29:53 <davdunc[m> we'll look into it then and see how we can work on this together.
16:30:07 <dustymabe> I poked around with it at one point, but then other things dragged me back away from it
16:30:49 <dustymabe> themayor: I know one step in the process that I did a PoC on required X.Y.Z versioning to be used. and in FCOS we have a X.Y.Z.A
16:30:52 <davdunc[m> understood.
16:30:57 <dustymabe> I don't know if that got relaxed yet or not
16:33:20 <davdunc[m> #link https://pagure.io/cloud-sig/issue/399
16:33:33 <davdunc[m> I just put together a tracking ticket.
16:35:47 <davdunc[m> okay. so we can work with you on that.
16:36:01 <davdunc[m> #link https://github.com/coreos/fedora-coreos-tracker/issues/148#issuecomment-1156644573
16:37:07 <davdunc[m> Are we code complete on the WAAgent patches we wanted to add to the RPM?
16:38:12 <davdunc[m> In working with dustymabe and the coreos team on the 6.2 kernel testing, there was some complications discovered in the cloud image creation.
16:40:41 <davdunc[m> okay. moving from this topic.
16:40:52 <themayor> Oh wow
16:41:01 <themayor> Any details on complications?
16:41:55 <davdunc[m> themayor: yea. we aren't enabling the full networking when using the intel enhanced networking when we upload them. but we can review that in  the next topic.
16:42:38 <themayor> Sure
16:42:50 <davdunc[m> we had the patch requirements for the waagent and I was wondering if that was in-place or if we needed to initiate the pull request to tie this one up?
16:43:10 <davdunc[m> Conan Kudo: do you remember/know?
16:43:48 <davdunc[m> okay moving on.
16:44:38 <davdunc[m> #topic 396 provide unversioned cloud images
16:45:26 <davdunc[m> eskultety brought this one to the meeting request
16:45:40 <davdunc[m> #link https://pagure.io/cloud-sig/issue/396
16:46:55 <davdunc[m> In my opinion, we should continue to use the major release.
16:49:10 <davdunc[m> A "fedora latest" designation doesn't seem consistent with our release process
16:49:49 <davdunc[m> it seems like that would be like saying CentOS/Latest and getting 9 the next time you want to deploy when you are using 8.
16:53:02 <davdunc[m> Are we making enough images to have a "latest"?
16:53:19 <davdunc[m> right now, I don't think so.
16:55:36 <davdunc[m> okay.
16:55:46 <davdunc[m> #topic open floor
16:55:55 <davdunc[m> Anyone have anything that they want to bring up?
16:58:23 <davdunc[m> #info Conan Kudo and I submitted a talk on Fedora Image building for Summit
16:59:19 <davdunc[m> #info CFP for Devconf.cz is coming up, we should keep our eyes out for that.
16:59:43 <davdunc[m> #info mhayden and I are working on the AWS SSM agent RPM efforts.
17:00:01 <davdunc[m> #endmeeting