16:57:53 <roshi> #startmeeting
16:57:53 <zodbot> Meeting started Fri Oct 10 16:57:53 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:57:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:58:01 <roshi> #meetingname Fedora Cloud WG
16:58:01 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
16:58:41 <roshi> #topic roll call
16:58:42 <dustymabe> .hellomynameis dustymabe
16:58:43 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@gmail.com>
17:00:01 <roshi> .hellomynameis roshi
17:00:02 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
17:00:16 <roshi> #chair dustymabe
17:00:16 <zodbot> Current chairs: dustymabe roshi
17:00:51 <dustymabe> roshi: looks like we have complete control
17:00:59 <roshi> muahaha!
17:01:29 <roshi> we can wait for people to show up
17:01:43 <kushal> .hellomynameis kushal
17:01:44 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
17:02:08 <scollier> .hellomynameis scollier
17:02:09 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:02:09 <kushal> roshi, dustymabe I will propose to move the meeting to some other day :p
17:02:36 <roshi> yeah, 2230 on a Friday night isn't fun
17:02:59 <dustymabe> kushal: you should vote
17:03:04 <dustymabe> #link http://whenisgood.net/recw7mb
17:03:22 <dustymabe> man.. what is the keyword for zodbot?
17:03:41 <roshi> which keyword?
17:03:56 <dustymabe> to add a link to the meeting notes? was I right?
17:04:30 <roshi> yeah, that's it
17:04:35 <roshi> meetbot picked that up
17:04:38 <dustymabe> ok. cool
17:04:48 <kushal> roshi, you have to add us to chair :)
17:05:04 <roshi> #chair kushal scollier
17:05:04 <zodbot> Current chairs: dustymabe kushal roshi scollier
17:05:09 <dustymabe> should we ping mattdm, etc ?
17:05:13 <roshi> I already added dustymabe
17:05:19 <roshi> I pinged im in cloud
17:05:30 <roshi> number80 said he'd be a bit late
17:06:38 <roshi> #topic Previous meeting follow up
17:07:29 <roshi> we'll skip jzb's items, unless someone has something for them
17:07:38 <roshi> #link http://meetbot.fedoraproject.org/fedora-meeting/2014-10-03/fedora-meeting.2014-10-03-17.01.html
17:07:41 <roshi> for the list
17:08:27 <roshi> mattdm to take changes in Fedora Cloud Working Group Governance Structure to FESCo once accepted.
17:08:52 <roshi> did we get enough votes on that draft?
17:09:07 * number80 waves
17:09:12 <dustymabe> roshi.. I don't know. Did we have to vote on the ticket?
17:09:19 <roshi> #chair number80
17:09:19 <zodbot> Current chairs: dustymabe kushal number80 roshi scollier
17:09:25 <kushal> roshi, I guess on mailing list yes.
17:09:42 <roshi> yeah, there were votes on the mailing list
17:10:16 * danofsatx is observing as an interested party
17:10:42 * jsmith shows up late...
17:10:58 <roshi> #chair jstephan
17:10:58 <zodbot> Current chairs: dustymabe jstephan kushal number80 roshi scollier
17:11:04 * roshi is trying to find the thread
17:11:20 * mattdm is here
17:11:26 <kushal> #chair mattdm
17:11:26 <zodbot> Current chairs: dustymabe jstephan kushal mattdm number80 roshi scollier
17:11:32 <kushal> #chair jsmith
17:11:32 <zodbot> Current chairs: dustymabe jsmith jstephan kushal mattdm number80 roshi scollier
17:11:37 * agrimm is here
17:11:42 <roshi> #chair agrimm
17:11:42 <zodbot> Current chairs: agrimm dustymabe jsmith jstephan kushal mattdm number80 roshi scollier
17:11:54 <dustymabe> agrimm: welcome
17:12:30 <roshi> mattdm: did you get what you need for taking the WG Governance change to fesco
17:12:33 <roshi> ?
17:13:20 <dustymabe> while we are waiting.. now that more people are here please vote for a new meeting time: http://whenisgood.net/recw7mb
17:13:31 <roshi> good call dustymabe
17:14:09 <mattdm> roshi yes, I think so
17:14:14 <roshi> awesome
17:14:23 * jsmith already voted for new times
17:14:32 <roshi> after fesco says go then the new slate is official?
17:14:43 <roshi> or are we already?
17:15:03 <mattdm> roshi: I'm going to put it through the hoops -- file a ticket and ask (by email) the old slate to vote
17:15:19 <mattdm> In retrospect, should not have put so many hoops.
17:15:25 <mattdm> It sounded good at the time :)
17:15:27 <roshi> that's what I thought, but couldn't remember where it landed :)
17:15:29 <scollier> dustymabe, voted.
17:15:41 <number80> mattdm: let's put a timeout, if you don't vote, it will be considered as +0
17:15:42 <jsmith> mattdm: I hear hula hoops are on sale if you buy six at a time :-)
17:16:04 <kushal> jsmith, :)
17:16:07 <mattdm> number80 yeah but the current rules say +5 needed to pass. just tryin' to do it by the rules
17:16:15 <roshi> the next action items are about atomic test days, which is still up in the air for a date
17:16:21 <number80> yup but it will be hard to reach some people :/
17:16:26 <mattdm> if that doesn't work, I'll take it to fesco and say that we couldn't get any response please override
17:16:29 <mattdm> which fesco can do.
17:16:51 <mattdm> in any case I think it's really a formality and shouldn't impede (or distract from)
17:16:55 <mattdm> actual ongoing work
17:16:59 <number80> *nods*
17:17:13 <roshi> makes sense, and following the rules is what differentiates us from the animals, right?
17:17:23 <mattdm> #action mattdm to take jzb's proposed changes to ticket and then to fesco
17:17:34 <roshi> sweet
17:17:36 <mattdm> roshi: heh.
17:17:39 <roshi> next on the list - roshi wait until next week for feedback on ticket 77 then move forward.
17:18:12 <mattdm> ps: since I didn't put myself on the slate I'm not going to vote on the new time but I will still try to show up for meetings
17:18:22 <roshi> all the feedback was good (on list) so I'll add it to the criteria
17:18:26 <roshi> if I haven't already
17:18:56 <kushal> mattdm, Am I in that list?
17:19:14 <roshi> it was never decided idt
17:19:18 <kushal> Something the current team will have to decide.
17:19:22 <mattdm> kushal: you aren't yet. yeah.
17:19:23 <kushal> roshi, Yes.
17:19:39 <roshi> last I remember was we were trying to decide what to do to you to make you earn it :p
17:19:47 <mattdm> exactly :)
17:19:50 <roshi> I mean, we all went through some grueling tests
17:19:55 <roshi> both physical and mental
17:20:02 <roshi> the bear boxing was the most fun, IMO
17:20:11 * mattdm thinks https://github.com/fedora-cloud/cloudtoserver is a good start :)
17:20:20 <mattdm> it's no bear-boxing, though
17:20:26 * gholms can contribute a sanctified goat if needed
17:20:37 * roshi was just looking at that - but will bring it up at Open Floor
17:20:41 <kushal> gholms, Thanks for the help :)
17:21:13 * number80 will test it
17:21:26 <roshi> me has no problem with kushal being on the list (especially since he's going to be working this full time)
17:21:37 <number80> I don't have any
17:21:38 <roshi> s/me//me
17:21:38 <dustymabe> +1
17:22:00 <mattdm> i'm +1 to it for the record :)
17:22:20 <roshi> aight gotta move through these action items or we won't finish in time :)
17:22:20 <roshi> kushal and roshi to work on Ticket 38 on Automatic Smoketests on Image Build w/an eye towards completion for Fedora 22.
17:22:39 * danofsatx is kind of glad he's not volunteering
17:22:42 <roshi> unless I'm doing things in my sleep again, I haven't linked up with kushal regarding this :)
17:22:48 * gholms gives roshi an #action
17:23:01 <roshi> don't worry danofsatx, we'll eventually get you
17:23:06 <roshi> ;)
17:23:21 <danofsatx> I can run.....about 10 steps ;)
17:23:23 <gholms> (you forgot to use one)
17:23:44 <roshi> #action roshi to link up with kushal and talk about smoketests
17:23:48 <roshi> roshi remind Cloud SIG about blocker review meetings.
17:24:07 <roshi> while I forgot to mail the list, I did ping the channel and will continue to do so
17:24:18 <roshi> number80 set a poll to change WG meeting date
17:24:28 <roshi> that's been done and people have voted
17:24:30 <number80> roshi: actually it's dustymabe
17:24:43 <roshi> just copypasting from minutes :)
17:26:03 <roshi> onto the meeting tickets
17:26:06 <roshi> #topic Smoketests on Image Build
17:26:07 <kushal> roshi, yup, I will drop you a mail on Monday.
17:26:19 <roshi> #link https://fedorahosted.org/cloud/ticket/38
17:26:24 <roshi> sounds good to me
17:26:28 <number80> roshi: well, I don't take credit from others ;)
17:26:39 <roshi> I'll be on a bit over the weekend as well
17:26:44 <dustymabe> number80: thanks
17:26:47 <roshi> lol, good call number80 :)
17:27:34 <roshi> nothing really to discuss for this ticket, moving on
17:28:08 <roshi> #action kushal to email roshi
17:28:20 <roshi> #topic Atomic Test Day
17:28:25 <roshi> #link https://fedorahosted.org/cloud/ticket/74
17:29:12 <roshi> I know we're waiting on a package to be ready
17:29:16 <roshi> for arm, I think
17:30:00 <roshi> without jzb here, not much to go off of
17:30:06 <roshi> anybody have anything for this ticket?
17:30:54 * jsmith has nothing on it
17:31:14 <kushal> Was disconnected
17:33:22 <dustymabe> roshi: I don't have anything for now
17:33:24 <dustymabe> next item?
17:33:30 <roshi> we're still waiting on a date, and I'll work with jzb onces the date is decided
17:33:58 <roshi> #action roshi to coordinate with jzb for Atomic testday once we have a date
17:34:01 <number80> ok
17:34:41 <roshi> #topic State of Cloud article
17:34:44 <roshi> #link https://fedorahosted.org/cloud/ticket/75
17:35:05 <roshi> I think this is just in a holding pattern until beta release
17:35:51 <dustymabe> agreed
17:36:16 <kushal> Yes.
17:36:28 <jsmith> I'll use that as the basis for my "Cloud" beat in the release notes :-)
17:37:00 <roshi> #topic Cloud image updates
17:37:16 <roshi> #link https://fedorahosted.org/cloud/ticket/51
17:37:26 <roshi> doesn't look like this was done
17:37:39 <roshi> ticket says to poke him today
17:38:01 <roshi> #action roshi to poke jzb regarding updating the wiki for cloud updates
17:38:10 <jsmith> I may try to help out with this as well
17:38:26 <jsmith> I had an interesting discussion with some of the folks on the Fedora Security Team about this subject
17:38:41 * jsmith adds this to his "things to write on a plane" list...
17:38:51 <roshi> what came up in that discussion?
17:39:12 <jsmith> roshi: Mostly some ideas for coordinating the "when to reroll" part of the discussion
17:39:32 <roshi> sounds good
17:39:35 * mattdm notes that he got pulled into something else. will read logs later
17:39:35 <jsmith> When to send the bat-signal, so to speak :-)
17:39:50 <roshi> no worries mattdm
17:39:59 <roshi> #undo
17:39:59 <zodbot> Removing item from minutes: ACTION by roshi at 17:38:01 : roshi to poke jzb regarding updating the wiki for cloud updates
17:40:26 <roshi> #action roshi and jsmith to poke jzb about cloud updates documentation
17:40:38 <jsmith> WORKSFORME
17:41:07 <roshi> #action jsmith to coordinate with jzb about the feedback from the security team
17:41:20 <roshi> #topic Release Criteria
17:41:22 <roshi> #link https://fedorahosted.org/cloud/ticket/77
17:41:29 <roshi> this is pretty much rolled up for beta
17:41:51 <roshi> will be looking to see if there are final criteria I need to draft
17:42:09 <roshi> #action roshi to update the wiki with the release criteria and close the ticket
17:42:29 <roshi> #topic Open Floor
17:42:49 <jsmith> The only thing I have for the open floor is my typical plea for help with documentation
17:43:01 <jsmith> Anybody want to help me with the "Cloud" beat for the release notes?
17:43:08 <roshi> kushal: I was looking at cloudtoserver and was wondering why use python? Wouldn't a bash script suffice?
17:43:09 <jsmith> Anybody want to help revive the Cloud Guide?
17:43:34 <roshi> I can help edit at least, jsmith
17:44:25 <number80> jsmith: I would help but I'm not confident enough on my english writing skills :/
17:44:51 <jsmith> number80: I'm happy to help edit/translate into English -- write *anything*, and I'll make it sound good :-)
17:44:58 <jsmith> roshi: Awesome, thanks :-)
17:45:10 <dustymabe> I have an item... I have coordinated with digital ocean a bit.
17:45:15 <roshi> sweet
17:45:19 <number80> jsmith: sounds good, I'll write it in old sumerian :o)
17:45:23 <kushal> roshi, In future we may want to have do more things inside those instances, having a programming language is better for that :p
17:45:53 <kushal> roshi, also I am staying within standard lib of Python as much as possible (like right now).
17:46:13 <jsmith> number80: I'd respond by saying "š’€¨", but I doubt you have the right font installed...
17:46:19 <number80> jsmith: \o/
17:46:27 <kushal> jsmith, eeks
17:46:36 <number80> kushal: we're thinking about removing even python from base image in the long term
17:46:38 <roshi> I was just wondering since I knew we were looking to perhaps get python out of the base image
17:46:54 <number80> programming env should be provided by the env&stack group
17:47:24 <kushal> ah, I always thought on python as more than the programming env. But I can see your view.
17:47:41 <number80> kushal: nothing is set in stone yet :)
17:47:49 <roshi> for sure
17:48:03 <kushal> roshi, number80 one of the best feature of modern linux distributions is Python in all default installs.
17:48:06 <roshi> I was just wondering, since I knew there was at least talk about removing python
17:48:42 <kushal> roshi, understood.
17:48:43 <number80> the idea was to get a minimal viable image because not everyone uses python/put your fav language here
17:48:47 <roshi> I would agree - but cloud is a bit more special purpose than a "default install" was how I understood it
17:48:57 * roshi loves him some python :)
17:49:04 <number80> may I suggest we discuss this on the list ?
17:49:10 <kushal> number80, Yes,
17:49:12 <roshi> sure
17:49:16 * number80 loves python too :)
17:49:22 <roshi> dustymabe: what did you find out with digital ocean?
17:49:29 <dustymabe> number80: roshi For DO: They say the next steps is for us to create an account with them and then let them know which account so that they can disable billing.
17:49:55 <dustymabe> do we have an official fedora email address we should use?
17:50:00 * roshi would welcome them disabling billing on his account :p
17:50:10 <dustymabe> agrimm: did you do stuff like this for aws?
17:50:45 <agrimm> dustymabe, me?  no... I was not involved in the original AWS account setup at all
17:50:58 <agrimm> I just got access a couple of weeks ago!  :)
17:51:15 <roshi> mattdm: might have your answer dustymabe
17:51:30 <number80> dustymabe: shared account ?
17:51:52 <roshi> the email we use for that is community-cloud@fedoraproject.org
17:52:12 <gholms> For AWS there's an "official" shared account, yeah.
17:52:16 <roshi> but I don't know who owns/runs that
17:52:27 <dustymabe> roshi: I'll coordinate with mattdm on this
17:52:29 <jsmith> mattdm runs it
17:52:52 <roshi> #action dustymabe to work with mattdm on Digital Ocean account
17:53:00 <roshi> anybody have anything else?
17:53:18 <dustymabe> thats it for me
17:53:28 <kushal> roshi, can we see the votes for meeting timings ?
17:53:53 <dustymabe> http://whenisgood.net/recw7mb/results/wx5ep2c
17:53:54 <roshi> I dunno
17:53:58 <dustymabe> thats is the link
17:54:02 <misc> Ā§win 14
17:54:36 <kushal> dustymabe, thanks
17:54:53 <dustymabe> kushal: np
17:56:16 <dustymabe> ok.. all done here?
17:56:22 * dustymabe has to run
17:56:48 <dustymabe> roshi: thanks for running the meeting
17:56:55 <dustymabe> you are getting good at this
17:57:00 <roshi> np :)
17:57:02 <roshi> thanks
17:57:14 <roshi> #endmeeting