19:00:17 <roshi> #startmeeting Fedora Cloud WG
19:00:17 <zodbot> Meeting started Wed Nov 12 19:00:17 2014 UTC.  The chair is roshi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:27 <roshi> #meetingname Fedora Cloud WG
19:00:27 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
19:00:48 <jzb> .hellomynameis jzb
19:00:48 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
19:00:51 <roshi> #topic Roll Call
19:00:57 <roshi> .hello roshi
19:01:00 <zodbot> roshi: roshi 'Mike Ruckman' <mruckman@redhat.com>
19:01:00 <janeznemanic> hi guys
19:01:17 <roshi> hey janeznemanic :)
19:01:59 <roshi> kushal: you here?
19:02:17 <kushal> .hellomynameis kushal
19:02:18 <zodbot> kushal: kushal 'Kushal Das' <kushaldas@gmail.com>
19:02:26 <kushal> roshi, thanks for the ping
19:02:31 <roshi> np
19:02:45 <oddshocks> .hellomynameis oddshocks
19:02:46 <zodbot> oddshocks: oddshocks 'David Gay' <dgay@redhat.com>
19:03:37 <roshi> well, I suppose we can get started
19:03:43 <roshi> perhaps others will trickle in...
19:03:55 <roshi> #topic Previous Meeting follow-up
19:04:05 <roshi> * kushal will keep an eye to verify actual release images on the mirrors
19:04:05 <roshi> * jzb to file rel-eng ticket for missing images
19:04:14 * roshi left one out since it's in a ticket
19:04:50 <kushal> I will be monitoring it :)
19:05:08 <roshi> sweet :)
19:05:10 <roshi> jzb: ?
19:05:12 <jzb> we do not have a release on the mirrors but are making significant progress on images.
19:05:19 <roshi> good to hear
19:05:21 <jzb> see:
19:05:28 <jzb> https://fedorahosted.org/rel-eng/ticket/6034
19:06:12 <roshi> #info Progress is being made on the images getting built
19:06:22 <roshi> anything else for followup? or jump to tickets?
19:07:00 * roshi moves onto the tickets
19:07:03 <roshi> #topic Atomic Testday (#74)
19:07:05 * dustymabe slinks in
19:07:07 <roshi> #link https://fedorahosted.org/cloud/ticket/74
19:07:12 <roshi> welcome dustymabe :)
19:07:12 <dustymabe> sorry I got held up
19:07:16 <roshi> no worries
19:07:33 <jzb> I sent out an update to the cloud list last night
19:07:39 <dustymabe> jzb: yep I saw it. Thanks for the update
19:07:42 <jzb> but totally neglected to update the ticket
19:07:42 <roshi> and I've updated fedocal
19:07:46 <jzb> mea culpa
19:07:55 <dustymabe> jzb: so we should promote next thursday?
19:08:14 <roshi> yeah
19:08:28 <roshi> jzb: do you have time to write something up for the magazine or should I do it?
19:08:41 <roshi> mattdm: could you put this in the next 5 things in fedora post?
19:08:47 <jzb> roshi: I'll get it
19:08:49 <jzb> dustymabe: yes
19:08:56 <roshi> sounds good
19:09:03 <roshi> let me know if you get swamped or something :)
19:09:39 <dustymabe> jzb: I already took off this thursday. but I am going to try to flesh out some test material for people to follow for next thursday
19:09:40 <jzb> roshi: well...
19:09:54 <dustymabe> jzb: in case we have people who want to help and don't have a lot of experience with atomic yet
19:10:10 <jzb> dustymabe: that would be everybody
19:10:17 <mattdm> roshi yes I will
19:10:22 <roshi> yeah, I don't have experience with atomic
19:10:33 <roshi> or much with docker, but I'm working on that bit :)
19:10:42 <roshi> thanks mattdm :)
19:10:48 <dustymabe> jzb: :) - ok. I'm hoping my material helps then!
19:10:52 <jzb> dustymabe: test material would be awesome.
19:11:19 <mattdm> maybe this went by already, but we're still working on getting a compose to actually test
19:11:27 <roshi> looks like we're good for this ticket, we can close it after the testday
19:11:28 <kushal> jzb, yes
19:11:46 <jzb> kushal: what was the question?
19:11:48 <roshi> yeah, jzb emailed the list - hopefully things are good to go by thursday
19:12:02 <kushal> jzb, I should have used +1 :)
19:12:11 <mattdm> presumably we'll have something tonight, and we'll ask oddshocks to upload that to ec2 too
19:12:19 <roshi> sounds like a plan
19:13:30 * jsmith shows up late :-(
19:13:45 <roshi> next ticket then?
19:14:00 * oddshocks nods
19:14:05 <roshi> #topic State of Cloud article
19:14:09 <roshi> #link https://fedorahosted.org/cloud/ticket/75
19:14:16 <roshi> #topic State of Cloud article (#75)
19:14:36 <roshi> this to go live once the image bit is sorted out?
19:14:44 <jzb> roshi: yeah
19:15:17 <roshi> anyone have anything else for this?
19:15:23 <roshi> if not I'll move on....
19:16:13 <roshi> #topic Publicize fedora-dockerfiles (#84)
19:16:16 <roshi> #link https://fedorahosted.org/cloud/ticket/84
19:16:38 <roshi> is this talking about the Final Release announcement?
19:17:19 <dustymabe> roshi: I'm not sure
19:17:25 <roshi> once I finally drill down into docker and atomic I hope to be able to help more with this
19:17:39 <jzb> roshi: I think mattdm means more generally + final
19:17:55 <jzb> we probably need to work the Dockerfiles into the cloud page too
19:17:56 <dustymabe> generally we could each promote on twitter/blogs
19:17:57 <kushal> roshi, things like blog posts and articles
19:18:07 <roshi> yeah, that was clear to me
19:18:22 <roshi> but the second comment mentioned release notes, so I was wondering which release notes
19:18:56 <roshi> having some nice means of testing a more complex dockerfiles setup could be useful for verifying the docker and atomic images
19:19:01 <roshi> kill two birds with one stone
19:19:13 <mattdm> roshi definitely!
19:19:14 <dustymabe> one thing that would be nice is to promote these once the dockerfiles themselves start using the "official" fedora21 base docker image
19:19:34 <roshi> (proverbial birds, of course "NO BIRDS WERE HARMED IN THE MAKING OF THIS DISTRO.")
19:19:45 <kushal> haha
19:20:08 <roshi> yeah
19:20:19 <dustymabe> should I add that to the ticket?
19:20:24 <dustymabe> add that comment
19:20:31 <roshi> with the birds?
19:20:43 <dustymabe> no.. about the official fedora 21 docker image
19:20:48 <roshi> :p
19:20:52 <roshi> sure
19:20:58 <dustymabe> ok.. i'll ask
19:21:01 <roshi> more info on the ticket can't be a bad thing I don't think
19:22:32 <roshi> anything else for this?
19:23:06 <roshi> #topic Upload Criteria (#80)
19:23:11 <roshi> #link https://fedorahosted.org/cloud/ticket/80
19:23:44 <roshi> I haven't proposed this yet
19:23:59 <roshi> #action roshi to email test@ list regarding the new criteria
19:24:27 <roshi> once I email the list, is a post to cloud@ with a pointer to the discussion good enough for you guys to follow?
19:24:33 <roshi> or should I cross post it?
19:24:50 <jzb> roshi: cross post to...where?
19:24:59 <roshi> from test@ to cloud@
19:25:00 <jzb> roshi: oh, a pointer should be fine
19:25:07 <jzb> hm. Wait.
19:25:18 <jzb> most of cloud is probably not on test.
19:25:28 <roshi> in case other cloud members wanted to comment in the discussion
19:25:34 <roshi> since QA handles the criteria
19:26:11 <roshi> could also point both lists to the ticket and try to have the discussion there
19:27:08 <jzb> roshi: +1
19:27:20 <roshi> discussion on ticket then?
19:27:24 <jzb> roshi: given past discussions - I also recommend setting a hard deadline for comments.
19:27:27 <jzb> roshi: yeah
19:27:35 * oddshocks is on cloud and pays close attention, but is not on test
19:27:55 <jzb> people are generally pulled in 1m directions so if they don't see something obviously needing their input, they may fail to say +1 or anything
19:28:09 <roshi> a fair point
19:28:29 <roshi> #action roshi to point discussion to the trac instance for both test@ and cloud@
19:28:58 <roshi> #topic OpenShift Commons (#83)
19:29:01 <roshi> #link https://fedorahosted.org/cloud/ticket/83
19:29:08 * roshi hasn't been tracking this one
19:30:09 <dustymabe> there was discussion last week
19:30:18 <dustymabe> kushal: do you recall?
19:30:27 <kushal> yes
19:30:44 <kushal> dustymabe, board is supposed to do something for this.
19:30:47 <dustymabe> did anyone hear anything back from pythondj
19:30:54 <jzb> no
19:31:16 <kushal> dustymabe, I do not have any other update on that.
19:31:16 <jzb> at least, I reached out separately and heard nothing back except "will be in touch after OpenStack Summit"
19:31:34 <dustymabe> cool
19:34:08 <roshi> this one good as is?
19:34:21 <dustymabe> roshi: I think so
19:35:17 <roshi> sounds good
19:35:21 <roshi> #topic Open Floor
19:35:30 <kushal> I have some
19:36:09 <kushal> I was in talk with lsm5 for the docker image release. We now have Fedora21 beta docker images released.
19:36:32 <roshi> good to hear
19:36:47 <kushal> #link https://github.com/docker-library/official-images/pull/313
19:36:58 <jzb> kushal: hooray!
19:37:10 <jsmith> That's great news...
19:37:28 <roshi> :)
19:37:46 <jzb> kushal: I'll put up a Fedora Magazine post on that unless you want to.
19:37:52 <kushal> I am working with lsm5 so that we can formalize the fedora docker releases.
19:38:04 <roshi> awesome
19:38:15 <kushal> jzb, I will work on one then, should be my first post :D
19:38:17 <jzb> kushal: oh - is it up on the hub ?
19:38:22 <jzb> kushal: groovy
19:38:29 <kushal> jzb, should be by now.
19:39:14 <kushal> EOF from me.
19:39:18 <dustymabe> cool
19:39:20 <dustymabe> I have something
19:39:50 <dustymabe> I have been working with DO. We have an image booting but provisioning via cloud-init is not working right now.
19:40:21 <roshi> sweet
19:40:21 <jzb> dustymabe: DO?
19:40:25 <roshi> digital ocean
19:40:29 <jzb> ah
19:40:37 * roshi has been really happy with them
19:40:50 <roshi> my irssi server is on a DO droplet :)
19:40:59 <roshi> it's how I'm always connected
19:41:09 <dustymabe> still working with them to get something working and also getting a process in place (still manual, but scripted) to convert our image we put out into something they can easily consume
19:41:34 <dustymabe> eventually they will have automatic uploading/etc..
19:41:37 <roshi> perhaps off topic, but what customizations do they need?
19:41:48 <oddshocks> so weird you mentioned DO at the same time I did in #fedora-cloud
19:41:56 * oddshocks setting up his first droplet now
19:42:29 <dustymabe> roshi: I still don't know them all but one example is they assume DOROOT to be the lable on the root filesystem
19:42:48 <dustymabe> obviously they are used to making their own images themselves
19:42:58 <dustymabe> perhaps we can help them become more flexible
19:43:11 <dustymabe> s/lable/label/
19:43:17 <roshi> ah, interesting
19:43:23 <roshi> that's not hard to fix at least
19:43:30 <roshi> yeah, that would be good :)
19:43:43 <dustymabe> roshi: agreed.. there are more that I am learning about today probably.
19:43:55 <roshi> cool
19:44:31 * oddshocks is curious if we have any process started now to talk to DO about a deal/partnership of some sort for fedora, as we are with... HP was it?
19:44:59 <dustymabe> oddshocks: what would be the nature of the deal/partnership?
19:45:04 <dustymabe> promote each other?
19:45:11 <dustymabe> or actually involving money?
19:45:31 <oddshocks> dustymabe: involving less money, rather ;)
19:45:52 <roshi> a thing I thought of, was if they give us access to their infra for testing images, we could handle the fedora image testing for them
19:45:52 <oddshocks> idk we can talk about this later. I don't know all the details. I think rackspace and GCE were higher priority anyway
19:46:00 <oddshocks> roshi: thank you
19:46:02 * jzb has one tiny thing
19:46:06 <oddshocks> dustymabe: that ^ :P
19:46:11 <dustymabe> jzb one sec
19:46:23 <dustymabe> oddshocks: roshi: we actually do have standing offer from DO
19:46:32 <dustymabe> once we create an account they will turn off billing
19:46:33 <roshi> oh cool
19:46:44 <dustymabe> the problem is getting legal to approve the terms of service
19:46:50 <roshi> ah
19:46:54 <oddshocks> dustymabe: oh shoot. well let's talk about that after meeting or later today :) I'm interested in DO
19:46:54 <dustymabe> I'm working on that...
19:46:59 <oddshocks> dustymabe: cool, thanks :D
19:47:04 <dustymabe> mattdm: knows more
19:47:06 <oddshocks> well, that's all I've got
19:47:08 <roshi> we for sure want legals signoff
19:47:11 <dustymabe> jzb: its all you now :)
19:47:21 <jzb> thx
19:47:27 <jzb> so - we need one or more testimonials
19:47:31 <jzb> for the Web site
19:47:34 <jzb> but also in general
19:47:46 <jzb> it'd be nice to put up case studies on Fedora Magazine
19:48:04 <jzb> but we definitely need at least one non-RHT user of Fedora Cloud $something
19:48:22 <jzb> to quote on the site when getfedora launches.
19:48:27 <jzb> anybody have any ideas?
19:48:51 <dustymabe> jzb: individuals? companies?
19:48:54 <dustymabe> both?
19:49:15 <jzb> dustymabe: either a company or a really well-known individual
19:49:23 <oddshocks> I do
19:49:29 <oddshocks> possibly
19:49:49 <dustymabe> mhayden?
19:49:55 <jzb> dustymabe: like, if you could get Patrick Debois or Gene Kim...
19:50:00 <dustymabe> not RHT.. well known
19:50:32 <jzb> dustymabe: Rackspace?
19:50:34 <roshi> what about euca? don't they run fedora stuff?
19:50:44 <oddshocks> Oh yeah an actual provider would be ill
19:51:00 <dustymabe> yeah.. he could probably do a personal testimonial or a joint personal and company one
19:51:09 <dustymabe> not sure though
19:51:31 <jzb> dustymabe: if he can give a "hey, I use Fedora cloud for all my dev/test needs" or something that'd be awesome.
19:51:51 <jzb> it doesn't necessarily have to be "Rackspace endorses this" but if he can say it's in use and we can use his work title...
19:51:55 <jzb> that'd be awesome.
19:51:58 <jzb> if that make sense.
19:52:17 <dustymabe> jzb: yep that makes sense.. he trolls around the fedora irc channels a decent amount
19:52:26 <dustymabe> I could reach out to him in an email as well
19:52:32 <dustymabe> if you'd like
19:52:37 <dustymabe> oddshocks: who did you have?
19:52:38 <jzb> dustymabe: that'd be spiffy thanks
19:54:32 <roshi> that what you needed jzb ?
19:54:38 <oddshocks> dustymabe: My idea wasn't as good :P I like someone from a provider more
19:54:58 <jzb> roshi: yep
19:55:01 <jzb> roshi: thanks!
19:55:35 <dustymabe> well he said we needed multiple.. soo
19:55:45 <dustymabe> leads are good :)
19:56:55 <roshi> np :)
19:57:08 * roshi sets the fuse
19:58:13 <jzb> *boom*
19:58:36 <dustymabe> thanks everyone for coming
19:59:08 <roshi> yeah, thanks!
19:59:13 <roshi> 3...
19:59:14 <janeznemanic> see you
19:59:25 <roshi> 2...
19:59:41 <roshi> 1...
19:59:50 <roshi> #endmeeting