17:01:46 <kushal> #startmeeting Fedora Cloud WG
17:01:46 <zodbot> Meeting started Wed Jan 13 17:01:46 2016 UTC.  The chair is kushal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:46 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:01:50 <dustymabe> .hellomynameis dustymabe
17:01:52 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:01:55 <kushal> #topic Roll Call
17:01:56 <dustymabe> adimania: good to see you!!
17:02:03 <kushal> .hellomynameis kushal
17:02:04 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:02:04 <rtnpro> .fas rtnpro
17:02:07 <tflink> .hellomynameis tflink
17:02:07 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:02:07 <jbrooks> .hello jasonbrooks
17:02:09 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:02:10 <sayan> .fas sayanchowdhury
17:02:12 <trishnag> .hellomynameis trishnag
17:02:12 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:02:15 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:02:17 <adimania> .fas adimania
17:02:18 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:02:20 <zodbot> adimania: adimania 'Aditya Patawari' <adimania@gmail.com>
17:02:22 <maxamillion> .hello maxamillion
17:02:23 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:02:25 <adimania> dustymabe, good to see you too. :)
17:03:04 <kushal> #chair dustymabe adamw rtnpro tflink jbrooks sayan trishnag maxamillion
17:03:04 <zodbot> Current chairs: adamw dustymabe jbrooks kushal maxamillion rtnpro sayan tflink trishnag
17:03:12 <kushal> jzb, sent his regards.
17:03:33 <kushal> Anyone else?
17:03:44 <kushal> #topic Action items from last meeting
17:03:45 <praveenkumar> .fas kumarpraveen
17:03:46 <zodbot> praveenkumar: kumarpraveen '' <kumarpraveen.nitdgp@gmail.com>
17:03:57 <kushal> * jzb will update #135 on Fedora 23 retrospective
17:03:57 <kushal> * kushal will update #121 with a alarm in Feb
17:03:57 <kushal> * Kushal will update #136 and drop a mail to the list
17:03:57 <kushal> * Kushal to update networkd ticket
17:04:01 <kushal> #chair praveenkumar
17:04:02 <zodbot> Current chairs: adamw dustymabe jbrooks kushal maxamillion praveenkumar rtnpro sayan tflink trishnag
17:04:14 <kushal> I hope I have updated all the tickets
17:04:22 <kushal> s/136/138
17:04:50 <kushal> I will talk to rel-eng today,and pass the details for a tree which we can release as updated base image
17:05:14 <kushal> Any questions/
17:05:15 <kushal> ?
17:05:32 <kushal> Moving to tickets then.
17:05:44 <kushal> #topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:06:13 <kushal> Anyone heard anything from the server wg?
17:06:50 <dustymabe> kushal: I asked mhayden to bring it up
17:06:57 <dustymabe> have not heard back from him on whether he did or not
17:07:07 <tflink> it came up during a server wg meeting
17:07:15 <dustymabe> tflink: :)
17:07:17 <dustymabe> yay
17:07:19 * tflink doesn't recall what came of it, though
17:07:30 <kushal> tflink, Thanks for the info :)
17:07:41 <kushal> Now we have to keep asking them for updates :)
17:07:47 <dustymabe> so, once I get in touch with mhayden I'll update the tickets
17:07:55 <kushal> dustymabe, Cool
17:08:08 <kushal> #action dustymabe to update #115 after talking to mhayden
17:08:20 <tflink> crap, I thought we were on a different ticket
17:08:31 <tflink> nevermind, I don't know if this was brought up or not
17:08:37 <dustymabe> tflink: ok
17:08:37 <kushal> Oh
17:08:41 <kushal> no problem :)
17:08:50 <kushal> #topic vagrant boxes fixups https://fedorahosted.org/cloud/ticket/136
17:09:17 * imcleod will be in and out a bit but will try to read backchat
17:09:19 <kushal> dustymabe, anything on this?
17:09:29 <dustymabe> so for this ticket we would need someone with knowledge of rel-eng + vagrant + image creation
17:09:37 <kushal> dustymabe, if you want, I can try this.
17:09:41 <dustymabe> someone like maxamillion or imcleod would be best (or possibly myself)
17:09:49 <dustymabe> kushal: that works!
17:09:51 <maxamillion> what's up?
17:09:53 <dustymabe> would love that
17:10:06 <kushal> #action kushal to work on https://fedorahosted.org/cloud/ticket/136
17:10:13 <dustymabe> maxamillion: we are in Fedora Cloud meeting (you may or may not know that already)
17:10:18 <kushal> maxamillion, just adding a CD drive to the vagrant images :)
17:10:22 <imcleod> kushal: I stand ready to support :-)
17:10:28 <dustymabe> yeah you do.. I see your .hello
17:10:36 <kushal> imcleod, you are my upstream rockstar :)
17:10:41 <maxamillion> dustymabe: yes, I did roll call ... but I'm somehow missing context on what you said and how it relates to the ticket in the topic
17:10:46 <kushal> #chair imcleod
17:10:46 <zodbot> Current chairs: adamw dustymabe imcleod jbrooks kushal maxamillion praveenkumar rtnpro sayan tflink trishnag
17:10:54 <maxamillion> dustymabe: why do we need releng people for vagrant fixes?
17:10:59 <kushal> #chair adimania
17:10:59 <zodbot> Current chairs: adamw adimania dustymabe imcleod jbrooks kushal maxamillion praveenkumar rtnpro sayan tflink trishnag
17:11:18 <dustymabe> because it includes a change to the vagrant boxes.. I don't think many of us know how those get created
17:11:46 <kushal> dustymabe, imcleod helped me to do that before
17:11:56 <kushal> dustymabe, I will update my worknotes to make sure everyone knows :)
17:12:03 <dustymabe> ok kushal, want to action yourself to work on this
17:12:11 <kushal> I already did :)
17:12:26 <kushal> Moving to next :)
17:12:27 <dustymabe> :) - you so fast
17:12:30 <maxamillion> yeah, I have no idea how the vagrant stuff gets created ... :/
17:12:37 <kushal> #topic Produce updated cloud base images https://fedorahosted.org/cloud/ticket/138
17:12:45 * mhayden stumbles in after a bunch of dings
17:13:03 <gholms> Heh
17:13:14 <kushal> As I updated few minutes back, I will talk to rel-eng, and update the ticket, and the list about the new tree which we can test and then release.
17:13:30 <kushal> #chair gholms
17:13:30 <zodbot> Current chairs: adamw adimania dustymabe gholms imcleod jbrooks kushal maxamillion praveenkumar rtnpro sayan tflink trishnag
17:13:38 <kushal> #chair mhayden
17:13:38 <zodbot> Current chairs: adamw adimania dustymabe gholms imcleod jbrooks kushal maxamillion mhayden praveenkumar rtnpro sayan tflink trishnag
17:13:44 <kushal> Good turnout.
17:14:05 <maxamillion> go team
17:14:10 <kushal> #topic Producing 2 week atomic images https://fedorahosted.org/cloud/ticket/139
17:14:21 <kushal> We had another release thanks maxamillion and team :)
17:14:33 <dustymabe> maxamillion: will update the atlas box today
17:14:36 <kushal> maxamillion, I guess after next release we can close this ticket.
17:14:41 <kushal> dustymabe, ^^
17:14:48 <dustymabe> kushal: cool
17:15:23 <maxamillion> yeah, 2 week atomic images are done unless there's something that needs doing
17:15:26 <maxamillion> we released yesterday
17:15:34 <maxamillion> (something that I'm not aware of anyways)
17:16:22 <kushal> Updated the ticket.
17:16:28 <kushal> Moving to next then.
17:16:50 <kushal> #topic Proposals for F24 features https://fedorahosted.org/cloud/ticket/143
17:17:09 <kushal> We have motd, and openshit one in.
17:17:51 <kushal> tflink, Do you know if roshi or you can make the wiki page changes required for the testcloud one? As it is already built for rawhide, it should be easy.
17:18:10 <tflink> what wiki pages need to be changed?
17:18:57 <kushal> tflink, wait, let me search
17:19:53 <kushal> tflink, https://fedoraproject.org/wiki/Changes/Local_Test_Cloud
17:20:11 <kushal> Oh, it has my name too.
17:20:38 <tflink> i still think it's a bit silly to have testcloud as a feature but sure
17:20:38 <kushal> tflink, I will do the changes in the wiki to make sure that it goes to wrangler.
17:20:45 <kushal> tflink, :)
17:20:46 <tflink> what's the deadline?
17:20:48 * linuxmodder 
17:20:59 <kushal> tflink, we slipped 2 weeks, so no problem.
17:21:09 <tflink> but when's the deadline?
17:21:26 * tflink just requested stable for f23 testcloud, FWIW
17:21:54 <kushal> 2016-01-26
17:22:01 <tflink> k, thanks
17:22:05 <kushal> tflink, nice to know that.
17:22:15 <kushal> For everyone
17:22:16 <kushal> https://fedoraproject.org/wiki/Releases/24/Schedule
17:22:57 <kushal> Moving next
17:23:08 <kushal> #topic AMI lifetimes (Cloud WG members vote needed) https://fedorahosted.org/cloud/ticket/99
17:23:20 <kushal> People voted in that.
17:24:10 <maxamillion> I'm pretty +0 on that ... no real preference, but it's probably a good idea
17:24:10 <kushal> So the problem is we have way too many snapshots, and AMI(s) in AWS, these are mostly nightlies, and other non-release ones. Causing a huge bill every month.
17:24:25 <maxamillion> ohhh, nvm ... I thought this was something else
17:24:44 <fhackdroid> .fas
17:24:44 <zodbot> fhackdroid: (fas <query>) -- Search the Fedora Account System usernames, full names, and email addresses for a match.
17:24:57 * jsmith shows up very late, sorry
17:25:06 * maxamillion throws a shoe at jsmith
17:25:08 <maxamillion> >.
17:25:09 <maxamillion> >.>
17:25:14 <maxamillion> bleh, I can't type ... ignore me
17:25:23 * fhackdroid waves to everyone o/
17:25:23 <kushal> maxamillion, :)
17:25:35 <kushal> fhackdroid, jsmith hello
17:25:42 <maxamillion> kushal: since people voted in ticket, is there anything else to discuss here?
17:26:03 <kushal> maxamillion, No, I am just informing everyone about this one.
17:26:10 <maxamillion> gotchya
17:26:24 <fhackdroid> kushal, hey
17:26:26 <kushal> maxamillion, we will also drop mails to the list explaining the point (or may be using the trac).
17:26:33 <maxamillion> kushal: +1
17:26:33 <kushal> fhackdroid, The meeting is on.
17:26:47 <kushal> We have 3 new tickets to discuss.
17:26:58 <kushal> #topic Create and host a Fedora 23 Cloud image supporting all languages https://fedorahosted.org/cloud/ticket/146
17:27:33 <kushal> I am -1 on this, as this will increase the size in a huge way.
17:27:35 <dustymabe> striker: that was timely
17:27:41 <striker> muaha
17:27:43 <striker> ha
17:27:45 <kushal> striker, hello.
17:27:47 <striker> hello
17:27:48 <dustymabe> I think we are discussing your ticket now
17:27:55 <striker> yes, I see in /topic
17:28:05 <striker> the gods of cloud were calling to me
17:28:14 <striker> so I answered
17:28:25 <kushal> Anyone else? any thoughts?
17:28:33 <striker> what are the thoughts so far?
17:28:39 <striker> +1 or no?
17:28:39 <dustymabe> kushal: I think the proposal was to host a 2nd image that contains the langs
17:28:40 <number80> wfm
17:28:51 <dustymabe> not to change the one we have
17:28:55 <striker> correct
17:29:07 <dustymabe> striker, is it not pretty easy to install the langs on boot?
17:29:10 <dustymabe> using cloud-init?
17:29:39 <kushal> dustymabe, that will also require updates to websites, and input from rel-eng.
17:29:39 <linuxmodder> requires  dnf-langpacks.noarch tho I thought even to do that
17:30:15 <kushal> dustymabe, We have to figure out what is required from rel-eng side to get it done.
17:30:28 <linuxmodder> dustymabe,  I'll be  listening in on striker's ticket as its something I hope to do also for other things
17:30:37 <kushal> It will be nice if we can do this after starting any new instance, that is using cloud-init or something.
17:30:40 <maxamillion> the langpacks is a tough one for me, I like the idea of a smaller cloud image but I hate to alienate users because their written language isn't supported out of the box ... not sure +/- 1 :/
17:31:38 <kushal> maxamillion, we have way too many langs :)
17:31:57 <linuxmodder> maxamillion,  is it  possible to make a  ?compressed ?  langpack thing ?  that  offers a  prompt  for desired lang /langs and  polls  server directly then purges?
17:32:18 <linuxmodder> kushal,  the backstory on striker's  ticket is for  building the live respins
17:33:00 <maxamillion> kushal: ah
17:33:02 <kushal> linuxmodder, Okay. I am trying to think if we can do it in any easy way.
17:33:04 <linuxmodder> the  respin folks  striker and  kk4ewt  are  wanting to keep using the cloud  qcow but it  strips  the langs  making it a  effective no-go for the respins
17:33:08 <dustymabe> live respins?
17:33:11 <dustymabe> using the cloud base image?
17:33:13 <linuxmodder> the updated lives
17:33:37 <kushal> striker, what about an unofficial image?
17:33:38 <linuxmodder> http://tinyurl.com/live-respins (redirects to  alt.fp.o./live-respins
17:33:51 <striker> an unofficial image would be fine
17:34:03 <kushal> striker, we can easily build that for you :)
17:34:07 <striker> but I have trouble building qcows at the moment (working on that myself)
17:34:14 <kushal> striker, You can then use it as you want.
17:34:19 <striker> I would accept an officially unofficial qcow that contains the langs
17:34:21 <kushal> striker, Cool, I will help you with that.
17:34:36 <striker> compromise++
17:34:41 <kushal> Is that okay to everyone?
17:34:43 <dustymabe> I don't understand.. how is the cloud base image being used for live respins?
17:34:52 <dustymabe> better yet.. what is a live respin :)
17:34:58 <kushal> striker, stage is yours :)
17:35:13 <striker> dustymabe: I host a VM on OpenStack that is used to rebuild the live ISOs as new Kernel versions are released
17:35:21 <striker> it works great because the VM is small and quick
17:35:38 <striker> Respins built on F22 Cloud had support for all Languages
17:35:48 <striker> On F23 Cloud, the respins are lacking
17:36:04 <linuxmodder> kushal,  pending rel-eng or  whoevers approval possible to  make that  official dev qcow  or  similar  so its  nmore  known as a slightly larger  but  more lang friendly  qcow?
17:36:05 <striker> the process pulls some information from the host OS, which is why Cloud works great for this
17:36:20 <dustymabe> striker: so the VM running on openstack is the one that needs the langs?
17:36:28 <striker> dustymabe: yes
17:36:35 <striker> F23 Server works fine
17:36:36 <dustymabe> and that VM is based on fed cloud base?
17:36:40 <striker> yes
17:36:50 <dustymabe> striker, so why not just update the user-data that you pass to that VM
17:36:56 <linuxmodder> dustymabe,  the ones her: https://alt.fedoraproject.org/pub/alt/live-respins/
17:36:57 <dustymabe> to install all langs?
17:37:00 <striker> I tried doing that
17:37:04 <dustymabe> yeah?
17:37:05 <kushal> linuxmodder, striker I can help you fast enough with the unofficial one, for any official one, you have to talk to rel-eng too
17:37:06 <striker> which is the trouble I am having
17:37:12 <striker> kushal: sounds good
17:37:30 <kushal> striker, what is your timezone?
17:37:34 <striker> EST
17:37:39 <linuxmodder> same here
17:38:06 <kushal> Cool, I will make one before tomorrow morning your time, please talk to me after the meeting in the #fedora-cloud channel.
17:38:07 <striker> kushal: maybe down the road even something under 'other downloads' would be fine
17:38:13 <striker> no need for a front-page post
17:38:29 <kushal> striker, yes
17:38:44 <kushal> Putting an action item
17:38:55 <linuxmodder> or in the spins section over on spins.fedoraproject.org
17:39:13 <striker> kushal: ack
17:39:13 <kushal> #action kushal will build an unofficial image with all lang packs for #146
17:39:14 <striker> ty
17:39:20 <kushal> #topic Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:40:08 <kushal> dustymabe, maxamillion you want to talk?
17:40:15 <dustymabe> sure
17:40:22 <dustymabe> I think we just need to vote
17:40:26 <dustymabe> I don't think anyone did in the ticket
17:40:58 <dustymabe> should I state the case here again, or is that done well enough in the ticket?
17:41:13 <kushal> Ticket text is good for me.
17:41:25 <kushal> So, we all should vote.
17:41:42 <dustymabe> yes
17:41:50 <dustymabe> jzb: has voted +1
17:42:06 <kushal> I am +1
17:42:25 <maxamillion> -1
17:42:57 <kushal> maxamillion, put it on the ticket.
17:43:09 <dustymabe> who else do we have here
17:43:14 <kushal> jsmith,
17:43:17 <kushal> number80,
17:43:24 <kushal> adimania, and rtnpro
17:43:36 <number80> +1
17:43:39 <rtnpro> aye
17:43:46 <kushal> On the ticket people :)
17:43:52 <rtnpro> ok
17:43:58 <adimania> will do
17:44:16 <jsmith> +1
17:44:42 <dustymabe> ok everyone add their +1 or -1 to the ticket
17:45:14 <kushal> Moving next.
17:45:22 <kushal> #topic Container "Packager" Guildelines and Naming Conventions https://fedorahosted.org/cloud/ticket/148
17:46:14 <kushal> maxamillion, I will go through the docs, and update the ticket later this week.
17:46:22 <maxamillion> alright, thanks
17:46:33 <number80> interesting idea, it'd be interesting to have container implementors to review these too
17:46:38 <jsmith> The only concern I have is in the name of the second document
17:46:48 <jsmith> Are they really "package" reviews?
17:46:56 <jsmith> (if the end result is a CLIB, not a package)
17:46:57 <maxamillion> basically right now we have guidelines for all sorts of rpm stuff but nothing for docker and I'd like more people than just me to be the "keepers of the guidelines" .... so I was hoping to open that to the cloud wg (I assume we're the most likely to be versed in docker things)
17:46:59 <kushal> Container reviews :)
17:47:13 <kushal> jsmith++
17:47:13 <zodbot> kushal: Karma for jsmith changed to 9 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:48:08 <maxamillion> jsmith: well, it just shares a lot in the way of process with the package reviews so I didn't want to duplicate the document and have to update both documents when shared content changes or is updated ... I'm certainly open to suggestion on how best to handle that
17:48:18 <jsmith> I've looked over the documents briefly, and didn't see anything concerning
17:48:28 <jsmith> I'll read over the guidelines again and make any comments I have in the ticket
17:48:46 <kushal> Everyone else, please do the same :)
17:48:56 <maxamillion> +1
17:49:30 <number80> now, w/ FESCo hat, should we consider transferring ownership of these guidelines to FPC?
17:49:59 <number80> that's something that needs to be discussed at some point
17:50:05 <maxamillion> number80: completely agreed
17:50:17 <number80> maxamillion: would you add the point to fesco meeting?
17:50:22 <maxamillion> number80: these docs ultimately are slated to go before FESCo for review/discussion
17:50:35 <kushal> number80++
17:50:36 <zodbot> kushal: Karma for hguemar changed to 5 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:50:41 <number80> maxamillion: yes, but we might just forward it to FPC
17:50:48 <maxamillion> number80: ah, fair
17:51:03 <number80> I'm not against having the WG take ownership but we haven't discussed that yet
17:51:20 <kushal> praveenkumar, dustymabe rtnpro and other container guys, please have a look :)
17:51:26 <number80> *nods*
17:52:01 <dustymabe> kushal: i'm booked up right now :(
17:52:44 <kushal> dustymabe, No problem :)
17:52:55 <kushal> We can move to open floor.
17:53:00 <jsmith> WORKSFORME
17:53:03 <kushal> 8 minutes on hand.
17:53:08 <kushal> #topic Open Floor
17:53:15 <kushal> After long time :)
17:53:31 * jsmith has nothing for the open floor
17:53:32 <kushal> Anyone? anything?
17:53:38 <rtnpro> so, I'd like to go ahead and update on my research so far of cloud motd
17:53:51 <kushal> rtnpro, Okay.
17:53:57 <kushal> rtnpro, Just remember the deadlines.
17:54:06 <number80> none
17:54:31 <rtnpro> so, I have been digging into pam.d amd how to execute scripts on login
17:55:13 <rtnpro> and I was able to wire up `dnf updateinfo` and `users` call, and dump the response to /etc/motd
17:55:51 <rtnpro> but, `dnf -qC updateinfo` is a CPU intensive operation and takes time to execute
17:56:08 <rtnpro> so, there's no room for running this operation at login
17:57:02 <rtnpro> after speaking with a dnf developer, I came to the conclusion that we need to cache the response of `dnf updateinfo` so that the info can be rendered immediately
17:57:34 <rtnpro> I am exploring into dnf plugins which exposes hooks whenever a transaction is run
17:58:07 <rtnpro> the plan is to store the response of `dnf updateinfo` whenever there's a transaction
17:58:46 <rtnpro> that's so far I have explored
17:59:09 <rtnpro> I will be coming up with a working POC in a few days and put it up for review
17:59:18 <dustymabe> rtnpro: when a transaction is run + daily would probably be useful
17:59:21 <rtnpro> any one, any question, suggestion?
17:59:36 <dustymabe> if no cached updateinfo is availabe we could also print out and say that it hasn't run yet
17:59:38 <rtnpro> dustymabe, that's the plan :D
17:59:49 <rtnpro> dustymabe, yes
18:00:25 <rtnpro> that's all from me :)
18:02:18 <kushal> And time over.
18:02:22 <kushal> Closing the meeting.
18:02:24 <kushal> #endmeeting