17:00:37 <rtnpro> #startmeeting fedora_cloud_wg
17:00:37 <zodbot> Meeting started Wed May 18 17:00:37 2016 UTC.  The chair is rtnpro. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:37 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:00:49 <rtnpro> #topic Roll Call
17:01:03 <rtnpro> .fas rtnpro
17:01:04 <zodbot> rtnpro: rtnpro 'Ratnadeep Debnath' <rtnpro@gmail.com>
17:01:06 <jbrooks> .hello jasonbrooks
17:01:07 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <JBROOKS@REDHAT.COM>
17:01:15 <kushal> .hellomynameis kushal
17:01:16 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:24 <jzb> .hellomynameis jzb
17:01:25 <zodbot> jzb: jzb 'Joe Brockmeier' <jzb@redhat.com>
17:01:29 <trishnag> .hello trishnag
17:01:30 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:01:37 * jzb in real-time meeting, may be distracted.
17:02:05 <dustymabe> .hellomynameis dustymabe
17:02:05 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:02:14 <tflink> .hello tflink
17:02:15 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:02:51 <rtnpro> #chair rtnpro dustymabe tflink trishnag jbrooks kushal
17:02:51 <zodbot> Current chairs: dustymabe jbrooks kushal rtnpro tflink trishnag
17:03:30 <rtnpro> #topic kushal to associate the items to owners in ticket 143
17:03:54 <kushal> oops
17:04:03 <kushal> #topic Action items from last meeting
17:04:11 <kushal> * kushal to associate the items to owners in ticket 143
17:04:12 <kushal> * kushal to clarify smoke test ticket requirements
17:04:12 <kushal> * jberkus to obtain stats about cloud vs hw deployments
17:04:12 <kushal> * mattdm to create ticket giving download page redesign options
17:04:12 <kushal> * kushal to do test day writeup
17:04:13 <kushal> * jberkus to work on test for kubernetes cluster on AWS etc
17:04:17 <sayan> .fas sayanchowdhury
17:04:18 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:04:25 <kushal> ^^ now all of us can update for the action items.
17:04:37 <rtnpro> #chair sayan
17:04:37 <zodbot> Current chairs: dustymabe jbrooks kushal rtnpro sayan tflink trishnag
17:04:40 <kushal> I commented on the smoke test ticket
17:04:58 <kushal> tflink, do you have any more comments on that?
17:06:01 <tflink> not sure how to do 3) in your comment
17:06:10 <tflink> or what all that would entail
17:06:36 <tflink> 3) is "scanning for executable(s) in image (should not be any random binary)"
17:06:52 <tflink> 2) is done by releng during the build process, I think
17:07:27 <kushal> tflink, Okay.
17:07:31 <tflink> but other than that, I think that atomic scan will take care of most of it
17:07:46 <kushal> tflink, Even I hope so.
17:07:55 <kushal> tflink, You may want to look at clair.
17:07:59 <tflink> do you really think we need openscap or clair in addition to atomic scan?
17:08:19 <kushal> tflink, i think atomic scan will have openscap in it.
17:08:29 <tflink> will do, from first glance, it doesn't seem to provide anything atomic scan doesn't though
17:08:43 <kushal> tflink, Okay.
17:08:55 <kushal> tflink, For clair, you should decide based on your timeline.
17:09:03 <kushal> I just wrote that as a note.
17:09:13 <kushal> Anyone here used Clair or Atomic scanner before?
17:09:19 <tflink> yeah, it came across as a suggestion
17:10:08 * tflink has only read about them, hasn't gotten to trying either yet
17:11:17 <kushal> We are actually missing many in today's meeting.
17:13:14 <kushal> Any more update from anyone?
17:13:29 <jzb> kushal: nothing here, sadly
17:13:31 <dustymabe> kushal: on this ticket?
17:13:52 <kushal> dustymabe, Or any of the other action items.
17:14:02 * kushal has some network lag btw
17:14:24 <dustymabe> kushal: I don't have any
17:14:24 <kushal> rtnpro, you can move to the tickets :)
17:14:31 <rtnpro> ok
17:15:17 <rtnpro> # topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:15:24 <rtnpro> #topic Fedora Cloud FAD (late 2015/early 2016) https://fedorahosted.org/cloud/ticket/115
17:16:20 <kushal> Everyone booked hotels?
17:17:09 * tflink is still looking for a roommate but has booked a room
17:17:33 <dustymabe> kushal: did you and adam get yors?
17:17:38 <dustymabe> yours
17:17:46 <rtnpro> jzb, what about you?
17:17:49 <kushal> dustymabe, Adam is supposed to book for both of us.
17:17:56 <dustymabe> rtnpro: jzb is local :)
17:17:57 <kushal> rtnpro, He lives there.
17:18:03 <rtnpro> my bad
17:18:37 <dustymabe> jbrooks: ^^
17:18:57 <jbrooks> dustymabe, I've booked a room
17:19:03 <dustymabe> cool
17:19:18 <kushal> Nice.
17:19:25 <dustymabe> kushal: since you and adam are rooming together you might want to update the wiki
17:19:34 <kushal> dustymabe, I will ping you after this for some flight help :)
17:19:44 <dustymabe> to remove the "hotel" part of your budget
17:20:28 <rtnpro> It seems like we are good here, shall we move to the next ticket?
17:21:07 <kushal> rtnpro, yes please :)
17:21:30 <rtnpro> #topic Fedora-Dockerfiles examples for Kubernetes https://fedorahosted.org/cloud/ticket/125
17:22:54 <jzb> rtnpro: I live in RDU
17:22:55 <jzb> :-)
17:23:49 <rtnpro> jberkus is not around
17:24:11 <kushal> rtnpro, let us move to next one
17:24:15 <rtnpro> ok
17:24:33 <rtnpro> #topic vagrant boxes fixups https://fedorahosted.org/cloud/ticket/136
17:25:01 <rtnpro> imcleod is not around, too
17:25:25 <rtnpro> dustymabe, any comment?
17:25:35 <dustymabe> rtnpro: not at the moment.. other than a sigh :)
17:25:41 <rtnpro> dustymabe, ok
17:25:48 <rtnpro> let's move to the next ticke
17:25:52 <rtnpro> ticket*
17:26:09 <rtnpro> #topic Proposals for F24 features https://fedorahosted.org/cloud/ticket/143
17:26:28 <kushal> rtnpro, I will have to update this.
17:26:49 <kushal> I should add all the missing action items from last week.
17:27:01 <kushal> #action kushal to associate the items to owners in ticket 143
17:27:10 <kushal> #action jberkus to obtain stats about cloud vs hw deployments
17:27:20 <kushal> #action mattdm to create ticket giving download page redesign options
17:27:29 <kushal> #action jberkus to work on test for kubernetes cluster on AWS etc
17:27:43 <kushal> rtnpro, please go ahead/.
17:27:48 <rtnpro> ok
17:28:07 <rtnpro> #topic Don't overwrite download location for 2 week atomic images https://fedorahosted.org/cloud/ticket/147
17:28:34 <dustymabe> rtnpro: next..
17:28:39 <dustymabe> we'll do this post f24
17:28:44 <rtnpro> ok
17:29:11 <rtnpro> #topic Container "Packager" Guildelines and Naming Conventions https://fedorahosted.org/cloud/ticket/148
17:29:49 <rtnpro> kushal, any comment?
17:30:03 <kushal> rtnpro, I am not the right person for that.
17:30:42 <rtnpro> maxmillion, mattdm is not around, so moving to next ticket
17:31:06 <rtnpro> #topic Need owner to define basic container smoke testing requirements https://fedorahosted.org/cloud/ticket/151
17:31:22 <kushal> rtnpro, We already discussed this in action items.
17:31:37 <rtnpro> ok, moving to next ticket
17:32:06 <rtnpro> #topic Fedora Coud Test Day for F24 https://fedorahosted.org/cloud/ticket/152
17:32:50 <rtnpro> can we close this ticket?
17:33:00 <kushal> rtnpro, I think I have to add my blog post to this and then close.
17:33:30 <dustymabe> kushal: now that we have bugs closed out and a working atomic host we should have a test day round 2
17:33:39 <kushal> dustymabe, Yes.
17:33:43 <dustymabe> all of those bugs finally made it to stable
17:33:54 <dustymabe> and I verified with the images that were built on sunday that they work
17:33:58 <rtnpro> #action kushal will add his blog post in the ticket and close #152
17:33:59 <dustymabe> for a small subset of use cases
17:34:15 <dustymabe> we really need to run all tunir tests against them though
17:34:42 <kushal> dustymabe, Yup.
17:35:15 <rtnpro> Moving to next ticket
17:35:28 <rtnpro> #topic design, deploy and document Fedora OpenShift Playground (FOSP) https://fedorahosted.org/cloud/ticket/153
17:36:05 <rtnpro> neither scollier or [Goern] are around
17:36:13 <rtnpro> moving to next ticket
17:36:33 <rtnpro> #topic make Fedora Atomic download page clearer https://fedorahosted.org/cloud/ticket/154
17:36:56 <dustymabe> was this mattdm?
17:37:15 <rtnpro> kushal, any update on this?
17:37:24 <kushal> dustymabe, Yup.
17:38:43 <rtnpro> huh?
17:39:03 <kushal> rtnpro, I am not the person to comment.
17:39:13 <rtnpro> let's move to next ticket
17:39:17 <dustymabe> yep
17:39:39 <dustymabe> not too many people getting involved today :)
17:39:40 <rtnpro> #topic Decide on post-GA update cadence for various deliverables https://fedorahosted.org/cloud/ticket/155
17:40:18 <rtnpro> maxmillion is not around, so moving to next ticket
17:40:38 <rtnpro> #topic Need complete Kickstart docs for Atomic Host https://fedorahosted.org/cloud/ticket/156
17:41:09 <rtnpro> neither of the participants in the ticket are here
17:41:19 <rtnpro> let's move to open floor
17:41:40 <rtnpro> #topic Open Floor
17:41:57 <kushal> number80, has resigned from the WG.
17:42:06 <kushal> I am sad to see him go :(
17:42:17 <rtnpro> yes, I saw the mail, too :(
17:42:36 <dustymabe> kushal: yeah. with my availability I feel almost like I should do the same - but I think I still add value
17:42:40 <dustymabe> so I'm hanging around
17:42:47 <dustymabe> :)
17:43:45 <rtnpro> hey, I needed some help with testing the latest release of fedora-motd
17:44:13 <rtnpro> https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8948356b9
17:44:28 <kushal> dustymabe, Next week I will be in portland (during the meeting)
17:44:33 <rtnpro> dustymabe, could you test it once to see if it addresses the issues you had reported
17:44:33 <dustymabe> rtnpro: yeah. unfortunately I can't manage to help there
17:44:42 <kushal> and the week after too
17:44:54 <rtnpro> dustymabe, ok
17:45:02 <dustymabe> will probably be a while because I'm swamped with summit deliverables
17:45:19 <rtnpro> trishnag, sayan, want to help with this?
17:45:24 <dustymabe> rtnpro: can you ping me on it after Fedora 24 release
17:45:27 <sayan> rtnpro: I will look into it
17:45:36 <dustymabe> yes. and please have others look/comment
17:45:38 <rtnpro> there's detailed instruction on how to test it
17:45:39 <sayan> and keep you posted
17:45:52 <rtnpro> sayan, cool
17:45:56 <jbrooks> rtnpro, I can run these tests you've listed in bodhi
17:46:04 <trishnag> rtnpro, Sure I will take a look into it
17:46:29 <rtnpro> jbrooks, do you mean that you were able to run these tests?
17:46:40 <jbrooks> rtnpro, no, I'll try them
17:46:50 <rtnpro> jbrooks, that will be great :)
17:47:04 <rtnpro> I will add an action item on this, then
17:47:23 <rtnpro> #action jbrooks, sayan and trishnag will help to test https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8948356b9
17:47:58 <rtnpro> I also renamed the project from fedora-motd to motdgen, to make it more generic
17:48:15 <rtnpro> The project renaming was suggested by walters
17:48:26 <dustymabe> rtnpro: yeah. i like that
17:48:42 <rtnpro> dustymabe, coreos guys also have a project called motdgen ;)
17:48:46 <dustymabe> kushal: do you want to remove number80 from charter?
17:48:57 <dustymabe> rtnpro: yeah?
17:49:01 <dustymabe> what does it do?
17:49:02 <kushal> dustymabe, we can do that during the fad.
17:49:15 <rtnpro> dustymabe, https://github.com/coreos/motdgen, but it dose not have any code
17:49:20 <dustymabe> rtnpro: probably want to call it something differnt then
17:49:44 <rtnpro> motdgen is cool and makes perfect sense
17:49:54 <rtnpro> and we have got a working code
17:50:15 <dustymabe> rtnpro: can you comment on their repo and ask what they are going to do with it?
17:50:20 <dustymabe> might be a similar idea
17:50:31 <rtnpro> and, with the ability to run any scripts under /etc/motdgen.d/ and access control, we will be super cool
17:50:41 <rtnpro> dustymabe, I will do that
17:50:55 <dustymabe> yeah, i'd rather either collab with them on it or use a different name
17:51:25 <rtnpro> #action rtnpro will speak with https://github.com/coreos/motdgen/ and figure out how we can collaborate on making a single tool for motdgen
17:51:26 <dustymabe> I don't see where you can open issues so you might have to do a PR
17:52:39 <rtnpro> me, neither :(
17:52:45 <trishnag> rtnpro, Where should I update after testing motdgen?
17:53:06 <rtnpro> trishnag, you can comment on https://bodhi.fedoraproject.org/updates/FEDORA-2016-c8948356b9
17:53:34 <rtnpro> trishnag, if you find an issue, you can file it in https://github.com/rtnpro/motdgen/issues
17:53:35 <trishnag> rtnpro, okay thanks :)
17:54:16 <rtnpro> Does anyone have anything else to discuss?
17:55:12 <dustymabe> rtnpro: just that we should try to test as much as possible between now and f24 release
17:55:25 <rtnpro> dustymabe, yeah
17:55:28 <dustymabe> sayan: is there an easy way to find the latest image uploads?
17:56:20 <sayan> dustymabe: I wrote a script - https://github.com/sayanchowdhury/-bin/blob/master/get_ami_from_compose_id.py
17:57:29 <dustymabe> sayan: do you mind periodically sending the output to the cloud list for the next few weeks
17:57:35 <dustymabe> once every few days
17:57:58 <dustymabe> just so that we can easily find the information and people will hopefully be more likely to test
17:58:12 <dustymabe> also sayan.. we don't do atomic host as part of the composes right?
17:58:12 <sayan> sure I can do that
17:58:24 <dustymabe> kushal: ^^
17:58:39 <dustymabe> atomic host follows the nightly process
17:58:58 <kushal> dustymabe, dgilmore is working on it.
18:00:03 <dustymabe> working on what exactly?
18:00:29 <kushal> dustymabe, to have 2WA images as part of standard composes.
18:01:23 <dustymabe> kushal: ok.  for some reason I thought that was never a goal
18:01:29 <dustymabe> either way - that is fine
18:01:45 <kushal> We need that to use autocloud to test all the images.
18:01:49 <kushal> We are over time.
18:01:56 <dustymabe> kushal: thanks for keeping up with this.
18:01:56 <kushal> rtnpro, feel free to end the meeting.
18:02:00 <rtnpro> yeah
18:02:01 <dustymabe> what would we do without you
18:02:08 <rtnpro> #endmeeting