17:00:08 <jbrooks> #startmeeting fedora_cloud_wg
17:00:08 <zodbot> Meeting started Wed Jul 20 17:00:08 2016 UTC.  The chair is jbrooks. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:08 <zodbot> The meeting name has been set to 'fedora_cloud_wg'
17:00:17 <jbrooks> #topic Roll Call
17:00:29 <bowlofeggs> !here
17:00:32 <scollier> .hello scollier
17:00:33 <zodbot> scollier: scollier 'Scott Collier' <emailscottcollier@gmail.com>
17:00:41 <bowlofeggs> .hello bowlofeggs
17:00:42 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <bowlofeggs@electronsweatshop.com>
17:00:46 <trishnag> .hello trishnag
17:00:47 <zodbot> trishnag: trishnag 'Trishna Guha' <trishnaguha17@gmail.com>
17:00:49 <nzwulfin> .hello mmicene
17:00:54 <zodbot> nzwulfin: mmicene 'Matt Micene' <nzwulfin@gmail.com>
17:00:57 <jberkus> .hello jberkus
17:00:58 <zodbot> jberkus: jberkus 'Josh Berkus' <josh@agliodbs.com>
17:01:24 <kushal> .hellomynameis kushal
17:01:26 <zodbot> kushal: kushal 'Kushal Das' <mail@kushaldas.in>
17:01:28 <dustymabe> .hellomynameis dustymabe
17:01:31 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dustymabe@redhat.com>
17:01:50 * kushal has few questions related to Flock etc, may be at first or for open floor.
17:02:15 <tflink> .hello tflink
17:02:16 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
17:02:20 <jbrooks> #chair bowlofeggs scollier trishnag nzwulfin jberkus kushal dustymabe tflink
17:02:20 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal nzwulfin scollier tflink trishnag
17:02:39 <jbrooks> #topic discuss Post-GA Cadence
17:02:49 <jbrooks> Last time we resolved to talk about this first
17:03:01 <jbrooks> https://fedorahosted.org/cloud/ticket/155
17:03:50 <kushal> 2WA atomic is good, but we are still missing info to release the base image.
17:03:59 <sayan> .hello sayanchowdhury
17:04:00 <zodbot> sayan: sayanchowdhury 'Sayan Chowdhury' <sayan.chowdhury2012@gmail.com>
17:04:07 <jbrooks> #chair sayan
17:04:07 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal nzwulfin sayan scollier tflink trishnag
17:04:11 <jberkus> jbrooks: we still need maxamillion for that
17:04:26 <jbrooks> jberkus, I just pinged him in fedora-cloud
17:04:48 <tflink> doesn't he have another meeting in this time slot?
17:05:12 <jbrooks> he's coming
17:05:15 <maxamillion> .hello maxamillion
17:05:16 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
17:05:19 <maxamillion> sorry all
17:05:19 <jbrooks> #chair maxamillion
17:05:19 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal maxamillion nzwulfin sayan scollier tflink trishnag
17:05:30 <maxamillion> I was sitting in #fedora-meeting waiting for the meeting to kick off ... which of course wasn't going to
17:05:37 <bowlofeggs> haha
17:05:42 <jbrooks> maxamillion, we're kicking off w/ https://fedorahosted.org/cloud/ticket/155
17:06:07 <maxamillion> cool cool
17:06:43 <kushal> maxamillion, :)
17:06:47 <jbrooks> I see the only question mark at https://fedoraproject.org/wiki/Fedora_Program_Management/Updating_deliverables/Fedora24#updating_deliverables is updating the atomic repos
17:07:11 <kushal> maxamillion, jbrooks we also have the other ticket to release updated base image.
17:07:17 <kushal> Which sadly we could not before.
17:08:15 <jbrooks> kushal, do you have a link for that one?
17:09:31 <kushal> jbrooks, https://fedorahosted.org/cloud/ticket/138
17:09:32 <kushal> https://fedorahosted.org/cloud/ticket/138
17:10:26 <jbrooks> OK, so, on 155, what's blocking us / what needs discussing?
17:11:03 <jbrooks> It seems to make sense to me to update the testing repo daily, and the 2-week one each two weeks
17:11:42 <dustymabe> jbrooks: seems reasonable
17:12:02 <kushal> jbrooks, sounds good.
17:12:07 <jbrooks> maxamillion, what say you?
17:12:30 <maxamillion> makes sense
17:12:34 <dustymabe> jbrooks: do we even have to limit the testing repo at all
17:12:41 <dustymabe> just have it update whenever a compose is done?
17:12:44 <dustymabe> like is done now?
17:12:57 <jbrooks> Oh, is that what we do now? That's better
17:13:08 <dustymabe> i think.. it basically updates all the time
17:13:22 <jbrooks> dustymabe, OK, so, right now, is that how the stable repo works, too?
17:13:30 <dustymabe> yeah
17:13:35 <dustymabe> I believe so
17:13:43 <dustymabe> basically one pulls from updates-testing
17:13:46 <dustymabe> and one pulls from updates
17:13:54 <dustymabe> both updated continuously
17:14:17 <jbrooks> OK, what's your take on continuing continuous for the stable repo?
17:14:36 <dustymabe> let me go look at ticket before I make an ass of myself
17:14:47 <jbrooks> Cool
17:15:38 <dustymabe> ok here is what I think
17:15:42 <dustymabe> which doesn't matter much
17:15:59 <dustymabe> there is a stable which updates every two weeks along with the release of atomic host
17:16:21 <dustymabe> there is a "continuous" which updates all the time, just like stable branch does now
17:16:37 <dustymabe> there is a "testing" which is the same as testing today - updates all the time, etcc
17:16:48 <maxamillion> "continuing continuous"? ... Fedora doesn't have a continuous yet
17:16:53 <jbrooks> see also: https://fedorahosted.org/rel-eng/ticket/6313
17:17:04 <jbrooks> maxamillion, is the current stable repo not continuous?
17:17:06 <dustymabe> yeah. continuous might be the wrong word
17:17:18 <maxamillion> jbrooks: not the way CentOS continuous is
17:17:19 <dustymabe> and that word means a lot of different things to different people
17:17:22 <jbrooks> Continuous from the stable repos
17:17:24 <maxamillion> jbrooks: it gets updated nightly
17:17:32 <jbrooks> got it
17:17:38 <dustymabe> so we may use a word like nightly or daily
17:17:43 <maxamillion> or wait
17:17:44 <jbrooks> maxamillion, is that the same for testing?
17:17:45 <dustymabe> instead of continuous
17:17:59 <maxamillion> the ostree gets updated constantly from bodhi actually ... I think
17:18:05 <jbrooks> #chair walters
17:18:05 <zodbot> Current chairs: bowlofeggs dustymabe jberkus jbrooks kushal maxamillion nzwulfin sayan scollier tflink trishnag walters
17:18:53 <jberkus> we need this on a web page somewhere ... once we figure out what the truth is
17:19:04 <jbrooks> dustymabe, OK, so you're saying, we add a new one, and the new one looks like it'd be the two-week one
17:19:12 <jbrooks> And have that become the default
17:19:28 <dustymabe> jbrooks: right
17:20:07 <dustymabe> so users could choose to test latest stable if they want to - and that would probably be a good way for us to try out the next two week release before it gets released
17:20:15 <jbrooks> The other thing to consider is when / whether / how to make exceptions for critical security issues
17:20:57 <jbrooks> We don't have to let that block us from adding this third stream, though
17:21:26 <jbrooks> maxamillion, What's your take on adding this two week only branch (is branch the right term)
17:21:33 <jbrooks> Is that doable
17:21:34 <jberkus> jbrooks: I'll be ready to tackle critical security issues once we have a track record of getting out the regular releases without a lot of trauma
17:21:47 <jbrooks> jberkus, good point
17:22:07 <maxamillion> jbrooks: I honestly don't know, this is off in the weeds of ostree creation that lmacken and dgilmore have done in the past, I'm not well versed in it enough to properly comment
17:22:36 <jbrooks> maxamillion, OK, I'll take an action to update the ticket and run this down some more before next mtg
17:22:41 <dustymabe> so I don't how difficult it is to make the tooling around it
17:22:44 <maxamillion> jbrooks: +1
17:22:53 <jbrooks> If there's nothing else for now on this, we can move ahead
17:23:00 <dustymabe> but at the highest level it is as simple as updating the file in the repo that points to what commit
17:23:22 <jbrooks> #action jbrooks to update / run down issues around two-week repo
17:24:29 <dustymabe> jbrooks: can you also capture the discussion we had here
17:24:35 <dustymabe> in one of the tickets?
17:24:38 <jbrooks> dustymabe, will do
17:25:01 <jbrooks> #topic issue 136 https://fedorahosted.org/cloud/ticket/136
17:25:25 <jbrooks> A few of us had an action item to look further into this, the vagrant fixups, I didn't look at it myself
17:25:42 <jbrooks> Was it decided that this was solved in the blog post thread?
17:26:20 <jbrooks> dustymabe, did you look at this any more?
17:28:12 <jbrooks> #topic other open items
17:28:31 <dustymabe> jbrooks: I did not- I thought imcleod was going to
17:28:42 <walters> i'm not sure how much it makes sense to talk about unless there's someone with both commit access, time and motivation
17:29:02 <jbrooks> jberkus, you have a few in here https://fedorahosted.org/cloud/report/9 -- any updates on #125, #153, #154
17:29:06 <jbrooks> walters, indeed
17:29:11 <walters> for reference i have all of those in centos CI so have been working on some of this there
17:29:26 <walters> i don't have commit access to fedora
17:29:34 <kushal> walters, which repos?
17:29:39 <jbrooks> walters, you're talking about the vagrant fixups?
17:29:49 <walters> no sorry, was talking about the release cadence ticket
17:30:17 <jbrooks> walters, OK, right, we'll get it straightened
17:30:37 <jberkus> lemme update those tickets
17:31:05 <walters> fwiw the reason i'm working in centos devel is that we really need testing on e.g. python2 before doing any downstream releases etc., and i see that as a gap
17:31:27 <walters> there is a larger picture issue that the centos base release cycle is better in general for servers
17:31:50 <dustymabe> walters: i.e. less moving parts
17:32:14 <walters> but if we find someone who can spend most of their time on this in fedora happy to help
17:33:31 <jbrooks> jberkus, This kickstart docs ticket, #156, can you own it?
17:33:58 <jberkus> jbrooks: sure.
17:34:27 <jberkus> jbrooks: I was hoping to doc an all-in-one-USB-key install, but I'm stonewalled by my lack of knowledge about EFIboot
17:35:32 <jbrooks> The only other unowned ticket in the list is #147, about overwriting the two-week dl location: https://fedorahosted.org/cloud/ticket/147
17:36:00 <dustymabe> is it unowned? I think maxamillion has that one
17:36:14 <jbrooks> dustymabe, You reported that one, what do we need to do to put this one to bed -- ah, there isn't a listed owner
17:37:03 <jbrooks> Do we know an EFIboot guru who can help jberkus?
17:37:13 <maxamillion> dustymabe: yeah, it's "on the list" but if someone has time to look at the code it'd be welcomed ... because of OSBS getting out the door later than it was supposed to I'm kind of knee deep playing catch up on other things that were supposed to be done by now
17:37:29 <dustymabe> maxamillion: understood
17:37:44 <jberkus> jbrooks: did you ever figure out a way to fix iptables using ansible?
17:38:10 <jberkus> jbrooks: if not, I really need to open a bug somewhere
17:38:21 <jbrooks> jberkus, I haven't looked at it since before summit -- yes, it seems like a bug
17:38:49 <kushal> We should mark it as open floor.
17:38:50 <jbrooks> maxamillion, I'll take a close look at #147 and see if I can help
17:38:57 <jbrooks> #topic open floor
17:38:58 <kushal> Okay, who all are coming to flock from here?
17:39:02 <jzb> yo
17:39:14 * kushal and sayan will be there.
17:39:16 <dustymabe> kushal: I'll be there
17:39:33 <kushal> Who else?
17:39:38 <kushal> maxamillion, jberkus jbrooks ?
17:39:50 <jbrooks> kushal, not me
17:39:51 <kushal> jzb, We should have the cloud WG meeting this time too.
17:39:59 <kushal> jbrooks, Okay, you can join in over hangout :)
17:40:00 <dustymabe> imcleod will be there
17:40:02 <jbrooks> :)
17:40:03 <dustymabe> and I think scollier
17:40:04 * walters can't make it (new child process in september)
17:40:10 <jbrooks> awesome
17:40:11 <dustymabe> walters: no!!!
17:40:14 <kushal> walters, Ah, congratulations :)
17:40:18 <dustymabe> walters: you will be missed!
17:40:22 <walters> kushal, thanks =)
17:40:29 <maxamillion> I'll be at Flock
17:40:32 <jberkus> congrats
17:40:34 * dustymabe was hoping to elbow bump with walters some more
17:40:39 <kushal> :)
17:40:41 <jberkus> I'll be at flock
17:40:42 <maxamillion> walters: congratulations!!!!
17:41:02 <scollier> dustymabe, yup, i'm booked.
17:41:03 <maxamillion> walters: you will definitely be missed indeed, but what a great reason to skip :D :D :D
17:41:17 <sayan> I need to talk on https://fedorahosted.org/cloud/ticket/99
17:41:36 <sayan> Do we delete the released AMIs?
17:41:53 <jberkus> sayan: I would like us to.  It's way confusing right now to pick the right AMI for a new instance
17:41:55 <kushal> sayan, NO
17:42:09 <jberkus> kushal: ?
17:42:18 <kushal> sayan, We do not delete anything formally GA released.
17:42:34 <bowlofeggs> i'll be at flock
17:42:44 <kushal> jberkus, After we release something, we are not supposed to delete any of those.
17:42:48 <kushal> bowlofeggs, :)
17:42:56 <jberkus> kushal: well, we have a serious usability problem then
17:43:07 <jberkus> kushal: try creating a new Atomic EC2 instance
17:43:12 <bowlofeggs>17:43:13 <jberkus> and try to pick the latest image
17:43:20 <jberkus> you'll see the problem
17:43:28 <kushal> jberkus, okay, I will try that tomorrow morning.
17:43:42 <bowlofeggs> dustymabe: have you convinced maxamillion to be your sponsor yet? i think he said he'd do the rest if i reviewed your vagrant-sshfs package, and that's done ☺
17:43:43 <kushal> jberkus, problem is someone may be depended on the released AMI
17:43:51 <jbrooks> jberkus, it seems pretty easy from https://getfedora.org/en/cloud/download/atomic.html
17:43:58 <jberkus> kushal: also, given that we do releases every 2 weeks, we can't keep them forever
17:43:59 <dustymabe> bowlofeggs: yeah, the problem is me.
17:44:01 <bowlofeggs> though i bet you have to do some reviews too
17:44:03 <dustymabe> I have to review other packages
17:44:03 <jbrooks> are those not the latest?
17:44:06 <jberkus> jbrooks: try it from inside AWS
17:44:23 <jbrooks> jberkus, I always start w/ an ami-ID
17:44:31 <maxamillion> wha?
17:44:31 <jbrooks> and search for that, and get it
17:44:33 <kushal> jberkus, we will have to ask FESCo on this then/
17:45:06 <dustymabe> jberkus: I'd prefer to not have them deleted
17:45:08 <dustymabe> but that is me
17:45:13 <dustymabe> AWS needs something like AMI streams
17:45:20 <dustymabe> so there can be versions of images
17:45:32 <dustymabe> or something like that
17:46:16 <jberkus> actually, I have an item on ticket 153
17:46:18 <jberkus> or related
17:47:23 <jbrooks> jberkus, Go ahead
17:47:26 <jberkus> dustymabe: imagine 2 years down the line, when we have another 80 minages
17:47:38 <jberkus> so the CNCF has a cluster for member projects
17:47:56 <jberkus> we've been looking for hardware for FedAtomOpenShift testing
17:48:16 <jzb> dustymabe: our AWS bill is ... impressive right now :-)
17:49:05 <dustymabe> jzb: yeah. thats another part of the problem
17:49:06 <jberkus> or FOSP
17:49:22 <kushal> jzb, correct, but we always had the idea not to delete the released ones, but delete all the nightlies and many other snapshots etc.
17:49:30 <jberkus> that seems like a good way to have hosting for that
17:49:31 <kushal> We should reevaluate the whole story there.
17:49:32 <dustymabe> i think after a release has passed, we could then delete all but first and last
17:49:41 <dustymabe> and then for current release. we keep all
17:49:54 <kushal> dustymabe, last time people release screamed at us.
17:49:57 <dustymabe> jberkus +1
17:50:19 <jzb> kushal: "people" or "person"?
17:50:20 <dustymabe> kushal: yeah but you deleted something you shouldn't have
17:50:26 <jberkus> dustymabe: that would make things considerably better, although I still think we should look at changing our naming scheme somehow, or at least documenting it
17:50:29 <kushal> oops
17:50:30 <jzb> I just remember there was one person who complained.
17:50:33 <dustymabe> an actual real release of an image
17:50:37 <kushal> dustymabe, last time people really screamed at us.
17:50:50 <kushal> jzb, One person on mail.
17:50:52 <dustymabe> I knew of one complaint
17:50:58 <kushal> Then gholms too
17:51:52 <jberkus> CNCF is still looking at how to set up access for non-employees of member companies; it might not be possible
17:52:26 <jberkus> so, first question: assuming I get a bunch of servers from CNCF, is there anything we'd want to use them for *other than* FOSP?
17:52:45 <kushal> On a side note, we have an opening for an intern to help us with atomic/cloud docs+examples+testing here in RH Pune.
17:52:52 <jbrooks> jberkus, FOSP seems like the most on-message use
17:53:01 <jzb> jberkus: so, a thoguht
17:53:02 <jzb> er, thought
17:53:04 <kushal> We are in the process of interviewing for the same.
17:53:14 <jzb> jberkus: the idea is to do testing of the entire stack
17:53:30 <sayan> well the complain was becuase we removed a 21 AMI, a release one I guess
17:53:35 <jzb> there's no reason that non-RHT folks would need direct access to servers if we were pushing changes via git/Ansible, or whatnot, right?
17:53:46 <jberkus> jzb: true
17:53:51 <jzb> IOW we could architect this so non-RHT folks can make changes
17:53:56 <jzb> they just can't touch the servers directly
17:53:58 <jzb> perhaps
17:54:02 <dustymabe> sayan: right but that was "the" release AMI for 21
17:54:04 <kushal> jberkus, btw, I want to sync up with you about FOSP.
17:54:05 <dustymabe> for that region
17:54:10 <dustymabe> there wasn't another option
17:54:16 <jberkus> kushal: sure. how much later will you be up?
17:54:22 <dustymabe> I think if we announce we are going to be deleting all but first/last for a relase
17:54:25 <maxamillion> I need food, see you folks later
17:54:27 <dustymabe> then that would be ok
17:54:31 <dustymabe> maxamillion: +1
17:54:33 <kushal> jberkus, Not today, may be on Friday or on next week.
17:54:33 <maxamillion> jbrooks: thanks for hosting!
17:54:35 * maxamillion &
17:54:38 <kushal> jberkus, I will drop you a mail.
17:54:42 <jberkus> ok
17:54:56 <jbrooks> All right, are we all set for this week?
17:55:01 <jkurik> Hi
17:55:02 <jkurik> I just would like to check whether there are any plans to do changes in PRD ?
17:55:04 <jkurik> or whether the WG is fine with the current version of it ?
17:55:16 <kushal> jkurik, we will meet during Flock
17:55:19 <jberkus> jbrooks: I think so
17:55:26 <kushal> and will get a change to discuss it.
17:55:32 <sayan> dustymabe: yes, but 21 was EOL around that time. Now, the thing is 22 is EOL so should we remove the AMIs?
17:55:36 <jberkus> second question is who else wants to be involved in setting this up (FOSP/CNCF)
17:55:48 <kushal> jberkus, count me in.
17:55:48 <jberkus> particularly, I could use some help on CI/automation
17:55:49 <jkurik> kushal: ok, thanks for letting me know
17:56:21 <kushal> jberkus, as it is a cloud image, autocloud can help in CI part.
17:57:09 <jbrooks> #endmeeting