16:30:27 <rfairley> #startmeeting fedora_coreos_meeting
16:30:27 <zodbot> Meeting started Wed Feb 27 16:30:27 2019 UTC.
16:30:27 <zodbot> This meeting is logged and archived in a public location.
16:30:27 <zodbot> The chair is rfairley. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:27 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:30:35 <rfairley> #topic roll call
16:30:50 <dustymabe> .hello2
16:30:50 <rfairley> .hello2
16:30:50 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:30:51 <ajeddeloh> .hello2
16:30:53 <zodbot> rfairley: rfairley 'None' <rfairley@redhat.com>
16:30:56 <zodbot> ajeddeloh: ajeddeloh 'Andrew Jeddeloh' <andrew.jeddeloh@redhat.com>
16:31:08 <dbenoit> .hello2
16:31:09 <zodbot> dbenoit: dbenoit 'David Benoit' <dbenoit@redhat.com>
16:31:09 <yzhang> .hello2
16:31:11 <zodbot> yzhang: yzhang 'Yu Qi Zhang' <jzehrarnyg@gmail.com>
16:31:52 <rfairley> #chair dustymabe ajeddeloh dbenoit yzhang
16:31:52 <zodbot> Current chairs: ajeddeloh dbenoit dustymabe rfairley yzhang
16:32:02 <sanja> .hello2
16:32:03 <zodbot> sanja: sanja 'Sanja Bonic' <sanja@redhat.com>
16:32:54 <jlebon> .hello2
16:32:55 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:33:03 <rfairley> give another min for people to join :)
16:33:14 <ksinny> .hello sinnykumari
16:33:15 <rfairley> #chair sanja jlebon
16:33:15 <zodbot> Current chairs: ajeddeloh dbenoit dustymabe jlebon rfairley sanja yzhang
16:33:15 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
16:33:18 <mnguyen_> .hello mnguyen
16:33:19 <zodbot> mnguyen_: mnguyen 'Michael Nguyen' <mnguyen@redhat.com>
16:33:42 <slowrie> .hello2
16:33:43 <zodbot> slowrie: slowrie 'Stephen Lowrie' <slowrie@redhat.com>
16:34:02 <lorbus> .hello2
16:34:03 <zodbot> lorbus: lorbus 'Christian Glombek' <cglombek@redhat.com>
16:34:47 <rfairley> #chair ksinny mnguyen_ slowrie lorbus
16:34:47 <zodbot> Current chairs: ajeddeloh dbenoit dustymabe jlebon ksinny lorbus mnguyen_ rfairley sanja slowrie yzhang
16:35:14 <rfairley> o/ hi all!
16:35:36 * ajeddeloh waves
16:35:42 <rfairley> #topic Action items from last meeting
16:35:48 <lorbus> o/
16:36:02 <rfairley> Action Items, by person
16:36:05 <rfairley> -----------------------
16:36:09 <rfairley> * ajeddeloh
16:36:14 <rfairley> * ajeddeloh to open a few tickets and design doc PRs for discussed
16:36:17 <rfairley> open floor topics on philosophy
16:36:18 <miabbott> .hello2
16:36:19 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
16:36:40 * rfairley needs to find a better way to paste these
16:37:15 <rfairley> ajeddeloh did these get opened?
16:37:18 <ajeddeloh> yeah
16:37:20 <rfairley> just looking in the tracker
16:37:21 <ajeddeloh> https://github.com/coreos/fedora-coreos-tracker/issues/153
16:37:46 <ajeddeloh> Haven't PRd the design doc yet since there hasn't been much discussion on the tracker
16:38:23 <rfairley> # link https://github.com/coreos/fedora-coreos-tracker/issues/153
16:38:31 <rfairley> #link https://github.com/coreos/fedora-coreos-tracker/issues/153
16:38:45 <jbrooks> .fas jasonbrooks
16:38:47 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <jbrooks@redhat.com>
16:39:03 <rfairley> #info To discuss more in linked ticket on Including fedora specific behavior
16:39:11 <rfairley> #chair miabbott jbrooks
16:39:11 <zodbot> Current chairs: ajeddeloh dbenoit dustymabe jbrooks jlebon ksinny lorbus miabbott mnguyen_ rfairley sanja slowrie yzhang
16:39:34 <rfairley> good to move to next?
16:39:44 <rfairley> next action item^
16:40:41 <rfairley> we can discuss more in the linked ticket, then maybe discuss that at the meeting next week
16:40:52 <rfairley> on fedora specific behavior^
16:41:00 <rfairley> * dustymabe
16:41:01 <rfairley> * dustymabe to create tickets for platform artifact creation
16:41:39 <dustymabe> #info dustymabe created tickets #146->#151 for image artifact uploads
16:41:44 <dustymabe> that's all
16:42:16 <rfairley> +1
16:42:39 <rfairley> * kaeso
16:42:42 <rfairley> * kaeso to create ticket for node arch-label introspection
16:43:24 <rfairley> kaeso - around?
16:43:36 * rfairley looking in tracker
16:43:42 <jlebon> https://github.com/coreos/fedora-coreos-tracker/issues/154
16:43:53 <lorbus> He might be in PTO
16:43:56 <lorbus> on*
16:43:57 <dustymabe> yeah he is out
16:44:06 <jlebon> i think it could be closed now with https://github.com/projectatomic/rpm-ostree/pull/1766, though let's let kaeso take a look
16:44:13 <rfairley> #info kaeso created labeling supported architectures and runtime introspection ticket
16:44:20 <rfairley> #link https://github.com/coreos/fedora-coreos-tracker/issues/154
16:44:31 <rfairley> jlebon: +1
16:45:07 <rfairley> let's move to meeting topics
16:45:21 <rfairley> https://public.etherpad-mozilla.org/p/20190227-FCOS-Meeting
16:45:40 <rfairley> if anyone has any open-floor topics for today, please feel free to add in the link ^
16:45:59 <rfairley> #topic Keep/Remove Python dependent package: policycoreutils-python
16:46:08 <rfairley> #link https://github.com/coreos/fedora-coreos-tracker/issues/126
16:47:06 <ksinny> We asked Dan on the ticket and he seems positive towards not having policycoreutils-python in FCOS
16:47:20 <dustymabe> +1 for trying it
16:47:29 <ksinny> we can use semodule, setsebool to do some selnux policy changes
16:48:23 <ksinny> does anyone think we might be still missing something if we don't ahave policycoreutils-python in FCOS base?
16:49:51 <ksinny> walters: jlebon: thoughts?
16:50:04 <jlebon> i'm good with shipping without it to start
16:50:10 <dustymabe> ksinny: i think if dan agrees we can go ahead and experiment
16:50:20 <rfairley> is there another tool that we might need to write for changing file contexts? https://github.com/coreos/fedora-coreos-tracker/issues/126#issuecomment-466185962
16:51:18 <jlebon> chcon should still be there. for modifying patterns, there's /bin/vi :)
16:51:30 <ajeddeloh> I'm +1 to not shipping it, we can always add things later, but not remove them
16:51:31 <jbrooks> I think I only use chcon
16:51:56 <ajeddeloh> UX doesn't need to be good for uncommon actions, it just needs to be possible
16:52:11 <ksinny> yeah, I used restorecon and chcon sometimes. That's it
16:53:07 <dustymabe> i think we're all agreed
16:53:09 <rfairley> +1 - seems we are in agreement on shipping without policycoreutils-python to start
16:53:35 <lorbus> +1
16:53:50 <ksinny> \o/
16:53:55 <rfairley> #info FCOS will not have policycoreutils-python in base packages
16:54:30 <ksinny> #agreed We will experimint with initially not shipping policycoreutils-python-utils in the FCOS base system
16:54:53 <rfairley> thanks ksinny :D
16:55:04 <ksinny> :)
16:55:19 <rfairley> I think we can head over to open floor topics now
16:55:35 <ksinny> yeah
16:55:51 <rfairley> #topic Open Floor
16:56:24 <rfairley> #topic tested out bare metal installer in PXE boot setup - seems to be working for BIOS (legacy boot) installs
16:56:31 <rfairley> #link https://github.com/coreos/fedora-coreos-tracker/issues/91#issuecomment-467631190
16:56:42 <ajeddeloh> woo!
16:56:59 <rfairley> dustymabe: want to start on this?
16:57:12 <ksinny> dustymabe++
16:57:29 <rfairley> ^ update on this for the discussion here I mean
16:57:57 <dustymabe> yep. basically i verified PXE installs can happen with bare metal legacy boot using the artifacts from the ISO we are generating
16:57:57 <rfairley> dustymabe++
16:58:18 <dustymabe> #info FCOS PXE installs can happen with bare metal legacy boot using the artifacts from the ISO we are generating
16:59:08 <dustymabe> that's all I had
16:59:09 <rfairley> nice!
16:59:11 <mnguyen_> dustymabe++
16:59:17 <yzhang> dustymabe++
16:59:17 <zodbot> yzhang: Karma for dustymabe changed to 10 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:00:00 <rfairley> good that bare metal is coming together more and more
17:00:20 * rfairley to next topic
17:00:29 <rfairley> #topic ignition spec 3.0.0 progress
17:00:45 <ajeddeloh> It's coming along nicely I think
17:01:02 <ajeddeloh> not going to quite make the "end of feb" goal we set
17:01:07 <rfairley> #link https://github.com/coreos/ignition/milestone/5
17:01:11 <ajeddeloh> but not _too_ far off
17:01:27 <lorbus> ajeddeloh++
17:01:28 <rfairley> ^these are quickly going through in the milestone
17:01:29 <ksinny> ajeddeloh++
17:01:29 <zodbot> ksinny: Karma for ajeddeloh changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:33 <jlebon> i'm actively playing with integrating it with FCOS
17:01:40 <rfairley> ajeddeloh++
17:01:40 <zodbot> rfairley: Karma for ajeddeloh changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:40 <ajeddeloh> jlebon++
17:01:40 <dustymabe> ajeddeloh: what are the largest work items we have left?
17:01:43 <zodbot> ajeddeloh: Karma for jlebon changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:43 <slowrie> ajeddeloh what major work for 3.0.0 is still outstanding?
17:02:09 <ajeddeloh> Largest ones are config merging rework and validation to reject duplicates
17:02:28 <ajeddeloh> then a bunch of tiny stuff that shouldn't be too bad
17:02:46 <ajeddeloh> then I'll release Ignition 2.0.0-alpha with spec 3.0.0-experimental
17:03:21 <dustymabe> ajeddeloh: of those two largest items are they both on you? or is someone else picking up one of them
17:03:23 <jlebon> another major one is sanity checking /var mounts work well as design
17:03:30 <ajeddeloh> yeah
17:03:44 <ajeddeloh> both on me, they're somewhat intertwined
17:03:57 <ajeddeloh> also both blocked on the automatic translation PR
17:04:08 <jlebon> that's part of the integration stuff i'm doing too. but i don't foresee issues
17:04:16 <jlebon> will be sure to review outstanding PRs!
17:04:37 <ajeddeloh> yeah having people to review the PRs recently has been massively helpful.
17:04:38 <slowrie> I'm planning on doing another pass through all the open PRs sometime this afternoon
17:05:49 <dustymabe> ajeddeloh: kk regarding 2.0.0-alpha
17:05:56 <dustymabe> is that the planned version number?
17:06:08 <ajeddeloh> n.b. we're skipping 1.0 for dumb golang vendoring related issues
17:06:17 <ajeddeloh> 0.x -> 2.x
17:07:28 * dustymabe speculates about going straight to 3.x :)
17:07:35 <ajeddeloh> nononononono
17:07:38 <dustymabe> 0.x -> 3.x (for spec 3.0.0)
17:07:44 <dustymabe> certainly easier to remember
17:07:55 <ajeddeloh> Yeah but they wont be tied together in the future
17:07:58 <ajeddeloh> and shouldn't be
17:08:15 <dustymabe> are they in the same repo?
17:08:18 <ajeddeloh> Ignition version itself is for API and user faces changes
17:08:28 <ajeddeloh> spec is for well the spec itself
17:08:29 <ajeddeloh> yeah
17:09:19 <ajeddeloh> Versioning them independently has been hugely helpful, it's a bit of confusion initially but worth it
17:10:04 <dustymabe> ehh. you're the experts :)
17:10:18 <dustymabe> next topic?
17:10:27 <ajeddeloh> example: if we rework the config/ directory so people vendoring ignition need to call a different api (as we plan to do) but don't change the spec, the change will be invisible to Ignition users but not Ignition as a library consumers
17:11:57 <rfairley> +1 - let's make a note of the 2.0.0-alpha version
17:13:09 <rfairley> #info Ignition API version will be vendored with the Ignition config (from 0.x to 2.x and 3.x)
17:13:46 <rfairley> ^ sounds correct?
17:14:02 <ajeddeloh> no
17:14:10 <rfairley> #undo
17:14:10 <zodbot> Removing item from minutes: INFO by rfairley at 17:13:09 : Ignition API version will be vendored with the Ignition config (from 0.x to 2.x and 3.x)
17:14:11 <ajeddeloh> They will be independently versioned
17:14:59 <ajeddeloh> #info Ignition API and config are versioned independently. Changes to the config version need a change to the API version (since new features were added or changed) but not vise versa
17:15:34 <rfairley> ahh, got it :)
17:15:52 <rfairley> moving to next topic
17:16:11 <rfairley> #topic now producing openstack artifacts in pipeline
17:16:45 <dustymabe> #info we are now producing openstack artifacts in the FCOS pipeline
17:16:52 <dustymabe> I believe strigazi asked for this
17:17:30 <dustymabe> https://github.com/coreos/fedora-coreos-pipeline/pull/50
17:17:39 <dustymabe> thanks jlebon for the review
17:18:01 <dustymabe> EOM
17:18:23 <jlebon> it's really nice how clean and easy to work on the pipeline is so far
17:19:04 <dustymabe> jlebon: yeah. there are a few papercuts, but it's mature for it's age IMHO
17:19:54 <jlebon> yeah, agreed
17:20:28 <rfairley> really cool seeing coreos-assembler, fedora-coreos-pipeline, fedora-coreos-config all come together
17:21:09 <rfairley> #endmeeting