16:30:02 <bgilbert> #startmeeting fedora_coreos_meeting
16:30:02 <zodbot> Meeting started Wed Jul 17 16:30:02 2019 UTC.
16:30:02 <zodbot> This meeting is logged and archived in a public location.
16:30:02 <zodbot> The chair is bgilbert. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:02 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:30:06 <bgilbert> #topic roll call
16:30:08 <bgilbert> .hello2
16:30:09 <zodbot> bgilbert: bgilbert 'Benjamin Gilbert' <bgilbert@backtick.net>
16:30:09 <slowrie> .hello2
16:30:12 <zodbot> slowrie: slowrie 'Stephen Lowrie' <slowrie@redhat.com>
16:30:14 <jlebon> .hello2
16:30:15 <rfairley> .hello2
16:30:15 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:30:17 <red_beard> .hello redbeard
16:30:18 <zodbot> rfairley: rfairley 'None' <rfairley@redhat.com>
16:30:19 <ajeddeloh> .hello2
16:30:21 <zodbot> red_beard: redbeard 'Brian 'redbeard' Harrington' <bharring@redhat.com>
16:30:22 <mnguyen_> .hello mnguyen
16:30:24 <zodbot> ajeddeloh: ajeddeloh 'Andrew Jeddeloh' <andrew.jeddeloh@redhat.com>
16:30:26 <zodbot> mnguyen_: mnguyen 'Michael Nguyen' <mnguyen@redhat.com>
16:30:51 <yzhang> .hello2
16:30:52 <zodbot> yzhang: yzhang 'Yu Qi Zhang' <jzehrarnyg@gmail.com>
16:31:10 <lorbus> .hello2
16:31:11 <vrutkovs> .hello2
16:31:11 <zodbot> lorbus: lorbus 'Christian Glombek' <cglombek@redhat.com>
16:31:14 <zodbot> vrutkovs: vrutkovs 'Vadim Rutkovsky' <vrutkovs@redhat.com>
16:31:30 <bgilbert> #chair slowrie jlebon rfairley red_beard ajeddeloh mnguyen_ yzhang lorbus vrutkovs
16:31:30 <zodbot> Current chairs: ajeddeloh bgilbert jlebon lorbus mnguyen_ red_beard rfairley slowrie vrutkovs yzhang
16:32:03 <ksinny> .hello sinnykumari
16:32:04 <zodbot> ksinny: sinnykumari 'Sinny Kumari' <ksinny@gmail.com>
16:33:25 <jbrooks> .fas jasonbrooks
16:33:27 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <jbrooks@redhat.com>
16:33:53 <kaeso[m]> .hello lucab
16:33:54 <zodbot> kaeso[m]: lucab 'Luca Bruno' <lucab@redhat.com>
16:33:59 <bgilbert> #chair ksinny jbrooks kaeso[m]
16:33:59 <zodbot> Current chairs: ajeddeloh bgilbert jbrooks jlebon kaeso[m] ksinny lorbus mnguyen_ red_beard rfairley slowrie vrutkovs yzhang
16:34:18 <bgilbert> hi all!  we're just going to have open floor today, but first, a bit of process to get through:
16:34:27 <bgilbert> #topic Action items from last meeting
16:34:39 <bgilbert> * ksinny to summarize discussion in ticket
16:34:46 <bgilbert> * bgilbert to summarize discussion in ticket
16:34:51 <bgilbert> those were... not phrased super-well :-/
16:35:09 <bgilbert> #info ksinny summarized stream metadata generator discussion in https://github.com/coreos/fedora-coreos-tracker/issues/193#issuecomment-501409882
16:35:30 <bgilbert> #info bgilbert summarized release notes discussion in https://github.com/coreos/fedora-coreos-tracker/issues/194#issuecomment-504289168
16:35:56 <ksinny> +1
16:36:15 <bgilbert> there are no `meeting` tickets, so:
16:36:19 <bgilbert> #topic Open Floor
16:36:55 <red_beard> Well, let me say congrats on the preview release.  i'm excited to be a pain in the ass ;)
16:36:55 <bgilbert> congratulations to everyone who contributed to the first Fedora CoreOS preview release!
16:37:01 <lorbus> FCOS Preview Release is out!!!
16:37:13 <jbrooks> wooo
16:37:13 <ksinny> \o/
16:37:15 <bgilbert> \o/
16:37:16 <ajeddeloh> o/
16:37:22 <yzhang> \o/
16:37:25 <rfairley> yayy
16:37:36 <jlebon> ๐ŸŽ‰
16:37:49 <vrutkovs> \o/
16:38:04 <red_beard> qq: is there anything in the pipeline for this for http://fedoramagazine.org?
16:38:08 <bgilbert> red_beard: yes
16:38:16 <kaeso[m]> red_beard: and we are happy to have you as a pain in the ass ;)
16:38:20 <lorbus> I'd like to open a bag of cookies :) bgilbert++ ajeddeloh++ jlebon++ rfairley++ yzhang++ lucab++ ksinny++
16:38:21 <zodbot> lorbus: Karma for ajeddeloh changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:38:24 <zodbot> lorbus: Karma for jlebon changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:38:27 <zodbot> lorbus: Karma for rfairley changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:38:30 <zodbot> lorbus: Karma for yzhang changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:38:32 <zodbot> lorbus: Karma for lucab changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:38:33 <bgilbert> red_beard: it'll have more detail than the release announcement for a general Fedora audience
16:38:50 <bgilbert> red_beard: immutable infrastructure, Ignition, multiple streams, etc.
16:39:09 <bgilbert> lorbus++
16:39:09 <zodbot> bgilbert: Karma for lorbus changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:40:02 <lorbus> mnguyen_++ slowrie++
16:40:03 <zodbot> lorbus: Karma for slowrie changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:40:27 <bgilbert> anyone have topics they want to discuss?  questions?  feedback?
16:40:35 <jlebon> would be cool if the ami id on the download page linked to the AWS EC2 launch wizard
16:40:52 <bgilbert> jlebon: +1
16:41:03 <rfairley> jlebon: +1
16:41:20 <red_beard> i would also suggest a _basic_ ignition/ct config where someone can just replace the ssh key
16:41:23 <jlebon> hmm, we should also probably link to the getting started guide from https://getfedora.org/en/coreos/download/ too
16:41:25 <vrutkovs> bgilbert: I'm running a pre-release version of FCOS, it doesn't have zincati - it cannot be updated to the latest, as there is no public ostree repo, right?
16:41:25 <ajeddeloh> Misc thought: we should have something like coreos.com/validate but for translating configs as well with fcct
16:41:29 <red_beard> that way they can copy/pasta something simple
16:41:52 <ajeddeloh> red_beard: see https://docs.fedoraproject.org/en-US/fedora-coreos/getting-started/
16:41:53 <jlebon> vrutkovs: if you add the remote, you should be able to `rpm-ostree rebase`
16:42:09 <rfairley> jlebon: could get the AWS launch link in, with the next iteration on the downloads page (working through a few errors in the rendering currently)
16:42:12 <bgilbert> jlebon: +1
16:42:25 <ajeddeloh> oh crap, just realized the formatting is a little broken there
16:42:28 <vrutkovs> jlebon: is there a remote address? I couldn't find one
16:42:32 <kaeso[m]> ajeddeloh: for ignition or for fcct?
16:42:41 <ajeddeloh> fcct
16:43:00 <jlebon> vrutkovs: depends how old your fcos is. it might already be there: /etc/ostree/remotes.d/fedora.conf
16:43:08 <bgilbert> ajeddeloh: oh yeah, we could do that, since FCCL is versioned
16:43:32 <jlebon> vrutkovs: if so, then yeah it's just `rpm-ostree rebase fedora:fedora/x86_64/coreos/testing`
16:44:13 <bgilbert> ajeddeloh: maybe we could arrange for FCCT examples to link to the online translator?
16:44:24 <bgilbert> might be a bit better than the CL two-tab mechanism, since it encourages playing around with the example
16:44:37 <ajeddeloh> bgilbert: ooh yeah, I like that
16:44:55 <bgilbert> (example of two-tab thing: https://coreos.com/os/docs/latest/booting-on-ec2.html#container-linux-configs)
16:45:00 <kaeso[m]> for the online-validator instead, can we get rid of that?
16:45:15 <bgilbert> kaeso[m]: coreos.com/validate, or the idea of a online validator?
16:45:24 <red_beard> interesting... the javascript on https://getfedora.org/en/coreos/download/ was taking a while to lead the image data
16:45:37 <vrutkovs> jlebon: hm, its a commit at 2019-05-31T12:56:07Z, nothing in /etc/ostree/remotes.d. I'll grab the URL from preview ISO then
16:45:39 <bgilbert> kaeso[m]: i.e., which "that"?
16:45:39 <kaeso[m]> the idea as a whole
16:45:41 <ajeddeloh> could make it so sitewithtranslator.com/translate?config=<urlencodedfcc> autofills in a config to it
16:45:41 <bgilbert> why?
16:46:18 <bgilbert> ^ kaeso[m]
16:46:19 <jlebon> vrutkovs: https://src.fedoraproject.org/rpms/fedora-repos/blob/master/f/fedora.conf
16:47:04 <mnguyen_> ajeddeloh: this formatting? https://github.com/coreos/fedora-coreos-docs/pull/3
16:47:08 <kaeso[m]> bgilbert:  because 1) people started relying on it for CI purposes 2) IMHO we would better provide an ignition-validate container instead
16:47:38 <kaeso[m]> ajeddeloh: ^^^
16:48:02 <bgilbert> re 1: they did?  that's... exciting
16:48:12 <vrutkovs> jlebon: +1, thanks
16:48:53 <kaeso[m]> bgilbert: yes, the latest example is https://github.com/coreos/ignition/issues/820
16:49:05 <ajeddeloh> mnguyen_: yeah :D
16:49:52 <red_beard> ok, just to clarify (since i'm bouncing between docs on docs.fp.org, getfedora.org, and github repos: the iso, kernel, and initramfs seem very small (and are referring to an "installer").  is it possible to just run in resident ram?
16:50:00 <bgilbert> red_beard: not yet
16:50:16 <bgilbert> red_beard: https://github.com/coreos/fedora-coreos-tracker/issues/105
16:50:21 <red_beard> ok, good to know.  that was the first thing i was going to try. :D
16:50:51 <bgilbert> current thinking is that the installer will go away once live PXE/ISO is working: https://github.com/coreos/fedora-coreos-tracker/issues/203
16:50:55 <ajeddeloh> we do want to support that eventually
16:50:59 <bgilbert> s/installer/installer images/
16:54:19 <red_beard> also, i'm going to have a quick PR on https://github.com/coreos/fedora-coreos-docs in a moment to fix the links.
16:54:53 <bgilbert> in the README?  thanks :-)
16:55:28 <x3mboy> !
16:55:36 <x3mboy> Hello
16:55:44 <x3mboy> Can I have a word in Open Floor?
16:55:57 <jlebon> x3mboy: hi!  shoot :)
16:55:58 <ajeddeloh> yup
16:56:04 <red_beard> you've alrady had 8 ;)
16:56:07 <red_beard> err 9
16:56:40 <x3mboy> I'm part of the Marketing team
16:56:42 <red_beard> but please, we're all ears.
16:57:06 <x3mboy> And we're trying to pull off a series of Infographics to be published in social media
16:57:19 <x3mboy> You can see the design ticket here
16:57:25 <x3mboy> #link https://pagure.io/design/issue/642
16:57:57 <x3mboy> The ticket is blocked on content, so I'm asking for your help with it
16:57:59 <bgilbert> x3mboy: thanks for bringing that up, it'd be good to discuss here
16:58:45 <bgilbert> #link https://pagure.io/design/issue/614#comment-542596
16:58:45 <red_beard> x3mboy: to clarify the idea would be to produce something to the effect of https://i.pinimg.com/736x/d6/f1/7d/d6f17d4c127438da4c3e482ee8d0c992--cloud-infrastructure-free-infographic.jpg for Fedora CoreOS?
16:58:49 <bgilbert> I liked ^ by way of example
16:59:09 <bgilbert> it's more of a cheat sheet for users, while red_beard's example is more marketing-y
16:59:38 <bgilbert> we should probably have both :-)
16:59:55 <x3mboy> red_beard, initially the idea is to launch a first one that explain what is Fedora CoreOS and its benefits
17:00:26 <kaeso[m]> my 2ยข: I'm not a huge fan of cheatsheet, they get stale very quickly. That's why we have versioned docs.
17:00:33 <jlebon> hmm, does a cheat sheet not imply documentation is inadequate?
17:00:36 <x3mboy> Then, in a 2nd round, we will like to launch a Cheatsheet for people that already know and use Fedora CoreOS
17:00:39 <red_beard> i think the notes about differentiating around vanilla fedora, atomic, and container linux would be useful.
17:01:26 <bgilbert> there might be value in reaching users who could be scared off by a pile of docs
17:01:28 <red_beard> x3mboy: related to that we produced notebooks many years ago with a similar idea.  i don't have one anymore but someone else might, which may be of some inspiration.
17:01:35 <bgilbert> complementary to docs, not a replacement for them
17:01:36 <red_beard> bgilbert++
17:01:36 <zodbot> red_beard: Karma for bgilbert changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:41 <red_beard> i agree completely
17:02:21 <jlebon> could still make it part of the docs though, right?
17:02:23 <x3mboy> The idea of the campaign, is to attract more people, and possibly more contributors
17:02:26 <red_beard> we saw a lot of uplift by making it trivial to begin and allowing folks to quickly discover what they needed to know without digging through a mountain of documentation
17:02:37 <kaeso[m]> if we want to have cheatsheets, I'd rather have their sources with the rest of the docs and versioned-built
17:03:11 <bgilbert> kaeso[m]: for the level of content I'm thinking of, I don't think there's much risk of change
17:03:19 <bgilbert> e.g.: how to run a container!  how to inject an SSH key!
17:03:27 <x3mboy> It's hard to do, but our approach now is to use social media more intensively since is one of the most popular ways people is using to get into news and information
17:03:34 <bgilbert> and there is some marketing benefit to having some nice graphic design along with those things
17:04:13 <x3mboy> bgilbert++
17:04:14 <zodbot> x3mboy: Karma for bgilbert changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:04:18 <x3mboy> That's exactly the idea
17:04:35 <jlebon> good points. i'm not well-versed in marketing, but i can definitely see the appeal of posting an infograph vs link to "boring" docs
17:04:36 <bgilbert> heh, maybe we could have a stable redirector URL that launches FCOS stable in AWS/GCE/etc.
17:04:46 <bgilbert> and dynamically looks up the AMI ID
17:05:52 <bgilbert> "try Fedora CoreOS at fcos.io/aws"
17:06:17 <red_beard> also a good call
17:06:51 <x3mboy> You can take a look at: https://pagure.io/design/issue/647 that is already finished, and see what we are looking for
17:08:50 <x3mboy> So, WDYT? Can someone take an action on it? If we can have this out relatively soon, we can launch the Infographics while you're at Flock
17:09:07 <bgilbert> x3mboy: +1
17:09:21 <bgilbert> anyone interested in working on the cheat sheet?
17:10:06 <bgilbert> x3mboy: Fedora Magazine draft should be ready soon, which can be a starting point for _some_ of the material for the marketing graphic
17:10:34 <x3mboy> Great
17:11:06 <bgilbert> x3mboy: what do you think of red_beard's point about comparing FAH/CL/FCOS?
17:11:19 <bgilbert> useful now for migrating users, but not as useful down the road
17:11:34 <jwf> For what it's worth, the Fedora Design Team has the design chops to help with the design collateral, but the place they need the most help is coming up with what to say :)
17:11:49 <bgilbert> jwf: +1
17:12:22 <x3mboy> bgilbert, for me it sounds a pretty good idea. Also, it would describe what people should expect from FCOS
17:12:30 <bgilbert> cool
17:13:15 <bgilbert> x3mboy: thanks for keeping this on our radar.  we'll put some cycles into it.
17:13:45 <x3mboy> Thanks
17:13:50 <x3mboy> EOF
17:15:02 <lorbus> jwf++ x3mboy++
17:15:03 <zodbot> lorbus: Karma for jflory7 changed to 9 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:15:06 <zodbot> lorbus: Karma for x3mboy changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:16:07 <jwf> x3mboy gets creds for doing the actual Fedora Marketing work, I am just lurking :)
17:17:17 <lorbus> everybody gets a cookie :D raise your voice if I or the bot forgot about you :)
17:17:41 <bgilbert> lorbus: +1
17:17:45 <bgilbert> any other topics to discuss?
17:18:05 <jlebon> thanks also to mboddu++, puiterwijk++, and nirik++ for all their help on the releng side
17:18:05 <zodbot> jlebon: Karma for kevin changed to 21 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:18:16 <bgilbert> absolutely
17:18:33 <red_beard> one quick question
17:18:38 <bgilbert> mboddu++ puiterwijk++ nirik++
17:18:39 <zodbot> bgilbert: Karma for mohanboddu changed to 18 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:18:41 <zodbot> bgilbert: Karma for puiterwijk changed to 16 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:18:44 <bgilbert> also relrod++ on the website side
17:18:44 <zodbot> bgilbert: Karma for kevin changed to 22 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:18:46 <mnguyen_> mboddu++ puiterwijk++ nirik++
17:18:47 <zodbot> bgilbert: Karma for codeblock changed to 11 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:18:49 <red_beard> when i'm looking at the overview and download pages, i see the links to sigs
17:18:58 <red_beard> but not information about the signing key itself
17:19:12 <mboddu> Woah, lots of cookies :D
17:19:16 <jlebon> that's a good point. it's the f30 primary key.
17:19:16 <relrod> :)
17:19:17 <bgilbert> it's the Fedora key, currently F30
17:19:17 <red_beard> can we publish the fingerprint of the pubkey and possible a link to it?
17:19:23 <bgilbert> yes, we should
17:19:23 <mboddu> Thanks to you all for your help as well
17:19:30 <mboddu> jlebon++ bgilbert++
17:19:30 <zodbot> mboddu: Karma for jlebon changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:19:33 <puiterwijk> mnguyen_: note that giving cookies only works if your IRC nick matches the one in FAS
17:19:34 <zodbot> mboddu: Karma for bgilbert changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:19:41 <slowrie> https://getfedora.org/security has links to the key
17:20:05 <jlebon> we should probably add a blurb on how to verify downloads
17:20:12 <slowrie> jlebon: +1
17:20:34 <bgilbert> rfairley, can we action you for website changes?
17:20:38 <red_beard> jlebon: it looks like linking https://getfedora.org/security/ and adding just a little to that would knock it out of the park
17:20:44 <rfairley> bgilbert: yes
17:20:57 <bgilbert> #action rfairley to improve visibility of Fedora signing key on download page
17:21:02 <red_beard> (mainly because it's not `CHECKSUM` files)
17:21:08 <rfairley> going to note the changes suggested here in the download page tracker issue
17:21:17 <rfairley> https://github.com/coreos/fedora-coreos-tracker/issues/192
17:21:18 <jlebon> red_beard: heh, was looking at that yeah
17:21:23 <bgilbert> #action rfairley to link AMI IDs on download page to AWS console launch page
17:21:44 <red_beard> but, everything worked as expected with the workflow.. so :thumbs_up:
17:21:51 <rfairley> feel free to suggest any other improvements too (either here or in comments in that issue) :)
17:22:12 <bgilbert> #action rfairley to add advice to download page on verifying downloads
17:22:40 <jlebon> poor rfairley, you're now the designated FCOS web designer :)
17:23:13 <bgilbert> rfairley++
17:23:14 <rfairley> heh :) will split some non-immediate items out into issues too
17:23:25 <rfairley> (issues that aren't ones just actioned / suggested here earlier)
17:23:50 <bgilbert> #action ajeddeloh to file tickets for FCCL online translator and for linking FCC examples to that translator
17:23:50 <rfairley> but will take care of these ones personally
17:23:54 <bgilbert> ajeddeloh: ^ ok?
17:24:06 <ajeddeloh> +1
17:24:11 <bgilbert> #action bgilbert to follow up on marketing infographics
17:25:00 <bgilbert> #undo
17:25:00 <zodbot> Removing item from minutes: ACTION by bgilbert at 17:24:11 : bgilbert to follow up on marketing infographics
17:25:26 <bgilbert> #action bgilbert to follow up on marketing infographics: intro to FCOS, FAH/CL/FCOS differentiation, hands-on cheatsheet
17:25:42 <red_beard> oh, one last question... is work being tracked to kick things across to virt-manager to get it towards supporting --location?
17:25:48 <bgilbert> #action bgilbert to file ticket for launch-on-this-cloud shortlink redirector
17:25:58 <bgilbert> red_beard: context?
17:26:09 * ajeddeloh needs to drop to catch a train
17:26:44 <bgilbert> (did I miss any #actions?)
17:26:55 <red_beard> bgilbert: we should probably go into more detail offline, but the TL;DR is that virt-manager (and it's related libraries) are heavily tweaked around .treeinfo support and anaconda, i'm sure some changes will need to be made on their side to support ignition et al
17:27:37 <red_beard> the end state is that a user could run `virt-install --location https://fcos.io/libvirt`
17:27:48 <bgilbert> red_beard: I'm not aware of it being tracked.  could you file an issue in fedora-coreos-tracker?
17:28:06 <red_beard> sure, i'll also do one in virt-manager and cross reference them
17:28:06 <bgilbert> red_beard: we also still have a rat's nest around libvirt and qemu support for userdata
17:28:27 <bgilbert> #action red_beard to file ticket for virt-install --location support
17:28:37 <red_beard> well, eventuall the qemu folks will have a proper moment when they step into the present ;)
17:30:23 <bgilbert> okay, anyone have anything else?  closing meeting in 60s
17:31:24 <bgilbert> #endmeeting