16:30:20 <dustymabe> #startmeeting fedora_coreos_meeting
16:30:20 <zodbot> Meeting started Wed Nov 18 16:30:20 2020 UTC.
16:30:20 <zodbot> This meeting is logged and archived in a public location.
16:30:20 <zodbot> The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:20 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:20 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:30:26 <dustymabe> #topic roll call
16:30:29 <dustymabe> .hello2
16:30:30 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:30:38 <skunkerk> .hello sohank2602
16:30:39 <zodbot> skunkerk: sohank2602 'Sohan Kunkerkar' <skunkerk@redhat.com>
16:30:53 <lucab> .hello2
16:30:54 <zodbot> lucab: lucab 'Luca Bruno' <lucab@redhat.com>
16:31:53 <bgilbert> .hello2
16:31:55 <zodbot> bgilbert: bgilbert 'Benjamin Gilbert' <bgilbert@backtick.net>
16:32:02 <jlebon> .hello2
16:32:03 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:33:47 <red_beard> .hello redbeard
16:33:48 <zodbot> red_beard: redbeard 'Brian 'redbeard' Harrington' <bharring@redhat.com>
16:34:28 <dustymabe> welcome all
16:34:35 <dustymabe> #chair skunkerk lucab bgilbert jlebon red_beard
16:34:35 <zodbot> Current chairs: bgilbert dustymabe jlebon lucab red_beard skunkerk
16:34:44 <dustymabe> #topic Action items from last meeting
16:34:50 <dustymabe> * travier to try to find a contact at OVH we can build a relationship with
16:34:51 <dustymabe> * red_beard to investigate forklifting FCOS artifacts into OVH to see if they work
16:35:29 <travier> .hello siosm
16:35:30 <zodbot> travier: siosm 'Timothée Ravier' <travier@redhat.com>
16:35:41 <jbrooks> .hello jasonbrooks
16:35:42 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <jbrooks@redhat.com>
16:35:56 <travier> I have contacted OVHcloud. This is in progress.
16:36:59 <dustymabe> #chair travier
16:36:59 <zodbot> Current chairs: bgilbert dustymabe jlebon lucab red_beard skunkerk travier
16:37:03 <dustymabe> #chair jbrooks
16:37:03 <zodbot> Current chairs: bgilbert dustymabe jbrooks jlebon lucab red_beard skunkerk travier
16:37:26 <dustymabe> travier: nice. I guess just add updates to the tickets now? I don't think we need to re-action the item, do you ?
16:38:30 <red_beard> I on the other hand got held up on my end
16:38:42 <dustymabe> red_beard: no problem. I'll re-action
16:38:47 <red_beard> Thx
16:38:52 <dustymabe> #action red_beard to investigate forklifting FCOS artifacts into OVH to see if they work
16:39:59 <dustymabe> #topic tracker: Fedora 33 rebase work
16:40:05 <dustymabe> #link https://github.com/coreos/fedora-coreos-tracker/issues/609
16:40:35 <dustymabe> The `testing` stream has now moved to F33 (which means stable will be there in 2 weeks (assuming all goes well))
16:41:08 <dustymabe> I closed out the ticket because there isn't any remaining work to do specifically for F33 other than just ongoing normal release work
16:41:36 <jlebon> \o/
16:41:36 <dustymabe> #info the testing stream has been rebased to F33, stable to follow in a few weeks
16:42:27 <dustymabe> anything else for this topic before I move on?
16:43:43 <dustymabe> #topic twitter account for Fedora CoreOS
16:43:49 <dustymabe> #link https://lists.fedoraproject.org/archives/list/coreos@lists.fedoraproject.org/message/I67KV5PUTTLJJL7NEYJGLECSQMKVN24F/
16:44:00 <dustymabe> The old @coreos twitter account is available (has quite a few followers). It's been offered to us to use.
16:44:02 <dustymabe> How do we want to proceed?
16:44:12 <dustymabe> Options:
16:44:14 <dustymabe> 1. take twitter account keep name/followers.
16:44:16 <dustymabe> 2. if possible: take twitter account renamve to @FedoraCoreOS (our existing name), keep followers
16:44:53 <red_beard> Please don't change the name to CoreOS.
16:45:05 <bgilbert> red_beard: the name is already @CoreOS
16:45:12 <bgilbert> the question is whether to change it in the other direction
16:45:30 <red_beard> Sorry @fedoracoreos
16:45:41 <cyberpear> I'd say keep the short handle but change the display name to Fedora CoreOS.
16:45:47 <red_beard> There's little value in changing it
16:45:48 <dustymabe> well, we have @CoreOS (existing account from CoreOS Inc), and @FedoraCoreOS (existing account that I started using earlier this year)
16:45:52 <red_beard> Agreed
16:46:06 <dustymabe> so we currently have two accounts
16:46:07 <jlebon> are there any downsides to option 1?
16:46:28 <red_beard> Not that I'm aware of
16:46:42 <lucab> isn't this a bit of a dark-SEO pattern? Like, getting people to follow something and then change it into something else
16:47:12 <dustymabe> ehh, the downside that I see is that we propagate the "CoreOS" name everywhere, where we'll probably have variants (RHCOS, FCOS, otherCOS, otherCOS) in the future
16:47:24 <dustymabe> kind of like "Atomic" in the past
16:47:29 <jbrooks> the only coreos that currently exists is the one built by this group
16:47:39 <dustymabe> jbrooks: what about RHCOS?
16:47:45 <jbrooks> this is the upstream
16:48:17 <bgilbert> there are a lot of RHCOS users who aren't necessarily interested in FCOS
16:48:36 <bgilbert> before this discussion came up, there was already a tweet saying that the account would be retired: https://twitter.com/coreos/status/1314623658095075329
16:48:40 <cyberpear> RHCOS is an implementation detail of OCP, per marketing I've seen
16:48:56 <bgilbert> lucab, not sure if that affects your concern
16:48:59 <jbrooks> I'd say rhcos users probably aren't interested in rhcos either ;) -- it's so under the covers of openshift
16:49:07 <dustymabe> :)
16:49:22 <dustymabe> I think I'm fine with option 1
16:49:36 <jlebon> RHCOS inherits from FCOS anyway (like likely any other future COS variant), so implicitly FCOS news is relevant to those users too
16:49:57 <cyberpear> it's got a blue check, so that's nice
16:50:10 <jbrooks> I'm +1 to option 1, though I think the display name should be Fedora CoreOS
16:50:10 <jlebon> i'm +1 for option 1 as well
16:50:12 <dustymabe> jlebon: there is a world where there is something even more "core" than current FCOS, that FCOS derives from
16:50:36 <dustymabe> future possible world
16:50:43 <dustymabe> but let's cross that bridge when we get there
16:51:34 <bgilbert> I'm -0.small to both options
16:51:39 <red_beard> Can we table this for a week?
16:51:46 <bgilbert> red_beard: why?
16:51:54 <dustymabe> #proposal We'll work with RH marketing to take and use the @coreos twitter account for Fedora CoreOS. We won't try to change the existing @coreos handle.
16:52:12 <red_beard> One, Because I'm on my phone right now
16:52:14 <lucab> I'm personally not very comfortable with both hijacking previous things nor conflating more things into the "coreos" label
16:52:23 <red_beard> Two, there are unintended consequences
16:52:31 <bgilbert> lucab: yeah, I think I agree
16:53:11 <bgilbert> we tried to get this account a while ago, and it wasn't available until now
16:53:23 <dustymabe> lucab: so an option 3. don't use @coreos account, keep using the @FedoraCoreOS account ?
16:53:27 <bgilbert> if we had gotten it a while ago, I think there would have been a good argument about continuity from Container Linux to FCOS
16:53:49 <bgilbert> but at this point it sounds as though we're primarily interested in the followers
16:53:53 <lucab> dustymabe: that's be my personal opinion, yes
16:53:55 <bgilbert> which doesn't feel great
16:54:15 <jbrooks> Aren't we interested in the followers?
16:54:30 <jbrooks> We're interested in serving the people who used containerlinux, aren't we?
16:54:31 <dustymabe> I am, but I understand the sentiment that it's a bit of "hijacking"
16:55:05 <jbrooks> I hear the hijacking concern, but then why call this thing Fedora CoreOS?
16:55:17 <bgilbert> jbrooks: we're interested in attracting them out of merit, sure
16:55:29 <jbrooks> the brand-jacking horse has left the stable
16:55:51 <dustymabe> 🤓
16:55:52 <bgilbert> naming isn't the same thing
16:56:08 <bgilbert> we never considered auto-upgrading CL machines into FCOS, for example
16:56:13 <jbrooks> I guess we could delete the coreos handle, and then change the fedora coreos one to coreos to have that shorter handle
16:56:17 <red_beard> Oh, And point three for tabling it, the situation isn't urgent
16:56:40 <dustymabe> jbrooks: that's my least favorite option
16:56:43 <dustymabe> :)
16:56:54 <dustymabe> ok we can table it until next week
16:56:59 <lucab> my personal feeling is that most @coreos followers were there for k8s/prometheus/etcd/go (in that order), not for ContainerLinux
16:57:11 <dustymabe> real quick before we break I want to write down all the options again
16:57:31 <dustymabe> 1. take twitter account keep name/followers. Stop using the @fedoraCoreOS account
16:57:44 <dustymabe> 2. if possible: take twitter account renamve to @FedoraCoreOS (our existing name), keep followers
16:57:57 <jbrooks> lucab, that's a fair point
16:58:14 <dustymabe> 3. don't take @coreos account, just keep using our existing @FedoraCoreOS with current followers (building them up from scratch)
16:58:43 <dustymabe> 4. Delete @coreos account, rename @fedoraCoreOS to @coreos (building followers from scratch)
16:58:56 <jbrooks> yeah
16:58:58 <cyberpear> 4. put a Twitter poll on the @CoreOS account
16:59:12 <jbrooks> interesting
16:59:35 <jbrooks> makes me wonder if you can create a poll that only followers can answer
16:59:47 <dustymabe> yeah, that would give us some more data
17:00:18 <dustymabe> jbrooks: maybe investigate that option and we can discuss it more next week too
17:00:30 <jbrooks> And dustymabe , option four wouldn't have to be from scratch, we could keep the current fedoracoreos followers
17:00:42 <jbrooks> ~76 of them
17:00:56 <dustymabe> jbrooks: i mostly said that to convey the difference between the two options
17:01:09 <dustymabe> starting from 77 is basically starting from scratch compared to the followers for the other account
17:01:14 <jbrooks> right
17:01:51 <dustymabe> ok I don't have any other topics for right now
17:01:53 <dustymabe> #topic open floor
17:02:03 <dustymabe> anything we should discuss? any other tickets to bring up?
17:02:40 <bgilbert> random passing thought (and I'll write up a real tracker ticket also)
17:02:54 <bgilbert> well, okay, not "random passing thought" so much as "idea that came up in a meeting"
17:03:20 <bgilbert> maybe we should have another tracker issue template for new cloud platforms
17:03:33 <bgilbert> that lists, in one place, all the info we need in order for the platform to be implementable
17:03:44 <bgilbert> where does userdata come from, ssh keys, network config, etc.
17:03:49 <red_beard> bgilbert: great idea
17:04:08 <skunkerk> bgilbert: +1
17:04:15 <red_beard> bgilbert: +1
17:04:16 <bgilbert> because it seems like we usually end up with a game of telephone
17:04:38 <dustymabe> seems reasonable to me
17:04:59 <dustymabe> btw I'm finally getting around to the multi-arch enablement work this week
17:05:02 <dustymabe> cc jcajka ^^
17:05:06 <red_beard> and/or re-explaining how various public cloud implementations work to the uninitiated
17:05:16 <bgilbert> +1
17:06:15 <dustymabe> any other topics for open floor? What have people been up to?
17:06:23 <red_beard> actually, yeah.
17:06:41 <dustymabe> #info openstack CI tests are now running each time we do a pipeline build!
17:06:53 <red_beard> summit is going to be wildly different again this year, anything interesting we'd like to push for/plan around?
17:07:36 <cyberpear> I've been trying to eliminate circular deps for Minimization. expect to send many PRs soon to packages
17:07:37 <dustymabe> red_beard: thanks for bringing it up. I'm going to be MIA on leave most of the first of the year, so I'll miss preparation for Summit
17:07:50 <dustymabe> cyberpear: nice!
17:08:01 <red_beard> dustymabe: looks like we may need a stand in then :D
17:08:20 <dustymabe> cverna: has been helping us organize some. jbrooks: might be able to help too
17:08:47 <dustymabe> we should at least get a ticket in the tracker for trying to bring together some ideas
17:09:29 <dustymabe> red_beard: want to create one?
17:10:04 <red_beard> sure thing
17:11:02 <dustymabe> ok, i'll close out the meeting soon unless we've got more open floor items
17:11:21 <jlebon> random, but this made me happy: https://github.com/fwupd/fwupd/pull/2601
17:11:36 <jlebon> that should allow us to shed a bunch of pkgs that initially came in with fwupd
17:11:45 <red_beard> hmmmm....
17:11:56 <red_beard> what labels should this non-technical issue use on github?
17:12:23 <dustymabe> typically lucab is our labelmaster :)
17:13:13 <red_beard> ok, i'll work with him ;)
17:15:07 <red_beard> my "proposal" would be something like "community/conference" "community/artwork" etc
17:15:13 <dustymabe> jlebon: that makes me happy too
17:15:17 <red_beard> just to socialize it early
17:16:26 <dustymabe> ok I'll close this out. thanks all for coming!
17:16:37 <red_beard> thanks, have a good week
17:16:41 <bgilbert> thanks dustymabe, thanks all!
17:16:51 <dustymabe> #action red_beard to open a ticket to strategize on FCOS RH summit presence
17:16:56 <dustymabe> #endmeeting