16:30:34 <dustymabe> #startmeeting fedora_coreos_meeting
16:30:34 <zodbot> Meeting started Wed May 26 16:30:34 2021 UTC.
16:30:34 <zodbot> This meeting is logged and archived in a public location.
16:30:34 <zodbot> The chair is dustymabe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:34 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:30:34 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:30:38 <dustymabe> #topic roll call
16:30:40 <dustymabe> .hi dustymabe
16:30:41 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:31:10 <copperi_> .hi copperi
16:31:10 <zodbot> copperi_: Sorry, but you don't exist
16:31:14 <lorbus> .hi
16:31:14 <jdoss> .hi
16:31:15 <zodbot> lorbus: lorbus 'Christian Glombek' <cglombek@redhat.com>
16:31:18 <zodbot> jdoss: jdoss 'Joe Doss' <joe@solidadmin.com>
16:31:19 <copperi_> hello copperi
16:31:25 <skunkerk> .hello sohank2602
16:31:26 <cyberpear> .hi
16:31:26 <zodbot> skunkerk: sohank2602 'Sohan Kunkerkar' <skunkerk@redhat.com>
16:31:29 <zodbot> cyberpear: cyberpear 'James Cassell' <fedoraproject@cyberpear.com>
16:31:44 <copperi_> * .hello copperi
16:31:59 <bgilbert> .hi
16:32:00 <zodbot> bgilbert: bgilbert 'Benjamin Gilbert' <bgilbert@backtick.net>
16:32:13 <fifofonix> .hello fifofonix
16:32:14 <zodbot> fifofonix: fifofonix 'Fifo Phonics' <fifofonix@gmail.com>
16:32:19 <lorbus> copperi: you have to use your fedora (fas) name
16:32:40 <jlebon> .hello2
16:32:41 <zodbot> jlebon: jlebon 'None' <jonathan@jlebon.com>
16:33:05 <copperi_> lorbus: that is my fas name
16:33:11 <copperi_> .hello copperi
16:33:12 <zodbot> copperi_: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
16:33:19 <dustymabe> #chair copperi_ lorbus jdoss skunkerk cyberpear bgilbert fifofonix jlebon
16:33:19 <zodbot> Current chairs: bgilbert copperi_ cyberpear dustymabe fifofonix jdoss jlebon lorbus skunkerk
16:33:43 <lorbus> :tada
16:33:47 <lorbus> * :tada:
16:33:49 <travier> .hello siosm
16:33:50 <zodbot> travier: siosm 'Timothée Ravier' <travier@redhat.com>
16:34:00 <lucab> .hello2
16:34:01 <zodbot> lucab: lucab 'Luca Bruno' <lucab@redhat.com>
16:34:05 <jaimelm> .hello2 jaimelm
16:34:06 <zodbot> jaimelm: jaimelm 'Jaime Magiera' <jaimelm@umich.edu>
16:34:23 <jbrooks> .hello jasonbrooks
16:34:26 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <jbrooks@redhat.com>
16:35:20 <dustymabe> #chair travier lucab jaimelm jbrooks
16:35:20 <zodbot> Current chairs: bgilbert copperi_ cyberpear dustymabe fifofonix jaimelm jbrooks jdoss jlebon lorbus lucab skunkerk travier
16:35:22 <lorbus> great turnout today, hello all :)
16:35:29 <dustymabe> #topic Action items from last meeting
16:35:35 <dustymabe> * jaimelm to ask the OKD working group if there are any implications that systemd-oomd would have on k8s/OKD
16:35:38 <dustymabe> * dustymabe to find out how systemd-oomd acts under cgroups v1 (if at all)
16:35:40 <dustymabe> * darkmuggle to investigate systemd-oomd (in use without swap) and report back next week
16:36:17 <dustymabe> #info systemd-oomd doesn't work with cgroups v1, but it gracefully does not run (no error) in that case: https://github.com/coreos/fedora-coreos-tracker/issues/840#issuecomment-848267411
16:37:13 <dustymabe> jaimelm: darkmuggle[m]: anything?
16:37:34 <lorbus> I missed the OKD WG last night again, maybe jaimelm has an update
16:37:44 <dustymabe> I was there for the first half of it
16:38:07 <lorbus> I think we'll move to cgroupsv2 with OKD soon too, no?
16:38:09 <jaimelm> we ran out of time before I could bring it up. I'll create a discussion item and point folks to that.
16:38:27 <dustymabe> #action jaimelm to ask the OKD working group if there are any implications that systemd-oomd would have on k8s/OKD
16:38:30 <jaimelm> We (OKDWG) will then talk about it at the next meeting.
16:38:41 <lorbus> thanks jaimelm
16:38:46 <dustymabe> #action darkmuggle to investigate systemd-oomd (in use without swap) and report back next week
16:38:58 <dustymabe> in that case I'll table the systemd-oomd discussion until next week
16:39:07 <dustymabe> #topic cgroups v2 strategy
16:39:13 <dustymabe> #link https://github.com/coreos/fedora-coreos-tracker/issues/292
16:39:22 <dustymabe> #info the next `testing` release will default to cgroups v2. Followed by `stable` two weeks after that.
16:39:28 <dustymabe> #link https://lists.fedoraproject.org/archives/list/coreos-status@lists.fedoraproject.org/thread/V6OSIUOL5ICEP7WMXLJ2NI47EFNQ3MYF/
16:39:32 <dustymabe> mostly an FYI ^^
16:40:02 <travier> https://github.com/openshift/okd-machine-os/pull/88 > PR to move OKD to cgroupsv2
16:40:49 <dustymabe> anything to discuss before we move to the next topic?
16:41:27 <jlebon> yay!
16:41:39 <dustymabe> #topic future communications on IRC
16:41:45 <dustymabe> #info it looks like Fedora is going to be going with Libera.chat in the future. We'll follow at the same time Fedora switches over.
16:41:51 <dustymabe> #link https://pagure.io/Fedora-Council/tickets/issue/372
16:42:13 <bgilbert> see also subthread at
16:42:15 <travier> Matrix bridges have been removed already
16:42:15 <bgilbert> #link https://pagure.io/Fedora-Council/tickets/issue/371#comment-734762
16:43:12 <bgilbert> it seems that if Libera is mentioned in the Freenode channel topic, Freenode will take over your channel
16:43:28 <dustymabe> interesting
16:43:39 <bgilbert> so we should be careful during the migration process, if Fedora as a whole doesn't come up with a redirection policy
16:44:18 <jdoss> I didn't have the "Death of Freenode" on my 2021 bingo card :(
16:44:30 <dustymabe> i'm hoping they do have a migration policy
16:44:44 <dustymabe> i was in #centos-devel and got moved to #centos-has-moved
16:44:56 <dustymabe> if I try to join it now I get "you must be invited"
16:45:25 <bgilbert> it sounds like channel ops are trying various approaches, yeah
16:45:30 <dustymabe> basically a clear sign something has changed and don't hang around in these channels no one is monitoring
16:46:01 <lorbus> there have apparently been a lot of take overs of channels of projects that have declared their intent to move to libera by the new freenode regime
16:46:27 <lorbus> on hacker news today...quite a few entries on the front page
16:46:51 <dustymabe> sad.. oh well. we'll deal with it as it comes
16:47:33 <lorbus> I do rely on the matrix bridge personally but apparently a new one for Libera.Chat is already WIP
16:47:40 <dustymabe> bgilbert: wonder if there is anything we should do for #coreos
16:47:59 <jaimelm> "This channel has moved to ##asterisk. The topic is in violation of freenode policy: https://freenode.net/policies"
16:48:07 <jaimelm> they are being assholes about it
16:48:16 <lorbus> that ^
16:48:18 <bgilbert> dustymabe: was thinking about that.  I don't think so.  the topic mentions the EOL and the channel gets basically no traffic, except by mistake
16:48:55 <dustymabe> i was wondering if we should just shut it down. and point people elsewhere
16:48:56 <jlebon> yuck, those topic hijacks are pretty scummy
16:49:01 <jdoss> What does ##channel even mean?
16:49:08 <nb> jdoss ## is unofficial
16:49:10 <cyberpear> just leave it be
16:49:18 <jdoss> Thanks nb
16:49:58 <bgilbert> dustymabe: current freenode policy forbids shutting down primary channels, and if you do it anyway, it says they'll respond by shutting down your channel
16:50:09 <travier> :D
16:50:27 <dustymabe> weird haha. wonder how #centos-devel got away with it
16:50:43 <dustymabe> oh well. IRC is also the subject of our next topic
16:50:46 <jlebon> has anyone connected to libera yet and do we already have a #fedora-coreos channel there we should be joining?
16:50:48 <travier> They did it early I guess
16:50:57 <jdoss> jlebon: dusty grabbed it
16:50:58 <jlebon> until we officially completely move over
16:51:05 <dustymabe> jlebon: There's a #fedora-coreos channel. I'm in
16:51:13 <travier> Hopefully we can switch to Matrix some time soon
16:51:32 <jlebon> ack ok. will join as well
16:51:33 <dustymabe> so feel free to join over there, but we'll keep conversations here until whenever the fedora flag day is (just to try to reduce confusion)
16:51:39 <lorbus> I think it'll be announced at https://pagure.io/Fedora-Council/tickets/issue/371 once the move is official/complete
16:52:00 <lorbus> everybody should probably create an account now
16:52:07 <dustymabe> i guess if we get taken over before that (for some reason) we'll move earlier
16:52:09 <jaimelm> Already did mine
16:52:25 <jdoss> same
16:52:35 <nb> Do *not* put anything in your topic about other irc networks
16:52:43 <nb> that is all i have to say at the moment
16:53:16 <dustymabe> nb. what if it's a link to a statement about moving? will that evade their detection?
16:53:17 <jaimelm> that was too easy
16:53:18 <cyberpear> nb: can someone tweak zodbot to prevent that?
16:53:24 <nb> cyberpear hmm, idk
16:53:38 <nb> dustymabe I would rather people just let us handle that
16:53:58 <dustymabe> nb: sounds good. we're not planning to do anything until fedora has ironed out the plan
16:54:06 <dustymabe> we're along for the ride
16:54:06 <nb> great
16:54:30 <dustymabe> #topic set up logging for #fedora-coreos IRC channel
16:54:39 <dustymabe> #link https://github.com/coreos/fedora-coreos-tracker/issues/11#issuecomment-848384177
16:54:49 <dustymabe> unrelated to the freenode drama (I think)
16:54:54 <bgilbert> so... we're losing our logging service again.  end of June.
16:55:17 <bgilbert> it kinda feels like we're running out of logging services.  I found one, and there might be more
16:55:36 <cyberpear> bgilbert: is that a paid service or?
16:55:36 <bgilbert> but it feels a bit like "someone on the Internet logging some random channels"
16:55:41 <jaimelm> bgilbert: do you have any experience with the one you linked to?
16:55:49 <bgilbert> I do not, I just did some googling
16:55:50 <lorbus> I don't want to oppose anything here, but it would be great if there was a GDPR/any other privacy law compliant logger that open source projects could rely in
16:55:53 <jaimelm> OK
16:55:54 <bgilbert> cyberpear: none of the ones so far have been paid
16:56:09 <dustymabe> lorbus: yeah, that would be nice
16:56:14 <jaimelm> indeed
16:56:17 <bgilbert> so a couple things:
16:56:17 <dustymabe> I liked the logbot interface, a lot
16:56:21 <bgilbert> dustymabe: yeah
16:57:11 <jbrooks> My team in RH's OSPO could run a logger for us
16:57:14 <bgilbert> 1) we have a month, and even if we take longer than that, losing logging isn't a huge huge deal.  maybe we should wait for the freenode problem to play out first, since our channel is probably moving.
16:57:25 <jaimelm> ^^
16:57:29 <cyberpear> has anyone inquired about taking over logbot.info? or reasons for shutdown?
16:57:36 <lorbus> maybe Fedora infra could help us with that too...it'd really be great to be able to self-control it
16:57:37 <jaimelm> With limited cycles everyone has, that sounds like a good plan.
16:57:46 <bgilbert> 2) does anyone know if the Matrix bridge will capture IRC history?
16:58:02 <misc> it does
16:58:05 <lorbus> also zodbot is logging all the #cmd things in meetings (and all of their contents while the meeting is on as well), if I'm not mistaken
16:58:11 <bgilbert> jbrooks: that'd be awesome!  we asked around at one point and got bogged down in GDPR questions.
16:58:36 <bgilbert> cyberpear: not afaik
16:58:58 <lorbus> yup matrix bridge can act as bouncer as well
16:58:58 <jbrooks> bgilbert, we run stuff that sometimes leads to GDPR requests, we can field them
16:59:07 <bgilbert> jbrooks: +1
16:59:21 * misc look at getting 6 more months of PTO
16:59:33 <lorbus> jbrooks++
16:59:33 <zodbot> lorbus: Karma for jasonbrooks changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:59:39 <bgilbert> notwithstanding jbrooks' offer, maybe Matrix is the right approach here?  that avoids asking someone to run Yet Another Service
16:59:39 <jbrooks> lol
16:59:40 <lorbus> that's be awesome
16:59:59 <jbrooks> Fedora is getting a hosted matrix service
17:00:09 <bgilbert> jbrooks: right, that's what I meant
17:00:19 <dustymabe> bgilbert: i.e. go "all in" on matrix?
17:00:33 <dustymabe> or just leverage the matrix bridge for the logging?
17:00:46 <bgilbert> dustymabe: just rely on it for our IRC logging
17:00:57 <dustymabe> WFM especially if it kills two birds with one stone
17:01:13 <bgilbert> what do other folks think?
17:01:15 <dustymabe> I guess I'd be interested in how nice the user interface is
17:01:15 <travier> Matrix should probably be the default for newcomers anyway
17:01:16 <cyberpear> /me wants to stay w/ IRC
17:01:27 <lorbus> works for me :)
17:01:42 <dustymabe> cyberpear: it would be bridged. I suspect most of us would probably still be connecting from IRC (unless we wanted to migrate)
17:02:00 <travier> Keeping the IRC bridge make sense for old timers that already have a complex setup and bouncers. Newcomers don't care and Matrix is much easier for them
17:02:08 <cyberpear> eventually, they'll fix the "XYZ sent a log message: link" issue
17:02:17 <jaimelm> agree with travier
17:02:18 <dustymabe> i've been wanting to migrate, just haven't had the kick in the rear enough to get it done
17:02:34 <jaimelm> there's age/experience threshold
17:02:45 <dustymabe> bgilbert: have we given you enough to chart a path forward here?
17:02:49 <bgilbert> practically speaking, our options are "do something now" and "do not do something now".  we can always add a logger later.
17:03:16 <dustymabe> I'd say "do not do something now" see how the matrix bridge (via Fedora matrix instance) to libera tuns out
17:03:19 <dustymabe> turns*
17:03:26 <bgilbert> #proposed We will not pursue a new IRC logger yet, pending possible channel migration and more experience with Matrix.
17:03:30 <jaimelm> Do we know the timeline for the Fedora hosted one?
17:03:36 <dustymabe> ack
17:03:40 <dustymabe> jaimelm: i'm not sure of that
17:03:40 <jaimelm> weeks? months?
17:03:47 <jbrooks> Probably more like weeks
17:03:49 <cyberpear> +1
17:03:50 <jaimelm> OK
17:03:59 <Southern_Gentlem> week
17:04:03 <jaimelm> ack
17:04:05 <dustymabe> Southern_Gentlem++
17:04:05 <zodbot> dustymabe: Karma for jbwillia changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:04:34 <Southern_Gentlem> things are in the works for it to happen asap
17:04:45 <jaimelm> cool
17:05:08 <travier> bgilbert: +1
17:05:15 <dustymabe> any final +1 or -1 to the proposed?
17:05:28 <Southern_Gentlem> bridges are being closed (matirx and telegram) so new ones can be created
17:05:36 <lorbus> 💃
17:05:54 <lorbus> +1
17:05:59 <dustymabe> #agreed We will not pursue a new IRC logger yet, pending possible channel migration and more experience with Matrix.
17:06:24 <dustymabe> #topic Consider alternating video/IRC meeting for FCOS group meetings
17:06:29 <dustymabe> #link https://github.com/coreos/fedora-coreos-tracker/issues/779
17:07:02 <dustymabe> #info our first high bandwidth video meeting will be next week 06/02/2021
17:07:12 <dustymabe> Will send out an email with an announcement
17:07:18 <jdoss> I think a video meeting would be cool from time to time.  Thanks for getting this going.
17:07:22 <jaimelm> looking forward to it.
17:07:37 <dustymabe> we have one ticket topic so far: https://github.com/coreos/fedora-coreos-tracker/issues?q=is%3Aopen+is%3Aissue+label%3Avideo-meeting
17:07:56 <dustymabe> i think we should use these to maybe go through Fedora Proposed changes as well
17:08:25 <dustymabe> so we can fill in time with relevant propsed changes from Fedora and discuss any implications so we can take part in the discussion process this cycle
17:08:26 <travier> dustymabe: +1
17:09:36 <jlebon> sounds like a good idea +1
17:10:02 <dustymabe> sweet :) - will be good to put faces with names/nicks (if you choose to share video)
17:10:13 <dustymabe> #topic open floor
17:10:22 <dustymabe> anyone with anything for open floor ?
17:10:31 <jdoss> What is the best way to showcase FOSS projects consuming FCOS?
17:10:37 <travier> I have a couple FCOS talks accepted (Pass the Salt 2021, DevOps France)
17:10:37 <jdoss> Mailing list post?
17:11:06 <jlebon> travier++
17:11:06 <zodbot> jlebon: Karma for siosm changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:11:06 <travier> We have page in the docs too
17:11:19 <jdoss> I am this ' ' close to launching a project for work that uses FCOS under the hood in a single node use case.
17:11:26 <travier> jdoss: https://docs.fedoraproject.org/en-US/fedora-coreos/fcos-projects/
17:11:28 <lucab> https://docs.fedoraproject.org/en-US/fedora-coreos/fcos-projects/
17:11:37 <lucab> :)
17:11:56 <jdoss> Cool. I will make a PR and make a mailing list post for it.
17:12:05 <jbrooks> Fedora Magazine, maybe?
17:12:05 <dustymabe> jdoss: all of the above!
17:12:05 <dustymabe> :)
17:12:05 <jbrooks> opensource.com is another option
17:12:05 <dustymabe> The Fedora Podcast just got rebooted
17:12:25 <jdoss> I was thinking of reaching out to do a Fedora Mag article too.
17:12:25 <dustymabe> jdoss++
17:13:00 <dustymabe> sounds awesome
17:13:16 <jdoss> It's mostly ducktape Dusty
17:13:35 <dustymabe> you're talking about the entire internet, right?
17:13:40 <jdoss> haha yes!
17:13:44 <dustymabe> :)
17:14:29 <copperi_> duct tape with holes
17:14:39 <dustymabe> any other topics for open floor?
17:15:50 <dustymabe> #info go vote in the Fedora elections https://communityblog.fedoraproject.org/f34-elections-voting-now-open/
17:16:03 <travier> #ivoted
17:16:06 <jdoss> Can I vote for you Dusty?
17:16:25 <dustymabe> write in vote :)
17:16:35 <jdoss> done
17:16:38 <dustymabe> i've thought about doing it in the past. always felt a little too busy to do it
17:16:43 <jdoss> Yeah I bet
17:16:50 <dustymabe> maybe next time (after this home renovation is done)
17:17:08 <jaimelm> baby renovation is ongoing
17:17:14 <jaimelm> I've found that out
17:17:16 <jdoss> I know that feeling.
17:17:17 <dustymabe> not saying I'd get elected, just that if I did I'd want to be able to do it right
17:17:44 <lorbus> dustymabe++
17:17:44 <zodbot> lorbus: Karma for dustymabe changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:17:53 <lorbus> you'd have my vote :)
17:17:53 <dustymabe> Thanks all for coming to the meeting today! This was fun
17:18:07 <dustymabe> see you in high definition next week
17:18:19 <cyberpear> IMO, they didn't loudly-enough announce nominations this time around; otherwise I'd have considered running
17:18:36 <dustymabe> #endmeeting