16:31:03 <jlebon> #startmeeting fedora_coreos_meeting
16:31:03 <zodbot> Meeting started Wed Nov 10 16:31:03 2021 UTC.
16:31:03 <zodbot> This meeting is logged and archived in a public location.
16:31:03 <zodbot> The chair is jlebon. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:31:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:31:03 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:31:16 <bgilbert> .hi
16:31:17 <zodbot> bgilbert: bgilbert 'Benjamin Gilbert' <bgilbert@backtick.net>
16:31:19 <jmarrero> .hi
16:31:20 <zodbot> jmarrero: jmarrero 'Joseph Marrero' <jmarrero@redhat.com>
16:31:21 <dustymabe> .hi
16:31:23 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
16:31:42 <jlebon> #chair bgilbert jmarrero dustymabe
16:31:42 <zodbot> Current chairs: bgilbert dustymabe jlebon jmarrero
16:31:43 <ravanelli> .hi
16:31:44 <zodbot> ravanelli: ravanelli 'Renata Renata Andrade Matos Ravanelii' <renata.ravanelli@gmail.com>
16:31:45 <bgilbert> #topic roll call
16:31:50 <miabbott> .hello miabbott
16:31:51 <zodbot> miabbott: miabbott 'Micah Abbott' <miabbott@redhat.com>
16:31:54 <jlebon> #chair ravanelli
16:31:54 <zodbot> Current chairs: bgilbert dustymabe jlebon jmarrero ravanelli
16:31:57 <jlebon> bgilbert: ahh thanks :)
16:32:02 <lucab> .hi
16:32:05 <zodbot> lucab: lucab 'Luca BRUNO' <lucab@redhat.com>
16:32:33 <lorbus> .hi
16:32:36 <zodbot> lorbus: lorbus 'Christian Glombek' <cglombek@redhat.com>
16:33:07 <jlebon> #chair lucab lorbus
16:33:07 <zodbot> Current chairs: bgilbert dustymabe jlebon jmarrero lorbus lucab ravanelli
16:33:10 <copperi[m]1> .hello copperi
16:33:11 <zodbot> copperi[m]1: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
16:33:52 <skunkerk> .hello sohank2602
16:33:53 <zodbot> skunkerk: sohank2602 'Sohan Kunkerkar' <skunkerk@redhat.com>
16:34:00 <mnguyen> .hello mnguyen
16:34:01 <zodbot> mnguyen: mnguyen 'Michael Nguyen' <mnguyen@redhat.com>
16:34:07 <jlebon> #chair copperi[m]1 skunkerk mnguyen
16:34:07 <zodbot> Current chairs: bgilbert copperi[m]1 dustymabe jlebon jmarrero lorbus lucab mnguyen ravanelli skunkerk
16:34:30 <jlebon> alrighty, will start at :35
16:35:01 <jlebon> #topic Action items from last meeting
16:35:30 <jlebon> Last meeting was by video. I don't *think* there were any AIs out of it.
16:35:42 <jlebon> at least dustymabe's follow-up email didn't mention anything :)
16:35:56 <jlebon> dustymabe: does that sound right?
16:37:07 <dustymabe> correct
16:37:08 <jbrooks> .hello jasonbrooks
16:37:09 <zodbot> jbrooks: jasonbrooks 'Jason Brooks' <jbrooks@redhat.com>
16:37:14 <jlebon> #chair jbrooks
16:37:14 <zodbot> Current chairs: bgilbert copperi[m]1 dustymabe jbrooks jlebon jmarrero lorbus lucab mnguyen ravanelli skunkerk
16:37:17 <jlebon> ok cool
16:37:23 <jlebon> let's move on to ticket items them
16:37:26 <jlebon> then*
16:37:34 <jlebon> #topic Platform Request: Nutanix AOS with AHV
16:37:39 <jlebon> #link https://github.com/coreos/fedora-coreos-tracker/issues/1007
16:37:52 <jlebon> skunkerk: do you want to introduce this topic?
16:37:54 <jaimelm> .hello2
16:37:55 <zodbot> jaimelm: jaimelm 'Jaime Magiera' <jaimelm@umich.edu>
16:38:01 <skunkerk> sure
16:38:01 <jlebon> #chair jaimelm
16:38:01 <zodbot> Current chairs: bgilbert copperi[m]1 dustymabe jaimelm jbrooks jlebon jmarrero lorbus lucab mnguyen ravanelli skunkerk
16:38:47 <skunkerk> As mentioned in the ticket, Red Hat wants to integrate their enterprise ready Kubernetes offering i.e. Openshift with the Nutanix AHV platform to support open hybrid multicloud solution
16:39:43 <walters> .hello2
16:39:44 <zodbot> walters: walters 'Colin Walters' <walters@redhat.com>
16:39:51 <travier> .hello siosm
16:39:52 <zodbot> travier: siosm 'Timothée Ravier' <travier@redhat.com>
16:40:09 <dustymabe> seems like the platform is built a bit to mimic openstack?
16:40:09 <jlebon> #chair walters travier
16:40:09 <zodbot> Current chairs: bgilbert copperi[m]1 dustymabe jaimelm jbrooks jlebon jmarrero lorbus lucab mnguyen ravanelli skunkerk travier walters
16:40:45 <skunkerk> So the initial POC has already been done as what it takes to support Nutanix AHV platform
16:40:47 <skunkerk> yeah
16:40:56 <skunkerk> `userdata` is provided through the config drive v2 method similar to Openstack. But they have not fully implemented meta_data.json functionality, so they are not populating any cloud-specific data there. Hence we're not adding any Afterburn support for it. You can use a custom script to inject ssh-keys but again that's something which is provided by the user.
16:41:17 <jaimelm> They put out a press release about the collaboration. I thought it was further along
16:41:47 <jlebon> 😢 config drive
16:42:16 <skunkerk> so we're going ahead with the Ignition support
16:42:28 <walters> does nutanix always provide the config drive?  IIRC that was the core problem with openstack, we didn't know whether to wait for it or not
16:42:32 <skunkerk> bgilbert: does that sound fine?
16:43:23 <bgilbert> skunkerk: that matches my understanding, yeah
16:44:15 <skunkerk> walters: Yeah, we've confirmed that with the Nutanix folks
16:44:23 <walters> ok that's good
16:44:37 <jlebon> seems like it'd be straightforward to implement overall
16:44:52 <dustymabe> what short platform name are we choosing? do we think there will more flavors than Nutanix AHV in the future?
16:45:11 <skunkerk> jlebon: yeah, that's what my understanding is
16:45:19 <lucab> I'm confused about the bit that says that there is no meta_data.json, but then the hostname is coming from metadata
16:46:12 <dustymabe> also from the description "qemu2 image format" -> do you mean "qcow2 image format" ?
16:47:13 <lucab> (I can put that doubt as a question in the ticket, if we can't answer right now)
16:47:49 <skunkerk> lucab: yeah, that would help
16:49:07 <skunkerk> dustymabe: I think that's what they meant
16:49:14 <jlebon> are there any objections to adding the platform?
16:49:44 <dustymabe> Not on my end
16:50:00 <jlebon> skunkerk: you can edit the comment. looks also like the answer to the SSH keys question should be no
16:50:06 <jlebon> ok cool, let me make a proposal
16:50:24 <skunkerk> jlebon: ack
16:50:46 <dustymabe> ooh ooh.. one more question that would be good to ask and get an answer to in the future skunkerk - can we get a community (unbilled) Fedora account to run CI/tests against?
16:50:59 <walters> do we have any CI resources allocated for this for Fedora?  I think OpenShift has or is working towards some in Prow, maybe that would necessitate crossing the prow bridge for FCOS CI in more cases
16:51:01 <dustymabe> well, that assumes Nutanix runs a cloud service for it (which they may not)
16:51:11 <jaimelm> dustymabe++
16:51:11 <zodbot> jaimelm: Karma for dustymabe changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:51:16 <walters> 👋 dusty
16:51:21 <dustymabe> walters: ha
16:51:24 <dustymabe> jinx
16:51:46 <dustymabe> I'll ask that question in the ticket.. jlebon you can move forward with #proposed
16:51:59 <walters> +1
16:52:22 <jlebon> #proposed we will add FCOS support for Nutanix AHV after fleshing out the few remaining questions
16:52:33 <jlebon> not sure if there's more colour to add there
16:52:48 <jaimelm> you have enough with "after..."
16:52:54 <jlebon> dustymabe, walters: nice. I think we should probably add a question related to CI to the checklist
16:54:01 <dustymabe> ack
16:54:03 <dustymabe> +1
16:54:06 <skunkerk> +1
16:54:09 <copperi[m]1> +1
16:54:24 <jlebon> #agreed we will add FCOS support for Nutanix AHV after fleshing out the few remaining questions
16:54:42 <jlebon> alrighty, let's move on!
16:54:59 <jlebon> #topic Project Updates for Community Outreach and Testing for .ign/.bu Changes
16:55:02 <jlebon> #link https://github.com/coreos/fedora-coreos-tracker/issues/799
16:55:18 <dustymabe> i added  the meeting label here
16:55:41 <dustymabe> was wondering if anyone still had this on their radar.. I think jaimelm maybe was going to reach out to a few upstreams (anyone else?)
16:55:55 <bgilbert> to be clear, what were the "ign/bu changes" here?
16:56:18 <lucab> silly question, what does AHV stand for?
16:56:41 <jlebon> we should also clarify which projects we're talking about
16:57:16 <jbrooks> lucab, looks like Acropolis Hypervisor
16:57:17 <dustymabe> bgilbert: IIRC it was related to the fcct -> butane switch and the `.bu` file suffix and getting editor support for displaying .bu and .ign with proper syntax highlighting for yaml/json
16:57:23 <bgilbert> ah, right
16:57:33 <dustymabe> though not much of that information is actually in the ticket
16:57:41 <jaimelm> bgilbert: the idea that any scripts, tools, etc. that folks have worked ater the suffix change
16:58:53 <dustymabe> jaimelm: were you going to work on reaching out to various upstreams to try to get syntax highlighting support?
16:59:14 <dustymabe> was that  a different ticket?
16:59:16 <jaimelm> Yeah, I have a list somewhere that I started. Sorry, I'll gave to dig.
16:59:32 <jaimelm> There were a few things folks brought to my attention.
16:59:40 <jaimelm> Let's skip until next meeting.
16:59:43 <jlebon> would be cool to also register a MIME type for Butane
16:59:54 <jlebon> (not suggesting to scope that into this ticket)
16:59:59 <dustymabe> jaimelm: +1 - thanks for working on it
17:00:10 <lorbus> +1 to MIME type
17:00:20 <dustymabe> we have a lot of old tickets I'm going to try to go through and "revive" over the next month or two
17:00:24 <jaimelm> We were going to. I *thought* bgilbert was going to look into it.
17:00:32 <bgilbert> fell off my list :-(
17:00:51 <dustymabe> :) - i'm throwing no stones - plenty falls off my list :)
17:01:00 <jlebon> yeah, agreed :)
17:01:02 <dustymabe> bgilbert++
17:01:04 <dustymabe> jaimelm++
17:01:04 <zodbot> dustymabe: Karma for jaimelm changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:01:22 * dustymabe is going to hack zodbot to be able to give more cookies to bgilbert
17:01:30 <jlebon> ok cool. anything else on this subject?
17:01:44 <copperi[m]1> dustymabe++
17:02:09 <jlebon> let's move on then!
17:02:16 <jlebon> #topic Open Floor
17:02:16 <copperi[m]1> dusty: hack so element can give cookies as well
17:02:24 <dustymabe> copperi[m]1: :)
17:02:33 <jlebon> anything anyone wants to bring up?
17:02:49 <dustymabe> #info testing is now rebased to F35 and updates are rolling out over the next few days
17:03:30 <dustymabe> also - i'm working on an email to send out about F35 (gives some highlights of recent work we've done, even if it landed in F34)
17:03:40 <jlebon> nice
17:03:51 <dustymabe> very rough draft of the email (mostly in bullet point form right now): https://hackmd.io/XsDAODlaT8O8zLVkqiOBkw?edit
17:04:07 <dustymabe> can anyone think of big items we've accomplished in the last 6 months that we should add as a highlight?
17:04:22 <jlebon> dustymabe: we should discuss some time soon whether we want to tweak the schedule for f36 to rebase testing at GA
17:05:02 <dustymabe> jlebon: agree
17:05:20 <jlebon> basically shift the schedule exactly as is by one week
17:05:29 <dustymabe> we could probably discuss that today if we wanted to - or put it as a future item
17:05:46 <jlebon> next community mtg maybe?
17:06:00 <dustymabe> WFM - though we'll need a reminder to discuss it (new ticket or action item probably)
17:06:13 <dustymabe> ticket might be nice to properly record the decision
17:06:28 <jlebon> #action jlebon to file a ticket about aligning testing with GA for f36
17:07:07 <dustymabe> jlebon++
17:07:09 <zodbot> dustymabe: Karma for jlebon changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:07:15 <jlebon> i feel like it's been a while since we've finished a community mtg that early
17:07:46 <dustymabe> you're just more efficient than I am
17:07:48 <walters> hm, probably not too hard to script up gathering releases of our projects from the last $timeframe
17:08:34 <jlebon> yeah. i usually also do a query for closed tickets within the date range in the tracker
17:08:36 <jaimelm> ^^
17:09:15 <dustymabe> +1 - yeah definitely trying to condense the info so it's not a huge list
17:09:27 <jlebon> alrighty. closing in 30 secs unless anyone has anything else
17:09:57 <jlebon> #endmeeting