16:31:06 <dustymabe> #startmeeting fedora_coreos_meeting
16:31:06 <zodbot> Meeting started Wed Dec 14 16:31:06 2022 UTC.
16:31:06 <zodbot> This meeting is logged and archived in a public location.
16:31:06 <zodbot> The chair is dustymabe. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:31:06 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:31:06 <zodbot> The meeting name has been set to 'fedora_coreos_meeting'
16:31:10 <dustymabe> #topic roll call
16:31:12 <dustymabe> .hi
16:31:13 <zodbot> dustymabe: Something blew up, please try again
16:31:16 <zodbot> dustymabe: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:31:32 <ravanelli> .hi
16:31:33 <zodbot> ravanelli: Something blew up, please try again
16:31:36 <zodbot> ravanelli: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:31:39 <dustymabe> .hello dustymabe
16:31:40 <zodbot> dustymabe: Something blew up, please try again
16:31:43 <zodbot> dustymabe: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:31:48 <travier> .hello siosm
16:31:49 <zodbot> travier: Something blew up, please try again
16:31:49 <dustymabe> looks like zodbot is having some serious trouble
16:31:52 <zodbot> travier: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:31:55 <travier> :/
16:32:12 <gursewak> .hi
16:32:13 <travier> well, we'll have to copy paste :(
16:32:13 <zodbot> gursewak: Something blew up, please try again
16:32:16 <zodbot> gursewak: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:33:14 <dustymabe> nah I think the meetbot pieces are working, just not the FAS name piece
16:34:44 <dustymabe> hmm - was hoping to get a few more people
16:35:04 <walters> .hi
16:35:05 <zodbot> walters: Something blew up, please try again
16:35:08 <zodbot> walters: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:35:45 <dustymabe> #chair ravanelli travier gursewak walters
16:35:45 <zodbot> Current chairs: dustymabe gursewak ravanelli travier walters
16:36:17 <dustymabe> ok let's get started
16:36:53 <dustymabe> #topic meetings for the remainder of 2022
16:37:22 <dustymabe> I propose that we cancel the remaining meetings of 2022 unless people plan on being around
16:37:30 <dustymabe> I'll be away
16:37:40 <walters> +1
16:37:53 <jlebon> .hello2
16:37:54 <zodbot> jlebon: Something blew up, please try again
16:37:57 <zodbot> jlebon: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:38:08 <ravanelli> +1
16:38:49 <dustymabe> #agreed the remaining meetings of the year, scheduled for 12/21 and 12/28 are canceled due to the holidays
16:38:53 <dustymabe> everyone good with ^^
16:38:54 <dustymabe> ?
16:39:16 <aaradhak> .hi
16:39:17 <zodbot> aaradhak: Something blew up, please try again
16:39:20 <zodbot> aaradhak: An error has occurred and has been logged. Please contact this bot's administrator for more information.
16:39:22 <dustymabe> #chari jlebon aaradhak
16:39:27 <dustymabe> #chair jlebon aaradhak
16:39:27 <zodbot> Current chairs: aaradhak dustymabe gursewak jlebon ravanelli travier walters
16:39:34 <jlebon> sorry, was in a mtg :)
16:39:49 <dustymabe> jlebon: :) - and now you're in another meeting
16:40:04 <dustymabe> #topic tracker: Fedora 38 changes considerations
16:40:13 <dustymabe> #link https://github.com/coreos/fedora-coreos-tracker/issues/1357
16:40:20 <travier> I'll be away too, fine to cancel
16:40:48 <dustymabe> ok I went through this ticket and updated all the item that were changes for f37, but got postponed with discussion from last cycle
16:41:05 <jlebon> nice
16:41:06 <dustymabe> so items 101 through 107 and items 201 through 203
16:41:29 <dustymabe> please do read through those comments (the ones that say `NOTES`) in each one and make sure you don't see any rationale that no longer applies
16:41:56 <travier> 115 does not apply to us. We'll have to make sure the package is not included
16:42:05 <jlebon> should we go through the other tickets and then finish with this and try to get to as many as we can?
16:42:30 <dustymabe> yep
16:42:35 <dustymabe> going through it now
16:42:39 <dustymabe> subtopic 108 KTLS implementation for GnuTLS
16:43:03 <walters> was thinking recently that we should ask Change owners to mark changes which are e.g. buildroot only or are otherwise known to  not affect editions etc
16:43:11 <travier> 109 is cool
16:43:28 <dustymabe> any thoughts on 108?
16:43:58 <walters> travier: yeah, though with https://github.com/coreos/rpm-ostree/issues/4155 we'd actually be able to use cosign which IMO would be even better 😄
16:44:21 <travier> oh yeah
16:44:27 <travier> that's cool
16:44:44 <travier> I want that:
16:44:46 <travier> !
16:44:49 <walters> dustymabe: I don't think anything important uses gnutls
16:44:51 <travier> 108 is crazy
16:45:03 <travier> ktls is just not a good idea
16:45:09 <travier> but it should not impact us
16:46:10 <dustymabe> walters OK - so anything important we use doens't use gnutls. Should be nothing for us to do here
16:46:18 <dustymabe> subtopic 109 Rpm Sequoia
16:46:59 <jlebon> cool
16:47:07 <jlebon> i don't think there's anything for us to explicitly do there
16:47:28 <travier> we'll probably use it via libdnf, etc.
16:47:57 <jlebon> 110 is also interesting but not relevant since we ship our own live media. and we already support mounts to persistent storage :)
16:47:59 <dustymabe> so - we'll probably use this via libdnf, but it's an implementation detail of RPM and hopefully we have nothing to do here
16:48:07 <dustymabe> is that right ^^ ?
16:48:19 <travier> hopefully yes
16:48:20 <jlebon> agreed
16:48:22 <dustymabe> subtopic 110 Modernize Live Media
16:48:31 <dustymabe> jlebon says "110 is also interesting but not relevant since we ship our own live media. and we already support mounts to persistent storage :)
16:48:38 <travier> yep
16:48:40 <dustymabe> so we can move past that
16:48:44 <dustymabe> subtopic 111 Ruby 3.2
16:48:46 <travier> ignore
16:48:56 <dustymabe> we don't ship ruby
16:48:57 <travier> we don't ship ruby
16:49:00 <dustymabe> subtopic 112 Reproducible builds: Clamp build mtimes to $SOURCE_DATE_EPOCH
16:49:34 <travier> good change, but foes not impact us, we ship everything with a 0 timestamp
16:49:36 <jlebon> no explicit action needed
16:49:50 <travier> does*
16:50:10 <walters> yeah, though we probably also should set SOURCE_DATE_EPOCH at build time, but this is a distinct thing
16:50:12 <jlebon> travier: i think this is about the rpm build improvements
16:50:24 <walters> for our "base image" aka `rpm-ostree compose tree`
16:50:28 <travier> yes
16:50:49 <travier> I mean the timestamp used in the RPM don't impact the ones we ship as we override eveything
16:50:57 <dustymabe> ok.. This is bout rpm build improvements and no explicit action needed from us
16:51:05 <jlebon> it might have an indirect impact via change detection
16:51:08 <jlebon> (in a good way)
16:51:28 <dustymabe> subtopic 113 Ostree Native Container (Phase 2, stable)
16:51:38 <travier> this is us :)
16:51:50 <travier> kinda impact us then :)
16:52:00 <dustymabe> yeah, I think we'll just link to https://github.com/coreos/fedora-coreos-tracker/issues/1363 here
16:52:23 <jlebon> +1
16:53:02 <dustymabe> maybe we can start with part of jlebon's proposal in https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/2SHXAMQ6TM6VIS4AB6NVN3OOEYKUPJMQ/ for F38 cycle
16:53:31 <dustymabe> next up...
16:53:35 <dustymabe> subtopic 114 LLVM 16
16:53:51 <jlebon> should be transparent to us
16:54:08 <dustymabe> subtopic 115 Add Fedora Auto Firstboot Services to desktop variants
16:55:18 <dustymabe> hmm - looks like this is something we want to make sure we don't pickup
16:55:25 <dustymabe> I guess it's targetted at desktop variants
16:56:03 <travier> yes, we don,'t want it
16:56:22 <travier> and I'm actively working on it to ask it to not be for rpm-ostree systems in general
16:56:32 <dustymabe> "this is targetted at desktop variants and should not affect us, though we need to make sure the package doesn't somehow get pulled in as a dependency."
16:56:46 <dustymabe> ok - on to self contained changes
16:56:55 <dustymabe> subtopic 204 Build Fedora IoT Artifacts with osbuild
16:57:31 <jlebon> travier: it'd be better to get it implemented in a way that works on both instead of differing
16:57:58 <dustymabe> "this change is specific to Fedora IoT. No action needed for FCOS.
16:57:59 <travier> jlebon: it's not obvious how we could do that
16:58:06 <travier> https://pagure.io/fedora-autofirstboot/issue/8
16:58:17 <travier> dustymabe: +1
16:58:59 <dustymabe> subtopic 205 Haskell GHC 9.0 & Stackage LTS 19
16:59:12 <jlebon> travier: "annihilates" is a strong word :)
16:59:26 <jlebon> skip
16:59:50 <dustymabe> i.e. we don't ship anything that uses haskell
16:59:54 <travier> jlebon: but it's really that, we already have enough users with issues with overlaying that don't understand that they are on the hook for figuring them
17:00:04 <travier> We don't want more
17:00:23 <jlebon> i wouldn't say it annihilates the benefits of image-based updates though
17:00:42 <jlebon> maybe we can chat more about this in a separate channel :)
17:00:45 <dustymabe> +1
17:00:48 <travier> yeah ok, maybe it's too strong :)
17:00:50 <dustymabe> subtopic 206 Major upgrade of Microdnf
17:01:00 <travier> sorry dusty
17:01:12 <travier> we don't use it
17:01:38 <travier> I had not seen https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/2SHXAMQ6TM6VIS4AB6NVN3OOEYKUPJMQ/ . +1 for the support phases
17:01:42 <dustymabe> yeah, we don't use microdnf - i do need to familiarize myself with all the proposed dnf5 changes though - seems like it's large
17:02:04 <travier> dnf5 is a big change apparently. would have to give it a try
17:02:12 <travier> wondering how that will impact rpm-ostree
17:02:37 <dustymabe> subtopic 207 SPDX License Phase 1
17:02:39 <jlebon> skip, but to watch. i think there's room for collaboration there as discussed in that thread
17:03:02 <jlebon> (^ for 206, not 207)
17:03:05 <dustymabe> +1
17:03:14 <dustymabe> for this one it seems like a tooling/packaging improvement
17:03:38 <dustymabe> am I reading it rigth?
17:04:01 <travier> Should only impact us for ours packages
17:04:07 <travier> (I have to go, sorry)
17:04:13 <dustymabe> right, but it seems almost opt-in?
17:04:38 <jlebon> indeed. they've pushed the cutover to a separate phase
17:04:51 <dustymabe> "we may need to update our packages to use new License identifiers, but for now it's opt-in."
17:04:59 <jlebon> +1
17:05:02 <dustymabe> if it's easy enough to do we could just go ahead and do it now
17:05:09 <dustymabe> subtopic 208 Node.js Repackaging
17:05:10 <jlebon> agreed. it's a nice improvement
17:05:21 <jlebon> skip
17:05:33 <dustymabe> skip, we don't use or include nodejs
17:05:37 <dustymabe> subtopic 209 PHP 8.2
17:05:41 <dustymabe> same for PHP
17:05:46 <dustymabe> subtopic 210 SWIG 4.1.0
17:06:36 <jlebon> can skip too. none of our direct projects use SWIG (libdnf does, but we don't enable it for rpm-ostree)
17:06:44 * dustymabe looks up what SWIG is
17:06:53 <dustymabe> subtopic 211 Deprecate python-toml
17:07:08 <dustymabe> jlebon: this must be why python3-toml dropped out of the dep tree in COSA
17:07:19 <dustymabe> we should update config-bot to use whatever its replacement is
17:08:02 <jlebon> dustymabe: indeed
17:08:22 <dustymabe> "No action other than making sure our releng tooling doesn't require it. We at least know config-bot needs to be updated"
17:08:29 <dustymabe> subtopic 212 PostgreSQL 15
17:08:41 <jlebon> skip
17:08:52 <dustymabe> we don't include postgresql database in FCOS :)
17:08:56 <dustymabe> subtopic 213 LXQt image for aarch64
17:09:16 <dustymabe> this is specific to the LXQt desktop
17:09:21 <dustymabe> subtopic 214 Remove initial-setup from KDE Spin & Kinoite
17:09:29 <dustymabe> this is specific to KDE* desktops
17:09:35 <dustymabe> subtopic 215 Prevent from building RPM packages providing python3dist(...) = 0
17:10:15 <dustymabe> looks like it's a build tooling thing - and we don't ship python things in FCOS anyway.
17:10:22 <jlebon> +1
17:10:24 <dustymabe> subtopic 216 MobilityPhoshImage
17:10:39 <dustymabe> new deliverable from Fedora - no implications for FCOS
17:10:44 <dustymabe> subtopic 217 Enable bootupd for Fedora Silverblue & Kinoite
17:11:16 <jlebon> this is silverblue and kinoite catching up to FCOS
17:11:22 <dustymabe> +1
17:11:27 <jlebon> so shouldn't be anything to do in FCOS
17:11:34 <dustymabe> subtopic 218 Build Fedora Silverblue & Kinoite using rpm-ostree unified core mode
17:11:37 <jlebon> well...
17:11:54 <jlebon> the change proposal says "Enable", which it isn't in FCOS
17:12:19 <dustymabe> hmm. something we should do?
17:12:23 <jlebon> not sure if that's still the plan, but if so it'd be worth discussing whether to do it in FCOS too
17:13:01 <dustymabe> who would know? walters?
17:13:29 <jlebon> ok, i think "enable" actually just means "allow users to manually update", not automatic updates
17:13:37 <jlebon> by reading the change proposal
17:14:02 <jlebon> "Thus bootloaders updates will remain a manually user triggered operation for now. "
17:14:14 <dustymabe> ok so we're back to...
17:14:20 <dustymabe> subtopic 218 Build Fedora Silverblue & Kinoite using rpm-ostree unified core mode
17:14:25 <dustymabe> this is specific to the build tooling used to create Silverblue/Kinoite
17:14:32 <dustymabe> and should not affect FCOS
17:14:36 <jlebon> +1
17:14:38 <dustymabe> subtopic 219 Remove Guile Support from GDB
17:14:55 <jlebon> we don't ship gdb
17:15:04 <dustymabe> and.... we're done!
17:15:37 <jlebon> :tada:
17:15:49 <dustymabe> there are a few tickets we have left open from the f37 cycle that we should maybe revive at some point
17:16:01 <dustymabe> https://github.com/coreos/fedora-coreos-tracker/labels/F37-Changes
17:16:39 <jlebon> good point
17:16:51 <dustymabe> I guess DNS Over TLS never happened and isn't in f38 proposed changes
17:16:56 <dustymabe> so maybe we should just close it
17:17:04 <dustymabe> s/proposed/accepted/
17:17:54 <dustymabe> yeah so I'll close that one with a note
17:18:01 <jlebon> did we say this would be the last mtg for the year?
17:18:08 <dustymabe> yes
17:18:12 <dustymabe> #topic open floor
17:18:18 <jlebon> ack ok
17:18:19 <dustymabe> jlebon: anything on your mind
17:18:25 <dustymabe> anything anyone wants to bring up?
17:18:40 <jlebon> nothing in particular :)
17:18:58 <dustymabe> #info we will still attempt to put out a triple release on the week of the 26th
17:19:35 <jlebon> +1
17:20:11 <dustymabe> #info the console changes finally landed in stable (today) https://github.com/coreos/fedora-coreos-tracker/issues/567
17:20:50 <dustymabe> #info GCP SEV support landed in the triple release today too: https://github.com/coreos/fedora-coreos-tracker/issues/1202
17:21:13 <dustymabe> are there any Fedora Changes we should file for the F38 cycle?
17:21:22 <dustymabe> any *more* I should say
17:22:56 <jlebon> i think to answer that, we should have a look over the FCOS priorities hackmd
17:23:01 <jlebon> which we should refresh soon
17:23:16 <dustymabe> yeah, for real. the last 3 months of this year have been a blur for me
17:23:25 <jlebon> would be good to pick that up again in January
17:23:40 <jlebon> heh, yup. same here, likely for the same reason :)
17:23:54 <dustymabe> looks like the change deadlines are coming up already
17:24:06 <dustymabe> system wide changes are 2022-12-27
17:24:13 <dustymabe> https://communityblog.fedoraproject.org/fedora-linux-38-development-schedule/
17:24:43 <dustymabe> so we probably missed the boat there already for anything new
17:24:49 <dustymabe> which is OK - there's always next time :)
17:24:50 <jlebon> yeah, no big deal
17:25:03 <jlebon> i think we'll have our plates full already with the container stuff
17:25:04 <dustymabe> ok i'll close out the meeting soon unless more topics come up
17:25:40 <walters> Thanks for running the meeting!
17:26:04 <dustymabe> #endmeeting