18:03:13 <decause> #startmeeting Fedora Council
18:03:13 <zodbot> Meeting started Mon Jan 11 18:03:13 2016 UTC.  The chair is decause. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:03:13 <zodbot> The meeting name has been set to 'fedora_council'
18:03:28 <decause> #topic Modularization Update with Langdon
18:03:39 <decause> #link https://plus.google.com/hangouts/_/stream/a2dbhl762i2p6q7xzffxp74wrma?pqs=1&hl=en&authuser=0
18:03:49 * decause will post link at end
18:03:56 <decause> *langdon talking now*
18:04:13 <decause> I will stop saying your name from here lwhite ;)
18:04:27 <decause> We're at stage 2 or 3 of the rings proposal
18:04:33 <mattdm> https://www.youtube.com/watch?v=nL9aQC_oOKo&feature=youtu.be
18:04:42 <decause> so, what we've been talking about is how can we go to th enext step
18:04:43 <mattdm> #link https://www.youtube.com/watch?v=nL9aQC_oOKo&feature=youtu.be
18:04:54 <decause> we were talking about simplifying and increasing what is available as far as REpos in Fedora
18:04:58 <decause> to allow for the growth of things
18:05:03 <mattdm> (the hangouts one will only allow 10 people)
18:05:13 <decause> how do we be more open ended, so that projects not at their "perfect" state can still participate
18:05:17 <decause> and distribute with Fedora
18:05:24 <decause> even when packaging (and code) is not quite right yet
18:05:29 <decause> keeping constraints lower
18:05:40 * robyduck here
18:05:42 <bexelbie> mattdm, do you need people to drop (/me had joined)
18:05:49 <mattdm> bexelbie: nope fine so far
18:05:51 <decause> another aspect was to deconstruct the distribution, so that compenents can be installable and have more lattitude on how they ar edistributed
18:05:57 <bexelbie> mattdm, don't hesitate to let me know if you do
18:06:05 <decause> echo...
18:06:25 <decause> q from mattdm: what is user benefit?
18:06:32 <decause> lwhite: chicken and egg thing
18:06:53 <decause> something like httpd, it could be in beta or alpha, and you want to install it under certain conditions
18:07:04 <decause> like for the "latest and greatest" version of your site, and you need a feature
18:07:15 <decause> but sometimes, you need to run your "regular old" mature and stable state versions
18:07:25 <decause> you want to b eable to disconnect when an application runs, and which version
18:07:33 <decause> we have ways to do this, but they are not consistent or pretty
18:07:46 <decause> some of this objective to make this a consistant and well understood solution
18:07:50 <decause> another example
18:07:57 <decause> you wanna ahve parallel installs
18:08:08 <decause> 2 different versions of sometthing depending on edition
18:08:22 <decause> in the server edition, you may want something very mature, but in the workstation, you want the more bleeding-edge
18:08:34 <decause> in the human/user case, it can be less reliable, or be more favorable on the UI side
18:08:58 <decause> on server side, maybe you want locked down and secure, but on workstation, maybe you want devs to use the other
18:09:07 <decause> #topic Where are we on this?
18:09:20 <decause> it's not going entirely well, but there is progress
18:09:34 <decause> the Envs/Stacks WG is where the bulk of this happened
18:09:47 <decause> nick coughlin's thread Alpeh Proposal
18:09:50 <decause> there are links
18:09:55 <decause> (someone link here plz?)
18:10:14 <decause> inclusion of applications inside of Fedora, without getting all the guarantees a typical package gets
18:10:19 <decause> arguing whether this is stage 2 or 4
18:10:21 <mattdm> links!
18:10:22 <decause> 3*
18:10:23 <mattdm> #link https://fedoraproject.org/wiki/Env_and_Stacks/Projects/PackageReviewProcessRedesign
18:10:24 <decause> you can package anything
18:10:30 <decause> becuase COPR has been a great success
18:10:37 <decause> it has plugins for dnf, so it "just works"
18:10:49 <mattdm> #link https://copr.fedoraproject.org/
18:10:49 <decause> some aspects of modularity doesn't allow parallel, but alternate versions
18:11:03 <decause> you can have bleeding-edge python avialble, even when there is something native
18:11:11 <decause> I was using a bunch of gnome3 addons this way
18:11:18 <decause> another initative by WG is the playground initiative
18:11:27 <decause> #topic Playground Initiative
18:11:34 <decause> a set of "Core" COPRs
18:11:44 <decause> closer to Fedora distro, to be part of  set
18:11:49 <mattdm> #link https://fedoraproject.org/wiki/Changes/Playground_repository
18:11:51 <decause> whil enot "completely" stable, theya r emoving int he right direction
18:12:06 <decause> the playground idea is simple access to all the COPRs demarcated as part of the playground
18:12:12 <decause> one repo to access them all
18:12:20 <decause> once step closer to distro-wide
18:12:27 <decause> another initiatvie from base WG
18:12:32 <decause> #topic BaseWG
18:12:42 <decause> they would define hte packages that are teh "Base" of each edition
18:13:04 <decause> the other aspect of pulling ocntent away from the OS, and defining the tight aspect of OS, versus everything else
18:13:15 <decause> which means definging the "bare minimum" that needs to be shared by all environments
18:13:23 <decause> which can include containers, server/workstation Editions
18:13:33 <decause> all the things that underpin apps that we should distribute in a distro
18:13:38 <decause> there have been some fits and starts
18:13:46 <decause> there are some applications that have been identified as "base"
18:13:54 <decause> but the charter definition has been a challenge
18:14:01 <decause> "what does bare minimum mean?"
18:14:09 <decause> is it just enough to get a prompt?
18:14:20 <decause> where does the C runtime fit in? Is it part of base, or some higher layer?
18:14:36 <decause> going further int he inclusive direction, should we include systemd? Or is that too far up the stack?
18:14:44 <decause> there have been many cicular discussions on that
18:14:52 <decause> #topic Prototype Proposals
18:15:10 <decause> I made some proposals, and those have somewhat stalled due to discussion
18:15:17 <decause> that is the update on the progress we've made
18:15:24 <decause> #topic Biggest Win
18:15:30 <decause> easily, this has been COPR
18:15:40 <decause> #topic Questions
18:15:53 <decause> mattdM: What is the state of the Playground Repo?
18:16:10 <decause> lwhite: Stalled. Env/Stacks WG hasnt' met in a while, and needs to get back on track
18:16:25 <decause> next steps for playground is drawing a line in the sand, putting something up, and seeing what happens
18:16:38 <decause> don't worry if it is the right answer or not, just put something up, and start somewhere
18:16:41 <decause> other questions?
18:16:50 <decause> next slide
18:16:58 <decause> #topic Updates needed
18:17:04 <robyduck> sorry decause I need to dive into this more, is the playground stuff on trac?
18:17:05 <decause> the wiki pages
18:17:16 <decause> robyduck: it is stalled, but discussions are ongoing
18:17:23 <decause> we're talking about going forward now
18:17:30 <robyduck> ok
18:17:44 <decause> lwhite: I've been writing up process for endusers to make decisions about whether this package is what you want to install
18:17:47 <decause> for example
18:17:52 <decause> when you do a package review, provide that info as metadata
18:18:10 <decause> I can choose to install a package, even if it failed package review, if this violation is tolerable "for me" as a user
18:18:12 <mattdm> robyduck: I think this is the latest draft
18:18:14 <mattdm> #link https://fedoraproject.org/wiki/Env_and_Stacks/Playground_repository_%28draft%29
18:18:32 <decause> we can bring that info to the end user, when package review fails, with exceptions, such as license review failures
18:18:37 <decause> then individual users can decide
18:18:45 <decause> allt he defaults would be against current model
18:18:55 <decause> another aspect is to bring the work within RHT, to the community
18:18:59 <decause> we've been struggling with how to do that
18:19:05 <decause> proposals around what base could look like
18:19:07 <robyduck> mattdm: thank you :)
18:19:20 <decause> inside, we're interested to help solve that problem, and we want to bring that experience into the ocmmunity
18:19:33 <decause> those are 2 steps
18:20:09 <decause> If we take the first step of allowing an enduser to understand which aspects are compliant, or what quality a metric is at, it opens up possobilities to get wway from the "perfect" concetric rings
18:20:19 <decause> it makes sense, we want a nice metaphor, but what I think is happening
18:20:23 <decause> there are orthogonal metrics
18:20:30 <decause> I have 3/4 of an email written up about this
18:20:40 <decause> where you want ot give someone a "mutual fund" style profile
18:20:47 <decause> "I'm a low-risk desktop user"
18:20:56 <decause> and then you get a guided version
18:21:08 <decause> "My risk profile is I want to retire in 2050, so I map to these mutual funds"
18:21:13 <decause> something along those lines
18:21:25 <decause> you don't worry about pretty rings, you map risk profile to a type of user
18:21:37 <decause> and then allow them to pick components that automatically map to risk profiles
18:21:50 <decause> the concern I have is, we have a 0 or a 1
18:21:59 <seseri> quick wuestion about getting copr packages into the playground repo
18:22:00 <decause> this package has perfect metrics, or it has one or more imperfect
18:22:05 <decause> it makes a binary decision
18:22:11 <decause> seseri: will post
18:22:16 <seseri> is that only something the owner can do? or will there be a kind of "voting" system
18:22:17 <decause> decause will post in the gchat
18:22:41 <decause> seseri++
18:22:41 <zodbot> decause: Karma for ageha changed to 1 (for the f23 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
18:22:42 <decause> posted
18:22:57 <decause> mattdm: the other problem, is that 1's are not actually ones
18:23:04 <decause> things are .6 to .8 in reality
18:23:23 <decause> packaging quality can be measured. You can measure bugginess, and list additional info
18:23:31 <decause> lwhite: it would be interesting to integrate karma into the output
18:23:37 <decause> rather than a 0/1
18:23:46 <decause> you can see when it is promoted or closer to ring 0
18:23:54 <decause> can we actually include info about deployments
18:24:01 <decause> how often to people include a particular package?
18:24:17 <decause> of these two markdown viewers, 57% use this one, and 2% use that one
18:24:42 <decause> mattdm: Does the packager include it? IS there a separate committee? Is it crowdsourced?
18:24:52 <decause> lwhite: it will depend on metric, and we need to increase automation.
18:25:07 <decause> some piece of software can look and make a determination, for say, test coverage
18:25:13 <mattdm> #info automate all the things!
18:25:14 <decause> the data needs to be auto-updated
18:25:20 <decause> there will be some self-review stuff
18:25:26 <decause> and the FPC will continue to do their thing
18:25:36 <decause> but instead of doing a review, they markup the package itself
18:25:45 <decause> and then we'd need to be able to degrade that info overtime
18:26:01 <decause> if a review hasn't been done in over a eyar, then we can verify the "recentness" of the information
18:26:18 <decause> mattdm: when a package comes into Fedora, we hvae people look over it, and an automated script to check things like where files are put.
18:26:25 <decause> that script has a checklist as an output
18:26:38 <decause> having that output, be part of the metadata, or some abstract of it, would be useful
18:26:59 <decause> lwhite: we'll put the presentation someowhere useful to find
18:27:07 <decause> #action decause post presentation to commblog
18:27:18 <decause> #topic Current Status
18:27:22 <decause> we're moving in fits and starts
18:27:27 <decause> we need more people to participate
18:27:36 <decause> the best place to find them is the Envs/Stacks WG
18:27:54 <decause> we need to reengage, and relieve some pressure from the work we do "all the time" so we can move forward with this work
18:28:07 <decause> seseri: did you get your question answered?
18:28:15 <seseri> no
18:28:28 <langdon> seseri, can you repeat for me?
18:28:33 <decause> 13:22 < seseri> is that only something the owner can do? or will there be a kind of  "voting" system
18:28:51 <seseri> *getting copr packages into playground
18:28:59 <mattdm> ahhhhh.
18:29:05 <decause> it's not just the ideas, it's the concept
18:29:08 <mattdm> I thought you were talking about someone else :)
18:29:10 <decause> there have been infra and tool changes
18:29:20 <decause> I'd very much like to see increased participation because we need peopel to do work
18:29:56 <decause> mattdm: how do repos get included in playground?
18:30:10 <decause> lwhite: it would be both self-nominated, and FPC review style
18:30:17 <decause> *lwhite digs for a link*
18:30:35 <decause> lwhite: the proposal didn't get approved, but we don't know yet
18:30:43 <decause> ENS or FPC will likely have final approval
18:30:58 <decause> (mattdm likes ENS)
18:31:05 <decause> as an acronym
18:31:55 <decause> #action decause talk to langdon about generating a task list for new contributors to get involved in Envs/Stacks
18:32:03 <bexelbie> Did we need to talk about flock bids?
18:32:07 <decause> #topic UnixStickers
18:32:23 <decause> #info We have approved UnixStickers to use our trademark
18:32:38 <decause> #info we'll be able to get free stickers for conferences
18:32:52 <decause> there will be other merch as the design team approves other artwork
18:33:35 <decause> #topic Other Business
18:33:41 <decause> #info video is off
18:33:55 <decause> is that it for council today then?
18:33:59 <decause> going once
18:34:02 <decause> going twice
18:34:05 <decause> going thrice
18:34:06 <bexelbie> did we need to talk about flock bids?
18:34:27 <decause> bexelbie: I reckon not. I would maybe just ping the flock-planning list to ask if anyone has questions?
18:34:39 <decause> cc me on that if you'd like
18:34:41 <bexelbie> I'll do so after a site visit this weekend
18:34:46 <decause> bexelbie: great!
18:34:57 <decause> bexelbie: take pics, maybe we can do a "teaser" post on the CommBlog ;)
18:35:02 <decause> please :)
18:35:13 <bexelbie> decause, heh, I'll see what I can do
18:35:17 <decause> :)
18:35:20 <decause> ok
18:35:25 <decause> I think that is it for council today
18:35:28 <decause> any other business
18:35:31 <decause> going once
18:35:34 <decause> going twice
18:35:37 <decause> going thrice
18:35:40 <decause> ok, thanks all
18:35:43 <decause> langdon++
18:35:45 <decause> mattdm++
18:35:50 <decause> thanks all for your time today
18:35:53 <decause> #endmeeting